Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Konfiguracja firewalla sprzetowego

tomasz_swansea 02 Oct 2010 01:16 3934 22
  • #1
    tomasz_swansea
    Level 10  
    Witam.
    Mam problem z konfiguracją firewalla:
    1.straszne lagi (myślę ze problem z dns)
    2.nie wiem jak otworzyć porty dla drugiej podsieci

    Konfiguracja wygląda tak:
    komputer podłączony do routera Belkin n1 vision siec 192.168.2.x ethernet
    router do firewalla Watchguard firebox siec 192.168.1.x ethernet
    firewall do modemu ethernet wan.
    Mam dostęp do obu podsieci z komputera 192.168.2.x
    Porty tylko otwieram do podsieci 192.168.1.x jak wpisuje hosta z 2.x to nie dziala
    Firewall działa w dwie strony nie wiem jak się do tego zabrać.
    Czy można skonfigurować dwa routery w jednej podsieci?
    Bo mi nie wyszło (z wyjątkiem kiedy Belkin działał jako AP) lecz w trybie router. Jest problem z portami zależy mi by Belkin działał w trybie router bo tylko wtedy działa QOS i pokazuje down/upload na wyświetlaczu co jest mi przydatne i najważniejsze ma 1000mb a firewall ma switch tylko 100mb.
    Sieć ma około 10 komputerów łącze 50Mbit i dwa serwery.
    Ja jeden to torent a drugi to AppleFS,samba i www i cups, z intranetu nie ma problemu z serwerami ale jak chce się dostać z internetu to porty są pozamykane serwer www jest w https
    ps w routerze Belkin firewall jest wyłączony

    Wdzięczny byłbym za pomoc.
  • #2
    bogiebog
    Level 43  
    Quote:
    czy mozna skonfigurowac dwa routery w jednej podsieci?

    w/g mnie należy

    Zakładam że ten belkin to ma tylko dostarczać WIFI dostęp.
    Po prostu w belkinie:
    - port WAN/Internet pusty - kabel z wgard idzie do portu LAN
    - wyłącz DHCP server
    - ustaw LAN IP na zgodny z siecią 192.168.1.x
  • #3
    tomasz_swansea
    Level 10  
    dzieki ale w jednej podsieci nie chca dialac a kabel jest tak jak piszesz
  • #4
    bogiebog
    Level 43  
    tomasz_swansea wrote:
    dzieki ale w jednej podsieci nie chca dialac a kabel jest tak jak piszesz


    Musi działać, nie ty pierwszy masz taką konfigurację.

    Opisz dokładnie jakie symptomy są "nie chce działać".
  • #5
    tomasz_swansea
    Level 10  
    serwer dhcp z firewalla nie przyznaje adresów do podsieci 192.168.2.x firewall nie otwiera portów do podsieci 192.168.2.x
    mozna jakos przeroutowac caly ruch z belkina do firewalla?
    jak ustawiam w firewallu host z podsieci 2.x mam komunikat only thrusted network range 192.168.1.x
    lan chce przez tylko przez belkina
    niewiem czy mozna jakos to przeroutowac?
    problem chyba w tym ze firewall to tez router ma 2 switche i dwa wany
    konfiguracja wyglada tak
    Konfiguracja firewalla sprzetowego

    Dodano po 6 [minuty]:

    a i jeszcze jedno z belkina portu wan idzie do portu lan w firewallu
    jak podlacze z belkina portu lan do portu lan to dhcp z firewalla dziala na podsieci 192.168.2.x i wszystko jest ok tylko ze nie dziala w belkinie QOS itd chce zeby belkin rutowal i traktowal firewall jako WAN
    a firewall otwieral porty dla routera belkin i jego podsieci
  • #6
    bogiebog
    Level 43  
    Quote:
    serwer dhcp z firewalla nie przyznaje adresów do podsieci 192.168.2.x firewall nie otwiera portów do podsieci 192.168.2.x


    Pewnie że nie przydziela.
    DHCP serwer z routera 192.168.1.x przydziela IP na sieci 192.168.1.x. Sieć 192.168.2.x likwidujesz i zastępujesz jej IP adresy adresami z sieci 192.168.1.x.

    czyli w belkinie:
    - port WAN/Internet pusty - kabel z wgard idzie do portu LAN
    - wyłącz DHCP server
    - ustaw LAN IP na zgodny z siecią x.x.1.x ale poza pulą DHCP serwera na watchgardzie, np 192.168.1.2
    - wszystkie ręcznie wpisane adresy x.x.2.x zmieniasz na x.x.1.x ale tak aby nie miały duplikatów z istniejącymy urządzeniami.
  • #7
    tomasz_swansea
    Level 10  
    tak zadziala ale czy jest szansa podlaczyc kabel z wgard do portu wan a nie lan?.

    Tak jak na obrazku
    Konfiguracja firewalla sprzetowego
    wszystko dziala wszystkie kompy maja net w belkinie dziala qos itd tylko ten firewall nie otwiera portu
    jak podlaczam wguard do lan to belkin nie routuje i niedziala qos
    ze tak powiem jak nie urok to sraczka:)

    Dodano po 3 [minuty]:

    myslalem tez o vlanie pomiedzy firewallem a belkinem ale tego to wogóle nie kumam

    z góry dzięki za pomoc

    Dodano po 13 [minuty]:

    czyli podsumowując
    konfig 1
    kabel z wguard do wyjscia lan w belkinie
    firewall otwiera porty i jest ok tylko jedna siec
    ale nie dziala QOS i nie rutuje dziala jak hub a nie switch
    konfig 2
    kabel z wguard do wejscia wan w belkinie (dwie podsieci bo na jednej nie dziala)
    firewall nie otwiera portów do drugiej podsieci ale za to w belkinie dziala QOS i rutuje
    jak zrobic aby Belkin rutowal QOS a firewall otwieral porty dla podsieci belkina

    Dodano po 11 [minuty]:

    nie jestem pewien czy problem nie jest w tym ze druga posiec nie ma nat-owania
    przy konfig 2
  • #8
    bogiebog
    Level 43  
    Quote:
    konfig 1
    kabel z wguard do wyjscia lan w belkinie
    firewall otwiera porty i jest ok tylko jedna siec
    ale nie dziala QOS i nie rutuje dziala jak hub a nie switch

    tak

    Quote:

    konfig 2
    kabel z wguard do wejscia wan w belkinie (dwie podsieci bo na jednej nie dziala)
    firewall nie otwiera portów do drugiej podsieci ale za to w belkinie dziala QOS i rutuje
    jak zrobic aby Belkin rutowal QOS a firewall otwieral porty dla podsieci belkina


    "rutował QOS" ? nie rozumiem, chyba mylisz pojęcia, wytłumacz o co ci chodzi dokładnie z tym rutowanie i QOS-em. Czego oczekujesz od QOS-u ?

    Quote:
    nie jestem pewien czy problem nie jest w tym ze druga posiec nie ma nat-owania
    przy konfig 2

    jak kabel idzie do portu WAN belkina to na pewno jest NAT-owana.

    Opisz dokładnie wymagania sieci to wtedy pomyślimy co da się zrobić z tym co masz, bo na razie nie widzę powodu dla którego nie możesz umieścić wszystkich urządzeń w sieci x.x.1.x.
  • #9
    tomasz_swansea
    Level 10  
    tak tylko problem w tym ze jak kabel idzie do wana i wszystkie urzadzenia sa w jednej podsieci to nie ma internetu i niemoge sie dostac do firewalla
    a jak kabel idzie do lan to belkin dziala jak AP
    w trybie AP nie dziala QOs czyli wszystko sie tnie jak jeden komp sciaga z np p2p
    wyswietlacz na belkinie nie podaje zadnych informacji o uzytej przepustowosci w trybie AP


    belkin routuje tylko do portu wan(swojego portu wan)

    jak umiescic dwa routery w jednej sieci? firewall tez ma wbudowany router

    Dodano po 3 [minuty]:

    czy mozna zrobic aby firewall dziala tylko jako brama?
  • #10
    bogiebog
    Level 43  
    > czy mozna zrobic aby firewall dziala tylko jako brama?

    nie rozumiem "tylko", a co ma nie działać ?

    Dodano po 1 [minuty]:

    > w trybie AP nie dziala QOs czyli wszystko sie tnie jak jeden komp sciaga z np p2p

    A dlaczego nie zrobisz QOS-a w watchgardzie ?
  • #11
    tomasz_swansea
    Level 10  
    funkcje w wguardie sa platne jest w nim bardzo fajny bandwitch mamager czyli QOS ale licencja mi wygasla a nowa to 300 usd a nie ma zadnych crackow itd...:)
    po drugie tak jak napisalem chce qos z belkina poniewaz tylko wtedy wyswietlacz na belkinie podaje informacjie o uzytej przepustowosci i szybkosci polaczen kazdego klienta nie musze wlaczac kompa i wiem co sie dzieje w sieci.
    moze wrocic do punktu wyjscia i otworzyc porty w firewallu?
    i zostawic dwie podsieci to mi nieprzeszkadza a wrecz lepiej bo mam odizolowane zasoby domowe od reszty sieci pod serwer 192.169.1.10 jest podpietych sporo klientow

    jak nie bylo tego firewalla to wszystko bylo ok belkin do modemu i po zawodach ,a teraz pomiedzy modemem a belkinem wstawilem firewall i mam problemy by otworzyc porty dla wybranych komputerow

    Dodano po 10 [minuty]:

    ponawiam pytanie
    czy mozna w firewallu ktory jest w podsieci 192.168.1.x
    otworzyc porty dla podsieci 192.168.2.x
  • #12
    bogiebog
    Level 43  
    A potrzebny ten wgard na cos ? usuń go i podłącz w jego miejsc belkina.

    Quote:
    czy mozna w firewallu ktory jest w podsieci 192.168.1.x
    otworzyc porty dla podsieci 192.168.2.x


    Można trzeba zrobić dwa przekierowania na x.1.1 i x.2.1
    np, weżmy port 2011
    w routerze x.1.1: 2011 => IP_tplinka:2011
    w routerze x.2.1: 2011 => IP_komputrea_x_2_x:2011
  • #13
    tomasz_swansea
    Level 10  
    brzmi interesujaco a mozesz dokladniej wytlumaczyc
    jak to przekierowac?
    wguard jest bdobrym firewallem zaplacilemm za niego sporo kasy bo te w routerach sa do bani jak porownac logi to watchguard co chwile cos wylapuje a belkin to tylko podstawowy firewall wiec trojany wirusy itd spokojnie sie komunikuja ze swiatem a wguard nie pusci niczego bez mojej wiedzy dlatego chce go miec

    Dodano po 7 [minuty]:

    podrzucam screena w firewalla
    Konfiguracja firewalla sprzetowego
  • #14
    bogiebog
    Level 43  
    Nie mam wgarda więc opiszę jak to zrobic w wgardzie.
    Co to za tplink ? przekierowania w domowych ruterach szukaj po Virtual Serwer lub Port Forward.
  • #15
    tomasz_swansea
    Level 10  
    tplink? nie rozumiem
    poszukam ale tam chyba niema port forward i virtual server
  • #16
    bogiebog
    Level 43  
    > tplink? nie rozumiem
    mea culpa, wydawało mi się że masz tplinka ale masz belkina

    Masz podręcznik do tego belkina w PDF-ie ? zamieść.
  • #18
    bogiebog
    Level 43  
    W manualu belkina znajdź rozdział
    Configuring Internal Forwarding Settings

    > tylko zaznaczam w belkinie firewall jest wylaczony
    firewall może być wyłączony ale NAT masz bo masz inną sieć 192.168.2.x wieć port forward musi działać.
  • #19
    tomasz_swansea
    Level 10  
    dzieki za porady sprawdze pojutrze jak mi poszlo i dam znac
  • #20
    tomasz_swansea
    Level 10  
    kombinowalem i nic firewall nie pozwala mi wpisac hosta z podsieci 192.168.2.x jakies pomysły?
  • #21
    bogiebog
    Level 43  
    firewall to masz na myśli watchguard ?
    w watch gardzie przekierowujesz na WAN IP typlinka, czyli 192.168.1.x a następnie w tplinku na IP x.x.2.x.

    np przekierowanie portu 2011 z zewnątrz na IP 192.168.2.33
    zakładając ze WAN IP tplinka jest 192.168.1.2

    w watchgardzi Port 2011 => IP=192.168.1.2 port=2011
    w tplinku: port 2011 => IP=192.168.2.33 port=2011
  • #22
    tomasz_swansea
    Level 10  
    belkin z podsieci 192.168.2.x ma niedostepną opcje port forwarding poniewaz firewall jest w nim wyłączony
    natomiast watchguard z podsieci 192.168.1.x nie chce forwardowac nic do podsieci 192.168.2.x
  • #23
    tomasz_swansea
    Level 10  
    no tak uruchomiłem to przekierowalem porty w podsieciach na belkinie i dziala :) temat do zamnknięcia:) dzięki za pomoc