Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[excel] funkcja dopisująca znak w komórce

MrGrzechoo 13 Oct 2010 15:16 52369 3
  • #1
    MrGrzechoo
    Level 10  
    Witam,
    proszę o pomoc jak można automatycznie wstawić znak w zaznaczonych komórkach pomiędzy wpisane już dane w komórce. Mam około 5000 wierszy i do każdego wiersza chce wstawić znak "/" w miejsce między drugą a trzecią literą lub cyfrą (znakiem) od prawej. Miało by to wyglądać tak:
    abcd1234 -> adcd12/34
    cdefghijk -> cdefghi/jk
    Znak "/" ma być wstawiony zawsze w tym samym miejscu (czyli między 2 a 3 znakiem od prawej)
    W jaki sposób można to rozwiązać w excelu (2003 lub 2007)?
    Czy w ogóle można zrobić coś takiego automatycznie?
  • Helpful post
    #2
    adamas_nt
    Moderator of Programming
    Wstaw nową kolumnę, wklej funkcję (przykład dla kolumny źródłowej A od 1 wiersza)
    Code:
    =FRAGMENT.TEKSTU(A1;1;DŁ(A1)-2)&"/"&PRAWY(A1;2)
    i przeciągnij w dół. Następnie zaznacz kolumnę, Kopiuj, Wklej specjalnie>wartości i usuń kolumnę źródłową.
    Tę samą funkcję można użyć w pętli VBA (mid, len, right). Warto, jeśli czynność będzie powtarzana...
  • Helpful post
    #3
    Januszf777
    Level 27  
    Witaj to samo rozwiązanie w nieco inny sposób, z ominięciem błędu dla pustek komórki:
    =JEŻELI(A1="";"";LEWY(A1;DŁ(A1)-2)&"/"&PRAWY(A1;2))
  • #4
    MrGrzechoo
    Level 10  
    Dzięki za rozwiązanie. Działa super. Teraz pokombinuje sobie w vba, żeby usprawnić trochę proces wstawiania.
    Rispekt dla adamas_nt i Januszf777
    O to mi właśnie chodziło.
    Pozdrawiam