Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

podlaczenie routera przez port serwisowy com

noname 15 Paź 2010 20:24 2042 8
  • #1 15 Paź 2010 20:24
    noname
    Poziom 11  

    Witam mam pewne obawy podczas podlaczenia rotera pod kompa przez port serwisowy by wgrac wlasciwe firmware. Problem w tym ze na rutrze na pinach Rx i Tx idzie zasilanie 3.3V o czym nie wspomniano na stronie oprucz ostatniego prawego pinu ktory jest jako 3.3V a na kompie ida ujemne tyle ze na Rx idzie -0.07V a na Tx idzie -10.13V. Teraz nei wiem czy mam szukac schematu serwisowki pod ten ruter czy mozna go poprotstu podlaczyc bezposrednio?
    no i czy mase tez podlaczyc czy nie?
    bo czwarty pin wole nie podlanczac bo przypali mi cos jeszcze, a nawet nie mam pojecia gdzie go dac wiec zostawie lecz nie wiem czy to bezpieczne podlaczyc to pod kompa.

    0 8
  • #2 15 Paź 2010 20:33
    ul1002

    Poziom 35  

    o ile wiem mase się podłącza, na sygnałowych masz -10V ? wogóle dobrze mierzysz to miernikiem ?

    co do szczegółów powinieneś podawać o jaki sprzęt chodzi, wtedy może znajdzie się ktos co to już przerabiał

    0
  • #3 15 Paź 2010 21:20
    noname
    Poziom 11  

    Mierzylem to miernikiem i to nie za 10zl. Minus do masy portu i lecialem po pinach pokolei. Model to speedport W500V zreszta to ten sam co po podanym linkiem jest

    0
  • #4 16 Paź 2010 10:20
    Platon
    Spec od komputerów

    Port szeregowy w routerze jest 3.3V, a interfejs szeregowy w kompie to jest RS232C który ma wyższe napięcia, i dodatkowo odwrócone. Musisz mieć konwerter np max3232

    0
  • #5 16 Paź 2010 12:13
    noname
    Poziom 11  

    tak tylko zastanawia mnie ze Rx ma -0.07V a Tx wskazuje -10.13V co przy ruterze jest jednako po 3.3V na obu Rx i Tx. ale dzieki za odpowiedz, jak bede w polsce to kupie bo w niemcach nie ma elektronicznych sklepow a jak sa to maja bardzo malo komponentów.

    0
  • #7 16 Paź 2010 12:44
    noname
    Poziom 11  

    na kompienie mase wsialem z gniazda portu nie z zasilania czy innego, a na ruterze wziolem z pinow ktore sa widoczne na zdjeciu w linku na poczatku.

    0
  • #8 16 Paź 2010 12:48
    lysy1980
    Poziom 30  

    Słuchaj, musisz zbudować konwerter poziomów LVTTL>RS232, najprostszy jest na 2 tranzystorach (używam z powadzeniem - zmontować można w kilka minut)

    podlaczenie routera przez port serwisowy com

    Zamiast 5V podajesz 3.3V z portu UART routera

    0
  • #9 05 Paź 2011 19:54
    noname
    Poziom 11  

    dzięki ale rozwiązałem to w inny sposób ten przydaje się kiedy już w ogóle nie da się przez siec.
    Rozwiązanie to przytrzymanie reset przez parę sekund aż bodajże nie mrugnie diodami czas to chyba 10 do 15sec lecz to musi być zrobione zaraz po włączeniu, wtedy przechodzi w tryb ratunkowy i można podać obraz na nowo. Aktualnie gdzieś mi się stracił ten router wiec tylko tyle mogę powiedzieć

    0