Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Nawigacja Nav-U 93tc sirf / mnea

23 Paź 2010 09:47 4858 24
  • Poziom 16  
    Witam. Mam taki problem.
    Otóż, korzystając z gotowego softweru wgrałem w swoje navi nakładkę gdzie jest automapa i igo. Igo wyrzuciłem, bo nigdy go nie lubiłem.
    Auto mapa 6.5 z mapą polski 1009 jest bardzo dokładna i w Polsce jest super. Za granicę natomiast chciałbym przerzucać się z powrotem na oryginalny Sony.
    Jest tam program Sirftech, który mi pozwala przełączać z Sirf na NMEA.
    Po zmianie łapie obszar gdzie się znajduje. Na sirfie jest dokładniejszy, w granicach ok. 2,5m błędu w szerokości i w długości.
    Po przełączeniu na NMEA działa normalnie automapa i spoko.
    Ale jak przełączę na Sirf i nawet złapie położenie, to po uruchomieniu oryginalnego pliku uruchamianego (w tym przypadku jest to nav-u2) nawigacja z oryginalnym softem Sony funkcjonuje, ale za nic w świecie nie widzi sygnału...

    Pytania:
    Czy oryginalne oprogramowanie Sony wykorzystuje protokół Sirf 57600 na ComPort 5? (tak mi się wydaje)

    Czym spowodowany jest fakt, że Po przestawieniu w SirfTech tego protokołu, oryginalny system go nie widzi?

    W jakim pliku ręcznie można zmienić protokół i częstotliwość?

    Gdybym teraz chciał wrócić całkowicie do oryginalnej mapy Sony i po prostu usunął bym wszystkie pliki z katalogu Sony->nav-u to przy wykorzystaniu
    oryginalnej płyty Dvd zainstaluję wszystko, czy ta płyta tylko kopiuje mapy?

    Do zrobić aby ściągnąć z navi pliki większe niż 10mb? Bo przy takich mi rozłącza połączenie z komputerem...


    Przepraszam za literówki i błędy merytoryczne, ale zaczynam przygodę z PDA.
    Z góry dziękuję za pomoc.
  • Poziom 38  
    1. kopiowanie plikow - za pomoca cecmd z MountedVolume na karte i z karty w czytniku na dysk - i odwrotnie. Proste.

    2. Protokol nie jest zmieniany w pliku, lecz w rejestrze. Dlatego tez po kazdym resecie wraca do ustawien fabrycznych. Najprosciej wiec powracac do oryginalnego trybu pracy chipsetu GPS poprzez reset - wtedy dziala prawidlowo w programie SONY.

    3. Jesli zadales sobie trud przejrzenia zawartosci skryptow ktore wgrales, zauwazysz, ze jest tam cala seria wpisow do rejestru, przestawiajaca tryb pracy chipsetu - to nie kwestia wylacznie sirftecha. Rozwiazanie tej kwestii w pkt.2

    4. tak - oryginalna plyta calkowicie przywraca stan fabryczny na urzadzeniu.
  • Poziom 16  
    Ok. Dzięki.
    Problemy po drodze:
    1. Nie mam karty.
    2. Po resecie wciąż nie przywraca się tryb normalnej pracy Sony. Wg. sirf'a jest aktywny ten co był przed resetem (albo sirf, albo nmea) Jak to możliwe?

    Teraz wszystko usunąłem (prawie-bo zostało Sony->nav-u i SystemInformation) i ładuję na nowo mapę z oryginalnej płytki dvd. Tylko czy to kopiuje pozostałe pliki również, czy tylko mapy?
  • Poziom 38  
    ad. 1 - W przypadku braku karty MS, nalezy ja np. ukrasc koledze z aparatu, gdy nie patrzy. Czytnik tez. Ew. wyjsciem jest tez zakup ;)

    ad. 2 - prawdopodobnie "soft" ktorego uzyles, ma zadane by automatycznie na starcie urzadzenia dokonywal wpisow w rejestrze - starsze wersje odblokowania Sony takj mialy - w mojej modyfikacji skrypt ten jest uruchamiany na zyczenie, ikonka (gdy chcemy AM) lub nie, gdy chcemy Sony.

    3. reset wykonuje sie nie przez "pykniecie" a przez "press and hold" ok. 6 sek.
  • Poziom 16  
    Pewnie tak jest.
    Co trzeba zrobić, żeby stać się posiadaczem Twojego skryptu? :)
  • Poziom 38  
    Zainstaluj mape AM uzywajac wskazanego obszaru (np. bez Irlandii i Wschodu) a nastepnie zarejestruj produkt. Dziala na 100%. Na tym Forum nie pomagamy w 'witaminizowaniu" oprogramowania.

    Poza tym, "emitowanie" to wypuszczanie, wydawanie, np. znaczka pocztowego. "Imitowanie" to udawanie czegos. Funkcji pliku lub glosu ptakow :)
  • Poziom 16  
    Dobra, już sobie poradziłem. Jeszcze tylko jedno pytanko.
    Jeżeli mam foldery X i Y w Mounted Volume
    Potem skórka X, gdzie w X->File->*.ini dla jakiegoś przycisku np.:
    NewIni = A.ini który otwiera podskórkę A, lub np.:
    NewIni = \MemoryStick\B\B.exe który otwiera B.exe z karty lub (już ostatni przykład) np.:
    NewIni = ..\C\C.exe któy otworzy z katalogu X->C->C.exe
    Jakim symbolem (komendą) odwołać się do dowolnego pliku ale umieszczonego poza katalogiem X??Do katalogu Y?
    Domyślnie /Mounted Volume/Y/Y.exe
    Lecz nie działa.
    Proszę o pomoc w tym i resztę mam zrobioną.

    Dodano po 26 [sekundy]:

    sorki za przemieszane slesze :)
  • Poziom 43  
    Pontikos napisał:
    ad. 1 - W przypadku braku karty MS, nalezy ja np. ukrasc koledze z aparatu, gdy nie patrzy. Czytnik tez. Ew. wyjsciem jest tez zakup ;)
    ...

    Twoja propozycja jest niemoralna. Czy Ty tak robisz, jeśli czegoś potrzebujesz ? Namawianie do kradzieży, jest karalne !
  • Poziom 38  
    Boleje nad tym, ze ktokolwiek mogl odebrac moja wypowiedz jako podzeganie do przestepstwa, przewidzialnego w Kodeksie Karnym (art. 278).

    Pragne wyjasnic, ze moja intencja bylo wylacznie humorystyczne podejscie do tak trywialnego "problemu" jak brak karty. Uzyty w wypowiedzi emotikon oraz kontext wypowiedzi jednoznacznie sugeruja kazdemu inteligentnemu czytelnikowi ton wylacznie zartobliwy.

    Boleje tez nad tym, ze osoba zglaszajaca moj post do moderacji skupila sie wylacznie na mym zarcie, zamiast na tresciach merytorycznych, przewazajacych w mojej poprzedniej wypowiedzi.

    zonas - opisz prosze konkretnie i krotko problem - postaramy sie pomoc. W jaki sposob wywolujesz aplikacje?
    W SystemInformation, ktorego zapewne uzywasz, podaje sie tzw. sciezki bezwzgledne do aplikacji - wtedy wszystko dziala jak trzeba i sie uruchamia! Zwroc uwage, ze w ostatnim przykladzie uzyles slashy w bledna strone - i jak to ma dzialac? ;)
  • Poziom 16  
    Jest tylko plik SysInfoSettings w katalogu X, który zawiera:
    Files\Ini\X.ini
    Czy to oznacza, że katalog X jest katalogiem bezwzględnym i aby mieć dostęp do wyższego katalogu trzeba zmienić na:
    X\Files\Ini\X.ini i katalogiem bezwzględnym będzie nadrzędny katalog nad X?
    Czy tylko mówi od czego startować?

    Bo SystemInformation jest exe'kiem i jego nie podejrzę ani nie zmienię.

    Najkrócej korzystam z tej śmiesznej nakładki z Iphone. A krótko problem polaga na tym, że tam na destktop'ie jest przycisk nawigacja, który otwiera pod-skórkę, gdzie wybieram Automapę lub Igo. Ale tam jest z karty, a ja mam zainstalowaną na nawigacji.
    Jest NewIni = \MemoryStick\AutoMapa EU\Automapa EU.exe
    Na logikę NewIni = \Mounted Volume\AutoMapa EU\Automapa EU.exe
    Nie działa... :( Jakiś komunikat po niemiecku, że nieprawidłowa składnia polecenia (niemiecki nie jest moją mocną stroną)
  • Poziom 39  
    usuń spację NewIni = \Mounted Volume\AutoMapa EU\Automapa EU.exe ma być
    NewIni = \MountedVolume\AutoMapa EU\Automapa EU.exe
  • Poziom 38  
    Koala - obawiam sie ze folder na Sony nazywa sie: "\Mounted Volume" - tak przynajmniej to _dziala_ w moim pakiecie :)
    Code:
    NewIni = \Mounted Volume\AutoMapa EU\wce42am.exe

    Chociaz ja uzywam:
    Code:
    Command = "\Mounted Volume\AutoMapa EU\wce42Am.exe"
  • Poziom 39  
    Są takie i takie modele. Zazwyczaj jest spacja i też taką ścieżkę ustawiam - ale miałem okazję się przekonać, że są bez spacji w nazwie.
  • Poziom 16  
    Dobra.
    A jak zrobię skrót do automapy i dam:
    NewIni = ..\Files\Automapa.lnk
    ??
  • Poziom 16  
    Na komendę:
    Code:
    Command = "\Mounted Volume\AutoMapa EU\wce42Am.exe"

    odpowiada:
    Code:
    Die Datei ist leer oder nicht im Unicode Format:


    Na komendę:
    Code:
    NewIni = \MountedVolume\AutoMapa EU\Automapa EU.exe

    odpowiada:
    Code:
    Datei nicht gefunden


    Po zrobieniu skrótu AutoMapa
    Na komendę:
    Code:
    NewIni = ..\AutoMapa.lnk

    odpowiada:
    Code:
    Die Datei ist leer oder nicht im Unicode Format:


    Jeszcze jakieś propozycje? :)
  • Poziom 38  
    Problem polega na tym, ze kolega edytuje pliki we Wordzie, lub czyms podobnym, co nie zapisuje plikow zgodnie ze standardem unicode - przeciez to masz napisane w kounikacie! :)

    Uzyj Notatnika M$ Windows i zacznij edycje od poczatku.
  • Poziom 16  
    Używam notatnika. Komunikat pisze, że plik jest pusty(nie istnieje) LUB jest niezgodny ze standardem Unicode. Jeżeli zmieniam te newini na oryginalne i działa - otwiera podskórkę, to mogę przypuszczać, że system zapisu znaków jest poprawny.

    Automapa odpala z poziomu commadera... Pisałem, że wszystko działa, poza jedno-przyciskowym uruchamianiem nawigacji...

    Abstrahując od tego - automapa 6.5.0, mapa europy 1024 i mam taki problem, że pomimo zestawu od tego sony i anteny kabelkowej, jadąc przez poza miejskie tereny potrafi mi notorycznie gubić sygnał gps na 1-3sek. Niby nic, ale czasem przelicza na nowo trasę i ten denerwujący dźwięk, kiedy gubi/łapie zasięg... Czasem komunikat: "Słaby sygnał GPS".
    Czy to normalne? Może coś przestawić w sirftech'u? Może antenę mam uszkodzoną? Czy po prostu ten model tak ma?
  • Poziom 38  
    1. zdecydowanie jest to typowa przypadlosc SONY. Jesli masz ustawienia comm5 i 57600, to OK.

    2. otworz ORYGINALNY plik ini w Notatniku z Windows XP. Powinien byc zgodny z Unicode, jesli ktos wczesniej nie edytowal go w Wordzie :)
  • Poziom 16  
    Ad.1. Nie da się nic z tym zrobić? Wychodzi, że jakieś 5" z biedronki za 200zł jest funkcjonalniejsze od Sony?

    Ad.2.
    Tak wygląda mój plik Desktop.ini:

    Code:

    ################################
    #
    #  Ustawienia
    #
    ################################

    GLOBALSETTINGS
    ShowMessage = 0
    QuitOnDoubleClick = no
    X = 0
    Y = 0
    Width = 480
    Height = 272
    Arrange = No
    BackgroundBitmap = ..\BG\Europe.bmp
    StartUpAnimation = NoAnimation
    ShutDownAnimation = NoAnimation
    Accelerated = yes
    TopMost = no

    ################################
    #
    #  Napis na górnym pasku
    #
    ################################

    TEXT
    x = -10
    y = 1
    Text =
    Color = BBBBBB
    FrameColor = 000000
    Size = 14
    Weight = 500
    CreateFont

    ################################
    #
    #  Przycisk 1
    #
    ################################

    ICONXPBUTTON
    x = 22
    y = 24
    NewIni = ..\AutoMapa.lnk
    SizeNormal = 48
    SizePushed = 128
    ScaleAlpha = 80
    IconNormal = ..\Icons\iphone\map.ico
    ScaleAlpha = 100
    IconPushed = ..\Icons\iphone\map.ico
    QuitOnExecute = no
    ShutDownAnimation = NoAnimation

    TEXT
    x = 44
    y = 2
    Text = Nawigacja
    Color = BBBBBB
    FrameColor = 000000
    Size = 20
    Weight = 900
    CreateFont

    ################################
    #
    #  Przycisk 2
    #
    ################################

    ICONXPBUTTON
    x = 172
    y = 24
    NewIni = Multimedia.ini
    SizeNormal = 48
    SizePushed = 128
    ScaleAlpha = 80
    IconNormal = ..\Icons\iphone\ipod.ico
    ScaleAlpha = 100
    IconPushed = ..\Icons\iphone\ipod.ico
    QuitOnExecute = no
    ShutDownAnimation = NoAnimation

    TEXT
    x = 196
    y = 2
    Text = Rozrywka
    Color = BBBBBB
    FrameColor = 000000
    Size = 20
    Weight = 900
    CreateFont

    ################################
    #
    #  Przycisk 3
    #
    ################################

    ICONXPBUTTON
    x = 322
    y = 24
    NewIni = Office.ini
    SizeNormal = 48
    SizePushed = 128
    ScaleAlpha = 80
    IconNormal = ..\Icons\iphone\mail.ico
    ScaleAlpha = 100
    IconPushed = ..\Icons\iphone\mail.ico
    QuitOnExecute = no
    ShutDownAnimation = NoAnimation

    TEXT
    x = 364
    y = 2
    Text = Biuro
    Color = BBBBBB
    FrameColor = 000000
    Size = 20
    Weight = 900
    CreateFont

    ################################
    #
    #  Przycisk 4
    #
    ################################

    ICONXPBUTTON
    x = 22
    y = 120
    NewIni = Tools.ini
    SizeNormal = 48
    SizePushed = 128
    ScaleAlpha = 80
    IconNormal = ..\Icons\iphone\tools.ico
    ScaleAlpha = 100
    IconPushed = ..\Icons\iphone\tools.ico
    QuitOnExecute = no
    ShutDownAnimation = NoAnimation

    TEXT
    x = 44
    y = 248
    Text = Ustawienia
    Color = BBBBBB
    FrameColor = 000000
    Size = 20
    Weight = 900
    CreateFont

    ################################
    #
    #  Przycisk 5
    #
    ################################

    ICONXPBUTTON
    x = 172
    y = 120
    NewIni = games.ini
    SizeNormal = 48
    SizePushed = 128
    ScaleAlpha = 80
    IconNormal = ..\Icons\iphone\wallpaper.ico
    ScaleAlpha = 100
    IconPushed = ..\Icons\iphone\wallpaper.ico
    QuitOnExecute = no
    ShutDownAnimation = NoAnimation

    TEXT
    x = 220
    y = 248
    Text = Gry
    Color = BBBBBB
    FrameColor = 000000
    Size = 20
    Weight = 900
    CreateFont

    ################################
    #
    #  Przycisk 6
    #
    ################################

    ICONXPBUTTON
    x = 322
    y = 120
    NewIni = Info.ini
    SizeNormal = 48
    SizePushed = 128
    ScaleAlpha = 80
    IconNormal = ..\Icons\iphone\browser.ico
    ScaleAlpha = 100
    IconPushed = ..\Icons\iphone\browser.ico
    QuitOnExecute = no
    ShutDownAnimation = NoAnimation

    TEXT
    x = 356
    y = 248
    Text = System
    Color = BBBBBB
    FrameColor = 000000
    Size = 20
    Weight = 900
    CreateFont

    ################################
    #
    #  Przycisk X
    #
    ################################

    ICONXPBUTTON
    x = 440
    y = 230
    NewIni = ..\Soft\VisualGPSce.exe
    SizeNormal = 36
    SizePushed = 64
    ScaleAlpha = 30
    IconNormal = ..\Icons\Zarowka.ico
    ScaleAlpha = 30
    IconPushed = ..\Icons\Zarowka.ico

    TEXT
    x = 180
    y = 120
    Text =
    Color = BBBBBB
    FrameColor = 000000
    Size = 20
    Weight = 900
    CreateFont

    ################################
    #
    #  Czas - zegarek
    #
    ################################

    #TIME
    #x =5
    #y = 1
    #Color = FFFFF
    #Format = H':'mm
    #Interval = 60000
    #Size = 14
    #Weight = 500
    #CreateFont

    ################################
    #
    #  Bateria
    #
    ################################

    BATTERY
    x = 450
    y = 4
    Width = 25
    Height = 12
    ColorBattery = A0A0A0
    ColorHigh = 00A000
    ColorLow = A0A000
    ColorCritical = A00000
    Segments = 3
    Interval = 1000
    CoolBattery = no


    Otwary z notatnika z oryginału.
  • Poziom 38  
    1. Sony jest dobre w robieniu telewizorow.I na tym powinno sie skupic. A o tym, ze 2 lata temu WYCOFALO sie z produkcji urzadzen GPS, to pewnie nie slyszales? :) Zastanow sie dlaczego :)

    2. przyjzyj sie plikowi wskazanemu we wpisie:
    NewIni = ..\AutoMapa.lnk
  • Poziom 16  
    Przyjrzałem się :)
    Zrobiłem "Skrót to AutoMapa Eu.exe", zmieniłem nazwę na "AutoMapa" i wkleiłem do \Mounted Volume\Iphone\Files\
    I co zrobiłem źle?
  • Poziom 38  
    Nie mecz juz ludzi i zacznij myslec ;/ Twoj post swiadczy o tym ze patrzyles, ale sie nie przyjrzales :)
    Wyciagnij wnioski z postow ktore zostaly juz napisane, zamiast powielac pytania, na ktore masz juz odpowiedzi ;/

    Zamiast skrotu (LNK) mozesz przeciez uzyc linku bezposredniego do pliku, ktory podalem - tak jest prosciej i dziala ;/

    To jest forum techniczne (nie przedszkole teleinformatyczne ;) ) - wymagamy tu jednak pewnych PODSTAW wiedzy na temat tego, co robimy...

    A takze umiejetnosci syntezy wiedzy juz uzyskanej, chociazby w danym watku.

    ...A jako ze Pakiet ktory wgrales, jest dostepny komercyjnie takze na Allegro - user: 123koala), zwroc sie do jego sprzedawcy / Tworcy o wyjasnienie kwestii konfiguracyjnych - na Forum staramy sie wyjasniac PROBLEMY z urzadzeniami, a nie zajmowac sie korekta scierzek dostepu w Pakietach, Komercyjnych, ktore ktos bez wiekszego celu pokomplikowal ;/

    Ja uwazam za nieetyczne sciagniecie odblokowania z Allegro czy z innego Chomika, a nastepnie walkowanie Forum tylko po to, by zorientowac sie, jak uruchomic ta nieszczesna Automape ;) To jest rola TWORCY Pakietu (masz do niego kontakt!)- on go zna najlepiej i powinien Tobie w tym pomagac!
  • Poziom 16  
    Ja mam zacząć myśleć. Przecież Ci napisałem, jaki Twoja komenda daje rezultat.
    Code:
    Wysłany: 26 Paź 2010 08:39    Temat postu: Re: Nav-U 93tc sirf / mnea
    
    Na komendę:
    Kod:
    Command = "\Mounted Volume\AutoMapa EU\wce42Am.exe"
    odpowiada:
    Kod:
    Die Datei ist leer oder nicht im Unicode Format:

    I na pewno nie jest to wina notatnika, którego użyłem. Napisałem również dlaczego.

    Ale jak się nie wie, to można napisać cokolwiek... Chociażby, że ktoś nie ma podstaw, czy nie analizuje, tego co chce mu się przekazać, mimo iż nie chce mu się nic przekazać.
    Ale tacy już jesteśmy-jako ludzie.
    Tak jak w podstawówce na klasówce. Albo ktoś wiedział, umiał i miał gdzieś czy ktoś od niego ściąga, a nawet czasem mu pomagał. Albo ktoś był snobem i uważał to, że on wie nie oznacza, że z kimkolwiek ma się dzielić... A nawet czasem się śmiał i dogryzał tym co nie wiedzieli. I tak trochę jest z tym forum...
  • Moderator - GSM
    j4rek napisał:

    Witam, temat jest zamknięty, ale mam rozwiązanie problemu z tego tematu: W sekcjach danego klawisza/ikony należy usunąć linię "ShutDownAnimation = NoAnimation". Pozdrawiam