Elektroda.pl
Elektroda.pl
X
SterControl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

S7-1200 komunikacja modbus omron v1000

26 Paź 2010 20:40 2897 6
  • Poziom 10  
    Witam
    Mam problem z komunikacją sterownika siemens z falownikiem omron v1000. Korzystam z gotowej biblioteki komunikacyjnej która znajduje się w 1200. Program stworzyłem zgodnie z instrukcją jaką można znaleźć na stronie siemensa. Sterownik wysyła dane ponieważ blok biblioteki pokazuje status "busy" lecz komunikacja nie kończy się poprawnie ponieważ nie otrzymuje potwierdzenia ze strony slave(falownika), ani nie mogę pobrać bądź wysłać do niego danych. Używam portu komunikacyjnego RS-485.
  • SterControl
  • Poziom 11  
    Witam
    Ja walczę z komunikacją modbus z tym samym falownikiem tylko ze za pomocą sterownika unitronics V280. I też mam z tym duży problem niby wszystko jest ok ale nie mogę odczytać rejestrów falownika. Jednakże udało mi się ostatnio ustawiać częstotliwość falownika z panelu, chociaż nadal występuje błąd komunikacji. Jak możesz prześlij mi swój program luknę na niego może coś ci podpowiem bo już dużo na temat tej komunikacji naczytałem. Pozdrawiam
  • SterControl
  • Poziom 25  
    Pytanie: dotyczy falownika

    - czy w falowniku są ustawione parametry pracy sieci Modbus?
    - czy zadawanie prędkości i rozkazów ruchu jest ustawione na Modbus?
    - czy jest ustawiony numer Slave`a?
    - czy połączenie kablowe jest wykonane poprawnie?
    - czy są założone terminatory?
  • Poziom 11  
    Przewody komunikacyjne należy podłączyć do R+ i R- , trzeba także połączyć zworą R+ z S+ i R- z S-. Spróbuj wysłać jakąś liczbę do rejestru 02H. Pozdrawiam
  • Poziom 10  
    mawi2 napisał:
    Pytanie: dotyczy falownika

    - czy w falowniku są ustawione parametry pracy sieci Modbus?
    - czy zadawanie prędkości i rozkazów ruchu jest ustawione na Modbus?
    - czy jest ustawiony numer Slave`a?
    - czy połączenie kablowe jest wykonane poprawnie?
    - czy są założone terminatory?


    Drogi kolego gdybym nie był tego pewny nie zawracał bym nikomu gitary na forum:)
    Problem rozwiązałem, okazało się, że parametr który ustawiałem wg instrukcji falownika RTS( instrukcja falownika podawała, że dla RS 485,RTS w falowniku musi być zawsze włączony) natomiast miał być wyłączony tak jaki i po stronie sterownika:) ot cały problem. Teraz sygnały szaleją po magistrali jak trzeba:P Dziękuję bardzo wszystkim za zainteresowanie. Pozdrawiam Karol
  • Poziom 20  
    Dołączę się do tematu . Zabrałem się z ciekawości do podłączenia Modbus w S7-1200 ( 1214C DC/DC/DC ) z procesorem komunikacyjnym CM1241 ( 241-1CH31-0XB0 ) . No i problem :cry: . Na procesorze widać że dioda TX mruga , mogę zadawać zmienne w programie ( RUN , Częstotliwość itp. ) natomiast nie mruga dioda RX i nie odbieram nic z V1000. Ponadto jak zmostkuję styki w przemienniku R+ z S+ i R- z S- przemiennik wyrzuca mi CE ( comunnication error ) spotkał się ktoś z takim wątkiem? czemu CM1241 wysyła a nic nie odbiera ?
  • Poziom 20  
    Zamieniłem V1000 na inny . Stary wylądował w koszu - uszkodzony :D . Zamykam temat