Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Bootloader Windows 7 długo się uruchamia

Afghan 24 Lis 2010 12:26 4978 8
  • #1 24 Lis 2010 12:26
    Afghan
    Poziom 11  

    Witam. Mam dziwny problem, otóż zainstalowałem wczoraj Windowsa 7 Ultimate na dysku którym miałem Windowsa XP. Windows 7 na partycji D:, a XP jest na partychji C:. Windows 7 zainstalował bootloadera. Teraz jak włączę komputer to zanim bootloader się załączy to przez jakieś 2-3 minuty jest czarny ekran. Później jak się pojawi już wszystko jest OK, wybieram który kolwiek system i się wszystko uruchamia jak potrzeba, ale czemu tak długo trwa zanim bootloader się pojawi. Dałem fixboot z konsoli płytki Windowsa XP, no i po włączeniu komputera XP uruchamia się prawidłowo, no oczywiście bootloadera już niema. Drugi raz zainstalowałem Windowsa 7 z myślą, że przy pierwszej jego instalacji poszło coś nie tak i może teraz dobrze nadpisze MBR, no ale znowu było to samo i na bootloader czekałem znowu z 2-3 minuty. Dodam, że Windows 7 jakoś sobie inaczej to wszystko przetwarza i jak się wejdzie w W7 to ta partycja na której jest zainstalowany W7 jest tu pokazane że to partycja C:, a jak się wejdzie w XP to XP jest na partycj C:. Ale podobno W7 tak robi i jest to prawidłowo. Nie wiecie co to może być?

    EDIT 1 Mam Hirens.BootCD, uruchomiłem komputer właśnie z tej płytki i w niej jest też jakiś bootloader, bo jest tam jakaś ramka w której można wybrać który system uruchomić. Gdy wybiorę w menu Hirens.BootCD.10.6 Windows XP to uruchamia się odrazu, a gdy wybiorę Windows 7 to znowu pojawia się czarny ekran na 2-3 minuty i po tym czasie dopier pokazuję się bootloader Windowsa 7 w którym znowu można wybrać który system uruchomić Windows XP czy Windows 7

    0 8
  • #2 24 Lis 2010 18:37
    helmud7543
    Poziom 42  

    1. Sprawdź dysk pod kątem uszkodzeń.
    2. System niezależnie od innego systemu instalowane na tym samym dysku/komputerze przypisuje literki partycjom i innym napędom, standardowo na tej na której jest zainstalowany przypisuje C:, więc dla XP C: będzie to jego własna (na której jest on sam), dla 7 również C: będzie jego własna (czyli ta na której jest 7).

    0
  • #3 24 Lis 2010 19:04
    Afghan
    Poziom 11  

    Dysk sprawdzałem i żadnych uszkodzeń nie ma. A może jakby zainstalował jakiś niezależny bootloader, nie wiecie czy jest jakiś? Ja już szukałem ale nic konkretnego nie znalazłem.

    0
  • #4 25 Lis 2010 01:38
    WojtasJD
    VIP Zasłużony dla elektroda

    Afghan napisał:
    A może jakby zainstalował jakiś niezależny bootloader, nie wiecie czy jest jakiś? Ja już szukałem ale nic konkretnego nie znalazłem.

    Wątpie czy to coś zmieni - jak odpalasz Hirens'a to już masz konkretny :D bootloader: GRUB4DOS - jak wybierasz z menu XP to ten szuka \ntldr a jak wybierasz Win7 - szuka \bootmgr a strzelam, że po wczytaniu \bootmgr jest zwłoka.

    Jest jakaś reakcja na [spację] ?

    Podaj model HDD, płyty głównej i rozkład partycji z menedżera dysków (diskmgmt.msc)

    0
  • #5 25 Lis 2010 08:55
    Afghan
    Poziom 11  

    WojtasJD napisał:

    Jest jakaś reakcja na [spację] ?

    Podaj model HDD, płyty głównej i rozkład partycji z menedżera dysków (diskmgmt.msc)


    Na spację brak jakiejkolwiek reakcji

    Dysk - Seagate ST3500418AS 500 GB
    Płyta - Asrock K10N78D
    Partycje:
    Wszystkie NTFS
    C: - 200,83 GB Zdrowy (Rozruch, Plik stronicowania, Zrzut awaryjny, Dysk logiczny)
    D: - 101,62 GB Zdrowy (System, Aktywna, Partycja podstawowa)
    E: - 163,30 GB Zdrowy (Dysk logiczny)

    Cytat:
    jak wybierasz Win7 - szuka \bootmgr a strzelam, że po wczytaniu \bootmgr jest zwłoka


    zgadza się tkj. napisałem w pierwszym poście po wybraniu w Hirens.BootCD.10.6 Windowsa 7 znów trzeba czekać jakiś czas, po czym pojawia się bootloader W7 i w nim znów można wybrać który system uruchomić i już stąd system uruchamia się od razu.

    0
  • #6 26 Lis 2010 09:06
    Afghan
    Poziom 11  

    To jak?? nie wiecie o co chodzi?? :(

    0
  • #7 26 Lis 2010 09:37
    helmud7543
    Poziom 42  

    No nie za bardzo... Może spróbuj zrobić rozruch na tym dysku, na którym jest system i z niego uruchamiać.

    0
  • #8 26 Lis 2010 10:06
    krzychupar
    Poziom 40  

    Najpierw z płyty instalacyjnej Windows7 spróbować naprawić bootloadera narzędziem do naprawy systemu podczas uruchamiania, później jeżeli masz dwa systemy zainstalować program EasyBCD 2.0.2 na Win7 i poustawiać sobie wybór systemu przy starcie w/g własnego uznania.

    0
  • #9 26 Lis 2010 10:54
    Afghan
    Poziom 11  

    helmud7543 napisał:
    No nie za bardzo... Może spróbuj zrobić rozruch na tym dysku, na którym jest system i z niego uruchamiać.


    No już to próbowałem dwa dni temu i niestety nie pomogło.

    krzychupar napisał:
    Najpierw z płyty instalacyjnej Windows7 spróbować naprawić bootloadera narzędziem do naprawy systemu podczas uruchamiania

    Też próbowałem już to. Naprawa nie pomogła, a też próbowałem drugi raz W7 zainstalować, który powinien wszystko nadpisać i nadal było to samo. Dodam, że przed drugą instalacją W7 dałem z konsoli naprawy systemu z XP fixboot co oczywiście dało tyle, że XP nadpisał MBR i po włączeniu kompa od razu uruchamiał się XP.

    0