Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Makro Excel nie oblicza formuły.

CrQ 28 Lis 2010 23:56 2278 3
  • #1 28 Lis 2010 23:56
    CrQ
    Poziom 11  

    Witam.
    Mój problem wygląda następująca, mam dużo plików w których chciałem zsumować jedną kolumnę a następnie dopisać tą wartość do nazwy pliku. Makro które mam dodaje formułę lecz niestety jej nie przelicza tak więc po otwarciu pliku mam kratki zamiast wyniku (jeśli zaznaczę komórkę i ja przeliczę wartość się wyświetla lecz mi to nic nie daje).
    Oto moje makro:

    Code:

    Sub czytajpliki_Click()
    Dim linia, sciezka, fs As Object, f, f2, k
    Application.ScreenUpdating = False
    sciezka = "D:\Analiza\przeliczone\"
    Set fs = CreateObject("Scripting.FileSystemObject")
    Set f = fs.GetFolder(sciezka).Files

    For Each f2 In f
        If Right(f2, 3) = "xls" Then
            Workbooks.OpenText Filename:=f2
           
        Range("C2").Value = "=SUMA(C4:C1441)"


        ActiveWorkbook.SaveAs Filename:="D:\Analiza\" & Worksheets(1).Name & ".xls", FileFormat:=xlNormal
       
        ActiveWorkbook.Close SaveChanges:=False
        End If
       
       
    Next
    Application.ScreenUpdating = True
    End Sub

    Mógł by mi ktoś napisać dlaczego mi to nie chce działać, oraz jak dopisać tą wartość do nazwy pliku ?
    Serdecznie pozdrawiam.

    0 3
  • Pomocny post
    #2 29 Lis 2010 00:40
    Aldrin
    Poziom 22  

    Zamiast Range("C2").Value = "=SUMA(C4:C1441)"

    Code:
    Range("C2").FormulaLocal = "=SUMA(C4:C1441)"


    Dopisanie wartości do nazwy pliku:
    Code:
    "D:\Analiza\" & Worksheets(1).Name & "-" & Range("C2").Value & ".xls"

    0
  • #3 29 Lis 2010 10:57
    CrQ
    Poziom 11  

    Dziękuje bardzo :) wszystko działa idealnie.

    0