Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Stacja lutownicza Avt-5228 (Atmega16)

Soulfly 19 Nov 2013 09:24 64369 114
Altium Designer Computer Controls
  • #91
    raven.1
    Level 9  
    Witam,
    Czy można do tej stacji użyć trafa 2x12 100W?
  • Altium Designer Computer Controls
  • #92
    Majtek
    Level 12  
    można, będziesz mia większy zapas mocy. Napięcie przy grzaniu nie będzie spadać.
  • #93
    nyquist
    Level 25  
    Witam,
    również przymierzam się do złożenia opisanej stacji, ale wcześniej chciałbym zapytać Kolegów, którzy już mają to za sobą, o kilka rzeczy, które mnie zastanowiły po zagłębieniu się w temat:

    1. Czy próbował ktoś po złożeniu układu programować Atmegę nie przez JTAG, ale ASP (np. UsbASP), czy nie będzie z tym problemu (oczywiście po podpięciu pod odpowiednie piny)?

    2. I jeszcze pytanie do autora pierwotnego projektu - czy istnieje może jakaś nowsza wersja wsadu (pytam, bo wspominał kolega o uwzględnianiu ewentualnych sugestii, nowych funkcjach, nie żeby pierwotna była zła).
  • #94
    raven.1
    Level 9  
    Ja też zapytam autora, czy jest jakaś możliwość ingerencji w soft? Zamieszczono chyba tylko pliki hex i bin, z którymi nie da się raczej nic zrobić :-/
  • Altium Designer Computer Controls
  • #95
    nyquist
    Level 25  
    Chciałbym poinformować, że dołączyłem go grona osób, które wykonały stację. Urządzenie jest po kilku pierwszych uruchomieniach oraz procedurze samostrojenia.
    Co do wykonania, to PCB według wzoru, metoda termotransferowa (żelazko), Atmega zaprogramowana za pomocą UsbASP ("dorobione" złącze), całość lutowana "transformatorówką", z Atmegą włącznie (ciężko było, ale da się) ;-) , wszystko upakowane do obudowy po zasilaczu ATX, kolba Zhaoxin ESD.
    Pozdrawiam, dziękując jednocześnie autorowi projektu :-)
  • #97
    User removed account
    User removed account  
  • #98
    dareck70
    Level 2  
    Szkoda, że moja odpowiedź trafiła do kosza. Żeby nie raziło nikogo moje wykonanie napiszę tylko, że stacja zrobiona i działa:
    Stacja lutownicza Avt-5228 (Atmega16)
    Pozdrawiam, Darek.
  • #99
    Freddy
    Level 43  
    Tylko co tu może inspirować, "glut" użyty do instalacji, bałagan w kablach, czy Twoje zniechęcenie do DIY ?
    Quote:
    ... To moje ostatnie DIY czegoś co można normalnie kupić. Teraz wiedząc przez co przeszedłem i ile czasu poświęciłem kupiłbym gotową lutownicę w sklepie.
  • #100
    electricianul
    Level 12  
    A też zapytam autora, czy jest jakaś możliwość zaprograniem USBasp
  • #101
    nyquist
    Level 25  
    electricianul wrote:
    A też zapytam autora, czy jest jakaś możliwość zaprograniem USBasp

    Pytanie co prawda do autora, ale swoje urządzenie programowałem właśnie przez USBasp, o czym napisałem wcześniej. Należy tylko wcześniej wyprowadzić sobie złącze (zgodnie z notą katalogową układu), gdyż projekt go nie przewiduje. Z samym programowaniem nie miałem żadnych problemów. Pozdrawiam.
  • #102
    Zygmek53
    Level 10  
    Witam. Mam płytkę w EAGLE zaprojektowaną według sugestii darekkro, (post 80) z gniazdem na USBasp, ale wydaje mi się że to autor powinien wyrazić zgodę na jej publikację. Stacja pracuje bardzo dobrze od kilku miesięcy, nie mam z nią żadnych problemów. Jest to trzecia stacja jaką wykonałem i chyba najlepsza jeśli chodzi o program, co za tym idzie funkcjonalność.
  • #103
    krychast
    Level 20  
    Podepnę się pod temat.Przerabiał ktoś płytkę ale klasycznie pod THT?
  • #104
    Janek Bień
    Level 18  
    Tak przyglądam się temu tematowi bo mam tez stacje lutownicza w której przydało by się wymienić elektronikę na "lepiej działającą "

    przyglądając się konstrukcji tej stacji oraz bardzo podobnej RL1 ( AVT-987)
    widzę że układ został żywcem z kopiowany a wraz z nim powielone pewne błędy i niedopracowania.

    po1 to chciał bym zadać pytanie autorowi projektu jak zrealizowana jest kompensacja zimnego końca termopary ? czy jest to zaimplementowane w programie ? bo na schemacie nie widzę .

    po2 w związku z kwestią kompensacji zimnego końca jak i zastosowanego wzmacniacza operacyjnego czy nie prościej było dać bardziej popularny i tańszy wzmacniacz np TLC277 oraz dodać podkówkę do zerowania a zarazem ustalenia kompensacji zimnego końca czyli taki zwykły off-set.

    po3 . wejście pomiarowe z termopary wzmacniacza operacyjnego wisi w powietrzu
    i jest obciążone tylko samą termopara . To jest bardzo poważny błąd konstrukcyjny ..
    ponieważ w przypadku uszkodzenia kabla , styku , czy samej termopary wejście
    faktycznie “wisi" w powietrzu i układ zachowa się w sposób niekontrolowany np .
    aktualna temperatura będzie ciągle niska - układ będzie ciągle grzał w wyniku czego grzałka się uszkodzi . ..
    Należy to zmienić . Przydał by się jakiś obwód z filtrem low-pass a sam koniec termopary dobrze jest podciągnąć do zasilania jakimś dużym rezystorem parę Mohm .
    wtedy gdy dochodzi do uszkodzenia kabla lub termopary układ wykrywa to jako przegrzanie lub nawet jako wyjście poza zakres i wyświetla błąd nie dopuszczając do uszkodzenia grzałki ...

    po4 wzmacniacz operacyjny można było zasilić z jednej strony napięciem 5V dodatkowy stabilizator napięcia +9V jest zbędny
    a sam układ zasilania bym przerobił tak aby korzystać ze zwykłego transformatora z pojedynczym napięciem 24V Napięcie ujemne można wytworzyć za pomocą podwajacza napięcia zasilanego z jednego z zacisków transformatora .

    po5 Po co w układzie obsługa detekcji przejścia przez zero a w związku z tym
    układ na komparatorze skoro działanie układu nie opiera się na idei regulacji fazowej ?
    a sama grzałka jest załączana na dłuższy czas jak okres napięcia sieci ?
    Jeśli celem miało być tylko zmniejszenie zakłóceń to daje się optotriaka z detekcja zera
    zapominamy o reszcie.

    po6 jeśli z jakiegoś powodu konieczna jest już detekcja zera sieci to można to zrobić prościej jednym tranzystorem i paroma rezystorami komparator jest owszem dobrym - precyzyjnym rozwiązaniem gdy zachodzi potrzeba bardzo stabilnego i dokładnego wyznaczenia zera sieci z zachowaniem wysokiej symetrii i z dokładnością do paru uS

    po7 kłopoty z LCD wynikają ze zbyt uproszczonego rozwiązania translacji poziomów pomiędzy logika 5v a 3v . Jak już na upartego ktoś chce powielić to co już kiedyś widział to można było by spróbować dać dzielniki napięcia o mniejszych wartościach rezystancji
    Chodzi o zmniejszenie impedancji linii sygnałowych SPI w celu ograniczenia wnikania zakłóceń . Wzmianka o stosowaniu precyzyjnym rezystorów w tym przypadku to już całkiem niepotrzebne i nieprawda ..
    Nie wiem na jakiej prędkości taktowania działa to SPI do LCDka ale
    można było jeszcze poeksperymentować z dodatkowymi niewielkimi kondensatorami na liniach SPI ( około 50-200pF ) ale wszystkie te rozwiązania nie są odpowiednie w tej aplikacji. Takie rozwiązania są tylko na laborke dobre a nie do urządzeń które maja działać .
    Jedyna słuszna droga to tak jak ktoś wcześniej podpowiadał bardzo mądrze aby cała cześć cyfrowa działała na logice 3V lub zastosowanie bramek - buforów typu LVC .zasilanych napięciem 3v Dzięki właściwości 5V tollerant serii LVC mamy szybkie, proste i pewne rozwiązanie problemu dopasowania napięć ..

    Zamiast potencjometru dał bym impulsator . zrezygnował bym wtedy z zakresów regulacji
    i dał ciągłą od 60-450stC.
    w menu kalibracji powinien być off-set albo hardwarowy na podkówce ale musi być
    bo zastosowanie różnych materiałów na styki okablowania termopary zawsze będzie powodować rożny offset więc nici z dokładnego i precyzyjnego wzmacniacza operacyjnego jak reszta nam wprowadza błędy pomiarowe.....


    Chętnie bym przeprojektował wszystko od nowa
    tak aby postarać się poprawić konstrukcje i usunąć ewentualne niedomagania układu
    Jeśli tylko zgodę na to wyrazi autor . A jak by jeszcze był chętny na drobne zmiany w programie to możemy naprawdę zrobić fajny sterownik do lutownicy
    Na pewno znajdzie się wielu chętnych na wymianę oryginalnej elektroniki popularnych chińskich stacji lutowniczych na cos co działa jak należy..
    Z mojej strony jestem otwarty na "współprace" bo i mi przydało by się coś zrobić z moja chińską stacją ..
  • #105
    kiedmar
    Level 2  
    Witam wszystkich.
    Jak widzę dyskusja dot. stacji troszkę przycichła. Pozwolę sobie jednak wrócić do tematu, ponieważ niedawno postanowiłem unowocześnić swoją stację lutowniczą i zmajstrowałem ten sterownik z małymi przeróbkami. Nie mogę niestety stwierdzić czy wszystko jest OK, ponieważ niestety mam problem z wyświetlaczem. Ten problem był już sygnalizowany, ale nie natrafiłem na żadną informację o rozwiązaniu tego problemu. Poszperałem w necie i okazało się, że do tel. NOKIA 3510i stosowano wyświetlacze różnych producentów/wytwórców (przynajmniej 3). Okazuje się, że pomimo że w tel. pracują one poprawnie, w innych aplikacjach już niekoniecznie. Tak było też i w moim przypadku i nie tylko. Chcąc to sprawdzić podłączyłem posiadany wyświetlacz na "pająka" pod uP z programem testowym, wszystko zasilane nap. +3.3V. Wyświetlacz ożył. Wniosek z tego jest taki, że nie wyświetlacze od N3510i są problemem, a oprogramowanie Atmegi16 przygotowane wyłącznie pod jeden model/typ wyświetlacza. Zatem uruchomienie stacji to loteria i zależy od szczęścia i typu użytego wyświetlacza. Pozostaje zatem polowanie na odpowiedni typ wyświetlacza, chyba że autor tego projektu dysponując kodem źródłowym dokonałby korekty oprogramowania (wg. mnie problem tkwi w sposobie inicjalizacji wyświetlacza).

    P.S. Problem z wyświetlaczami do N3510i opisano na tym forum pt. Wyświetlacz nokia 3510i nie rusza

    Pozdrawiam
  • #110
    nyquist
    Level 25  
    kamil1994zielony wrote:
    Czy ma ktoś jakiś dobry patent jak dobrze i równomiernie podświetlić wyświetlacz ?

    Sam nie byłem zachwycony oryginalnym podświetleniem Nokii, więc usunąłem tylną folię (lusterko) i podświetliłem wyświetlacz od tyłu białymi diodami LED. Po modyfikacji wyświetlacz jest bez problemu czytelny nawet w jasnym świetle. Pozdrawiam.
    Stacja lutownicza Avt-5228 (Atmega16)
  • #112
    nyquist
    Level 25  
    krychast wrote:
    Co to za obudowa, przełączniki?

    Jeżeli pytanie było skierowane do mnie, to przyciski typu PBS26BR, natomiast obudowa ze standardowego zasilacza ATX + jakaś grubsza blacha aluminiowa z odzysku na front.

    Janek Bień wrote:
    Chętnie bym przeprojektował wszystko od nowa
    tak aby postarać się poprawić konstrukcje i usunąć ewentualne niedomagania układu (...)

    Czy udało się koledze skontaktować autorem układu? Jest szansa na wspomniane modyfikacje?
    Osobiście, z perspektywy czasu, najbardziej drażni mnie konieczność ciągłego przełączania pomiędzy zakresami regulacji temperatury, idealny byłby tu enkoder.
  • #113
    Krater28
    Level 18  
    Witam
    Myrek1 wrote:
    I jak działa? Pytam bo jestem autorem tej konstrukcji :)
    Może jakieś sugestie co do poprawek w sofcie? Z perspektywy czasu wydaje się, że lepiej jest dać automatyczne włączenie grzania po włączeniu lutownicy.

    Temat stanął bo autor projektu AVT-5228 milczy jak grób a jak widać chciał wysłuchać opinii i propozycji zmian od innych użytkowników - pytanie czy brak czasu czy jakaś umowa długoterminowa z AVT?

    Do propozycji "Janek Bień" dodał bym jeszcze możliwość wyboru w menu typu termopary. Ogólnie propozycje modernizacji są dość gruntowne więc można by dodać możliwość podłączania różnych typów lutownic - zamontować parę gniazd z przypisanym typem termopary i wybierać z menu lub lepiej przyciskiem konkretne gniazdo które ma być grzane i monitorowane w danym momencie.
    Może mam dziwny pomysł ale zastanawiam się czy by nie zrobić lutownicy pęsetowej z dwóch lutownic z termoparami (do konstrukcji można by wykorzystać same grzałki z termoparą do tychże lutownic) - wtedy trzeba by monitorować dwie termopary.
  • #114
    MORT
    Level 24  
    W sumie dobry pomysł. Generalnie nie to żebym narzekał na działanie Avt-5228 bo od kilku lat działa u mnie w warsztacie bez przerwy ale gdyby obsługiwała ta stacja kolby Wellera to byłoby pięknie wmrp albo jeszcze lepiej wmrt.
  • #115
    mkmar
    Level 11  
    darekkro wrote:
    Uważam,że autor niepotrzebnie skomplikował budowę stacji,co często powoduje zawieszanie się wyświetlacza LCD sterowanego przez dzielniki napięcia.
    Osobiście zamiast stabilizatora 3,3V dałem mostek,a stabilizator 3,3V dałem w miejsce stab. 5V, czyli zasiliłem całość nap.3,3V.
    W takim wypadku aby uzyskać pełny zakres pomiarowy, trzeba zmostkować rezystor R12.
    Usunąć niepotrzebne rezystory R15,R18,R19 i zmostkować R14,R16,R17.
    Sprawdzić czy zastosowana ATMEGA16 przystosowana jest do pracy na napięciu 3,3V i 16MHz i ewentualnie na taką podmienić..
    Aby podświetlanie nie było zbyt słabe zamieniamy R20,R22 na 68ohm.

    UWAGA!!!

    Po modyfikacji, by nie uszkodzić wyświetlacza, bezwzględnie odłączamy go na czas podłączenia sterownika do programatora, aby nie pojawiło się nap. 5V na wyświetlaczu.
    Jeszcze tylko BODLEVEL ustawiamy na 1 (niezaprogramowany) i cieszymy się bezproblemową pracą wyświetlacza.


    W/g datasheeta na 3,3V może pracować Atmega16L i to na 8 MHz, natomiast Atmega16 tylko 5V i 16 MHz. W takim razie którą Atmegę można zastosować w takim przypadku?