Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Stacja lutownicza Avt-5228 (Atmega16)

Soulfly 16 Gru 2010 18:43 62710 114
  • Stacja lutownicza Avt-5228 (Atmega16)

    Oglądając wiele umieszczonych tutaj konstrukcji postanowiłem zbudować swoja stację lutowniczą.
    Wybór padł na opracowanie zamieszczone w Elektronice Praktycznej 4/2010. Na temat elektroniki nie będę się rozpisywał,
    jedynie dodam, że płytkę zrobiłem metodą fotochemiczną. Więcej tutaj: Link. Kolba lutownicy to popularny SL-IN Solomona.
    Obudowę wykonałem z blachy ocynkowanej o grubości 0,5mm. Następnie polutowałem elementy i zaszpachlowałem miejsca lutowania.
    Panel przedni wydrukowałem na papierze samoprzylepnym i zabezpieczyłem folią samoprzylepną.

    Co nieco o wyświetlaczu. Wyświetlacz pochodzi z Nokii 3510i, koszt około 7zł. Lcd ma poważną wadę - trudno go równomiernie podświetlić.
    Ja usunąłem oryginalną plastykową ramkę. Lcd przykleiłem do płytki z plexi (gr. 5mm) o tych samych wymiarach co wyświetlacz.
    W plexi nawierciłem 2 otwory, w które wsunąłem diody 3mm. Mimo starań nie udało mi się go równomiernie podświetlić.

    Trochę u użytkowaniu.
    Przyciskiem 1 od lewej ustawiamy skokowo zakres temperatury co sto stopni, wywołujemy menu (100, 200, 300, 450).
    Następny przycisk to sleep do usypiania oraz w górę.
    Ostatni to On/Off i w dól.
    Potencjometrem ustawiamy dokładnie temperaturę w zakresie 0-100 stopni (w wybranym zakresie).
    Lutownica sprawuje się wyśmienicie, od 25 st. do 450 st. nagrzewa się w około 60 sekund.

    Stacja lutownicza Avt-5228 (Atmega16)Stacja lutownicza Avt-5228 (Atmega16) Stacja lutownicza Avt-5228 (Atmega16) Stacja lutownicza Avt-5228 (Atmega16)
    Stacja lutownicza Avt-5228 (Atmega16) Stacja lutownicza Avt-5228 (Atmega16)Stacja lutownicza Avt-5228 (Atmega16) Stacja lutownicza Avt-5228 (Atmega16)

    Fajne! Ranking DIY
    Potrafisz napisać podobny artykuł? Wyślij do mnie a otrzymasz kartę SD 64GB.
    O autorze
    Soulfly
    Poziom 12  
    Offline 
    Soulfly napisał 35 postów o ocenie 168, pomógł 1 razy. Mieszka w mieście M-ko Śl.. Jest z nami od 2003 roku.
  • Sklep ElwronSklep Elwron
  • #2
    Myrek1
    Poziom 23  
    I jak działa? Pytam bo jestem autorem tej konstrukcji :)

    Może jakieś sugestie co do poprawek w sofcie? Z perspektywy czasu wydaje się, że lepiej jest dać automatyczne włączenie grzania po włączeniu lutownicy.
  • #3
    H3nry
    Poziom 31  
    Zdecydowanie nie przepadam za AVT ale ten projekt robi naprawdę spore wrażenie .
    Realizacja wzorowa, widać ogrom pracy ale efekt godny naśladowania .
    Jakiej mocy jest ten Solomon ?
  • #4
    voland
    Poziom 15  
    Fajny projekt, bardzo mi się podoba, choć najważniejszym elementem i tak jest kolba, a to na ogół trzeba kupić ( na ogół kupuje się tanią ). Ostatnio kupiłem stację Xytronic 168-3c, jedno analogowe pokrętło do regulacji temperatury i ot cała historia a dokładność +-3 stopnie i bardzo solidna kolba z możliwością doboru wielu grotów. Więc nie trzeba cudów na mikrokontrolerach aby mieć czym porządnie lutować. Ale twoje urządzenie wykonane fachowo, super to wygląda, chyba jedna z lepszych na forum.

    Dodał bym taką blaszaną nakładkę na obudowę pod gąbkę aby nie zniszczyć jej przy czyszczeniu grota, obudowa prezentuje się więc warto by takie coś dodać. Pozdrawiam.
  • #5
    Maticool
    Poziom 20  
    Witam.
    Nie wiem dokładnie jak rozwiązałeś podświetlenie, ale jego równomierność można poprawić ścinają tylną powierzchnie pleksy pod kątem tworząc coś na kształt długiego klina z grubszym końcem tam gdzie są diody. A jeszcze lepiej jest ją lekko zaokrąglić tzn żeby kąt stopniowo rósł w miarę oddalania od diod. Można to zrobić zgrubnie szlifierką a potem drobnym papierem ściernym. Przy okazji uzyskuje się matową powierzchnię rozpraszającą światło. - sprawdzone.
  • Sklep ElwronSklep Elwron
  • #6
    modelloo
    Poziom 12  
    Witam
    super stacja robi wrażenie od dawna czegoś takiego szukałem, pytanie czy jest możliwość zamieszczenia wsadu do procesora i wzoru płytki ?
  • #7
    Pablo_470
    Poziom 12  
    Witam.
    Super konstrukcja. A jak chcesz lepiej podświetlić to spiłuj "czubki" diod led, to będą lepiej rozpraszać światło bo koniec diody działa jak soczewka. Ja tak robiłem i było dobrze.
    Pozdrawiam
  • #8
    muszynsk
    Poziom 12  
    Witam,

    Czy mógłbyś powiedzieć coś o konstrukcji mechanicznej?
    Jak wycinałeś/obrabiałeś blachę?
    Wyrzynarka, nożyce?
    Jak wyciąłeś otwory?

    Pozdrawiam
  • #9
    Karol966
    Poziom 30  
    Witam.

    Wykonanie na wysokim poziomie. Zastanawiam się jakie były problemy z lutowaniem blachy oraz czym wykonałeś w niej otwory np te wentylacyjne jak i pozostałe. Może zamieścisz w tym temacie materiały do jej wykonania dla innych - płytka, wsad/ źródło. W końcu to nie tajemnica ;)

    Dodano po 9 [minuty]:

    Mam jeszcze jedno pytanie do autora projektu. Na komparatorze oraz elementach z nim połączonych jest zbudowany układ detekcji zera prawda? Nie prościej zastosować transoptor z podwójna diodą + 2 rezystory? Sam takie rozwiązanie stosowałem przy sterowaniu fazowym i nie było z nim żadnych problemów. Jedyna trudność to dobranie rezystora przed transoptorem - przydaje się do tego oscyloskop.
  • #10
    szympek;)
    Poziom 20  
    Hej.Konstrukcja godna podziwu.A odnośnie kontrolera to czy dobrze zrozumiałem że na przyciskach góra/dół(na zdjęciu prawo/lewo) ustawiasz temperaturę co 100*c (w ostatnim zakresie 50*c) a na potencjometrze "dokładniej"(co stopień?) ??Pytam bo na zdjęciu masz ustawione 405*c
  • #11
    MORT
    Poziom 24  
    A może ktoś ma płytkę do tego projektu w PDF?
  • #12
    Soulfly
    Poziom 12  
    Lutownica spisuje się świetnie, jedynie może zmieniłbym kolor tła na bardziej kontrastowy.
    Jeśli chodzi o budowę od strony mechanicznej, to blachę wycinałem zwykłymi nożycami do blachy, niestety nie posiadam gilotyny (szkoda). Otwory wycinałem za pomocą wałka giętkiego i Dremela. Otwory wentylacyjne wyciąłem ze starej obudowy z zasilacza pc i wstawiłem do wyciętych otworów w obudowie. Lutowałem zwykłą cyną, wcześniej miejsca lutowania smarowałem mieszanką pasty do lutowania rur miedzianych i kwasu solnego z cynkiem. Aha blachę wyginałem między dwoma kątownikami w imadle.

    Przyciski góra/doł slużą do chodzenia w menu, zakresy 100 - 400 ustawiam przyciskiem range/menu. Potencjometrem dostrajamy temperaturę w wybranym zakresie.
  • #13
    Karol966
    Poziom 30  
    Gdzie można taką pastę kupić? Tzn gdzie to się domyślam, jak się ona nazywa? Bo na pewno jest dużo bardziej aktywna niż jakakolwiek pasta lutownicza, znajdująca się w szufladzie przeciętnego elektronika.

    PS. Dobrze rozumiem, otwory wentylacyjne są wlutowane?
  • #14
    Soulfly
    Poziom 12  
    Karol966 napisał:
    Gdzie można taką pastę kupić? Tzn gdzie to się domyślam, jak się ona nazywa? Bo na pewno jest dużo bardziej aktywna niż jakakolwiek pasta lutownicza, znajdująca się w szufladzie przeciętnego elektronika.


    Obojętnie jak pasta do lutowania rur miedzianych, pełno tego w marketach budowlanych. Ja mam jakąś starą pastę, teraz są lepsze wynalazki.

    karol966 napisał:
    PS. Dobrze rozumiem, otwory wentylacyjne są wlutowane?

    Tak są wlutowane, dobrze widać to na zdjęciach.
  • #15
    malachowski
    Poziom 11  
    Pytanie do autora projektu Myrek1. Czy jest szansa na zmianę softu aby obsługiwał wyświetlacz od Nokia 6100 gdyż ma on już wbudowane podświetlanie.
  • #17
    KGS
    Poziom 23  
    Witam!
    Proszę.Wzory PCB do stacji AVT5228 w postaci formatek zawierających po 6 płytek na arkusz A4.Archiwum zawiera obrazy lustrzane (mirror) oraz bez odbicia lustrzanego (no-mirror) Pozdrawiam! :D
  • #18
    hacker_ice

    Poziom 24  
    Witam,

    Czy mogę wykorzystać do tego projektu, kolbę ze stacji np PT 803? Ma ona 35W, tylko nie wiem jaką posiada termoparę ;/ czy ktoś byłby mi w stanie odpowiedzieć?

    Pozdrawiam,
    Damian
  • #19
    rafik100
    Poziom 11  
    witam
    mam pytanko
    w projekcie jest: kolba(lutownica) np. pensol SL-1, a w podstawowych informacjach napisano, że lutownica o mocy do 40W. I stąd moje pytanie, bo posiadam taka lutownicę (SL-1), ale na mojej napisane jest 48W więc czy można zastosować taką??
    Jeszcze może ktoś napisał by jaki ekran powitalny jest wyświetlany po włączeniu??
    pzdr :)
  • #20
    KGS
    Poziom 23  
    Witam!
    W opisie (spisie elementów) EP 4/2010 napisane jest transformator 2x12V 2A. Więc od jego mocy głównie zależy moc zastosowanej kolby.Pozdrawiam! :D
  • #21
    rafik100
    Poziom 11  
    Super :)
    możesz jeszcze napisać czy 5 nóżkę Atmegi podpiąłeś do VCC?? bo na płytkach nie jest nigdzie podłączona.
    Znalazł jeszcze ktoś jakieś błędy??
  • #22
    zdenek_zdenek
    Poziom 19  
    A jak z wyświetlaczami, czy wszystkie trzy typy pasują czy tylko jeden.
  • #23
    Soulfly
    Poziom 12  
    rafik100 napisał:
    Super :)
    możesz jeszcze napisać czy 5 nóżkę Atmegi podpiąłeś do VCC?? bo na płytkach nie jest nigdzie podłączona.
    Znalazł jeszcze ktoś jakieś błędy??
    Nigdzie jej nie podłączałem, zostawiłem jak jest.
    zdenek_zdenek napisał:
    A jak z wyświetlaczami, czy wszystkie trzy typy pasują czy tylko jeden.
    Wszystkie jakie miałem działały bez problemu.
  • #24
    mirkap
    Poziom 12  
    KGS napisał:
    Witam!
    W opisie (spisie elementów) EP 4/2010 napisane jest transformator 2x12V 2A. Więc od jego mocy głównie zależy moc zastosowanej kolby.Pozdrawiam! :D


    a czy takie trafo będzie dobre?
    Link
  • #26
    mmuppet
    Poziom 2  
    Witam. Super projekt. Właśnie jestem na ukończeniu. Prawie działa, lutownica już grzeje, ale nie działa mi wyswietlacz. Nie wiem czemu. Miał ktoś z was już taki problem? Sprawdzałem połaczenia, wydają się byc ok. Napięcie ze stabilizatora 3,30V czyli idealne. Nic nie wyświetla, Ekran czarny. diody podświetlające działają, jak wcisne sleep to się wygaszają. Wyglada na to że sama lutownica działa ok. Sprawdzałem juz 2 wyswietlacz bo myslalem ze moze poprzedni byl uszkodzony, ale tutaj ten sam objaw. Prosiłbym o pomoc.
  • #27
    drake68
    Poziom 13  
    Sprawdziłeś poprawność połączeń LCD z złączem na PCB bo wygląda to na błąd w połączeniu.
    Stacja lutownicza Avt-5228 (Atmega16)
    Wrzuć fotkę połączenia LCD z PCB.
  • #28
    mmuppet
    Poziom 2  
    Tak sprawdziłem połaczenia miernikiem wg tego schematu i wszystko jest ok.
    Na PCB połączenia od złącza SL3 do wyprowadzeń mikrokontrolera też są w porządku. Rezystory na tych wyprowadzeniach też sprawdziłem. Kiedy powinien wyswietlacz zadziałac ? Po włączeniu do sieci od razu czy po wciśnieciu przycisku ON/Off ? Ja mam tak: Jak wlożę wtyczkę do sieci to załącza mi sie dioda zielona od Powera i diody podświetlające wyświetlacz. A wyświetlacz dalej czarny. Czy ma wpływ na wyświetlacz wsad do eepproma? Przy programowaniu wgrał mi się normalnie ale przy weryfikacji wyświetliła mi się niezgodnośc. Odpuściłem sobie to bo w opisie pisało że bez wsadu w eepromie bedzie dzialalo tylko nie bedzie grafik. Zapisują się tam ustawienia z autostrojenia i nastawy stacji. Wydaje mi się ze nie ma to bezpośredniego wpływu, bo przecież stacja działa. A co do wyświetlacza. To szukam dalej co może byc powodem, dwa wyświetlacze już mi nie zadziałały raczej mało prawdopodobne że kupiłem dwa uszkodzone wyświetlacze, ale nie wykluczam i tego. Może komuś się jeszcze jakiś pomysł nasunie bedę wielce zobowiązany za pomoc i sugestie.
  • #29
    drake68
    Poziom 13  
    Widok wyświetlacza od strony blaszek kontaktowych:
    Stacja lutownicza Avt-5228 (Atmega16)
    Czy tak masz połączone piny LCD?
    Wyświetlacz powinien zadziałać zaraz po włączeniu zasilania,ukazuje się ekran powitalny.U mnie był błąd weryfikacji ale tylko pamięci eeprom ,ale mimo tego układ
    pracuje stabilnie.
  • #30
    mmuppet
    Poziom 2  
    To zle podlaczylem. :-) Na odwrót. Pin 1 tam gdzie VLCD a pin 8 tam gdzie Reset. W pewnym momencie też o tym myslalem i kolejny raz przelutowałem, ale tez nie dzialalo, wiec wróciłem do tego co poprzednio. Ciekawe czy przez takie polaczenie moglem uszkodzic te wyswietlacze. Hmmm. przelutuje i posprawdzam. A jak nie pojdzie to kupie nowy wyswietlacz. Dam znac czy mi sie udało. Dzieki za pomoc.

    Dodano po 34 [minuty]:

    Wyswietlacz zadzialał. :-) , Wielkie dzieki. Jednak zle bylo podlączone.