Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Dziwne wartości z przetwornika ADC

22 Gru 2010 12:19 930 6
  • Poziom 11  
    Mam problem ponieważ ADC po skonfigurowaniu i uruchomieniu zwraca na przemian 0, 255, czasem 8. (mam płytkę startową). Spróbowałem zewrzeć pin ADC do masy, później do 3v3 ale to prawie nic nie daje. Czy wina może leżeć w czasie uruchomienia albo czasie próbkowania?
  • Poziom 21  
    Jaki przetwornik ADC, jaka płyta startowa ( CD z instalką )?

    Prosimy o więcej informacji , albo do jasnowidza !
  • Poziom 11  
    Procesor to arm7tdmi: at91sam7s256
    Płytka ARMbrd1

    Jednak podłączenie do 3v3 sprawia że zwracane są tylko wartości 255(8 bitowy tryb). Gdy podepnę do wejścia (ADJ1, tutaj jest potencjometr), bądź do masy pojawiają się śmieci.
    W pewnej książce czytałem że rezystancja zewnętrznego źródła mierzonego napięcia powinna być mniejsza niż
    10*(SH_TIME-470) <-- czy trzeba na to zwracać uwagę?
  • Poziom 12  
    Witam
    Czy jest podpięte napięcie referencyjne?
    Pozdrawiam
  • Poziom 11  
    Ponieważ jest to płytka od producenta(a nie home made) na pewno tak. Zakładam to również dlatego że inne peryferia są podpięte tak jak trzeba(zwieram tylko odpowiednie piny między urządzeniami a mikroprocesorem)
  • Poziom 12  
    Płytki fabryczne nie maja na stałe podpiętego napięcia referencyjnego. Ponieważ dokładność pomiaru zależy od tego napięcia, użytkownik musi mieć możliwość podłączenia Uref z odpowiedniego źródła w zależności od potrzeb. Płyty Olimexu i Propoxu maja wyprowadzony odpowiedni pin (ADVREF). Gdybym robił płytę home made to oczywiście bym podłączył napięcie referencyjne - 3.3V z zasilania, godząc się na błędy odczytu, lub wykorzystał układ scalony dający dokładne napięcie referencyjne.
  • Poziom 11  
    U mnie też jest ten pin. Sprobuję go podpiąć do 3v3. Dzięki.
    Nie był podpięty aref:(.
    Dzięki. Wydawało mi się że na takiej płytce jest podpięte defaultowo.