Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Router ADSL, D-Link G604t ADSL2+ generation II, firmware

29 Gru 2010 00:33 6189 30
  • Poziom 8  
    Witam, z uwagi na to, iż jest to mój pierwszy post tutaj, chciałbym się przywitać - Cześć!

    A teraz do rzeczy, problem wygląda następująco, zakupiłem router d-link g604t ADSL2+ generacji II, po kilku tygodniach użytkowania chciałem zmienić firmware i przy tym zabiegu coś się stało... mianowicie, korzystam z tego routera jako modemu adsl dla neostrady, po tym małym niedociągnięciu w zgrywaniu firmware na nowe urządzenie w ogóle nie wykrywa adsl, dioda status nie robi nic, reset... hmmm jaki reset, na wszystkie sposoby robiłem i nic, kolejne próby wgrania firmware wg instrukcji z tego jak i innych forów nic nie dały (każda możliwa wersja nie instaluje się).

    Pytania moje brzmią:
    1. W czym może tkwić problem ?
    2. Jak go rozwiązać?
    3. Czy już mam zamawiać nowe pudło ?
    4. Ewentualnie gdzie w okolicach Wrocławia mogę go oddać do "podniesienia" i ile to może mnie kosztować?

    z góry dziękuję za pomoc (jakąkolwiek) ;)
  • Poziom 21  
    Generacja druga ma obsługę Qos oraz WPA2, wiec musi mieć i inne oprogramowanie.
    Pytanie jakie bebechy na w środku w sumie najwazniejszy procesor oraz producent pamięci. Mówią ze jest to ten sam sprzęt co 2640T posiadający PSP Boot

    Wg jakich poradników próbowałeś naprawić? daj linki
  • Poziom 21  
    To oprogramowanie w podanych linkach jest do generacji pierwszej, nie ruszy u Ciebie.

    Czy możesz obecnie wejść w panel administracyjny (192.168.1.1) ?

    Jeśli nie to ustaw na sztywno adresy jak tutaj:
    Router ADSL, D-Link G604t ADSL2+ generation II, firmware

    Zamieszczam paczkę ratującą w załączniku, uruchamiasz zaznaczasz Corruped > Next, wyłączasz router z prądu na co najmniej 5 sekund, ponownie Next w ciagu 0,5 - 1 sekundy po tym włączasz zasilanie routera i czekasz spokojnie aż pasek dojdzie do końca, po udanej operacji odpinasz i za chwile podpinasz zasilanie. Powinien już żyć.

    PS.
    1. Musisz robić to na Windows XP najlepiej z wyłączonym firewallem (na nowszych nie da rady)
    2. Może być wymagane bawienie się z włączaniem i wyłączaniem zasilania routera, dlatego trzeba go mieć pod ręką.
    3. Nie baw się w kable COM (RS-232) ani żadne JTAG, postawisz go przez kabel sieciowy na 100%
    Załączniki:
  • Poziom 8  
    Kilkakrotnie wykonalem to, oczywiscie nie moglem dostac sie spod przegladarki do ustawień więc ustawiłem to tak jak napisałeś. niestety nie przyniosło to efektu, nie wiem czemu. router zachowuje się nadal tak samo... ;/
  • Poziom 21  
    Czy pasek stanu doszedł do końca bez problemów?
    Jeśli tak to znaczy ze Boot jest nie naruszony (i w sumie nie miało go co naruszyć).
  • Poziom 8  
    tak, bez problemu doszedł do końca.

    P.S

    Kolejnych kilka prób, bez zmian ;x nadal nie robi nic sensownego, niby wrzuca to firmware ale nic z tego nie wynika ;/
  • Poziom 21  
    Spróbuj w takim razie to, soft od DSL-2640T (ale nic się nie bój), i rozpakuj to najlepiej bezpośrednio na C:\

    Od strony software to do swojego D-linka (w prawdzie GEN I ale nie ważne) wgrywałem chyba wszystko, softem się nie da uszkodzić, gorzej jak już ktoś grzebie w partycji MTD2 (Boot loader). Dlatego wiem, że postawisz swój router.

    Jak teraz nie ruszy to podaj jaki soft miałeś wcześniej, zrób zdjęcie routera, etykietki na nim oraz wnętrza (tam powinna widnieć wersja fabrycznie wgranego softu jeśli nie spisałeś nigdzie)
    Załączniki:
  • Poziom 8  
    wgrywa się równie dobrze jak tamten soft ale niestety zmian nie widać ;x jakieś pomysły jeszcze ? serwis mi to zrobi czy będą wołać piniondze ? ;D
  • Poziom 21  
    nikt za darmo się nie będzie bawił, a sprawa jest banalna.
    jak pisałem zamieść zdjęcia, bo być może starsze wersje oprogramowania używały jeszcze innego Boot loadera (adam2)
  • Poziom 8  
    zdjęcie routera ? tak ?
  • Poziom 21  
    "Jak teraz nie ruszy to podaj jaki soft miałeś wcześniej, zrób zdjęcie routera, etykietki na nim oraz wnętrza (tam powinna widnieć wersja fabrycznie wgranego softu jeśli nie spisałeś nigdzie)"

    pisalem wyżej
  • Poziom 8  
    Router ADSL, D-Link G604t ADSL2+ generation II, firmware Router ADSL, D-Link G604t ADSL2+ generation II, firmware Router ADSL, D-Link G604t ADSL2+ generation II, firmware


    z tego co pamiętam i widzę tutaj na etykiecie było to V3.00B01T01.TX

    Przepraszam za jakość ale lepszym sprzętem teraz nie dysponuje ;/
  • Poziom 8  
    Router ADSL, D-Link G604t ADSL2+ generation II, firmware


    Teraz wyskakuje mi coś takiego.
  • Poziom 21  
    Spróbuj ten soft (Routertech), pewnie nie będzie działać wifi ale tym sie zajmiemy później:

    a jak nie to:
    1. Podlaczasz komputer z routerem
    2. Wchodzisz w konsole (terminal) Start>uruchom> piszesz cmd
    3. Tam klepiesz ftp 192.168.1.1
    4. Login adam2 haslo adam2
    5. Klepiesz get mtd2 c:\boot.bin
    6. I umieszczasz ten plik tutaj, popatrzymy co tam jest
    Załączniki:
  • Poziom 30  
    Też się podłączę pod temat, ale ja znowu potrzebuję bootloadera do porównania G604T z G604T GEN II. Jeśli koledze krzykaczek nie udało się połączyć przez ftp pod adresem 192.168.1.1 to niech spróbuje pod 192.168.1.199.
    Jeśli to nie problem prosiłbym także o zdjęcie wnętrza.

    Bootloader już zdobyłem, jest to ADAM2 nie PSPBOOT i jest inny niż w wersjach z DSL-G604T pierwszej generacji, prawdopodobnie w drugiej generacji jest zastosowany inny switch, po wgraniu bootloadera z gen. 2 do gen. 1 nie da rady wgrać przez kabel ethernet oprogramowania, czy przy użyciu TIUPGRADE czy PCTOOL jak i FTP. Brak jakiejkolwiek komunikacji z routerem, objaw jest taki sam jak przy wgraniu bootloadera z modemu/routera z jednym portem LAN, bez switcha. Oczywiście jest dostęp z poziomu konsoli ale nic to nie daje. Trzeba wgrywać przez JTAG właściwy bootloader i dopiero firmware.

    P.S. Zdjęcia wnętrza jednak by się bardzo przydały.
  • Poziom 2  
    Witam.
    Ja też mam problem z tym routerem. Palą sie diody Power wlan i jak kabel podlacze to lan. Próbowalem różne firmware i niby pisze że wgrał ale nie mozna sie połączyc przez przegladarkę.Nawet próbowałem przez program router repair tool, pctool i nic. Wykrywa bootloader ale pisze , że to psboot. Czy wie ktoś co zrobić?
  • Poziom 21  
    wcisnij reset i wtedy sproboj sie polaczyc przez kabel
  • Poziom 2  
    Reset to ja wciskalem juz ze sto razy. Nie wiem czy dobrze ip routera wpisuje 192.168.1.1 . Ale np status nie powinno sie świecić?
  • Poziom 8  
    Cytat:
    Spróbuj ten soft (Routertech), pewnie nie będzie działać wifi ale tym sie zajmiemy później:

    a jak nie to:
    1. Podlaczasz komputer z routerem
    2. Wchodzisz w konsole (terminal) Start>uruchom> piszesz cmd
    3. Tam klepiesz ftp 192.168.1.1
    4. Login adam2 haslo adam2
    5. Klepiesz get mtd2 c:\boot.bin
    6. I umieszczasz ten plik tutaj, popatrzymy co tam jest


    niby się łączę z ftp i przy próbie logowania na adam2 gdy prosi o hasło nie mogę go wpisać i wyskakuje mi- nieprawidłowe polecenie.
    Wracam tu po okresie nieobecności i braku czasu na zajęcie się tym routerem ;) mam nadzieję, że pozostała Tobie jeszcze odrobina chęci na pomoc ;)
    Pozdrawiam
    Edit: połączyłem się w końcu tyle że przy próbie pobrania mtd2 wyskakuje mi komunikat - file not found... więc chyba jakimś cudem wywaliłem bootloadera jak dobrze rozumiem... tylko nie wiem jak i dlaczemu.
  • Poziom 30  
    Jakby wywaliło bootloader to byś się nie połączył.
  • Poziom 8  
    w takim razie jakiś pomysł na to ?
  • Poziom 21  
    W takim razie ciągle szukamy odpowiedniego softu, bo bootloader chodzi (choc nadal nie wiemy jaki masz czy adam2 czy psp). Przydało by się to w pierwszej kolejności sprawdzić.

    A tak nawiasem mówiąc to opuściłem swojego Dlinka G604 v1( bo zrywał wifi czy soft firmowy czy routertech) na rzecz używanego Tp-link TD-W8901G i problemy się skończyły. Dlatego ciężko będzie mi ponownie zaufać firmie Dlink
  • Poziom 8  
    bootloader to wg mnie na pewno adam2 bo przy łączeniu do ftp prosi o login i hasło własnie do niego.
  • Poziom 11  
    <jak postawić router g604t genII (wifi 1350A) ze sprawnym bootloaderem>
    1. sciagamy pc tool 2.4
    2. programem do aktualizacji firmware w trybie corrupted image dowiadujemy sie na jakim ip czatuje nasz bootloader
    3. ustawiamy sztywne ip i brama jak ip bootloadera
    4. odpalamy pctool wyłączamy router włączamy i po paru sekundach ok5? klikamy retrive assign ip powinno sie połączyć jak nie probojemy do skutku
    5. wgrywamy DLinkAU-A_DSL-G604T_singleimage_kernel_fs_V3.02B01T01.AU-A.20080827
    6.nastepnie config.DLinkAU-A_DSL-G604T.img >>>>to wszystko z oryginalnej paczki firmware Firmware_V3.02B01T01.AU-A.20080827
    7. teraz plik env run script
    8. odlanczamy zasilanie i wlanczamy router powinien sie juz normalnie uruchomic
    9. jeśli nie ma wifi --> musimy zczytać TNETW ID
    10. ściągamy firmware_tool-096 i probojemy nim zczytać (domyślny login telnet to admin admin) jesli nie mozemy zczytac tnetw id wchodzimy w router do STATUS --> LOG i patrzymy na tekst za ap <cośtamcośtam> failed tam będzie plik dwieliterki_nasz numer tnetw id .bin
    11. wchodzimy do firmware tool zakładka 1350a wpisujemy nasze tnetwid oraz mac i dajemy bulid einveirnoment probojemy wysłać do routera jeśli sie nie uda to kopiujemy wszystko z okienka i wsklejamy do pliku txt wywalamy linijki z partycjami (mtd1,mtd2 itd) i zapisujemy
    12. przygotowany plik ładujemy za pomocą pctool 2.4 (run script)
    13. resetujemy router
  • Poziom 8  
    router żyje, mogę się połączyć z nim przez przeglądarke, neta skonfigurowałem ale niestety odkąd ożył nie mogę wykonać tego żeby wifi działało, przez pc tool się nie łączy już z nim ;x w czym leży problem ?
  • Poziom 11  
    pc tool sie nie łączy bo zmieniło sie ip bootloadera (patrz pkt 2)
    pytanie jest czy zczytałeś ten nr tnetw id bo bez niego wifi nie będzie
  • Poziom 8  
    dobra, wifi się uruchomiło. jak przyjdzie moje urządzenie z wifi to sprawdzę czy działa tak jak należy i dam znać. kolejnym problemem jest to, że czasem się wiesza i w momencie ponownego uruchomienia moje dane od neo zanikają i muszę od nowa go konfigurować. da się coś z tym zrobić ? ;> czy to już po prostu przypadłość taka tego firmware ? ;>
  • Poziom 11  
    wgraj teraz 604
    normalnie przez strone routera powinno pomoc
    jak sie wgra to poczekaj kilka minut zanim zaczniesz coś ustawiać