Elektroda.pl
Elektroda.pl
X
Elmark
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Termostat AVT950 z Pic16F628

avs1 04 Sty 2011 21:21 1854 5
  • #1 04 Sty 2011 21:21
    avs1
    Poziom 15  

    Zmontowałem termostat AVT 950 na procesorze PIC16F628 z czujnikiem temperatury DS18B20 i okazało się że temperatura wyświetlana na wyświetlaczu jest 1,5 stopnia C wyższa niż zmierzona na wzorcowym termometrze rtęciowym.Czy ktoś podpowie jak rozwiązać ten problem? Czy jest to wina czujnika ,procesora czy programu?

    0 5
  • Elmark
  • #2 04 Sty 2011 21:35
    skalsky5000
    Poziom 20  

    Każdy przyrząd/element pomiarowy ma swój błąd.O ile pamiętam DS ma 0,5stopnia.Nawet twój wzorcowy termometr nie mierzy wartości dokładnie

    0
  • Elmark
  • #3 04 Sty 2011 23:15
    avs1
    Poziom 15  

    Czytałem ,że dallasy mają błąd 0,5 i gdyby tyle było to byłoby fajnie ale ja mam 1,5.Tem termometr testowy ma atest tak że trzba mu wierzyć.Dallasy też można programować tylko jeszcze niewiem jak. I może taki błąd odejmować procesor prze odczytem tylko trzeba mieć kody zródłowe i wiedze jakto zrobić.

    0
  • #4 05 Sty 2011 12:25
    adamwesola
    Poziom 24  

    Program z pewnością można dostosować do konkretnego egzemplarza ds1820, tylko ze to dużo więcej fatygi niż kupienie sprawnego.

    0
  • #5 15 Lut 2011 14:44
    dingo148
    Poziom 16  

    Dołączam się do tematu bo mój problem jest podobny.
    Mianowicie, po złożeniu układu i podłączeniu, temperatura mierzona wyświetla mi 3,0 st C a nie 20 st C (temp. pokojowa). Nawet jak ogrzeję czujnik to wartości bardzo wolno się zmieniają ( nawet jak przyłożę lutownicę do czujnika to temperatura zmienia się z 3,0 do max 8,0 st C). Wszystko inne działa ok. Dodam że w opisie avt jest czujnik DS18B20 a mój to DS1820 (bez B). Ale jak patrzę na schematy aplikacyjne tych dwóch czujników to niczym się nie różnią. Ponadto przy pierwszym podłączeniu spalił mi się tranzystor BC547 ale tylko dlatego że przez przypadek wlutowałem przekaźnik 24V zamiast 12V. Czy to mogło spowodować uszkodzenie czujnika ?
    Pozdrawiam

    0
  • #6 15 Lut 2011 15:44
    wzk
    Poziom 19  

    Zastosuj właściwy czujnik i po kłopotach.
    Jeżeli chcesz wiedzieć więcej dlaczego tak Ci działa dotychczasowy, to bardziej przyłóż się do czytania not katalogowych a zobaczysz różnicę.

    0