Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Link na 10km - problem z predkoscia

Zoll 12 Paź 2004 13:21 1949 20
  • #1 12 Paź 2004 13:21
    Zoll
    Poziom 13  

    Witam

    Zrobilem link na 10km na:

    2x parabola 90cm z promiennikami
    1x WAP 1965 kabel do promiennika 1,5m
    1x karta Sparklan WL-360R kabel do promiennika 7m

    W programie Network Stumbler mam nastepujace wyniki na karcie

    SNR od 30 do 33 nieraz spadnie na
    jeden cykl na 18
    Sygnal/Noise od -62 do 70 dBm nieraz spadnie do 84
    wskaznik w WinXp pokazuje 4 kreski na 5

    AP z karta laczy sie na 2Mb/s lub 11Mb/s

    co powinno dawac transfery rzedu 250kB/s i 1,3MB/s

    Jednak co udaje sie osiagnac to jedynie 12kB/s max niezaleznie czy jest
    2Mb/s czy 11Mb/s

    Moze mi ktos poradzic co moze byc przyczyna tak niskich transferow i jak
    pozbyc sie tej nie dogodnosci

    0 20
  • #2 12 Paź 2004 17:22
    elektryk
    Poziom 42  

    Jak mierzysz transfer?

    0
  • #3 12 Paź 2004 21:39
    Zoll
    Poziom 13  

    Predkość odczytuje w LanSpeed2 i w Windows comander

    i wiem ze przy 2Mbit/s transfer powinien byc na poziomie 150kB/s

    0
  • #4 13 Paź 2004 09:52
    Zoll
    Poziom 13  

    Dodam jeszcze ze w statystykach na AP mam taki komunikat

    Good Packets 7311
    SEND
    Dropped Packets 7149

    Good Packets 17311
    RECV
    Dropped Packets 1


    WYdaje mi sie ze pakiety wysylane z AP gina gdzies po drodze

    0
  • #5 13 Paź 2004 10:26
    Kolek
    Poziom 25  

    Jeśli jest możliwość to sprawdziłbym jak działa na krótszym kablu karta<->promiennik, tam gdzie pracuję niedopuszczalną rzeczą jest zrobienie tak długiego kabla do WLAN.

    0
  • #6 13 Paź 2004 15:05
    Zoll
    Poziom 13  

    Niestety nie moge za bardzo skrócic kabla.

    Wydaje mi sie ze kabel wpływa na poziom sygnału i jak by byl za dlugi to sygnal byl by slaby. (ale moge sie mylic)

    Znalazlem w oprogramowaniu do karty takie wskazniki.

    Link Quality - okolo 75%
    Sygnal strenth - okolo 75%

    A jak bym skrócił kabel do 1m to zyskal bym max 2db bo tyle miejwiecej tlumi ten kabel

    0
  • #7 13 Paź 2004 19:22
    techrys
    Poziom 28  

    Pytanie, czy w pobliżu pracują inne sieci wlan - u mnie jest tak gęsto, że jest problem złożyć link na parabolach 90cm na 2km...
    A tak poza tym zmień kable na H1000 i przelotka bezpośrednio z H1000 na sma (są takie bezkablowe). Wszystkie wtyczki koniecznie pozłacane, jeżeli lutujesz to dobrym spoiwem. Antena koniecznie musi być w celu - odległość 10km daje już spory rozrzut. Zainteresuj się też możliwością zhaczenia wapa 1965 (i nie tylko jego) poprzez sprzetowe (tzn. za pomocą lutownicy) usunięcie funkcji diversity - daje to mały, ale zauważalny wzrost mocy wyjściowej - ale o szczegóły pytaj(cie) pana google.

    0
  • #8 13 Paź 2004 21:48
    salmon
    Moderator - Sieci, Internet

    Cytat:
    AP z karta laczy się na 2Mb/s lub 11Mb/s

    co powinno dawac transfery rzedu 250kB/s i 1,3MB/s


    Fajnie by było, gdyby transfer na WLANie można było wyliczyć przeliczając bezpośrednio bity na bajty... Niestety sporo "pary idzie tu w gwizdek" - a dokładnie w "opakowanie" pakietu - co daje efektywny transfer ok. 600KB/s przy rate=11Mbit/s

    Co oczywiście nie zmiania faktu. że 12KB/s to kiepski transfer...

    Wygląda to na problem czysto "eterowy" - jakieś sieci po drodze na kolizyjnym kanale, zakłócenia, itp. Druga sprawa, że na takej odległości nie można się spodziewać (wychodząc dopuszczalną ustawowo mocą), że połaczenie będzie zestawiało się stale na 11Mbit/s. Myślę, ze jeżeli jest to możliwe, to wymuszenie górnej granicy na 2Mbit/s jest bardzo wskazane - APek nie bedzie marnował czasu na renegocjacje transferu- bo kilka pakietów pod rząd udało mu się przesłać z niższą prędkością bez powtórek.

    Staranność wykonania toru antenowego to podstawa, kolega Techrys napisał chyba wszystko.

    0
  • #9 14 Paź 2004 11:55
    Zoll
    Poziom 13  

    Witam

    Wydaje mi sie ze antenki ustawilem idealnie. Po drodze jest kilka sieci ale dopiero na 7ch a ja jestem na 1ch. Ma przeciwnej polaryzacji jest juz tlok wiec tam to nawet nie probowalem.

    Oczywiscie wymuszam predkos 2mbit/s ale to nic nie daje.

    Wap1965 przerobilem na DWL-900AP+ i poziom sygnalu troszeczke sie poprawil. Wgrywalem nawet ten soft co ziska z niego maxa ale nie bylo widac roznicy. Postaram sie przerobic tak jak radzisz jak cos znajde w google.

    Troche boje sie zmieniac kabel z H155 na H1000 bo dodatkowe przejscia dadza dodatkowe tlumienie i moze wyjsc na to samo. Najpierw podmienie AP. A pozniej uzyje 2 Ap jako MOST. Jak to nie pomoze to zmienie ten 7 m kabel na h1000.

    Jak ktos ma jeszcze jakies sugestie to bardzo prosze bo nieraz najprostrze rozwiazania prowadza do sukcesu.

    0
  • #11 14 Paź 2004 15:40
    Zoll
    Poziom 13  

    Z tego opisu wynika ze moj AP przy wysylaniu duzej ilosci danych zmniejsza moc nadawania. Ponieważ parametr signal quality jest umnie raczej niezmieny a skacze tylko signal strength. Coraz bardziej wydaje mi sie ze przyczyna jest nie sprawny AP. Wszystko sie okaze jak podlacze nowego AP.

    0
  • #12 14 Paź 2004 17:06
    gemitech
    Poziom 13  

    Nie wiem czy to coś pomoże, ale spróbuj coś pokombinować z parametrem RTS Threshold. Trochę na ten temat jest opisane tu http://www.siecibezprzewodowe.a.pl/new_site/glowna/wapy/wap1965.htm

    Rozumiem że skoro piszesz

    Cytat:
    Na przeciwnej polaryzacji jest juz tlok wiec tam to nawet nie probowalem.

    to teraz jesteś na polaryzacji pionowej (bo ta jest rzadziej używana), więc sprawdź swoje anteny odnośnie tego.

    Na 2 Mbit piwinneś mieć transfery około 100 kB/s.

    Jednak to tak długich linków proponowałbym mocniejsze AP np. taki http://www.dipol.com.pl/sklep/n2612.htm

    0
  • #13 14 Paź 2004 17:33
    Zoll
    Poziom 13  

    Cytat:
    Nie wiem czy to coś pomoże, ale spróbuj coś pokombinować z parametrem RTS Threshold


    Ten parametr zmieniaem w pelnym zakresie jedyne co zauwazylem ze ponizej wartosci 400 sa duze klopoty z laczeniem sie z siecia.

    0
  • #14 14 Paź 2004 22:16
    Zoll
    Poziom 13  

    Cytat:
    Zainteresuj się też możliwością zhaczenia wapa 1965 (i nie tylko jego) poprzez sprzetowe (tzn. za pomocą lutownicy) usunięcie funkcji diversity - daje to mały, ale zauważalny wzrost mocy wyjściowej - ale o szczegóły pytaj(cie) pana google.


    Niestety ni nie moge znalesc na temat kakiej przerobki. Moze komus udalo sie cos znalesc.


    W czasie testow zobaczylem ze jezeli wysylam dane do lanu to osiagam transfery 8x wieksze niz jak cos odbieram. Co mi sie wydaje ze problem tkwi w AP.

    0
  • #15 31 Paź 2004 23:39
    Zoll
    Poziom 13  

    W niedziele podmienilem AP na WAP-4000 transfer spadl do 5kB/s

    Juz mi rece odpadaja bo niewiem co jest zle:(

    0
  • #16 01 Lis 2004 07:36
    techrys
    Poziom 28  

    Odpal jakiegoś linuxa (choćby knoppixa) po stronie wapa, spingaj drugi koniec i sprawdź czy masz duplikaty i ile ich jest. A tak poza tym zmień parabole (ale tylko czasze) na 110cm.

    0
  • #17 01 Lis 2004 08:39
    paawel
    Poziom 21  

    Zamiast sieciówki radiowej postaw jakiegoś AP z kablem też max 1- 1,5 m
    Powinno pomóc -- chociaż prawde mówiąć 10 km to spora odległość.
    pozdr

    0
  • #18 03 Lis 2004 07:48
    Zoll
    Poziom 13  

    Narazie podkreciłem AP wgrywajac do niego poprawiony soft tzn z WAP1965 zrobiłem DWL-900AP a pozniej wgralem do niego PowerHack.

    Efekt jest taki ze poziom sygnału polepszył sie o 5dBm a transfer wzrósł z 12kB/s na prawie 40kB/s.

    Teraz pora wymienic jedna parabole 90cm na 110cm i zmiejszyc dlugość kabla. Mam nadzieje ze to juz pomoże ale i tak jest juz dużo lepiej. Można przynajmniej juz grac w sieci:)

    0
  • #19 03 Lis 2004 07:51
    techrys
    Poziom 28  

    Zoll napisał:
    Narazie podkreciłem AP wgrywajac do niego poprawiony soft tzn z WAP1965 zrobiłem DWL-900AP a pozniej wgralem do niego PowerHack.

    Jakim cudem to zrobiłeś?? Próbowałem wielokrotnie i zawsze dostawałem checksum error.

    0
  • #20 03 Lis 2004 08:07
    Zoll
    Poziom 13  

    Cytat:
    Jakim cudem to zrobiłeś?? Próbowałem wielokrotnie i zawsze dostawałem checksum error.


    1) Wgrywam soft do wap1965 który pozwala wgrac uaktualnienie od DWL-900AP
    2) Następnie wgrywam standardowe oprogramowanie do dwl-900ap
    3) A teraz juz te przerobione

    Wieczorem zamieszcze dokładny opis i odpowiednie pliki.

    0