Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Proszę o reset baterii dell c400 sl394

kris125 18 Sty 2011 20:56 8652 33
  • Relpol
  • Pomocny post
    #2 19 Sty 2011 21:08
    jarob
    VIP Zasłużony dla elektroda

    Jakich ogniw będziesz używał?

    Twój oryginalny wsad miał ustawione napięcie ładowania (CV) na poziomie 13,5 V. Takie napięcie jest stosowane w przypadku ogniw LG.
    Jeśli będziesz miał ogniwa innego producenta, to napięcie to powinno wynosić 12,6 V. Dlatego przygotowałem Tobie dwa wsady:

    0
  • #3 19 Sty 2011 21:22
    kris125
    Poziom 8  

    zastosowałem ogniwa LG więc pierwszy wsad będzie odpowiedni dzięki serdeczne.

    0
  • #4 23 Lut 2011 18:41
    kris125
    Poziom 8  

    Po wgraniu wsadu dioda ładowania miga raz zielono trzy razy żółto :cry:


    Proszę o reset baterii dell c400 sl394

    0
  • Pomocny post
    #5 23 Lut 2011 19:42
    jarob
    VIP Zasłużony dla elektroda

    Bezpiecznik termiczny jest cały?

    0
  • #6 23 Lut 2011 20:02
    kris125
    Poziom 8  

    termik ma 10k to chyba jest dobry, a 5A SF jest cały ale brak przejścia

    0
  • Pomocny post
    #7 23 Lut 2011 20:34
    jarob
    VIP Zasłużony dla elektroda

    Nie chodziło mi o termistor pomiarowy temperatury, tylko o ten bezpiecznik termiczny 5A SF. Jeśli nie ma on przejścia, to nie jest cały, tylko jest uszkodzony.

    0
  • Relpol
  • #8 23 Lut 2011 20:42
    kris125
    Poziom 8  

    ok cały oznaczało nie przepalony czyli wymiana dzięki za pomoc po wymianie dam znac czy wszystko gra

    0
  • #11 17 Sty 2013 15:31
    mac_defense
    Poziom 10  

    Dear jarob,

    as i can see for the 12.6V file there is 0x8C1C inside and for the 13.5V file there is 0x2C3D. But how can i calculate back these values.
    For example 12600 is in hex 0x3138 and 13500 is in hex 0x34BC.
    Can you help me to understand.

    Thanks!

    0
  • #12 17 Sty 2013 18:36
    jarob
    VIP Zasłużony dla elektroda

    First you need to apply of the dump the Mirror16bites and MirrorAddr.
    After this operation, the hexedit window can be read ManufacturerName.
    Then the voltages can be read 12600, in hex​​ 0x3138.

    0
  • #13 18 Sty 2013 14:20
    mac_defense
    Poziom 10  

    Dear jarob,

    many thanks!

    Do you have a software which can mirror the bits automatically?
    Or must this be done by hand.

    If i want to re-programm the sl394. Must i remove the sl394 from the PCB.
    Programm your file and then bring it back to the PCB.

    0
  • #14 18 Sty 2013 14:48
    jarob
    VIP Zasłużony dla elektroda

    mac_defense napisał:
    Do you have a software which can mirror the bits automatically?


    Here is the program - https://www.elektroda.pl/rtvforum/viewtopic.php?p=11703792#11703792

    mac_defense napisał:
    If i want to re-programm the sl394. Must i remove the sl394 from the PCB.
    Programm your file and then bring it back to the PCB.


    Yes, it is.
    Only better read your dump, correct it and save again as.

    0
  • #17 22 Sty 2013 09:18
    mac_defense
    Poziom 10  

    Dear Jarob,

    many thanks. But the Battery will not work.
    The LED 1,3 and 5 is blinking.
    Attached also a picture from SBW.
    The charging voltage and charging current are "0".
    Is there a bit inside for a permanent failure which will lock the battery for ever?
    Do you have a complete list for all bytes inside the bin file.

    Please help!
    Thanks.

    0
  • #18 23 Sty 2013 13:01
    mac_defense
    Poziom 10  

    Dear Jarob,

    is it possible that this permanent failure is stored in the BH5740AFS.

    Do you have a datasheet for this IC.

    0
  • #19 23 Sty 2013 14:13
    jarob
    VIP Zasłużony dla elektroda

    mac_defense napisał:
    But the Battery will not work.
    The LED 1,3 and 5 is blinking.


    Is before replacing the cells, battery working?

    Is disconnected cells from electronics in the correct order?

    mac_defense napisał:
    is it possible that this permanent failure is stored in the BH5740AFS.

    No

    0
  • #20 24 Sty 2013 07:50
    mac_defense
    Poziom 10  

    Hello,

    it was not working before. This was the reason why i changed the cells.

    Disconnection and connection of the cells always in right order

    Any help.

    0
  • #21 24 Sty 2013 08:02
    Huaer
    Poziom 12  

    Possible reasons:
    1. Fuse
    2. SYS_PRESENT pin
    3. Hardware failure.

    0
  • #23 24 Sty 2013 10:02
    mac_defense
    Poziom 10  

    Dear Huaer,

    Fuse is ok.
    My Battery has the following pins

    +
    CLK
    DATA
    PRS
    PRES
    NC
    B/I
    -


    "-" and "PRS" are connected on the Battery.

    I connect "-" and "PRES" then i can communicate via Smart Battery Workshop with the Battery.

    0
  • #24 25 Sty 2013 11:37
    mac_defense
    Poziom 10  

    Hello,

    has anybody a spare PCB from this battery.
    I need some boards for testing.

    0
  • #25 26 Sty 2013 23:49
    Wiesław Rzepka

    Poziom 31  

    General problem is Sanyo battery. Therefore, because almost never "manual" reset fails. See the Battery Remaining is 0 and should be 10% of the battery capacity. And therefore Charging Current and Charging Voltage SBW on the screen are the 0 th.

    0
  • #26 27 Sty 2013 20:13
    mac_defense
    Poziom 10  

    Has anybody done an reset on this type of battery and it worked?

    If yes, please send me the working bin files for the sl394.

    0
  • #27 27 Sty 2013 22:28
    Wiesław Rzepka

    Poziom 31  

    I did not make this battery, but a colleague jarob so. Write to him.

    0
  • #28 28 Sty 2013 07:57
    mac_defense
    Poziom 10  

    Hello,

    he gave some answers, see above.

    But i think he has at the moment no time to give answers.
    Hope he has some help for me.

    0
  • #29 28 Sty 2013 08:44
    jarob
    VIP Zasłużony dla elektroda

    Hello

    Try to upload a dump "nowy_dell_c400_sl394_4000_VC-126_ok.bin", which improved to a colleague / kris125 /.

    If it will work, I will try to find of your a dump locks.

    0
  • #30 30 Sty 2013 15:33
    mac_defense
    Poziom 10  

    Dear Jarob,

    i tried "nowy_dell_c400_sl394_4000_VC-126_ok.bin" but the same.
    LED 1,3 and 5 are blinking any other ideas.

    0