Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Naprawa WRT54GL v1.1 uszkodzony LAN?

24 Sty 2011 17:42 10120 32
  • Poziom 18  
    Witam.
    Postanowiłem założyć temat odnośnie naprawy WRT54GL v1.1 (oraz inne wersje)
    Z tego co się orientuję nie jestem jedyną osobą mającą tego typu problem,
    na początku myślałem że router jest uszkodzony programowo,
    jednak po próbach "postawienia" go na nogi które trwały ponad 2dni, skończyły mi się możliwości naprawy software poprzez JTAG.
    Dodam tylko że router trafił w moje ręce już uszkodzony, nie wiem w jaki sposób,
    ale przypuszczam że uszkodzenie mogło mieć miejsc w czasie burzy,
    seria WRT jest podobno bardzo podatna na wyładowania atmosferyczne.
    Chciałbym zaznaczyć że naprawiłem już 2 taki routery i posty typu:
    "czy na pewno dobrze wgrałeś CFE lub Kernel" nie są raczej na miejscu.
    Temat założyłem aby naprawić router i pozostawić wiedzę dla potomnych.
    Pisałem na innych forach poświęconych tego typu urządzeniom oraz alternatywnym softom ale na tego typu portalach nie otrzymałem pomocy w zakresie elektroniki.

    Wracając do tematu:
    Aktualnie do Linksys-a został wgrany nowo wygenerowany plik CFE z "jego" mac adresem. Do flasha został również wysłany (przez JTAG) plik z softem (rozszerzenie .bin) jednak bez rezultatu.
    W chwili obecnej stawiam na uszkodzenie sprzętu a dokładnie transformatora zabezpieczającego LAN i WAN, w tym urządzenie jest on "zalany" w jednej kości,
    ma oznaczenie HN72564VG.
    Po wpięciu przewody w obojętnie jaki port LAN lub WAN w komputerze a właściwie karcie sieciowej widnieje komunikat "przewód sieciowy jest odłączony".

    W tym miejscu pojawia się pytanie jak sprawdzić ten transformator bez wylutowania?
    Może ktoś przypuszcza jeszcze jakieś inne możliwe usterki?

    Załączam zdjęcia płyty routera:

    Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN?
  • Poziom 18  
    Sorry. Już zmienione :)
    czekam na Wasze sugestie.
  • Poziom 18  
    Postanowiłem wyodrębnić temat w którym mam nadzieje padną jakieś konkretne możliwe usterki czystko elektroniczne.
    Mam nadzieje że uda mi się z tym uporać i w temacie zostanie sporo informacji dla osób chcących naprawić swój sprzęt.
    Chciałbym aby oba tematy były aktywne ale jeśli chcesz jeden zamknąć to chyba lepiej ten poprzedni.
    Pozdrawiam i od razu dzięki za wymianę zdań w tamtym temacie.
  • Poziom 39  
    Czy porty działają możesz też szybko sprawdzić łącząc je patchcordem, bez komputera.
    Ten transformator dopasowujący możesz sprawdzić omomierzem. Inna sprawa to brak napięć na opornikach 75 ohm pomiędzy gniazdami a transformatorem. Muszą być. Bywa, że od przepięć pada któryś z oporników.
    Sprawdź też napięcie na opornikach 68 ohm z drugiej strony transformatora.
  • Poziom 18  
    Napięcie na rezystorach pomiędzy prockiem a transformatorem jest bardzo małe i waha się w zakresie kilku-kilkunastu mV.
    Transformator ma wydzielonych 5 sekcji 4LAN i WAN rezystancja pomiędzy punktami zarówno po stronie wtórnej jak i pierwotnej wynosi 0,9-1,2Ω
    Na rezystorach 75Ω pomiędzy transformatorem a gniazdami napięcia brak,
    pomierzyłem te rezystory (co prawda bez wylutowywania) i maja wartości bliskie 75Ω więc są ok.
    Wszystko wskazuje na uszkodzony transformator, mam racje ?
  • Poziom 39  
    Nie, trafo nie ma nic wspólnego z zasilaniem gniazd RJ-45. Jeśli nie ma fizycznego zwarcia pomiędzy tymi 5-cioma sekcjami oraz nie ma zwarcia pomiędzy częścią , nazwijmy to, zewnętrzną, czyli od strony gniazd RJ-45 a częścią wewnętrzną, prowadzącą do procesora, to transformator jest sprawny. Ma takie niskie wartości oporności cewek. Musisz przejrzeć ścieżki dokąd prowadzą i odnaleść uszkodzony element ( przerwa ). Napięcia muszą być. Sprawdź element LA12 znajdujący się obok przetwornicy (blisko jest scalak, kondensator, transformatorek ). Mam na stole ten router, ale w wersji z 2 transformatorkami.
  • Poziom 18  
    Zwarcia pomiędzy sekcjami oraz pomiędzy jedna a drugą stroną transformatora niema. na LA12 brak napięcia, napięcie na kondensatorach CH1,2,3,4,5 waha się w granicach kilku mV, ścieżki mają przejście a na rezystorach 75Ω których jest po 3szt. na każdy LAN brak napięcia.
    Na kondensatorach (myślę że to kondensatory) M1 i M2 które znajdują się pomiędzy transformatorkiem a LAN-em pojawia się "co jakiś czas" napięcie kilku mV zaś w pustych punktach m3, m4, m5, m6, m7, m8, m9, m10 występuje znikome napięcie (mV).
    Nie mam zielonego pojęcie w czym może tkwić problem, ale wygląda na to że przed trafem wszystko jest ok.
  • Poziom 39  
    To szukaj uszkodzonego elementu w przetwornicy. Nie poddawaj się :D . Zrób dobre zdjęcia i wyślij mi na email. Spróbuję ci pomóc.
  • Poziom 18  
    Nie poddaje się :) ale spędziłem już sporo czasu nad tym nieszczęsnym routerem i pomału mam dość :roll:
    Da dobra sprawę wystarczyło by mi uruchomić jeden port LAN żebym tylko mógł wrzucić jakieś Tomato lub DD-WRT, router miał zostać rozszerzony o czytnik kart i takie tam.
    Zrobię fotki jutro i wrzucę na elektrodę, może ktoś jeszcze się wypowie w temacie.
  • Poziom 39  
    Nie uruchomisz jednego portu, lecz wszystkie. Jak znajdziesz gdzie masz uszkodzony element, przez który przetwornica nie pracuje. Mają wytwarzać 5V i 3.3V. Nie masz zwartych diod Shottky DA6 i DA7 ? Napisz, na jakich są scalakach te przetwornice. Te małe smd obok okrągłych pionowych cewek - UC9, UC11, UC12. Może być na PW.
  • Poziom 18  
    1509-33(0723bl), 1509-50(0723al), RT9167A, AP1605.
    To są wszystkie małe scalaki w pobliżu przetwornicy.
  • Poziom 39  
    wojto15-05 napisał:
    1509-33(0723bl), 1509-50(0723al), RT9167A, AP1605.
    To są wszystkie małe scalaki w pobliżu przetwornicy.


    1509-33 to jest 3.3V
    1509-50 to jest 5V

    Masz na nich tyle ? Na elektrolitach ?
  • Poziom 18  
    Dokładnie takie jak napisałeś.
  • Poziom 39  
    LA12 ma zwarcie czy przerwę ? Powinna mieć zwarcie. Dla porządku sprawdź na zwarcie wszystkie LA jakie znajdziesz.
  • Poziom 18  
    LA12 ma zwarcie.

    PS: Wszystkie LA jakie znalazłem mają zwarcie.
  • Poziom 39  
    Z LA12 idzie napięcie na cewki wszystkich 4-ech portów, odwróć płytkę i sprawdź czy napięcie tam jest. Zobaczę w tym moim jak tam jest z napięciami i jak idą. Choć to inne PCB...
  • Poziom 18  
    Pomiar napięci pomiędzy masą (złączem od anteny) a kolejnymi punktami transformatora daje taki sam wynik 3,33V od strony procesora a od strony LAN O więc tak jak być powinno.
  • Pomocny post
    Poziom 39  
    Nie jest tak jak powinno, bo na opornikach 75 ohm ma być napięcie. Idzie z innej strony, przez rezystor ok. 10 ohm ( o ile dobrze pamiętam), choć może to być tzw. O ohm. Musisz na "macaka" szukać tego napięcia na opornikach i cewkach, mierząc z jednej i z drugiej strony elementu. Znajdziesz tego z przerwą.
  • Poziom 18  
    Jutro będę modził może akurat znajdę :)
    Dzięki wielkie za pomoc, bardzo mi pomogłeś.
    Będę się odzywał jak coś sprawdzę.
    Pozdrawiam.
  • Poziom 39  
    Zdjęcia, kolego, zdjęcia...
  • Poziom 18  
    Ha ! nie mógł bym spać jak bym nie sprawdził, znalazłem rezystor wychodzący od cewki 10Ω zmierzyłem na nim napięcie i okazało się że wynosi 0V.
    obok niego kondensator smd na nim również 0V a przed nim cewka na której jest 5V.
    Zobaczymy co będzie po wymianie ale to już nie dziś,
    foto zrobię jutro przy dobrym oświetleniu i makro jak się uda.
  • Poziom 39  
    Myślę, że trafiłeś. Dla pewności jeszcze zmierz czy nie masz zwarcia do masy - z tej strony opornika gdzie nie ma napięcia. Bo jak wlutujesz ten spalony a będzie zwarcie to znowu się swajczy.
  • Poziom 18  
    Przesyłam zdjęcia płyty,
    jakością nie grzeszą ale starałem się zrobić jak najlepsze.
    Aktualnie biorę się za sprawdzanie rezystorów, cewek, kondensatorów.

    Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN?
    Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN? Naprawa WRT54GL v1.1 uszkodzony LAN?
  • Poziom 10  
    Witam,

    tag: WRT54GL v1.1 miga power a lan świeci ciągle

    mam podobny problem, kontrolka zasilania mruga, a te od lanu świecą ciągle.
    Raz zdarza się, że po włączeniu zasilania zapalają się 3 a raz wszystkie. Próbowałem połączyć się JTAGiem, ale nic z tego (kabelek OK, bo już raz go używałem).
    Router jest podobno po źle wgramy sofcie, trochę za niego dałem, bo wierzyłem, że wystarczy tylko JTAGiem po operować i będzie OK.

    Bardzo proszę o sugestie co dalej w tym temacie?

    Czy Panu "wojto15-05" udało się naprawić swój?

    Z poważaniem,
    Kamil
  • Poziom 18  
    Witam,
    Od tamtej pory naprawiłem już sporo WRT-ków i wszystko poszło po jtag-u,
    ale ten przypadek który opisałem do tej pory leży, najprawdopodobniej została uszkodzona pamięć ale jak na razie nie wpadła mi taka kostka w ręce.
    A próbowałeś usuwać plik krnel i w ostateczności cfe ?
    jeśli skasujesz cfe co tak jak pisałem jest ostatecznością, będzie musiał wgrać oprogramowanie przez jtag`a, trwa to bardzo długo jednak czasem pomaga i stawia router na nogi, ale to dopiero jak wszystkie inne metody zawiodą.
  • Poziom 10  
    W moim przypadku nie mogę się nawet połączyć z układem - a robię to przez JTAGa:
    wrt54g -probeonly /noemw
    Dzisiaj jeszcze na chwilkę przysiadłem i pomierzyłem nap. - jest tak jak u Ciebie.
    Choć to, że nie mogę się połączyć z chipem wskazywałoby raczej na walniętą pamiątkę, lub brak zas., ale to jest bo sprawdzałem.
    Na youtube jest filmik, jak gość naprawia ten router właśnie z tymi samymi objawami - po jtagu usuwa tylko nvram.
    Gdybym mógł się z nim połączyć... (kabelek jest 100% OK i lutowania też :/)
    No nic dzięki za odpowiedź, może jeszcze powalczę, ale jak znajdę na pewno dam znać.
    pozdro
  • Poziom 10  
    myślę, że Panu pomorze ostatni post w tym temacie.
    Ja mojego chyba już nie postawię, bo brak komunikacji świadczyłby o uwalonym procku - to chyba on komunikuje się po JTAGu, a nie flash :). Czy da się to jeszcze jakoś potwierdzić?