Elektroda.pl
Elektroda.pl
X
Mitronik
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Eagle] Prośba o sprawdzenie poprawności schematu

mattkap 04 Lut 2011 13:16 2771 6
  • #1 04 Lut 2011 13:16
    mattkap
    Poziom 11  

    Witam jest to mój pierwszy schemat. Starałem się trzymać podstawowych wytycznych dotyczących jego tworzenia, ale coś czuję że ludzką cechą się mylić i popełniłem błędy. Stąd moja prośba do doświadczonych kolegów, aby spojrzeli krytycznym okiem na schemat. Zamieszczony w załączniku i wykonany w EAGLE.

    Będę się cieszył ze słów krytyki poprawiając swe błędy i ucząc się jak to ma wyglądać.

    Trochę o samym schemacie, w założeniach ma to być sterownik do stanowiska pomiarowego na uczelni. Zbudowany jest w oparciu o Atmege16. Sygnałami wejściowymi są impulsy z czujnika położenia wału i nie umieszczony na schemacie, gdyż nie do końca wiem jak to zrealizować sygnał napięciowy z czujnika tensometrycznego o zasilaniu 12V i czułości 3mV/V. Sygnałami wyjściowymi będą sygnały wyzwalające przekaźniki i przede wszystkim odizolowana optycznie część klucza prądowego sterowanego PWMem.

    Za wszelkie uwagi z góry dziękuję i będę się starał uzupełniać braki na bieżąco.

    0 6
  • Mitronik
  • #2 04 Lut 2011 16:55
    Bonkot
    Poziom 39  

    mattkap napisał:
    Witam jest to mój pierwszy schemat. Starałem się trzymać podstawowych wytycznych dotyczących jego tworzenia, ale coś czuję że ludzką cechą się mylić i popełniłem błędy. Stąd moja prośba do doświadczonych kolegów, aby spojrzeli krytycznym okiem na schemat. Zamieszczony w załączniku i wykonany w EAGLE.

    Będę się cieszył ze słów krytyki poprawiając swe błędy i ucząc się jak to ma wyglądać.

    Trochę o samym schemacie, w założeniach ma to być sterownik do stanowiska pomiarowego na uczelni. Zbudowany jest w oparciu o Atmege16. Sygnałami wejściowymi są impulsy z czujnika położenia wału i nie umieszczony na schemacie, gdyż nie do końca wiem jak to zrealizować sygnał napięciowy z czujnika tensometrycznego o zasilaniu 12V i czułości 3mV/V. Sygnałami wyjściowymi będą sygnały wyzwalające przekaźniki i przede wszystkim odizolowana optycznie część klucza prądowego sterowanego PWMem.

    Za wszelkie uwagi z góry dziękuję i będę się starał uzupełniać braki na bieżąco.

    Witam
    Skoro jest to twój pierwszy projekt, to postaram się zbyt mocno cię nie "pognębić". A więc, elementy dobieraj zgodnie z ich parametrami. Chodzi mi o wielkość obudów transformatora ,mostka prostowniczego kondensatora C3 (trafo jak na 180W to obudowa mikroskopijna, mostek na ok 20 ÷ 30A a kondensator ? ). Poszukaj najpierw w internecie takich elementów i dopiero w programie staraj się dopasować takie lub podobne obudowy. Transformator tej mocy sugerowałbym umieścić poza płytką a na płytce umieścić tylko złącze (np ARK). Skoro projektujesz przy użyciu elementów przewlekanych to nieporozumieniem jest zastosowanie gniazda ISP (CON1) i rezystora nastawnego (R1) w technologii SMD. Niepotrzebnie stosujesz "tak wielkie" rezystory, w zupełności powinny wystarczyć 0204/7 (biblioteka RCL >R EU_>). Także nie bardzo widzę potrzebę sygnalizowania zmiany stanu przekaźnika diodami LED. Do wyjść przekaźników powinieneś podłączyć jakieś złącza, bo jak na razie będą one przełączać "sobie a muzom". Masz też niepodłączone kondensatory C4 i C5 do masy. Nie musisz także prowadzić połączenia z jednego krańca schematu na drugi. Wystarczy, że umieścisz np: przy zasilaniu 5V, symbol tego zasilania a program wszystkie ścieżki z tym symbolem będzie traktował jako jedną. Na koniec rysowania schematu włącz "ERC" i postaraj się usunąć wszystkie uwagi jakie pojawią się w jego raporcie (jak na razie to te możesz zignorować). Na razie tyle spostrzeżeń, może inni zobaczą więcej.
    Pozdrawiam.

    0
  • Mitronik
  • #3 07 Lut 2011 18:31
    mattkap
    Poziom 11  

    Witam uwagi były pomocne i poprawki zostały naniesione. Załączam poprawiony schemat i proszę o dalsze uwagi. W między czasie pozmieniały się trochę wytyczne projektu, ale idea jest nadal ta sama. Choć Atmega może wydawać się teraz nieco "goła" ponoć później będzie rozbudowywana.

    0
  • Pomocny post
    #4 07 Lut 2011 23:26
    marco47
    Poziom 41  

    Nie podłączaj AREF do AVCC, tylko daj tam kondensator 10uF. A napięcie ustaw programowo.
    Jest to bezpieczniejsze i bardziej wygodne.
    Bo jeżeli przez nieuwagę ustawisz napięcie referencyjne na 2.56V (wewnętrzne), to podanie w tym samym czasie napięcia z zewnątrz (+5V), może doprowadzić do zniszczenia Atmegi.

    Dodaj jeszcze kilka kondensatorów elektrolitycznych (100-220uF) na zasilaniu +5V, bo same ceramiczne to za mało.

    Brakuje rezystora 10k podłączonego do Reset i do +5V.

    0
  • #5 08 Lut 2011 12:15
    mattkap
    Poziom 11  

    Dziękuję za uwagi poprawiłem kolejne błędy i dodałem brakujące elementy wg cennych uwag. Dziękuję za zainteresowanie tematem. Kolejny raz wrzucam poprawioną wersję w pierwszym poście. Jeśli ktoś dopatrzyłby się jeszcze błędów będę bardzo wdzięczny.

    Pozdrawiam Mateusz.

    0
  • Pomocny post
    #6 08 Lut 2011 18:23
    marco47
    Poziom 41  

    Niepoprawnie podłączyłeś kondensator do AREF.
    Kondensator C1 przy Reset nie łącz z +5V tylko z masą.

    Aby nie było znowu pomyłki pokazuję poprawnie narysowany schemat.
    Jak widzisz zlikwidowałem wszystkie linie które doprowadzały zasilanie i zastąpiłem je odpowiednimi symbolami.
    Wtedy schemat nabiera przejrzystość, i łatwiej go odczytać.

    [Eagle] Prośba o sprawdzenie poprawności schematu

    0
  • #7 20 Lip 2011 10:25
    mattkap
    Poziom 11  

    Dziękuję marco47

    Twoje uwagi pozwoliły na poprawne wykonanie projektu ostatecznie rozrósł się jeszcze bardziej i troszkę jeszcze trzeba było posiedzieć nad projektem PCB. Ogólnie zachęcam do realizacji własnych projektów i cieszę się że istnieją tacy ludzie, którzy pomagają w problematyce elektronicznej.

    Dziękuję jeszcze raz wszystkim dyskutującym.

    0