Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Poprawność podłączenia mikrokontrolera

05 Lut 2011 17:20 2067 16
  • Poziom 11  
    Witam.
    Posiadam programator USBasp i uC atmega16.
    Programy nie wykrywaja mi uC.
    Czy coś źle podłączyłem?
    Oto schemat który narysowałem i sposób w jaki go podłączyłem. Te pomarańczowe to kondensatory. Z zasilaniem dodatkowym czy bez nie działa.
    Schemat wykonany w paincie za co przepraszam.
    Poprawność podłączenia mikrokontrolera
  • PCBway
  • Poziom 32  
    A Vcc do procesora podłączyłes?
  • Poziom 20  
    Jeśli podłączyłeś to jak na rysunku to nie ma szans działać bo kondensatory masz szeregowo w liniach zasilania
  • Poziom 11  
    Poprawiłem to w następujący sposób Poprawność podłączenia mikrokontrolera
    i ciągle nic ;/
  • PCBway
  • Poziom 20  
    Noga 31 popraw kondensator bo jest szeregowo.Ten prostokąt z lewej to gniazdo czy wtyczka i od której strony ? ? ?
  • Poziom 11  
    poprawiłem, ciagle nic.
    Poprawność podłączenia mikrokontrolera

    Prostokąt ten to wtyczka, jest podłączona prawidłowo
  • Poziom 32  
    Tak sobie możesz rysować dla siebie, więc nie oczekuj że ktoś bedzie sie wysilał. A skoro jest dla ciebie prawidłowo to w czym problem?
  • Poziom 20  
    Z czego zasilasz ten procesor w trakcie programowania ?
  • Poziom 11  
    zasilacz 12V i stabilizator napięcia 7805
  • Poziom 20  
    Programator tez tym zasilasz ?
  • Poziom 11  
    próbowałem z zasilaniem i bez niego bo niby wystarczy zasilanie z programatora
  • Poziom 20  
    Piszesz ze używasz USBasp jesteś pewien ze programator sprawny ? ? Jakiego programu używasz ?

    Dodano po 9 [minuty]:

    Fabrycznie atmega ma ustawiony oscylator na 1Mhz wiec musisz przełączyć zworkę SCK_slow na programatorze.
  • Poziom 11  
    khazama AVR Programmer. Zworka jest przełączona. Programator kupiłem sprawny sprawdzony przed wysyłka. Gdy próbuje przesyłać dane zapala się dioda od transmisji wiec raczej działa
  • Poziom 20  
    A na innym procku próbowałeś ?
  • Poziom 11  
    Nie mam innego procka
  • Poziom 42  
    Panie autor, zanim zaczeniesz robić takie układy polecam ci jednak nauczyć się najpierw rysować schematy poprawne a nie umieszczać tutaj laurek rodem z przedszkola ;) ..... sam przez to będziesz ciągle błędy w układach robił, palił scalaki a inni nie będą cię rozumieli gdy będziesz zadawał pytania na jakimś forum. Masz przecież do dyspozycji darmową wersję programu EAGLE do pobrania ze stronki www.cadsoft.de . Opisów też znajdziesz na niecie mnóstwo jak narysować w nim szybciutko swój schemat.

    Ok a teraz do meritum, zanim zaczniesz sprawdzać innego procka itp - to najpierw sprawdź czy ty w ogóle dobrze podłączasz się go GNIAZDA lub WTYCZKI - ISP (KANDA) ????? bo coś mi się zdaje, że tu robisz wielki błąd (poza tymi schematami oczywiście).

    Poniżej masz widok takiego gniazdka na płycie wraz z rozpisanymi pinami tzn ich numerami. A patrząc na te twoje ala-pseudo-schematy coś mi się wydaje, że robisz wszystko odwrotnie.

    Poprawność podłączenia mikrokontrolera