Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Czujnik wilgotności w stacji pogodowej

mczapski 08 Lut 2011 10:45 1506 0
  • #1 08 Lut 2011 10:45
    mczapski
    Poziom 38  

    Użytkuję stację pogodową trudną do identyfikacji (przynajmiej na razie). Stacja przez rok można powiedzieć, że spisywała się poprawnie. I właśnie w niedzielę wskazania z czujnika zewnętrznego radiowego popsuły się. Mianowicie temperaturę zawyżył o ok 10 st C a wilgotność spadła do 20%. Ponieważ nic szczególnego nie dało się stwierdzić zajrzałem do środka czujnika/nadajnika. I jedyne miejsce chyba niepoprawne to woda w komorze czujników temperatury i wilgotności. Wydmuchałem wodę i osuszyłem rejon czujników. Zmieniły sie wskazania temperatury ale wilgotność pozostała 20. Wyciągnąłem czujniki z komory (czujnik wilgotności przyklejony na glue). Z termistorem wszystko w porządku a czujnik wilgotności optycznie w porządku. Czujnik oznaczony chyba tylko pomarańczową kropką i optycznie podobny (lub identyczny) jak GY-HR 002. Próby bezpośredniego zawilgocenia czujnika skutkują zmianami wskazań. Równoległe podłączenie kondensatora 68 nF też powoduje wzrost wskazań do 95%. Pomiary oporności czujnika dały jakieś wielkie wartości, ale nie mam warunków do pomiarów fachowych jak na taki element. I obecnie mam dylemat
    jak usprawnić wskazania wilgotności zewnętrznej. Czy to jednak padnięty czujnik? A jeśli tak to jakiego szukać?
    I jeszcze dla uzupełnienia podaję, że przetwornik na płytce EM3331TXC, gdzie na ścieżkach napylna jakaś górka.
    Stwierdziłem w wyniku zabaw, że w warunkach pokojowych wynik w miarę poprawnych wskazań uzyskuję przez podłączenia kondensatora 1 nF lub rezystora 33 kOhm. Czyli dalej nie wiem jaki to ma być ten czujnik.
    Dla potomnych. Czujnik zbocznikowany po pewnym czasie zaczął pokazywać całkiem poprawne wartości. Później generalnie zbuntował się cały nadajnik zewnętrzny tj cały czas nadawał (czerwona lmapka). Z braku pomysłów połozyłem romontowany w szufladzie. I kiedy w końcu paxdziernika spróbowałem go uruchomić okazało się, że owszem działa i przekazuje informacje do stacji do dzisiaj. Czyli pewno wilgoć robi swoje i nie ma na to rady.

    0 0