Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Pompa wspomagania TRW- Faulty

09 Lut 2011 17:53 20769 18
  • Poziom 17  
    Witam serdecznie
    Pompa wspomagania TRW (od skoda fabia) po naprawie. Na stole vcds (adres 44) wywala błąd 01309 - Power Steering Control Module (J500) 37-00 - Faulty. Podpięta do samochodu –to samo .Błąd nie chce się skasować ani w samochodzie ani na stole .
    Pytanie
    1)czy błąd 01309 - Power Steering Control Module (J500) 37-00 - Faulty (jesli pompa jest już elektrycznie sprawna i jest w samochodzie) powinien dąć się normalnie wykasować vcds-em pod adresem- 44 -czy nie ? Jest to błąd 37-00 - Faulty a nie No Communication.
    2) czy ktoś podłączał tą pompę na stole do vag-a i czy każda (dobra czy zła) bez samochodu wywala błąd 01309 - Power Steering Control Module (J500) 37-00 Faulty ? czy raczej nie powinno być tego błędu (na stole)?
    3) Czy ktoś z szanownych kolegów dysponuję wsadem do 24c02 z tej pompy ?
    Jeśli tak to bardzo bym prosił o kontakt . Chciałbym go porównać z moim.

    4) czy można wymusić jakoś start tej pompy na stole ?
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 39  
    Uszkodzony moduł sterujący pompy.
  • Poziom 17  
    trans-serwis napisał:
    Uszkodzony moduł sterujący pompy.


    Na to wskazuje błąd- ale napisałem że pompa (elektronika) naprawiona a błąd dalej występuje. Czy dobra pompa na stole( bez samochodu wywala błąd 01309 - Power Steering Control Module (J500) 37-00 Faulty ? czy raczej nie powinno być tego błędu (na stole)?
    Znasz odpowiedz na któreś z pytań z pierwszego postu ?
  • Poziom 39  
    1. Skąd pewność, że pompa jest elektrycznie sprawna.
    2.Nie wiem.
    3. Nie mam takiego wsadu.
  • Użytkownik obserwowany
    Ale co naprawione- błąd braku komunikacji?
  • Poziom 17  
    Bo przesiedziałem nad nią tydzień i prawie schemat narysowałem .Sprawdziłem co tylko mogłem ale 100% pewności że dokładnie wszystko sprawdziłem nie mam -stąd ten post .
    Myślę (może się mylę...) że pompa po usterce wpisała sobie na stałe do pamięci info o błędzie, którego normalnie nie da się skasować, żeby się o tym przekonać zadałem te właśnie pytania. Odpowiedzi na nie pokierowały by mnie, co dalej robić z tym fantem .

    romoo napisał:
    Ale co naprawione- błąd braku komunikacji?


    uszkodzone tranzystory- wymienione. Sterowanie nimi od procka do bramek sprawdzone i jest ok.
    Komunikacja jest bo sterownik jest wykrywany i pokazuje wartości w blokach pomiarowych -te co może pokazać na stole np. temperaturę modułu ,godziny przepracowane
  • Poziom 10  
    witam
    Właśnie kilka dni temu dostałem 4 pompy TRW (i 2 koyo) do naprawy. Jako że jest to nowy temat dla mnie do rozgryzienia mam parę pytań do kolegi i myśle że bede mógł też pomóc. Cześć pomp jest już elektrycznie naprawiona, (wymiana tranzystorów i oporników sterujących), część była po prostu zalana i po wysuszeniu nie ma namierzalnych uszkodzeń na miernik. Zrobiłem też interfejs CAN z myślą że bede mógł pompy uruchomić na stole. Interfejs jest na sja1000 + procek z rodziny 51'. Problem w tym że nie mogę znaleźć nigdzie procedury uruchomienia takiej pompy przez CAN ani nie wiem jakie bajty w ramce za co odpowiadają, nie wiem też jak ją zapytac aby przesłała liste swoich błędów. W elektronice samochodowej to mój pierwszy temat wiec prosze wybaczyć za głupie pytania. W zamian mogę jutro podesłac wsady pamieci w wszystkich moich pomp. Aha nie wiem też do końca jakie sygnały przychodzą do pompy z samochodu. Zlokalizowałem magistrale CAN na pinach pompy i zrobiłem symulator czujnika skrętu TRW ale wiem że cześć pomp sygnał o położeniu kierownicy dostaje po magistrali. Nie wiem też jak wyglądają takie ramki CAN z czujnika skrętu w kabinie. Jeśli jest ktoś zainteresowany wymianą wiedzy prosze o kontakt gg: 5140227, lub mail proox(malpa)tlen.pl
  • Poziom 17  
    Witam
    o wreszcie ktoś chętny do współpracy :)
    Jeśli możesz to wsady podeślij mi na maila . Dobrze było by żebyś je jakoś opisał ,który wsad z jakiej pompy i najlepiej jakie błędy wyrzuca na stole. .Pompę możesz na stole zapytać o błędy vcds-em (inaczej vag-com hex )

    Interesuje mnie ten twój interfejs ,który zrobiłeś -Jeśli możesz to podeślij mi też szczegóły co do tego interfejsu.

    Co do pomp TRW, bo taką właśnie mam.
    Podłączenie po kolei zaczynając od złącza 4pin : 1-CAN L ,2-CAN H,3-pusty nie podłączony,4-+12V po stacyjce (15)
    grube 2pin:(stałe zasilanie z akumulatora (30) 1- masa ,2- +12V
    i ostatnie czujnik obrotu kierownicy 3pin: 1-zasilanie czujnika 2-masa 3-wyjście czujnika
    Pompa ma chodzić nawet bez podpiętego czujnika skrętu .Błędy czujnika skrętu nie zapisują się na stałe do pamięci pompy .Po zdjęciu zasilania powinny zniknąć,a po ponownym włączeniu stan wejść czujnika jest sprawdzany od nowa i jeśli nie ma czujnika pompa wywala błędy ale powinna normalnie ruszyć .

    Jak zrobiłeś symulator czujnika?

    Najbardziej przydatne było by właśnie zmuszenie pompy do pracy na stole ale to chyba nie takie proste (choć na pewno wykonalne) pompa dostaje sygnał startu po Can z komputera jeśli ten uzna, że pompa ( po ładnym przedstawieniu mu się ) nie ma błędów i jest gotowa do pracy .
    Trzeba by zrobić symulator can i wydać pompie takie polecenie trzeba jeszcze znać rozkaz i umieć go wysłać ,pewnie gdzieś mają takie programy ale gdzie i jak je zdobyć ....
    Acha pompa monitoruje napięcie obu zasilań ,może wystartować w samochodzie tylko przy zapalonym silniku i jeśli zasilanie na niej nie spadnie za dużo np pod wpływem złego stanu instalacji lub nie kontaktów

    Na razie tyle ode mnie
  • Użytkownik obserwowany
    Podeslij wsady dobrze opisane o nr pompy i jakie ma błędy.
    POzatym mozesz wymienić memorki i zobaczyć czy nowe błędy zarejestruje w niej.
    Albo pusta pamięć wlutować.
  • Poziom 10  
    Witam
    Postaram się dziś podesłać wsady. Też prawie zrysowałem schemat tej płytki i piny pompy miałem rozszyfrowane, nie byłem pewien tylko "napięcia po kluczyku". Mój interfejs CAN jest zrobiony na szybko i jestem na etapie kończenia pisania programu na procka (jeszcze go nie podłączałem do pompy). Na razie jest to najprostsza wersja, procek odczytuje interfejs CAN i wysyła ramki po RS232 do PC gdzie w TERMINALU Windowsa można sobie przeglądać ramki. Jak rozszyfruje transmisje z pompą to docelowo ma to być urządzenie z klawiaturą i wyświetlaczem graficznym LCD i symulatorem czujnika skrętu pozwalające na całkowitą diagnostykę takiej pompy i jej prace na stole. Pompa bez ruchu kierownicą nie pobiera dużego prądu, mi wyszło w FABII około 3A a przy kręceniu kierownicą skakało do 30A, jest jeszcze kwestia próbkowania przez cęgi wiec samych "szpilek" prądu nie uchwyciłem. Na stole powinna pobierać jeszcze mniej bo bez płynu. Jeśli nikt nie podpowie jakie ramki krążą po CANie to sie położę z interfejsem pod samochód i zapisze całą wymianę danych w mojej FABII. I TU MAM PYTANKO DO KOLEGÓW!!! Czy magistrala CAN do pompy to ta sama co na złączu ODB w kabinie. Bo w dokumentacji elektrycznej komputera widać że jest kilka linii CAN i transmisja ma różne prędkości. Szybka do urządzeń podstawowych takich jak pompa i silnik. Wolna natomiast do mniej znaczących peryferiów takich jak elektryczne szyby, klima, radio.
  • Poziom 17  
    romoo napisał:

    Albo pusta pamięć wlutować.


    che.. che.. na pustej nie pójdzie

    Lukasz W napisał:
    nie byłem pewien tylko "napięcia po kluczyku".

    elektronika startuje -łącznie z zasilaniem 5V na układy dopiero po podaniu tego napięcia . Pobór prądu z podłączonymi tylko 12V stałe na (30) = 0,3mA
    natomiast z podłączonym dodatkowo 12V po kluczyku (15) pobór ok. 80 mA i can na stole od razu również jest wysyłany można sprawdzić oscyloskopem.

    Lukasz W napisał:
    Czy magistrala CAN do pompy to ta sama co na złączu ODB w kabinie.

    Raczej nie. Transmisja od złącza w kabinie przechodzi przez
    Address 19: CAN Gateway (łączy "toto" wszystkie transmisje żeby dogadały się między sobą)
    Part No: 6N0 909 901
    Component: Gateway K<->CAN 1S31
    Przynajmniej tak jest w tej fabi z moich testów, wychodzi że ze złącza do Gateway leci po K
    Ja mam trochę utrudniony dostęp do prób przy samochodzie bo pompa jest u mnie a auto kilka kilometrów dalej
    Lukasz W napisał:
    Pompa bez ruchu kierownicą nie pobiera dużego prądu, mi wyszło w FABII około 3A a przy kręceniu kierownicą skakało do 30A


    Vcds ma taką funkcje że oprócz jeszcze innych rzeczy pokazuje prąd pobierany przez pompę .Osobiście tego nie sprawdziłem bo pompa w rozsypce ale gdzieś poczytałem że ta pompa może pobierać nawet do 45 A przy kręceniu kierownicą

    i w końcu nie wiem jak zrealizowałeś symulator skrętu kierownicy ?
    Nie wiem co jest w środku bo nie miałem go do roboty .Masz taki rozebrany i możesz kliknąć fote?
  • Poziom 10  
    Aby zachęcić kolegów do pomocy oferuje zaprogramowany procek i schemat urządzenia w zamian za istotne informacje jak wygladają ramki CAN odbierane i wysyłane przez pompę oraz jakie bajty za co odpowiadają. Interesują mnie pompy TRW i KOYO.
  • Poziom 17  
    Tak muszę sobie sam odpowiedzieć na parę pytań :

    ad1) Niestety, nie da się .

    ad2) Tak ja podłączałem i takiego błędu być nie powinno.

    ad3) Dzięki koledze Lukasz W już mam i sobie pooglądałem . Bardzo dziękuję koledze .

    Niestety na 4 pytanie nie uzyskałem odpowiedzi ani sobie z tym nie poradziłem . Dlatego nie zamknę tematu. Może znajdzie się jeszcze ktoś życzliwy, kto pomoże w budowie jakiegoś symulatora can ,który wyda odpowiednie dyspozycje pompie, żeby ta gadzina ruszyła na stole .
  • Poziom 10  
    Spokojnie, ja pracuje nad tym problemem. Niestety szalejąca grypa opóźniła prace nad interfejsem.
  • Poziom 2  
    Cześć mam pytanko mam w fabi problem z błędem 00816 - Power Steering Sensor (G250): Faulty, wymieniłem czujnik na nowy i jest to samo po odłączeniu czujnika jest błąd 00816 - Power Steering Sensor (G250): Open or Short więc sterownik czujnik widzi. Czujnik nowy jest nowy:) nie używany, i na pewno dobry typ. Czy to będzie wina elektroniki czy jednak nowy czujnik też jest uszkodzony? I mam pytanko jaki sygnał wyjściowy daje czujnik skrętu?
  • Poziom 18  
    A czy to nie jest wina wiązki ?
  • Poziom 2  
    Czujnik wymieniony z nową wiązką.
  • Poziom 17  
    może czujnik a może elektronika pompy (postawiłbym na czujnik) .
    czujnik 3pin: 1-zasilanie czujnika 2-masa 3-wyjście czujnika zmierz zasilanie miedzy 1 i 2 powinno być ponad 12v i oscyloskopem na 3-wyjście- zobacz co jest i jak się zmienia podczas kręcenia kierownicą.