Elektroda.pl
Elektroda.pl
X
Elektroda.pl
MetalworkMetalwork
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sterowanie napięciem zmiennym

PiotrEtenM500 10 Lut 2011 18:40 15641 122
  • #31
    atom1477
    Poziom 43  
    asembler napisał:
    atom1477 napisał:
    asembler napisał:
    Napiecie dostanie sie poprzez złącze kolektor baza.

    Jakim cudem?

    Przecież aby włączyc ten tranzystor napiecie na bazie musi byc wieksze o na emiterze o 0.7V. a skor napiecie na emiterze teoretycznie osiągnie 12V to na bazie pojawi si ete 12V. Tak?

    A od kiedy to napięcie na emiterze wymusza napięcie na bazie?
    To napięcie na bazie wymusza napięcie na emiterze.
    Podając na bazę 5V wymusisz na emiterze 4,3V, i nic po za tym.
    Emiter nie będzie na siłę chciał zwiększyć swojego napięcia do 12V.
  • MetalworkMetalwork
  • #32
    asembler
    Poziom 32  
    Faktycznie nie PNP ale i tak nie ma prawa działac bo żeby go właczyc to procesor musialby byc zasilany z 12V
  • MetalworkMetalwork
  • #34
    Fredy
    Poziom 27  
    asembler napisał:
    Faktycznie nie PNP ale i tak nie ma prawa działac bo żeby go właczyc to procesor musialby byc zasilany z 12V


    eetam - nie masz racji. Będzie działać - wszytko jest OK.
    Tranzystor PNP tu nie ma racji bytu - no chyba że jako kolejny stopień sterowany tym tranzystorem NPN.
  • #36
    Fredy
    Poziom 27  
    A układ ten , to nie wiem czy autor zauważył aby działać to procek musi dawać ciągłe impulsy ( około 50 Hz) i to w odpwoiednim momencie. A niby skąd ma procek wiedzieć kiedy włączyć ,skoro nie ma detekcji zera?

    Także po raz kolejny twierdzę że przyczyna tkwi w tym kondensatorze - należy go wywalić i po sprawie.
  • #37
    asembler
    Poziom 32  
    Abstrachując od tej całej dyskusji to czy ktoś o zdrowych zmysłach podłączyłby w ten sposób tranzystor?
    Ja bym się bał bo to szukanie kłopotów w przypadku przebicia tranzystora atmega też leci i o to mi chodzi od samego początku.
  • #38
    atom1477
    Poziom 43  
    Jeżeli tam nadal jest kondensator, to faktycznie trzeba dawać impusly (ale wcale nie trzeba ich z niczym synchronizować).
    Nie wyjaśnia to jednak dlaczego triak się nie wyłącza.

    asembler napisał:
    Abstrachując od tej całej dyskusji to czy ktoś o zdrowych zmysłach podłączyłby w ten sposób tranzystor?
    Ja bym się bał bo to szukanie kłopotów w przypadku przebicia tranzystora atmega też leci i o to mi chodzi od samego początku.

    Zakładając przebicie to żaden schemat nie ma sensu bo przecież tak samo można założyć że każdy inny element też może przebić.
    Więc myślę że po prostu teraz jak zrozumiałeś o co chodzi to się wykręcasz :D
  • #39
    asembler
    Poziom 32  
    No i tak sie powinno robic. Po co maja straty być wieksze niż potrzeba?

    Fredy napisał:


    eetam - nie masz racji. Będzie działać - wszytko jest OK.

    W takim razie jakią amplitudę będą miały impulsy na emiterze?
  • #40
    atom1477
    Poziom 43  
    asembler napisał:
    No i tak sie powinno robic. Po co maja straty być wieksze niż potrzeba?

    Ale nie należy przesadzać. Przecież nawet dokładając optoizolację nic nie zyskasz, bo można założyć że optoizolacja też przebije.
    Dlatego nie przesadzajmy z tym zakładaniem.
    Optoizolacja na 99,9% nie przebije.
    I tak się składa że tranzystor w układzie OC, też nie.

    asembler napisał:

    Fredy napisał:


    eetam - nie masz racji. Będzie działać - wszytko jest OK.

    W takim razie jakią amplitudę będą miały impulsy na emiterze?

    4.3V.
  • #41
    LordBlick
    VIP Zasłużony dla elektroda
    atom1477 napisał:
    Nie wyjaśnia to jednak dlaczego triak się nie wyłącza.
    Bo jest wysterowany przez diodę zabezpieczającą w µC ? Optoizolacja ?
  • #42
    asembler
    Poziom 32  
    Albo dac NPN "normalnie" czyli emiterem do masy i wtedy dziala na 100%
    Rozebrałem swój regulator bo juz nie pamietałem jak to zrobiłem i mam własnie tak zrobione a opornik do +12V 620 Ohm.
  • #44
    PiotrEtenM500
    Poziom 19  
    Atom, nadal ten sam problem nie chce się wyłączyć i szaleje w chwili zbliżenia lutownicy czyli włącza wyłącza w tempie jak sadze sieci.
    Dla pewności podłączyłem MOC3021 i przy optoizolacji
    wszystko działa jak należy. Zresztą to klasyczne podłączenie
    które od zawsze stosowałem. Zastanawia mnie czy CNY17
    nie pomoże, niestety w domu nie mam ani jednej sztuki. Jutro przyniosę z pracy
    i podłącze, ale to wraca do pierwszego zamieszczonego schematu czyli wersja z tranzystorem


    Sterowanie napięciem zmiennym
  • #46
    PiotrEtenM500
    Poziom 19  
    Tak, jest żle rysowane.
    bez kondensatora układ jest podatny na zakłócenia, wystarczy przeciągnąć ręką
    przy bramce i zaczyna pulsacyjnie włączać/wyłączać. Możliwe, że przyczyną jest układ budowany na "pająka". Przy PCB nie powinno się to dziać
  • #47
    janbernat
    Poziom 38  
    Moze by tak zewrzeć kabelkiem gate z GND i zobaczyć czy się wyłączy.
    atom- a jak ty odróżniasz A1 od A2 w triaku w zasadzie symetrycznym?
    I jak procesor miałby się spalić- nawet dla 24V/330ohm=7.27mA?
    P.S.
    No i w zasadzie jak te masy są podłączone?
    No bo nie wiadomo czy na tych 24 V nie jest podłączona żarówka 100W.
  • #48
    atom1477
    Poziom 43  
    Triak nie może być symetryczny. Przecież przy napięciu A1...A2 równym np. 24V gdyby na bramce względem np. A1 było 0V, to względem A2 było by 24V. Albo jak względem A2 0V, to względem A1 24V. To w obydwu przypadkach triak powinien się wyzwolić.
    A tak nie jest. Nie wyzwala się w obydwu przypadkach.
    Po prostu nie ma takiego napięcia na bramce żeby przy 24V pomiędzy A1 i A2 jednocześnie pomiędzy A1 i G oraz A2 i G było 0V.
    Zatem jedna elektroda musi być wyróżniona i tylko napięcie względem niej decydować o wyzwalaniu, nie?
    A jak odróżniam A1 od A2?: na podstawie datasheeta :D
  • #49
    janbernat
    Poziom 38  
    Bardzo dawno tego nie robiłem.
    Czyli- T1 albo A1 do GND i sterowanie Gate względem T1 (A1).
    Kupię i sprawdzę.
    P.S.
    Triak teoretycznie powinien być symetryczny.
    P.S.2
    Ale nie jest.
    To wynika z budowy struktury.
  • #51
    atom1477
    Poziom 43  
    No właśnie. Czyli triak jest złożeniem dwóch tyrystorów, ale nie takich samych tyrystorów.
    Jeden z tych tyrystorów jest klasycznym tyrystorem z bramką będącą bazą tranzystora NPN w tym tyrystorze.
    Drugi z kolei już nie. Jego bramką jest baza tranzystora PNP.
    Czyli schemat zastępczy triaka jest taki:
    Sterowanie napięciem zmiennym
    a nie taki:
    Sterowanie napięciem zmiennym
    jak się często błędnie rysuje.
  • #52
    PiotrEtenM500
    Poziom 19  
    Poskładałem układ BT136, ale zamiast Atmegi dałem stabilizator 7805.
    Ze stabilizatora podaje 5V przez rezystor 330Ohm na Gate i pracuje
    zgodnie z założeniami czyli przy podaniu napięcia „włącza” się Triak ,
    ale rezystor grzeje się. Więc sprawdziłem prąd jaki płynie do Gate,
    wynosi 17mA. Taki prąd może być nie bezpieczny dla uC i to mogło być przyczyną
    „niewyłączania” się triaka. Więc pozostaje tak jak na początku narysowałem
    dołączyć tranzystor, tyle, że to powinien być, nie NPN, a PNP.
  • #53
    asembler
    Poziom 32  
    Ja mam zrobione sprawdzone do 20A triak.
    Sterowanie napięciem zmiennym
  • #54
    janbernat
    Poziom 38  
    Nie widzę triaka.
    A atom i light już dogłębnie wyjaśnili.
    Rezystor może się trochę grzać przy 85mW.
  • #55
    PiotrEtenM500
    Poziom 19  
    janbernat napisał:
    Nie widzę triaka.
    A atom i light już dogłębnie wyjaśnili.
    Rezystor może się trochę grzać przy 85mW.


    Przy 17mA PORT atmegi "zawiesza" się wiec jest naturalnym że
    konieczny jest tranzystor, choć jest też inne rozwiązanie jakie
    teraz sprawdziłem wystarczy miedzy PORT a GATE dać kondensator
    na porcie podawać prostokąt i działa jak należy;)
    ale to nie takiego rozwiązania szukam

    jest dokładnie tak jak pisał:

    Light-I napisał:
    Bez optotriaka, lub co najmniej transoptora, będzie ciężko - potencjały sterujące względem masy najlepiej, gdyby zmieniały swoją polaryzację...
    EDIT : po przemyśleniach...


    Twoje przemyślenia przełożyłem na doświadczenia i potwierdzam zgodność teorii z praktyką.
  • #56
    asembler
    Poziom 32  
    Niemozliwe żeby przy 17mA sie zawieszała Atmega. Niejednokrotnie pobieram wiecej i nic nie ma prwawa się zawieszać, chyba ze podpinasz port do wyższego napiecia niż zasilanie czego raczej nie powinno sie robić.
  • #57
    landy13
    Poziom 29  
    Może pomyśl o triaku dedykowanym do takich zastosowań. Np. takim.
    Sterowałem go z Atmegi przez 510Ω i nic się nie grzało.
  • #58
    atom1477
    Poziom 43  
    Akurat zastosowany triak jest mniej więcej dedykowany. A nawet bardziej dedykowany. Ma przecież mniejszy prąd wyzwalania niż ten z Seguro.
    Więc i na nim spokojnie zadziała.
    17mA na pewno nie uszkodzi portu.
    Całkowicie dopuszczały jest prąd 20mA.
    A krótkotrwały nie powodujący całkowitego uszkodzenia procka (co najwyżej ewentualne jego nieprawidłowe działanie) to 40mA.
    Pokaż program bo od dłuższego czasu czuję że to w nim jest problem.
  • #59
    PiotrEtenM500
    Poziom 19  
    landy13 napisał:
    Może pomyśl o triaku dedykowanym do takich zastosowań. Np. takim.
    Sterowałem go z Atmegi przez 510Ω i nic się nie grzało.


    Jeśli prześledzisz temat i zwrócisz uwagę na jpgi zobaczysz tam triak Z0107
    urządzenie będzie bazować na tym traiku, a to dlatego że będzie tego
    512 szt istotnym są gabaryty i koszty.
  • #60
    asembler
    Poziom 32  
    To chyba zastosujesz jakies rejestry przesuwne a nie bezpośrednio z Atmegi.
    Przy zastosowaniu 74hc595 mozesz bez tranzystorka sterować triakiem SMD nie pamietam teraz symbolu ale parametry to 1A 400v koszt 0.6zł/szt.
    Stosowane w sterownikach pralek elektrolux z 5V bez optoizolacji żadnej.