Elektroda.pl
Elektroda.pl
X
Elektroda.pl
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sterowanie napięciem zmiennym

PiotrEtenM500 11 Lut 2011 21:02 15203 122
  • #61
    PiotrEtenM500
    Poziom 19  
    atom1477 napisał:
    Akurat zastosowany triak jest mniej więcej dedykowany. A nawet bardziej dedykowany. Ma przecież mniejszy prąd wyzwalania niż ten z Seguro.
    Więc i na nim spokojnie zadziała.
    17mA na pewni nie uszkodzi portu.
    Całkowicie dopuszczały jest prąd 20mA.
    A krótkotrwale nie powodując całkowitego uszkodzenia procka (co najwyżej ewentualne jego nieprawidłowe działanie) to 40mA.
    Pokaż program bo od dłuższego czasu czuję że to w nim jest problem.


    Pomiary i testy robiłem teraz bez atmegi symulowałem "1" stabilizatorem 7805, wiec program tu nie ma nic do rzeczy.

    Sam program to standard

    Code:

    do
    Set Portb.1
    Wait 2
    Reset Portb.1
    loop


    asembler napisał:
    To chyba zastosujesz jakies rejestry przesuwne a nie bezpośrednio z Atmegi.
    Przy zastosowaniu 74hc595 mozesz bez tranzystorka sterować triakiem SMD nie pamietam teraz symbolu ale parametry to 1A 400v koszt 0.6zł/szt.
    Stosowane w sterownikach pralek elektrolux z 5V bez optoizolacji żadnej.


    Wolałbym skoncentrować sie na temacie głównym, unikajmy rozwijania innych aspektów. Temat zakłada wysterowanie triaka Z0107 bez stosowania optotriaków. Dopuszczam możliwość zastosowania transoptora ILQ615 SMD, a najlepiej bezpośrednio lub przy pomocy tranzystora
  • PCBway
  • #62
    asembler
    Poziom 32  
    Tylko gdzie znajdziesz procesor z 512 wyjsciami.
    Ja bym rozwinął własnie temat bo niektóre sprawy same by sie rozwiązały.
  • #63
    PiotrEtenM500
    Poziom 19  
    asembler napisał:
    Tylko gdzie znajdziesz procesor z 512 wyjsciami.
    Ja bym rozwinął własnie temat bo niektóre sprawy same by sie rozwiązały.


    Są to 4 urządzenia po 128 portów.
    każdy port ma swoje czujnik, czyli wejścia.
    Nie chce opisywać całości bo to inny temat

    Poprosiłem o pomoc w rozważeni - jeden port i podłączenie do niego traika.

    Narazie jest "poprawnie", z wyjątkiem rezystora,
    podłączonego do Bramy Triaka o mocy 0.125W,
    po 2 minutach robi się czarny
  • #65
    PiotrEtenM500
    Poziom 19  
    Myśle,że to nic nie zmieni. Trzeba będzie wpiąć tranzystor ewentualnie transoptor dla zabezpieczenia AVR'a. Nie bardzo wiem jak wpiąć tu transoptor

    Jeśli dodam tranzystor, to "odciąże" uC, ale rezystor 330 nadal będzie się grzacz, 0.25W też jest bardzo gorący.

    Wresja P
    Sterowanie napięciem zmiennym

    Wersja N

    Sterowanie napięciem zmiennym

    Wersja Transoptor

    Sterowanie napięciem zmiennym
  • PCBway
  • #66
    atom1477
    Poziom 43  
    PiotrEtenM500 napisał:
    atom1477 napisał:
    Akurat zastosowany triak jest mniej więcej dedykowany. A nawet bardziej dedykowany. Ma przecież mniejszy prąd wyzwalania niż ten z Seguro.
    Więc i na nim spokojnie zadziała.
    17mA na pewni nie uszkodzi portu.
    Całkowicie dopuszczały jest prąd 20mA.
    A krótkotrwale nie powodując całkowitego uszkodzenia procka (co najwyżej ewentualne jego nieprawidłowe działanie) to 40mA.
    Pokaż program bo od dłuższego czasu czuję że to w nim jest problem.


    Pomiary i testy robiłem teraz bez atmegi symulowałem "1" stabilizatorem 7805, wiec program tu nie ma nic do rzeczy.

    Ma, bo jak sam napisałeś, przy 7805 wszystko działa jak należy a przy uC nie.

    PiotrEtenM500 napisał:
    Sam program to standard

    Code:

    do
    Set Portb.1
    Wait 2
    Reset Portb.1
    loop

    No i proszę, mamy odpowiedz. A nie mówiłem? :D

    Powinno być:
    Code:

    do
    Set Portb.1
    Wait 2
    Reset Portb.1
    Wait 2                    'Tego brakowało
    loop


    EDIT.
    A jeżeli rezystor 0.25W nadal będzie bardzo gorący a triak nie będzie się chciał wyłączać, to stwierdzę że jednak źle podłączyłeś triaka (A1<-->A2).
    Żeby to sprawdzić, to w wersji bez uC tylko z 7805, podłącz bramkę triaka rezystorem do masy. Prawdopodobnie wcześniej nigdzie jej nie podłączałeś. A w momencie podania na rezystor 5-viu V załączał się triak co sugerowało że wszytko jest w porządku.
    Tym razem nie zostawiaj rezystora (a więc i bramki) niepodłączonego tylko podłącz go na sztywno do masy. Jeżeli triak się załączy to znaczy że masz pomylone anody.
  • #67
    PiotrEtenM500
    Poziom 19  
    Nie wiem ile da się odczytać ze zdjęcia. Widać BT136, 7805, rezystor pod przewodami.

    Triak się ślicznie włącza i wyłącza. problem pozostaje rezystorem dałem 330 , 0,25W i nadal jest bardzo gorący znacznie mniej niż na 0805, ale temperatura nie akceptowalna.

    Sterowanie napięciem zmiennym

    Co do softu to pisałem z buta i nie dopisałem "łejta" w programie jest jak najbardziej poprawnie
  • #68
    asembler
    Poziom 32  
    To moze faktycznie zastosuj optotriak zamiast transoptor i triak. Moze da sie dobrać do twoich parametrów.
  • #69
    atom1477
    Poziom 43  
    Chm, a któro to triak? :D To najmniejsze pewnie?
    Daj jeszcze ze 2 zdjęcia. Z innych stron.
  • #70
    asembler
    Poziom 32  
    Traik to ten bez kondensatorów filtrujących. Pierwszy plan
  • #71
    atom1477
    Poziom 43  
    A, to teraz załączasz przez transoptor? On nic nie daje. Jak już to trzeba było by dać optotriaka.
    No i jeżeli podłączyłeś to tak jak na tym schemacie na górze to robisz jedno wielkie zwarcie.
    Coś niemożliwe rzeczy się tu dzieją. U mnie triak normalnie się włącza i wyłącza. Czy to sterowany pinem uC czy też podczas samodzielnego podłączania go kabelkami gdzieś tam (i oczywiście nic się nie grzeje).
  • #72
    PiotrEtenM500
    Poziom 19  
    Jest podłączone dokładnie tak:


    Sterowanie napięciem zmiennym

    Na GATE triaka jest 13V !!!
  • #73
    atom1477
    Poziom 43  
    PiotrEtenM500 napisał:
    Jest podłączone dokładnie tak:

    Czyli źle. Masa nie jest wspólna.
    Masa 7805 i A1 triaka muszą być wspólne.
    Zamiast mostka Graetza daj jedną diodę prostowniczą co pozwoli połączyć to tak jak opisałem.
    No i weź pod uwagę że wyprostowane i odfiltrowane napicie przemienne 24V będzie bliskie maksymalnemu napięciu pracy stabilizatora 7805. Będzie to ze 33V a 7805 wytrzymuje 35V.
    Ale rozumiem że takie kombinacje to tylko do testów więc niech będzie.
  • #74
    asembler
    Poziom 32  
    To nie ma prawa dzialać
    Spróbuj dac oddzielne zasilania bo minus na mostku musi byc na triaku T1
  • #75
    PiotrEtenM500
    Poziom 19  
    Wiec to powinno być tak?

    Sterowanie napięciem zmiennym

    Tylko odrobine uciekamy od tematu. To mam być podpięte pod pod AVR konkretnie pod Atmegę256[/img]
  • #76
    asembler
    Poziom 32  
    Nic nie odbiegamy atmegę sobie podłączysz pod 5V.
    Z drugiej strony ja bym dał oddzielne zasilanie.
    Albo dodatkowye trafo albo dodatkowe uzwojenie.
  • #77
    PiotrEtenM500
    Poziom 19  
    asembler napisał:
    Nic nie odbiegamy atmegę sobie podłączysz pod 5V.


    Sterowanie napięciem zmiennym

    Cytat:
    Z drugiej strony ja bym dał oddzielne zasilanie.
    Albo dodatkowye trafo albo dodatkowe uzwojenie.


    Z dodatkowym trafem może być problem, w zakładzie są częste kontrole, każdy zasilacz musi mieć CE, Więc muszę kupować w sklepie gotowce z atestem. zasialcz z dwoma napięciami nie kupię. Dlatego musze bazować na jednym zewnętrzym AC 24V 4A
  • #78
    asembler
    Poziom 32  
    Ale taki zasilacz 5V to majątek kosztuje jakieś 10zł.
    A CE to nie jest atest tylko deklaracja producenta.
  • #79
    PiotrEtenM500
    Poziom 19  
    Nie chodzi o cenę, te akurat znam, chodzi o zachowanie kompaktowości, zasilacz musi być na zawnątrz. W obudowie nie znajdę miejsca.

    Zabrałem się za szkic projektu i chyba masz rację bez 2 TR może sie to nie udać.
  • Pomocny post
    #80
    atom1477
    Poziom 43  
    PiotrEtenM500 napisał:
    Wiec to powinno być tak?

    Sterowanie napięciem zmiennym

    Tak.
  • #81
    atom1477
    Poziom 43  
    PiotrEtenM500 napisał:
    Zabrałem się za szkic projektu i chyba masz rację bez 2 TR może sie to nie udać.

    A to wcześniej jak zasilałeś ATMegę?
  • #82
    asembler
    Poziom 32  
    Przeciez widać że z tego samego stabilizatora i stąd zała ta dyskusja.:-)
  • #83
    PiotrEtenM500
    Poziom 19  
    osobny zasilacz, ale tak jak widać na obrazu nie było wspólnej GND
    patrz pierwszy jpg

    Dodano po 2 [minuty]:

    asembler napisał:
    Przeciez widać że z tego samego stabilizatora i stąd zała ta dyskusja.:-)


    Z tego samego Surce były testy jak na zdjęciu.
    Atmege zasilam osobno

    Troche chaotycznie to opisywałem bo zbudowałem na szybko
    by nie palić atmeg układ na stabilizatorze
  • #84
    asembler
    Poziom 32  
    PiotrEtenM500 napisał:
    osobny zasilacz, ale tak jak widać na obrazu nie było wspólnej GND
    patrz pierwszy jpg

    Dodano po 2 [minuty]:

    asembler napisał:
    Przeciez widać że z tego samego stabilizatora i stąd zała ta dyskusja.:-)


    Z tego samego Surce były testy jak na zdjęciu.
    Atmege zasilam osobno

    Troche chaotycznie to opisywałem bo zbudowałem na szybko
    by nie palić atmeg układ na stabilizatorze


    Z tego co pisałeś to wyglądało że masz jedno trafo i tak chciałes docelowo zasilać.
  • #85
    PiotrEtenM500
    Poziom 19  
    tak masz słuszność chcę zrobić na jednym trafie,
    Twoje podpowiedzi o zastosowaniu 2 tr
    faktycznie wskazują na to że tak trzeba będzie zrobić
    wiec należy ten chaos informacyjny usystematyzować i
    przedstawić warunki

    1. Sterowanie triaka bezpośrednio z atmegi
    możliwość zastosowania ILQ615/tranzystora,
    2. Wspólne trafo AC24V
    3. Zakładamy ze steruje tylko jednym triakiem (pomijam inne porty)

    Jeśli będą 2 trafa czy to będzie miło sens masy nadal będą wspólne?

    Sterowanie napięciem zmiennym

    Jeszcze jedna uwaga rezystor 0,25W grzeje sie "średnio" 0,5W jest letni ale takich nie posiadam w SMD
  • #86
    atom1477
    Poziom 43  
    PiotrEtenM500 napisał:
    osobny zasilacz, ale tak jak widać na obrazu nie było wspólnej GND
    patrz pierwszy jpg

    Na pierwszym jpg masy są wspólne.
    Jak mamy Ci pomóc skoro dajesz schematy niezgodne z rzeczywistością i programy niezgodne z rzeczywistością?

    Co do schematu wyżej to jest on ok.
  • #87
    janbernat
    Poziom 38  
    Ja bym dał jedno trafo 24V- jak musi być CE to w obudowie- i małą przetwornicę na 5V.
    Może być bez izolacji.
    Gotową albo na jakimś tanim scalaku.
    Chyba wyjdzie taniej.
  • #88
    Fredy
    Poziom 27  
    Nie rozumiem - zamiast dać transoptor albo optotriak (najlepiej z detekcją zera) idziecie w podwójne uzwojenia?>
    Po co?
  • #89
    PiotrEtenM500
    Poziom 19  
    Fredy napisał:
    Nie rozumiem - zamiast dać transoptor albo optotriak (najlepiej z detekcją zera) idziecie w podwójne uzwojenia?>
    Po co?


    Już tłumacze

    1. potrzeba portów 512 to koszty i brak miejsca problemy z dostępnością w smd
    2. brak miejsca na optotiaki w obudowie dip
    3. mam transoptory które mogę wykorzystać ILQ615 SMD
    4. rozważałem czy da się sterować przez tranzystor by odciążyć uC
    5. jest jeszcze kilka innych mnie istotnych które nie poruszę bo to inny temat

    jesli mam dac transoptor, to można dać też tranzystor na jedno wyjdze? czy mas zna myśli opto izolację?
  • #90
    Fredy
    Poziom 27  
    mam na myśli optoizolacje oczywiscie. Przecież masz tylko 2 rozwiązania - albo dac podwójne uzwojenie albo dac pojedyńcze z optoizolacją.

    W tym układzie co podałes ostatnio chcesz sterowac triakiem wprost z procka. Sam pisałes że triak potrzebuje prawie 20mA do wyzwolenia.
    Jeśli cchesz użyć więcej takich obwodów to policz sobie czy nie przekroczysz pradu max dla ATMEGI.
    ja bym jednak dał tranzystory. Co więcej - AVRy nie mają zbyt dużego prądu wyjściowego, lepiej radzą sobie w odwrotnym kierunku czyli do masy.
    Sprawdz to w Datasheet.