Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

TDA7396 - pętla masy. Budowa wzmacniacza stereo.

26 Lut 2011 22:26 6106 28
  • Poziom 12  
    Mam malutki problem. Buduję sobie wzmacniacz stereo na dwóch kościach TDA7396 i niestety mam pętlę masy.
    Obudowy są na jednym radiatorze na podkładkach silikonowych.

    Masa dochodzi do układów z zasilacza i pętlę powoduje masa na kablu sygnałowym z wtyczką jack. Odłączając masę zasilania- układ się wyłącza, odłączając masę z sygnału- układ nie gra.

    Macie jakieś pomysły jak zażegnać ten problem?

    Nie jestem elektronikiem i walczę z tym już trzeci dzień. Nie mam pomysłów dla tego liczę na waszą pomoc ;]
  • Poziom 28  
    Cytat:
    Masa dochodzi do układów z zasilacza

    Z jednego, wspólnego?
    Cytat:
    odłączając masę z sygnału- układ nie gra

    Czy z dwóch osobnych?
  • Poziom 12  
    Małe sprostowanie: zamiast zasilacza używam akumulatora ponieważ ze wszystkich mi dostępnych źródeł napięcia on daje zerowe zakłócenia.
    Tak więc jest jeden akumulator zasilający oba scalaki.

    Sygnał odpowiadający za Lewy głośnik wraz z masą idzie do jednego scalaka, a sygnał odpowiadający za prawy głośnik + masa do drugiego. Eksperymentowałem z tą masą, odłączałem z jednego scalaka, z obu i nic mi to pozytywnego nie przyniosło ;/ masa musi być ;/
  • Poziom 28  
    No tak, masa być musi...
    Ale kurcze, mnoży ci się ona z opisu na opis.
    O ile jestem jeszcze w stanie pojąć, ile tych mas masz, z sygnałową zrób może tak:
    TDA7396 - pętla masy. Budowa wzmacniacza stereo.
  • Poziom 12  
    Nie no tak jak wspomniałem w pierwszym poście masa jest tylko przy zasilaniu i sygnale.

    Sytuację z ilustracji już przerabiałem- kabel masowy przylutowałem za pomocą krótkiego kabelka rozgałęziającego do pierwszych pinów

    TDA7396 - pętla masy. Budowa wzmacniacza stereo.
    Nic to nie dało niestety ;/
  • Poziom 27  
    Ale jaki masz problem?
    Piszesz że masa musi być - to oczywiste.
    Coś ci źle działa? Ale co?
    Są zakłócenia?
    Wzbudza się układ?
  • Poziom 28  
    No to nie wiem.
    Tutaj piszesz, że czytałes notę. A zapewniłeś to?:
    TDA7396 - pętla masy. Budowa wzmacniacza stereo.
    czy na pałę podpiąłeś pin 1 do masy?
  • Poziom 12  
    Tak są zakłócenia i to straszne. Po podłączeniu przewodu sygnałowego do układu głośnik zaczyna dość głośno buczeć, ba zdarzyło się nawet że posłuchałem sobie jakąś audycję radiową...

    Gdy mam podłączony tylko jeden układ scalony wszystko gra perfekt. Zero zakłóceń. Po przylutowaniu masy w drugim scalaku do pinów 6 i 10 wszystko również jest ok z pierwszym scalakiem. Jazda zaczyna się gdy do pinu nr.1 załączę masę przewodu sygnałowego. Wtedy zaczynają się cuda o których wspomniałem wcześniej.

    Póki co wszystko mam zamontowane na pająka w celu szybszej eliminacji źródła zakłócenia. Na PCB z uwagi na większe powierzchnie ścieżek niż w przypadku kabli z "pająka" zakłócenia były tak duże że strach się bać.
  • Poziom 12  
    fotonn napisał:
    No to nie wiem.
    Tutaj piszesz, że czytałes notę. A zapewniłeś to?:
    TDA7396 - pętla masy. Budowa wzmacniacza stereo.
    czy na pałę podpiąłeś pin 1 do masy?


    pierwszy pin to masa drugi sygnał

    Cytat:
    single ended mode with one onput capacitively coupled to the signal GND
  • Poziom 32  
    Nie bardzo rozumiem jak Ty to podłączasz. Montaż na płytce (jeśli tak to jakiej), czy jakaś konstrukcja partyzancka? Pin 1 masz przez kondensator do masy? Masa powinna być podłączona najpierw do układów, a dopiero od nich poprowadzona do jacka. Jak możesz daj fotki swojej konstrukcji, tylko takie żeby było coś widać.
  • Poziom 12  
    płytka- jednostronny laminat
    1 pin podłączyłem do masy z jacka przez kondensator 4,7 uF

    Fotek tamtej konstrukcji nie mam bo pcb wylądowało w koszu. Akurat robię pcb na jednego tda bo zmieniłem koncepcję. Jak skończę to dodam foto.

    Jeśli dowiem się jak można podłączyć te kości stereo to zrobię drugą pcb pod drugie tda, zmodyfikuję tą pierwszą pcb i będzie super ;]

    Panowie za pół godzinki dam foto
  • Poziom 12  
    jdubowski napisał:
    GeTaS napisał:
    płytka- jednostronny laminat
    1 pin podłączyłem do masy z jacka przez kondensator 4,7 uF


    Owa masa z jacka oczywiście jakoś połączona z masą reszty układu?

    Się rozumie.
    Niestety pcb nie będzie bo wywiało mi wszystkie wiertełka które miałem .szukałem i nic.
    Jak wygląda pcb? zrobiona najprościej wg. schematu. żadnych cudów. sądzę że fotka była by tu zbędna
  • Specjalista - urządzenia lampowe
    GeTaS napisał:
    jdubowski napisał:
    GeTaS napisał:
    płytka- jednostronny laminat
    1 pin podłączyłem do masy z jacka przez kondensator 4,7 uF


    Owa masa z jacka oczywiście jakoś połączona z masą reszty układu?

    Się rozumie.


    No to zobacz co będzie jak zmienisz miejsce tego połączenia.
  • Poziom 12  
    Witam ponownie. Kupiłem nowe wiertełka i skończyłem dwie osobne płytki do wzmacniaczy. Połączenia wykonałem cieńszymi ścieżkami niż w pierwotnej wersji PCB. Co się okazało moja lutownica widocznie jest za gorąca ponieważ w pierwszej płytce odpadła jedna ścieżka którą zastąpiłem białym kabelkiem.(foto). Płytki wykonałem bez ścieżki masa jack- masa scalaka żebym mógł swobodnie dobrać odpowiednie miejsce tak jak to kolega jdubowski doradził.

    Jaki efekt? CHYBA wszystko działa. Czemu chyba? otóż nie mogę tego w 100% powiedzieć ponieważ nie mogłem dokonać odsłuchu ma pełną skalę ponieważ rodzice już śpią...

    Co udało mi się dostrzec to jakieś błędy w regulacji głośności za pomocą potencjometru przykręconego tymczasowo do jednego z PCB (foto)

    Otóż do mniej więcej 1/3 obrotu regulacja przebiega płynnie. Podczas dalszego kręcenia podgłośnienie jest słabe by na końcu gwałtownie podgłośnić dźwięk. Potencjometr jest nowy 2x100k

    Jakieś sugestie Panowie?

    Jutro sprawdzę wzmacniacze na docelowych kolumnach i dam wam znać jak poszło.

    A na koniec fotki o których wspomniał szod. Jakość nie powala na kolana ponieważ zdjęcia były robione suszarką do włosów (żarcik...)

    TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo.
  • Poziom 32  
    Do regulacji poziomu dźwięku stosuje się potencjometry z charakterystyką B, Ty masz A. Przynajmniej ja tak widzę z nalepki na nim. Jeśli tak, to do wymiany.
  • Poziom 12  
    No bez jaj.... I co ja teraz z nim mogę zrobić? nada się on chociaż do regulacji wentylatora? 7zł poszło... w .. ech szkoda gadać.
  • Poziom 32  
    Coś tam zrobisz kiedyś. Dokup jeszcze z jeden albo dwa plus trochę dodatkowych części i zrób sobie regulator barwy dźwięku do tego wzmacniacza ;)
  • Poziom 12  
    Dobry pomysł. Jak tylko dokończę ten wzmacniacz żeby działał na 100% i dokończę kolumny to wezmę się za taki regulator
  • Poziom 12  
    Witam panowie ponownie po jednodniowej przerwie. Cały dzień przeznaczyłem na obudowę. Mam taką do wzmacniacza audioton zrobioną z drewna ale zrezygnowałem i korzystając z okazji że jechałem do Bydgoszczy- to tam jest ten najbliższy sklep; kupiłem obudowę Z1. Zapytałem się o ten potencjometr o charakterystyce B ale nie mieli. Ostatecznie zadowoliłem się obudową i elementami do skonstruowania regulatora obrotów wentylatora. Po powrocie do domu znalazłem na dnie skrzynki, uwaga uwaga:

    TDA7396 - pętla masy. Budowa wzmacniacza stereo.
    regulator reagujący na temperaturę :D Od razu porzuciłem pomysł z regulowaniem temp za pośrednictwem potencjometra ( kupione elementy się do czegoś przydadzą)

    Dobra mniejsza o to. O co się teraz rozchodzi: Po zmajstrowaniu obudowy, zrobienia tylnego panela, połączeniu wszystkiego w całość... zawiodłem się.

    Jeden wzmacniacz nie działa tak jak powinien. Dźwięk płynący z niego jest słabej jakości i co najgorsze cichy. Po zdemontowaniu go odkryłem, że strasznie mocno się grzeje. Co najciekawsze przed montażem nic złego się z nim nie działo, dla tego postanowiłem podłączyć go bezpośrednio do akumulatora bez sygnału i kolumny- myślałem że coś nie tak jest z instalacją w obudowie. Niestety bezpośrednie podłączenie nic nie dało- wzmacniacz nie domaga. Co może być tego przyczyną? Jakieś sugestie panowie? 8 marca jadę ponownie do Bydgoszczy i mógłbym w ostateczności kupić nowe TDA7396 gdyby te okazało się walnięte.

    Na koniec coś dla oka, czyli fotki obudowy, wnętrza(jeszcze przed uporządkowaniem kabli ponieważ nie mam małych opasek zaciskowych) i trefnego wzmacniacza.

    TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo.

    TDA7396 - pętla masy. Budowa wzmacniacza stereo. TDA7396 - pętla masy. Budowa wzmacniacza stereo.
  • Specjalista - urządzenia lampowe
    GeTaS napisał:

    Dobra mniejsza o to. O co się teraz rozchodzi: Po zmajstrowaniu obudowy, zrobienia tylnego panela, połączeniu wszystkiego w całość... zawiodłem się.


    Podkładki izolacyjne partacko założone, byc może masz zwarcie miedzy radiatorem a wkładką radiatorową. Po drugie - sprawdź czy nie masz gdzieś zimnych lutów, po trzecie - płytki wygląda że wiszą na końcówkach układów.

    BTW - zasilacz jest w oddzielnej skrzynce?
  • Poziom 12  
    Podkładki nie są założone partacko. Lewa się nieco przekręciła, a prawa wygląda jak wygląda bo majstrowałem nieco z podłączeniem tej drugiej kostki. Izolacja jest poprawna sprawdzana kilka razy multimetrem. Z resztą sprawdzałem źle działający segment poza całą konstrukcją bezpośrednio podłączony do źródła zasilania bez sygnału i kolumny ( jak to już było wcześniej stwierdzone).

    Zimnych lutów nie ma- lutowałem wszystkie połączenia ponownie.

    Trzecia sprawa: W tym momencie płytki wiszą ale gdy wszystko będzie działać poprawnie to przykleję je na gąbkę samoprzylepną ( taka sztywna gąbka powleczona z obu stron klejem). Moim zdaniem bardzo dobre rozwiązanie. Nie jest to wzmacniacz estradowy- ten będzie stał przy pc i nie będzie wielokrotnie ruszany, dla tego gąbka starczy.

    Zasilacza nie mam na razie. Na chwilę obecną wzmacniacz zasilany jest z akumulatora. Jak wszystko będzie działać poprawnie to zabiorę się za zasilacz. Od początku założyłem, że źródło zasilania będzie w osobnej skrzynce. Moim zdaniem estetyczniejsze wykonanie.
    Żyłą uziemniającą pociągnę przewód remote dla automatycznego załączania zasilacza + (co nie jest związane z tematem) opóźnione załączanie kolumn bo puka niemiłosiernie podczas włączania :cry:
  • Poziom 12  
    Wiecie co może być przyczyną słabego bassu w tym wzmacniaczu?
  • Specjalista - urządzenia lampowe
    GeTaS napisał:
    Podkładki nie są założone partacko. Lewa się nieco przekręciła, a prawa wygląda jak wygląda bo majstrowałem nieco z podłączeniem tej drugiej kostki.


    Pierwsze pytanie po co one w ogóle tam są - wkładka radiatorowa jest połączona z masą (pin 6), każda podkładka pogarsza tylko kontakt termiczny.
    Brak za to pasty termoprzewodzącej.

    GeTaS napisał:
    Wiecie co może być przyczyną słabego bassu w tym wzmacniaczu?


    Masz na myśli obcięcie niskich tonów?

    1. kondensator blokujący zasilanie - brak lub za mała wartość
    2. kondensator blokujący zasilanie - za daleko od układu, za wąskie ścieżki
    3. kondensatory na wejściach - za małe

    Masz mam nadzieję porządne głośniki w odpowiednich obudowach?
  • Poziom 12  
    Bez podkładek robi się pętla masy. Czemu nie ma pasty? Wyobrażasz sobie ciągłe odkręcanie i przykręcanie posmarowanych kostek? ja nie, dla tego nie smarowałem ich jeszcze.

    Dałem inne kondensatory na wejściu i jest lepiej.

    Trzeba jeszcze dokupić drugi scalak i chyba wszystko już będzie gotowe.
  • Poziom 12  
    Witam Panowie i Panie po znacznej przerwie. Dokupiłem nowe kondensatory, nowy układ scalony, bo jeden miał focha, zmontowałem wszystko i jestem zarąbiście zaskoczony :D Projekt skończony ;]
    Wzmacniaczyk gra z kompletem takich oto kolumienek które dostałem od kumpla za palmtopa. Były rozbite więc rozkleiłem je, posklejałem porządnie i ozdobiłem czarną okleiną. Na oklejenie czeka jeszcze druga sztuka. Oto one:

    TDA7396 - pętla masy. Budowa wzmacniacza stereo.

    Na moje skromne ucho gra wyśmienicie. Jedyne co mnie irytuje to po dotknięciu potencjometru słyszę piknięcie w kolumnach. No nic. kupię plastikową gałkę i będzie po problemie ;]

    Uzbieram kasę i zabiorę się za zrobienie porządnego zasilacza do tego wzmacniacza.

    Jeszcze raz wielkie dzięki dla wszystkich którzy mi pomogli. Jest to pierwsza w pełni samodzielna konstrukcja, od wykonania projektu pcb poprzez trawienie, lutowanie po przykręcenie ostatniej śrubki :D

    Trzeba będzie się wziąć za coś bardziej ambitnego w przyszłości
  • Poziom 32  
    Metalową obudowę potencjometru podłącz do masy.
  • Poziom 12  
    Sprawdzę to Panowie :D Dzięki za kolejną radę

    Podłączyłem potencjometr pod masę i zadziałało ;]