Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Biazet TC460 - dziwne zachowanie ukł. sterowania.

10 Mar 2011 23:16 2151 12
  • Poziom 14  
    Witam,
    zacznę może od początku: telewizor pracował jakiś czas, po czym ktoś próbował przełączyć go za pomocą klawiatury lokalnej na inny program, więc osoba ta otworzyła klapkę, chciała nacisnąć P+ i w tym momencie, jak wynika z relacji "popieściło ją" [ładunkiem elektrostatycznym] i nie dało się go już przełączyć na inny program [był na pr. 2], po wyłączeniu i ponownym włączeniu z gł. włącznika załączył się automatycznie [powinien do czuwania]; obrazu brak, dźwięku także i oczywiście brak reakcji na zdalne i lokalne sterowanie.

    Usunąłem teletekst i rozwarłem Z801 - bez skutku.
    Napięcia zasilacza dobre, a nawet idealne [w tym: 5V = 5.08V, 12V=12.06V].
    Mierząc napięcia na samym procesorze dotykając sondą do wyprowadzenia 32 [kwarc] nagle zaskoczył i tu zaczyna się cyrk...

    Otóż wskoczył program 2 [a jakże] jednak przy próbie wciśnięcia np. 3 wskakuje na chwilkę, po czym sam wraca do 2 - zaznaczę w tym miejscu, że pamięć EEPROM jest sprawna, tzn. pamięta co jest na jakim programie nastrojone - przy próbie zrobienia głośniej czy ciszej to samo, niby pojawia się pasek z głośnością ale po chwili wskakuje na "2". Jeżeli spróbujemy go wyłączyć to obraz zrobi się ciemny [taki jak po włączeniu] i po chwili wraca na 2. Jedyne wyjątki to wtedy, kiedy przełączy się go na AV, albo wciśnie strojenie automatyczne - wtedy wykonuje odpowiednią funkcję [dostraja się do stacji]. Jednak nie sprawdziłem, czy na AV można normalnie regulować np. głos.
    Jeżeli uda nam się go odpalić to teletekst też wchodzi, ładuję stronę, jednak kiedy wciśniemy jakikolwiek klawisz numeryczny dodaje "2" ile się da, do końca adresu strony: 6** -> 622.

    No po prostu ubzdurał sobie tą dwójkę...

    Nie ukrywam jestem trochę zdezorientowany, osobiście podejrzewam ubicie proca ładunkiem [nie wiem jak, ale jednak], tylko dziwi mnie że:
    1) po dotknięciu sondą nóżki 31 lub 32 nie od razu, ale zaskakuje. Wątpię aby był to sam kwarc [jeszcze nie podmieniałem. bo nie miałem go pod ręką].
    2) jakby proc padł, to chyba by takich numerów nie strzelał - pewnie w ogóle byłby trupem, tym bardziej, że napięcia ma w przybliżeniu zgodne ze schematem:

    Biazet TC460 - dziwne zachowanie ukł. sterowania.

    Gwoli wyjaśnienia:
    U nominalne -> schemat
    U po włączeniu -> napięcia mierzone po włączeniu gł. włącznikiem - czarny ekran etc.
    U po "starcie" -> napięcia po "zaskoczeniu"

    martwi mnie odchyłka na 18 nóżce - powinno być 0.1V jest 0.6V i akurat P+ jest w gałęzi z tym wyprowadzeniem - czyżby port I/O dostał w trąbę i przez to świruje?

    Ma któryś z kolegów jakiś pomysł na tego maniaka dwójki?
    Pozdrawiam.
  • Użytkownik obserwowany
    Możesz to streścić do niezbędnego minimum?
  • Poziom 43  
    Pogadamy jak wymienisz pamięć. Teraz nie ma o czym. Chyba, że wolisz zaczynać od podmiany PCA84C640.
  • Poziom 22  
    Wylutuj klawiaturę lokalną i zobacz, czy dalej będzie się tak zachowywał.
  • Poziom 33  
    DKAG napisał:
    Wylutuj klawiaturę lokalną i zobacz, czy dalej będzie się tak zachowywał.

    A co ma klawiatura do tego, dla czego ludziom w głowie mącisz.
  • Poziom 14  
    Witam ponownie..

    Re antagonista: Nie masz niczego ciekawego do dodania, to się nie wypowiadaj.

    Re DKAG: klawiatura sprawdziłem na samym początku.

    Re mirex: scalaka będę mieć dopiero coś koło wtorku, więc wtedy zobaczymy, myślisz, że to przez EEPROMa takie coś może się dziać? Tylko dlaczego? Ja na początku ją wykluczyłem, o czym pisałem z tego powodu, że jak wybierzemy np. 4 czy 5 to one na ułamek sekundy się pojawiają [głowica się przestraja] ale potem z powrotem wraca na 2..

    Tak czy inaczej dzięki za odp. pozdrawiam.
  • Poziom 22  
    lamer. napisał:
    DKAG napisał:
    Wylutuj klawiaturę lokalną i zobacz, czy dalej będzie się tak zachowywał.

    A co ma klawiatura do tego, dla czego ludziom w głowie mącisz.

    Ano przez analogię do starszych Elemisów (na przykład 5550). W nich jest podobnie zbudowana klawiatura i występowała podobna sytuacja. Wyprowadzenia switchy miały mikrozwarcia do swoich metalowych obudów i procesor wykonywał różne dziwne polecenia, które nie miały pokrycia w opisie klawiatury lokalnej.
  • Poziom 33  
    Cytat:
    Ano przez analogię do starszych Elemisów (na przykład 5550). W nich jest podobnie zbudowana klawiatura i występowała podobna sytuacja.

    Tak tak, zwłaszcza ,że...
    Cytat:
    więc osoba ta otworzyła klapkę, chciała nacisnąć P+ i w tym momencie, jak wynika z relacji "popieściło ją" [ładunkiem elektrostatycznym] i nie dało się go już przełączyć na inny program [był na pr. 2], po wyłączeniu i ponownym włączeniu z gł. włącznika załączył się automatycznie [powinien do czuwania]; obrazu brak, dźwięku także i oczywiście brak reakcji na zdalne i lokalne sterowanie.

    ładunki elektrostatyczne nie uszkadzają klawiatury.
  • Poziom 22  
    lamer. napisał:
    Cytat:
    Ano przez analogię do starszych Elemisów (na przykład 5550). W nich jest podobnie zbudowana klawiatura i występowała podobna sytuacja.

    Tak tak, zwłaszcza ,że...
    Cytat:
    więc osoba ta otworzyła klapkę, chciała nacisnąć P+ i w tym momencie, jak wynika z relacji "popieściło ją" [ładunkiem elektrostatycznym] i nie dało się go już przełączyć na inny program [był na pr. 2], po wyłączeniu i ponownym włączeniu z gł. włącznika załączył się automatycznie [powinien do czuwania]; obrazu brak, dźwięku także i oczywiście brak reakcji na zdalne i lokalne sterowanie.

    ładunki elektrostatyczne nie uszkadzają klawiatury.

    Lamerku, a doczytałeś do końca?
    Cytat:
    Otóż wskoczył program 2 [a jakże] jednak przy próbie wciśnięcia np. 3 wskakuje na chwilkę, po czym sam wraca do 2 - zaznaczę w tym miejscu, że pamięć EEPROM jest sprawna, tzn. pamięta co jest na jakim programie nastrojone - przy próbie zrobienia głośniej czy ciszej to samo, niby pojawia się pasek z głośnością ale po chwili wskakuje na "2". Jeżeli spróbujemy go wyłączyć to obraz zrobi się ciemny [taki jak po włączeniu] i po chwili wraca na 2. Jedyne wyjątki to wtedy, kiedy przełączy się go na AV, albo wciśnie strojenie automatyczne - wtedy wykonuje odpowiednią funkcję [dostraja się do stacji]. Jednak nie sprawdziłem, czy na AV można normalnie regulować np. głos.
    Jeżeli uda nam się go odpalić to teletekst też wchodzi, ładuję stronę, jednak kiedy wciśniemy jakikolwiek klawisz numeryczny dodaje "2" ile się da, do końca adresu strony: 6** -> 622.

    Pozdrawiam.
  • Poziom 14  
    DKAG z tym, że wtedy, jeżeli byłoby zwarcie na tym klawiszu to zamiast ciągłego wklepywania "2" na telegazecie powinien ładować aktualnie przesyłaną stronę - bo taką akurat ten klawisz ma funkcję w czasie działania teletekstu. Poza tym nawet jak wcisnę na pilocie 5 to on i tak wraca do 2, a więc zmienia program niesekwencyjnie.

    Pozdrawiam.
  • Poziom 22  
    Cytat:
    martwi mnie odchyłka na 18 nóżce - powinno być 0.1V jest 0.6V i akurat P+ jest w gałęzi z tym wyprowadzeniem - czyżby port I/O dostał w trąbę i przez to świruje?

    Idź tym tropem. Na niej powinieneś mieć 5V.
    Odlutuj ją i włącz tv. Wszystko stanie się jasne, czy procesor, czy klawiatura.
  • Poziom 14  
    Witam po małej przerwie, ale w międzyczasie uszkodziłem sobie oko i musiałem poczekać, aż mi widzenie stereoskopowe wróci :]

    Otóż po wykonaniu wszystkiego co wcześniej pisane - co nie odniosło skutku, zamówiłem ja w sklepie pamięć - sugerując się schematem PCF8582A, takową dostałem, ale przyglądając się płycie, widzę, że siedzi tam PCF8582E-2P i tu zaczyna się małe zmieszanie z mojej strony, bo wg. serwisówki są to układy zamienne, jednak trzeba wprowadzić małe zmiany w aplikacji, problem w tym, że nie za bardzo serwisówka pokrywa się z tym co widzę na płycie, ponieważ wg. niej, 7k. układu E-2P powinna być pusta, a układu 8582A powinna mieć doczepiony układ RC, z kolei na płycie jest odwrotnie, tj. układ "zastany" E-2P ma el. RC.
    Nie wiem teraz, gdzie jest błąd [a może to nie ma znaczenia?].
    W każdym bądź razie poświęciłem jedną zamówioną kość i wlutowałem na miejsce starej, bez ingerencji w elementy poboczne - czyli niby tak jak serwisówka radzi..

    Efekt - taki sam. wskakuje "2" jak tylko chce. Tak więc chyba to będzie wina PCA..

    Niech mnie tylko któryś z kolegów oświeci, jak w końcu ta pamięć ma być wlutowana - z czy bez RC na 7 końcówce.

    Pozdrawiam.

    P.S. jako małe objaśnienie:
    Biazet TC460 - dziwne zachowanie ukł. sterowania.
  • Poziom 14  
    Witam ponownie, winowajcą okazał się jednak PCA84C640. Wymiana pomogła.
    Co do pamięci, to po wlutowaniu 8582A zamiast 8582E-2 - bez jakiejkolwiek zmiany aplikacji telewizor działa jak należy, stroi, pamięta, huczy i buczy, tak więc nie wiem gdzie w serwisówce jest błąd.

    Pozdrawiam pomagających ;]