Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

S-Meter DSM-2000 na wyświetlaczu cyfra 0

oki188 18 Mar 2011 00:31 1667 10
  • #1 18 Mar 2011 00:31
    oki188
    Poziom 22  

    Witam.
    Nabyłem uszkodzony miernik firmy GE Elektrotechnik model DSM2000
    Miernik ma następujący problem.
    Po podłączeniu do zasilania na wyświetlaczu pokazuje cyfrę 0
    jak na obrazku

    S-Meter DSM-2000 na wyświetlaczu cyfra 0

    Niestety po podłączeniu do wyjścia S-metr w radiu Intek M790 czyli podaniu sygnału nic się nie zmienia i dalej miernik pokazuje 0

    Niestety firma pościerała napisy na układach co utrudnia ich weryfikację.
    Co do tych 4 przełączników też nie wiem jaka konfiguracja powinna być ustawiona oryginalnie.

    Moje pytanie brzmi co może być nie tak z tym miernikiem co wymienić z widocznych elementów. Dodam iż wydaje mi się iż układ w obudowie DIP8 to LM358 ale mogę się mylić.
    Może ktoś z was koledzy miał styczność z takim miernikiem lub schematem do niego a może ktoś posiada identyczny i podesłał by mi fotki elektroniki z góry i ścieżek od spodu.
    Za wszelką pomoc bardzo dziękuję

    0 10
  • #2 18 Mar 2011 01:44
    SP8JZ
    Poziom 33  

    Wszystko by było ładnie, pięknie gdyby nie jeden mały szczegół.
    Jakbym zobaczył tego eproma tak z odległości powiedzmy 5 metrów, to powiedziałbym sprzedającemu, aby szukał sobie następnego klienta.

    Ale powalczyć warto, może Michał SP5IT, albo ktoś z bardziej doświadczonych ode mnie miał to coś pod respiratorem.

    PS. A tak na marginesie źle postąpiłeś robiąc te zdjęcia, bo widać flasha, mogłeś dobić eprom

    0
  • #3 18 Mar 2011 09:09
    oki188
    Poziom 22  

    Aha czyli problemem może być eprom hmm.
    W nocy walczyłem trochę z tym ustrojstwem i zobaczyłem pod spodem 1 zworkę którą można było przestawić jak ją przestawiłem to miernik wskazywał pod samym napięciem na lewym wyświetlaczu cyfrę 9 a na prawym cyfrę 30 po podpięciu do radia i włączeniu znów pokazał 0 i dalej brak reakcji.

    0
  • #4 18 Mar 2011 09:24
    sq6ade
    Poziom 40  

    Hehe - jaki fajowy klasyk. :) :)
    Widać prawie od razu jak to działa ...
    Przetwornik A/D równoległy podaje na wejścia adresowe EPROMa wagę
    binarną pomiaru. Eprom-matryca przekodowuje dane na informacje sformatowane na wyświetlacz 7-seg uwzględniając skalę np. decybelową.

    Kilka dodatkowych scalaków służy do multipleksowania danych wyjściowych z pamięci , buforowania wyświetlacza i ew steruje taktowaniem A/D.

    I prawdopodobnie 1 opamp na wejściu.

    Widać że DIP-SW jest na starszych wejściach adresowych - prawdopodobnie można nim wybierać rodzaj wskazania (w różnych jednostkach).

    Diagnozę proponuje zacząć od przejrzenia działania przetwornika którym może być
    takie coś:
    http://www.national.com/ds/DC/ADC0801.pdf

    p.s.
    Zaklej czymś okienko pamięci - może być guma do żucia.

    0
  • #5 18 Mar 2011 10:32
    gregorio27
    Poziom 31  

    Cytat:
    Zaklej czymś okienko pamięci - może być guma do żucia.
    Jak dostała strzała z flesza z ksenonem w środku do już nie musi zaklejać a raczej poszukać wsadu.

    0
  • #6 18 Mar 2011 12:29
    oki188
    Poziom 22  

    Pamięć dostała akurat strzała z telefonu z diodą :) więc raczej nie powinna się wysypać ( teraz już ją zakryłem naklejką).
    Tak myślę czy powodem mogą być wyschnięte elektrolity, diody wszystkie posprawdzałem i są sprawne.

    0
  • #7 18 Mar 2011 12:51
    SP5IT
    VIP Zasłużony dla elektroda

    Moim zdaniem szlag trafił eprom.
    Michał

    0
  • #8 18 Mar 2011 13:50
    sq6ade
    Poziom 40  

    Chcesz znaleźć przyczynę niedziałania musisz się zapoznać z zasadą działania
    urządzenia.
    Na początek sprawdź przetwornik i generator taktujący .

    Cytat:
    Moim zdaniem szlag trafił eprom.


    Kasownik pamięi EPROM z diody LED ? Dobry patent - trza zgłosić do działu DIY
    :lol: :lol:

    Nawet jakby pamięć utraciła część danych - układ wyświetlałby najwyżej bzdury.

    0
  • #9 18 Mar 2011 14:16
    SP5IT
    VIP Zasłużony dla elektroda

    Jak w latach 90 robiłem TNC to eeprom po jakimś czasie tracił zawartość jeśli był nie zaklejony. A diody LED emitują jakąś część UV obok światła widzialnego.
    M

    0
  • #10 18 Mar 2011 14:21
    sq6ade
    Poziom 40  

    Po długotrwałym wystawieniu na promieniowanie słońca może stracić
    część danych.

    W urządzeniach zamkniętych na stałe naklejkę dają lub nie
    choć w dobrym zwyczaju jest dać.
    Np CB które miały matrix na pamięci wogóle nie miały naklejek fabrycznie.

    W TNC wypadnie 1 bit z pamięci i TNC nieżywe.
    W tym przypadku nie.

    0
  • #11 23 Mar 2011 22:49
    oki188
    Poziom 22  

    niestety naprawa mnie przerasta miernik może naprawi kto inny.

    0