Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

IBM T22 - Brak napięcia na baterii - Potrzebny schemat elektroniki

19 Mar 2011 09:36 7034 32
  • Poziom 11  
    Witam,

    Bateria nie podaje napięcia w ogóle, w systemie wykrywana - ale stan krytyczny 0%.
    Ogniwa wszystkie sprawne, prądu nie ma na pinie oznaczonym "+" na obudowie.
    Jakie elementy mam sprawdzić?

    IBM T22 - Brak napięcia na baterii - Potrzebny schemat elektroniki
  • Poziom 11  
    Posiada ktoś schemat do tej elektroniki? Myślę, że to jakiś bezpiecznik ale nie wiem gdzie ich szukać, 2 znalazłem ale przewodzą prąd.

    Przepraszam że post pod postem, ale nie chcę żeby ugrzęzło na dole bez rozwiązania
  • Poziom 22  
    może najpierw podaj jakiś model baterii pojemność, więcej informacji wtedy może ktoś będzie w stanie pomóc w naprawie ale jeśli bateria jest martwa to może ona być uszkodzona i nie będzie się jej dało naprawić tym bardziej ze t22 to juz stary model laptopa
  • Poziom 11  
    Nie mam już tej naklejki z modelem na baterii wiec nie podam, ale jest zdjęcie elektroniki, i do tej elektroniki potrzebuje schematu, albo wiadomości co mam sprawdzić.

    To musi być jakiś bezpiecznik bo bateria się zgłasza w systemie, pokazuje firmę i datę pierwszego użycia, ilość cyklów itd, tylko na "+" nie podaje napięcia, bo probowałem miernikiem minus z ogniwami i napięcie jest, a na "+" nie ma wogóle.
  • VIP Zasłużony dla elektroda
    Bezpiecznik masz przyklejony na pastę termoprzewodzącą do tranzystorów.

    Piszesz, że podane są informacje z baterii, ale ich nie podajesz - one są bardzo ważne.
    Podajesz, że ogniwa są sprawne, ale również nie podajesz na jakiej podstawie tak twierdzisz.

    Poczytaj podwieszone artykuły.
  • Poziom 11  
    Oznaczenia:
    M37516
    M6A29
    0502A

    M61040
    FP-CU0
    BC6431

    Ogniwa myślę, że są sprawne, bo każde daje napiecie a gdy spiąłem na krótko kabelkiem do wyjścia to laptop chwilę działał na tej baterii.

    Okazało się, że ten bezpiecznik przyklejony do tranzystorów nie przewodzi prądu. Gdzie mogę kupić taki? O co mam pytać w sklepie?
  • VIP Zasłużony dla elektroda
    W sklepie takiego nie kupisz. Co z nim zrobić i jak sprawdzić ogniwa masz napisane w artykule "Jak prawidłowo zadawać pytania?" oraz w "FAQ dotyczącym baterii".
  • Poziom 11  
    Przepraszam za moje laickie pytania:

    Dla bezpieczników SC Protector, zasymuluj podgrzewacz, rezystorem 20...80 Ohm, w przypadku jego przerwania. Jeśli bezpiecznik SC Protector jest zlutowany, a nie zastąpiony nowym - wylutuj klucz, który nim steruje.

    Jak mam to polutować? I gdzie znajduje się ten klucz sterujący?
  • Poziom 15  
    Witam

    Mam pytanie czy Kolega dangerzone6 stwierdził co nie gra w tej baterii? Mam na oku laptopa T22 za grosze ale jest ten sam problem z baterią. czy to się da zrobić. Bezpieczniki jest niby OK (tak twierdzi obecny właściciel). Na stykach jest 0V

    Pozdrawiam
  • Poziom 13  
    Troszkę odświeżę temat.
    Mam baterię z układem M37512 na pokładzie.
    W programie be2works przy odczycie danych baterii otrzymuję:
    DesignCapacity: 3 mAh
    FullChargeCapacity: 3 mAh
    CycleCount: 3
    Date: 1980.00.03 y.m.d
    DesignVoltage: 3 mV
    ManufactureName: Read ERROR
    DeviceName: Read ERROR
    SerialNumber: 3
    ChargingCurrent: 3 mA
    ChargingVoltage: 3 mV
    DeviceChemistry: Read ERROR
    Temperature: -272,9 C
    Voltage: 3 mV
    Current: 3 mA
    RelativeSOC: 3%
    AbsoluteSOC: 3%
    RemainingCapacity: 3 mAh
    Mfg1: 3 integer
    Mfg2: 3 integer
    Mfg3: 3 integer
    Mfg4: 3 integer


    Przy odczycie wsadu otrzymuję komunikat, że nie znaleziono adaptera.
    Ktoś ma pomysł jak to ruszyć?
    Napięcia na sekcjach baterii są dobre, więc może elektronikę szlag trafił?
  • Poziom 13  
    Na krańcach smbus'a baterii powinno być jakiekolwiek napięcie jak dobrze czytałem faq. Na całej baterii jest ponad 9V.
    Niestety u mnie żadnego śladu napięcia. Bezpiecznik wydaje się być dobry (oporność 53 omy).
    Jakiś punk zaczepienia?
  • VIP Zasłużony dla elektroda
    53 Ohm to wartość rezystancji grzałki. pozostałe przejścia powinny mieś znacznie mniejszą oporność. Bezpiecznik raczej jest uszkodzony. Odczyty po SMBus są nieprawidłowe.
  • Poziom 13  
    Wstawię obrazek bo nie bardzo wiem jak to objaśnić:
    IBM T22 - Brak napięcia na baterii - Potrzebny schemat elektroniki
    * między nogą 1 i 2 oraz 1 i 3 jest opór 53 omów;
    * między 2 i 3 jest 1 om;
    * pomiędzy 2 i 3 jest przejście (tester ciągłości);
    * pomiędzy 1 i 2 oraz 1 i 3 ciągłości brak.

    Tak powinien się on zachowywać?
  • VIP Zasłużony dla elektroda
    Tak, teraz podałeś oporności między wszystkimi nogami.

    Bezpiecznik jest sprawny.

    W jaki sposób próbujesz odczytać raport, a w jaki wsad kontrolera?
  • Poziom 13  
    Odczytuje skonstruowanym z faq adapterem poprzez szynę smbus programem be2works. Raczej wyprowadzenia podłączam dobrze bo próbowałem zamieniać je miejscami to wtedy program nic nie sczytywał.
    Dane sczytuje klikając "Read", a wsad wybieram eeprom i także "Read" - wtedy też wywala błąd, że nie znaleziono adaptera.
  • Poziom 13  
    Replace cells with 470 ohm resistors.
    Znaczy zamienić je jednym opornikiem czy ile ogniw tyle oporników?

    Connect pins 12, 9 and 43 of M37512
    No to będzie nie lada wyzwaniem z moimi paluchami ..ale dam jakoś radę.
    Widzę, że drucik od rezystora jest grubszy od nóżki pina w eepromie - ciężka sprawa.

    No nic czekam na info o rezystorach i zabieram się do roboty.
  • Poziom 27  
    Ile sekcji tyle oporników
  • VIP Zasłużony dla elektroda
    Przeważnie te piny są wyprowadzone na punkty lutownicze, do których łatwiej się podłączyć.
  • Poziom 13  
    Rezystory połączone jak należy, nóżki zwarte - robię odczyt i dalej to samo.
    Więc zastanawiam się nad punktem 3:
    Connect power.
    Nie bardzo wiem co mam przez to rozumieć - liczyłem, że chodzi może o podłączenie zasilania do adaptera (5V).
    Może jednak do VH i VG podłączyć mam ogniwa?
    ..ryzykować nie będę więc poczekam na Wasza opinię.
  • VIP Zasłużony dla elektroda
    Masz podłaczyć nie ogniwa, a około 12 V na styki + i - baterii
  • Poziom 13  
    Zrobiłem wg instrukcji. Po odczytaniu danych z baterii otrzymałem:

    DesignCapacity: 15 mAh
    FullChargeCapacity: 15 mAh
    CycleCount: 15
    Date: 1980.00.15 y.m.d
    DesignVoltage: 15 mV
    ManufactureName: Read ERROR
    DeviceName: Read ERROR
    SerialNumber: 15
    ChargingCurrent: 15 mA
    ChargingVoltage: 15 mV
    DeviceChemistry: Read ERROR
    Temperature: -271,7 C
    Voltage: 15 mV
    Current: 15 mA
    RelativeSOC: 15%
    AbsoluteSOC: 15%
    RemainingCapacity: 15 mAh
    Mfg1: 15 integer
    Mfg2: 15 integer
    Mfg3: 15 integer
    Mfg4: 15 integer

    Dane się zmieniły w porównaniu z pierwszym odczytem, a dokładnie każda wartość x 5.

    Niestety wsadu nie mogę odczytać, bo gdy to robię wykasuje komunikat "Adapter not found"

    Napiszę jak to podłączam, żeby wyeliminować (lub potwierdzić) moją winę:
    Bateria ma 7 pinów:
    |1| |2|3|4|5|6|7|
    1 jest odseparowana od reszty.
    2 podłączam +12V;
    3 - wolny;
    4 - SDA;
    5 - SCL;
    6 - wolny;
    7 - GND adaptera i -12V
    Jest to bateria z notebooka Lenovo 3000 P/N: 42t5216
  • Poziom 27  
    Ja bym podłączył 12v na + i - całego pakietu ogniw, a nie na złącze. Myślę, że chodzi o to żeby zasymulować ogniwa.
  • Poziom 13  
    Niestety nic to nie dało - wynik, który otrzymałem jest taki jak na samym początku.
    Nie mam na razie ku temu żadnych przesłanek, ale zaczynam podejrzewać, że elektronika po prostu padła...
  • Poziom 13  
    Oczywiście uszkodzenie elektroniki jest moim domysłem, który chciałbym w 100% potwierdzić, żebym nie grzebał niepotrzebnie w baterii.
    Ktoś ma jakiś może pomysł jak dalej postępować?
  • Poziom 13  
    Odświeżę temat po raz kolejny.
    Nie rozwiązałem problemu swojej baterii, ale mam kolejna problemową z podobną sytuacja dotyczącą odczytu wsadu - może rozwiązując ten problem dojdę co z tama baterią.
    Bateria HP, trzyma 2 min, elektronika BQ2084, podłączam adapter i odczytuję dane baterii:

    DesignCapacity: 7 mAh
    FullChargeCapacity: 7 mAh
    CycleCount: 7
    Date: 1980.00.07 y.m.d
    DesignVoltage: 7 mV
    ManufactureName: Read ERROR
    DeviceName: Read ERROR
    SerialNumber: 7
    ChargingCurrent: 7 mA
    ChargingVoltage: 7 mV
    DeviceChemistry: Read ERROR
    Temperature: -272,5 C
    Voltage: 7 mV
    Current: 7 mA
    RelativeSOC: 7%
    AbsoluteSOC: 7%
    RemainingCapacity: 7 mAh
    Mfg1: 7 integer
    Mfg2: 7 integer
    Mfg3: 7 integer
    Mfg4: 7 integer

    Akumulatorki trzymają ładnie napięcie - po 4V na sekcji.
    Problem z tym, że nie mogę odczytać z chipu bo otrzymuje komunikat "Adapter not found". Odczytuję dane oczywiście po szynie SMBus.

    No i teraz pytanie - oznacza to, że:
    * elektronika jest uszkodzona;
    * zablokowany jest dostęp do wsadu i nic nie poradzę.
    Ewentualnie jak wykluczyć któreś z powyższych.
  • Poziom 21  
    Wydaje mi się,oglądając te "odczyty" w przypadku różnych baterii, że masz uszkodzony interfejs, świadczą o tym te jednakowe dane.W pierwszym odczycie (post #10) wszystkie wartości równe "3", w drugim (post#22) wszystkie równe "15" i w ostatnim (post#26) wszystkie równe "7". Może to świadczyć albo o źle zmontowanym interfejsie, złym układzie bufora (74LS05) albo o uszkodzeniu układu.Sprawdź jeszcze raz interfejs
  • Poziom 13  
    Mam inna baterię, którą ostatnio regenerowałem i dziś podłączając do niej adapter mogę wszystko ładnie odczytać (także jest na układzie BQ2084).
    Liczę więc na to, że adapter jest sprawny.
  • Poziom 21  
    Pisząc w poprzednim poście(#27) o uszkodzeni interfejsu pomyślałem o uszkodzeniu układu 74LS05 (bo to najczęstszy rodzaj w przypadku podłączenia do "+" baterii) ale może też być zły kontakt,zimny lut lub tp.co zakłuca prawidłowy odczyt.To Ty musisz wiedzieć co jest lub było "nie tak" w poprzednich i podanych tu w temacie odczytach.
  • Poziom 13  
    No, ale wyraźnie napisałem, ze adapter jest sprawny.
    Cytat:
    To Ty musisz wiedzieć co jest lub było "nie tak"

    ..no gdyby wiedział nie zawracałbym nikomu gitary.

    Zauważyłem też, że przy (nazwijmy to ogólnikowo) sprawnej baterii przy odczytywaniu danych baterii programem BEW świeci dioda A i po odczycie B (czyli świecą obie).
    Natomiast przy bateriach, które mają błędny odczyt dioda A gaśnie po sczytaniu danych i świeci samo B.