Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Tomato na ASUS RT-N-10 konfiguracja qos + niemożność połączenia

sirdoom 21 Mar 2011 20:34 4908 21
  • #1
    sirdoom
    Level 10  
    Witam.
    Pierwszy mój problem polega na tym, że lubię grać w gry sieciowe, ale mam dzielone routerem łącze 1Mb z netii. Kiedy ktoś prócz mnie jest w sieci i na przykład przegląda strony internetowe, to łapię ogromne lagi w owych grach. Czy istnieje możliwość takiego skonfigurowania qos w tomato, by (w tym wypadku zależy mi na portach 5000 - 5200 UDP) prędkość łącza nie była w żaden sposób ograniczana (np nie gram, to chcę mieć dostępny cały zakres łącza), ale gry sieciowe miały jakby większy priorytet, nie zależy mi na jakimś większym priorytetowaniu (innymi słowy gry,porty które chcę > reszta)? Zdaję sobie sprawę, że nawet jeśli jest taka możliwość, to prawdopodobnie nie zniweluje problemu całkowicie, ale 100-300ms, jest dużo lepsze niż skoki 100-4000ms.
    Jeżeli istnieje możliwość takiego skonfigurowania qos, to bardzo bym prosił podać mi jak tego dokonać, bo jestem totalnym laikiem w tej dziedzinie :|



    Sprawa druga: często zachodzi u mnie problem natury takiej, że nie mogę połączyć się z routerem. Prawie zawsze problem występuje, gdy chcę się połączyć dajmy na to drugi, trzeci itp raz w ciągu dnia, gdy router był włączony. Wydawało mi się, że problem mógł leżeć w czasie dzierżawy - domyślnie był to tydzień, a kiedy urządzenie było rozłączone, nadal znajdywałem je na liście urządzeń. Skróciłem do 30 min. Na swoim laptopie problemu raczej nie zauważam (inna sprawa, że raczej go nie wyłączam), ale trudno go odtworzyć, za to laptop siostry ma często spore problemy z połączeniem się do sieci (siostra jak kończy użytkowanie to hibernuje go). Za to chyba nigdy się nie zdarzyło, by restart routera nie pomógł. Tutaj rodzi się problem. Przykładowa sytuacja - korzystam z internetu i za chiny nie mogę zerwać połączenia bo "coś tam", a siostra nie może się połączyć. Dochodzi do konfliktów, bo nie zrestartuję routera, bo zerwie mi połączenie.
    Nie wiem czy to ma jakieś znaczenie, ale mój laptop hula na win7, a siostry na win xp. Dodam, że na starym routerze nigdy nie miałem takiego problemu.

    Prawdopodobnie będą potrzebne jakieś dane konfiguracyjne tomato (Wersja 1.28 RAF PL by shibby), ale nie wiem od czego zacząć. Dodam, że mam wszystkie mogące połączyć się z siecią urządzenia jakie mam w domu wpisane w statyczne DHCP, ale bez niego problem także istniał.
  • Helpful post
    #2
    SP2UKP
    Level 15  
    sirdoom wrote:
    Witam.
    Pierwszy mój problem polega na tym, że lubię grać w gry sieciowe, ale mam dzielone routerem łącze 1Mb z netii. Kiedy ktoś prócz mnie jest w sieci i na przykład przegląda strony internetowe, to łapię ogromne lagi w owych grach. Czy istnieje możliwość takiego skonfigurowania qos w tomato, by (w tym wypadku zależy mi na portach 5000 - 5200 UDP) prędkość łącza nie była w żaden sposób ograniczana (np nie gram, to chcę mieć dostępny cały zakres łącza), ale gry sieciowe miały jakby większy priorytet, nie zależy mi na jakimś większym priorytetowaniu (innymi słowy gry,porty które chcę > reszta)? Zdaję sobie sprawę, że nawet jeśli jest taka możliwość, to prawdopodobnie nie zniweluje problemu całkowicie, ale 100-300ms, jest dużo lepsze niż skoki 100-4000ms.
    Jeżeli istnieje możliwość takiego skonfigurowania qos, to bardzo bym prosił podać mi jak tego dokonać, bo jestem totalnym laikiem w tej dziedzinie :|

    Z tym problemem na razie dajmy sobie spokój. Najpierw trzeba mieć pewne, bezproblemowe połączenie żeby myśleć o konfiguracji QoS'a.

    sirdoom wrote:
    Sprawa druga: często zachodzi u mnie problem natury takiej, że nie mogę połączyć się z routerem. Prawie zawsze problem występuje, gdy chcę się połączyć dajmy na to drugi, trzeci itp raz w ciągu dnia, gdy router był włączony. Wydawało mi się, że problem mógł leżeć w czasie dzierżawy - domyślnie był to tydzień, a kiedy urządzenie było rozłączone, nadal znajdywałem je na liście urządzeń. Skróciłem do 30 min. Na swoim laptopie problemu raczej nie zauważam (inna sprawa, że raczej go nie wyłączam), ale trudno go odtworzyć, za to laptop siostry ma często spore problemy z połączeniem się do sieci (siostra jak kończy użytkowanie to hibernuje go). Za to chyba nigdy się nie zdarzyło, by restart routera nie pomógł. Tutaj rodzi się problem. Przykładowa sytuacja - korzystam z internetu i za chiny nie mogę zerwać połączenia bo "coś tam", a siostra nie może się połączyć. Dochodzi do konfliktów, bo nie zrestartuję routera, bo zerwie mi połączenie.
    Nie wiem czy to ma jakieś znaczenie, ale mój laptop hula na win7, a siostry na win xp. Dodam, że na starym routerze nigdy nie miałem takiego problemu.

    Prawdopodobnie będą potrzebne jakieś dane konfiguracyjne tomato (Wersja 1.28 RAF PL by shibby), ale nie wiem od czego zacząć. Dodam, że mam wszystkie mogące połączyć się z siecią urządzenia jakie mam w domu wpisane w statyczne DHCP, ale bez niego problem także istniał.


    Wyjaśnijmy na wstępie jedno - czy ten router kiedykolwiek pracował poprawnie z tym firmwarem? Na stronie http://www.polarcloud.com/tomato ten model nie jest wymieniony. Wiesz na pewno, że problemy z połączeniem/rozłączeniem nie są spowodowane wymianą firmware'u? Czy potrzebny był Ci ten firmware? Może jednak lepiej wrócić do standardu. QoS też chyba był tam dostępny a pewnie jednak większa jest szansa na poprawne zestawianie połączeń.

    Pozdrawiam

    Jarek
  • #3
    sirdoom
    Level 10  
    Niestety, zainstalowanie firmware ASUS'a nie pomogło rozwiązać drugiej kwestii (zresetowałem też ustawienia do fabrycznych). Nadal siostra często by się połączyć, musi zrestartować router. A lagi jak były, tak są mimo, że ustawiłem w qos'ie by interesujące mnie porty miały wysoki priorytet, ale teraz są nawet większe czasem.
    Tomato działa poprawnie z RT-N-10. Wielu userów nie tylko na tym forum na pewno to potwierdzi.
  • #4
    hermes-80
    Level 43  
    Potwierdzam, że wersja Shibbiego była specjalnie na tym routerze testowana przez twórce modyfikacji, a dokładnie ta wersja pasuje tylko na RT- N10 - http://tomato.groov.pl/K26/build52-029H-PL/
    Po drugie trzeba zainstalować najnowsze stery kart wifi do laptopów.
    Po trzecie nie mamy żadnej pewności, że masz poprawnie skonfigurowaną sieć bo jeśli takie cyrki ci się dzieją to wskazuje na niepoprawna konfiguracje (konflikty IP).
    Po czwarte QoS działa tylko na Uploud.
    Po piąte 1 Mb/s D i U ? to barrrrrrdzo mało chociasz do gier sieciowych wystarcza jakieś 200kb/s D wolnego pasma.
    I podczas skonfigurowanego QoS gdy braknie D to zaczynają się lagi (sam dysponuje 2Mb/s D i 512kb/s U na 4 kompy w sieci i również posiadam Tomato lecz na innym routerze)
  • #5
    sirdoom
    Level 10  
    Jeżeli dobrze rozumiem, to chyba udało mi się naprawić problem z laptopem siostry. Wygląda na to, że Windows zapominał klucza sieciowego, bo w momencie kiedy wystąpił problem z połączeniem wystarczyło go wpisać na nowo i zaskoczyło. Konfliktów IP żadnych być nie mogło, bo zwykłego DHCP też wcześniej próbowałem. Ale jak już wspominałem problem trudno odtworzyć pstrykając palcami...
    Nie wiedziałem, że QoS działa tylko na upload. W sumie to by dużo wyjaśniało, a mój net jest ADSL, czyli mam 1Mb downloadu i 256kb uploadu (tak jak w większości tego typu), płacę tanio, więc nie narzekam póki co. Planuję upgrade, ale nie wiem co z tego wyjdzie.
  • #6
    sirdoom
    Level 10  
    A jednak problem nie jest rozwiązany. Próbowałem aktualizować sterowniki do karty sieciowej siostry, bawiłem się konfiguracją sieci. Konfliktów IP nie ma. Zielonego pojęcia nie mam gdzie ruszyć dalej. Router raczej uszkodzony nie jest, bo na moim laptopie działa ok - rozłączenia są raz na tydzień max, a u siostry kilka razy na dzień nawet :/
  • #7
    hermes-80
    Level 43  
    Zainstaluj u siostry program Inssider i przeskanuj otoczenie i wrzuć screena z tego skanowania.
    Wrzuć również wynik komendy - ipconfig /all z jej laptopa pisany w cmd.
  • #9
    hermes-80
    Level 43  
    Masz dość duży tłok w eterze zmień kanał na 6 a jak nadal będzie problem to na 13.
  • #10
    sirdoom
    Level 10  
    Tego już też wcześniej niestety próbowałem. Przez dłuższy czas tomato miał ustawiony kanał na auto, ale sam zobaczyłem na którym kanale nic nie ma - ustawiłem wtedy na 13. Teraz na firmware asusa, znowu jest auto. Zaczynam się zastanawiać, czy router nie jest w jakiś sposób uszkodzony, bo jak miałem stary, to na nim nie było żadnego problemu z łącznością. Wypożyczę od kolegi jego stary router i zbadam, czy faktycznie coś w tym jest. Na szczęście tego asusa dalej mam na gwarancji, ale problem polega na tym, że on może wrócić z powrotem - jak pisałem problem trudno odtworzyć na zawołanie i tylko laptop siostry ma z nim problem :/
  • #11
    hermes-80
    Level 43  
    Więc problem w laptopie leży.
  • #12
    sirdoom
    Level 10  
    No tak, ale jak sobie z tym poradzić? Aktualizowałem sterowniki do karty wifi, wyczyściłem całą konfigurację sieci. Po prostu nie ma prawa się tylko czasem nie łączyć/rozłączać. Z kolei takie cyrki tylko są obserwowane na tej domowej sieci z innymi żadnych problemów siostra nie raportowała.
    Już nie mam pojęcia co jeszcze mogę zrobić.
  • #13
    hermes-80
    Level 43  
    Jaką wersje Tomato masz na tym routerze ?? I model karty siostry w laptopie.
    A co do 1 problemu bo nie odpowiedziałem na zagadnienie z pingami to ta sprawę rozwiązuje narzędzie RAF czyli ustawienie dla każdego pasma, które będzie sobie mógł wykorzystywać bo QoS jest dobry ale jak masz wysoki Download i nie musisz się martwić tym, że przy zwykłym użytkowaniu ci się zapycha.
  • #14
    sirdoom
    Level 10  
    Obecnie nie mam tomato, a firmware aususa (1.0.2.4), a tomato które było wcześniej to Wersja 1.28 RAF PL by shibby. Siostra w laptopie ma Aetheros AR2427.
  • #15
    hermes-80
    Level 43  
    1.28 RAF PL by Shibby - Shibby wypuścił chyba z 10 wersji więc takie oznaczenie, które ty podajesz nic nie mówi :!:
    Instalowałeś najnowszą wersje z tej strony: Link?
  • #16
    sirdoom
    Level 10  
    Fakt tomato-K26-1.28.8052RAF-PL-MIPSR2-028H-Std.
    Tak, sterowniki najnowsze z tamtej strony
  • Helpful post
    #17
    hermes-80
    Level 43  
    A widzisz :!: Zainstaluj wersje, tą która wcześniej podałem czyli z końcówka 029H.
    I przetestuj. Również możesz sprawdzić starsze sterowniki do karty siostry instalując inne wersje ale odległe co najmniej o pół roku.

    Juz wersja 029H nieaktualna :!:
    Shibby wydał wersję 030H pod RT-10N
    http://tomato.groov.pl/K26/build52-030H-EN/tomato-K26-1.28.9052RAF-EN-MIPSR2-030H-Std.trx
    Tą zainstaluj.
  • #18
    sirdoom
    Level 10  
    Problem z łączeniem rozwiązał się sam. Trafiłem na moment w którym siostrę rozłączało. Brałem lapka do łapy... Łączyło, brała siostra - rozłączało. Myślę sobie "wtf", siostra leżała na łóżku, a ja nieznacznie bliżej routera. Okazuje się, że laptop siostry, kiedy ona leży na łóżku trafia na jakąś dziurę w sieci i nie mogło się łączyć. Na szczęście miałem antenę ze starego routera (spalił się), która jest prawie 3 razy większa (nie wiem czy to ma jakieś znaczenie :P ), ale na niej nie ma żadnej dziury.
    W takim razie ten problem jest już rozwiązany i dzięki za pomoc. Teraz kwestia QoS: na dniach będę miał 4 razy szybsze łącze niż mam obecnie (4Mb download/1 Mb upload). Na takich łączu chyba bardziej się opłaca skonfigurować QoS. Jak to skonfigurować, by porty UDP 5000-5200 miały największy priorytet uploadu i downloadu? Chodzi mi o to, by siostra jak będzie wchodziła na jakieś strony internetowe nie zamulała łącza tylko dlatego, że na stronie jest dużo obrazków, albo gdy będzie coś wysyłała, bo to oznacza pewny lag i ping ~500ms.
  • #19
    hermes-80
    Level 43  
    Jak już pisałem QoS jest dla Uploudu, a pakiety downloud wskakują jak im się podoba czyli jeśli pakiety U dostaną przez QoS pierwszeństwo to oznacza, że i szybciej wrócą do puki Download jest nie wysycony.
    Podczas wysycenia D jest odczuwalne przyspieszenie nadanych priorytetów ale zaczynają się schody z niestabilnością tego pierwszeństwa na D co za tym idzie zaczyna szwankować ping.

    Odniesienie do rzeczywistości jest takie, że przy moim łączu 512kb/2M gdy gram w grę, która zużywa jakieś 100kb D i 50kb U przy nie wysyconym U i wysyconym D do 2M przez brata i you tube mam porządne lagi mimo, że na pozostałych kompach www działa poprawnie.
    Więc zastanów się czy wystarczy ci samo QoS.
    Gdy są bardzo wrażliwe na takie dziury.
    Quote:
    która jest prawie 3 razy większa (nie wiem czy to ma jakieś znaczenie Razz ), ale na niej nie ma żadnej dziury

    Rozmiar zawsze ma znaczenie ;) i nie wierz gdy ktoś zaprzecza ;) .
  • #20
    sirdoom
    Level 10  
    Co mogę w takim wypadku zrobić, by zmniejszyć lagi? Zauważyłem, że w tomato w zakładce QoS dla klas mogę zmienić Inbound Limit (rozumiem, że jest to download). Wystarczy jak ograniczę dla klasy do której jest przedzielone www (a więc też zdaje się youtube) bandwith do dajmy na to 70-80%?
  • Helpful post
    #21
    hermes-80
    Level 43  
    Ile razy mam pisać, że Qos jest tylko dla Uploudu, a reszta to dla picu tam jest wstawiona, i nie ma żadnego znaczenia :!:
    No ale testuj, próbuj bo najlepiej jest się przekonać na własnym doświadczeniu.
  • #22
    sirdoom
    Level 10  
    Dzięki jeszcze raz za pomoc ;) Temat uważam za rozwiązany, punkty pomocy poleciały.