Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

TDA7318 przesterowuje się

23 Mar 2011 15:39 3400 8
  • Poziom 11  
    Witam serdecznie,
    złożyłem sobie wzmacniacz na lm3386 2-kanałowy, do niego podłączony jest jako przedwzmacniacz TDA7318, sterowany za pomocą ATmegi 8515. Problem jest taki, że nawet na średniej głośności podanej na przedwzmacniacz, na kolumnach słychać przesterowanie, zarówno na głośnikach średnio-niskotonowych jak i na wysokotonowych. Sprawdziłem, że:
    - przesterowanie wytwarzane jest przez TDA7318
    - po odłączeniu jednego kanału, dowolnego (przewód pomiędzy przedwzmacniaczem a końcówką mocy), problem ustaje, drugi kanał od razu gra czysto
    - TDA7318 ma 4 wyjścia, 2 przednie i 2 tylne (front i rear), korzystam z tylnych, jednak na przednich jest identycznie
    - układ zbudowany w oparciu o datasheet, elementy takie same, dodatkowo na wyjściach też dodane kondensatory 2.2u 50V

    Skąd może się brać to przesterowanie? Proszę o pomoc...
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 30  
    Może na dwóch kanałach ci zasilacz nie wyrabia dlatego zniekształca . W przedwzmacniaczu w AudioSwitch na ile masz ustawione Gain ?
  • Poziom 11  
    do atmegi i tda7318 jest oddzielny zasilacz, wydaje mi się, że spokojnie powinien wystarczyć, bo z noty katalogowej wynika, że tda pobiera raczej mało prądu, zasilam go 9V, więc napięcie nie jest za niskie.
    Co do gain'a, w AudioSwitch jest ustawiony na 0dB.
  • Poziom 30  
    Miałem na myśli zasilacz dla LM-a nie TDA , bo może się okazać że na dwóch kanałach to zasilacz z końcówki nie wyrabia i to ona powoduje zniekształcenia.
  • Poziom 11  
    przełożyłem transformator trochę mocniejszy z innego mojego podobnego wzmacniacz i jest to samo, także prawie na pewno przesterowanie wynika z działania przedwzmacniacza.
    Jeszcze takie pytanie: w układzie są dwa kondensatory 2.7nF od sopranu, u mnie zamieściłem 3nF gdyż takie posiadałem, czy jest taka możliwość, że to właśnie stąd się bierze przesterowanie?
  • Poziom 30  
    Raczej nie powinno to mieć wpływu , zrobiłem kiedyś ten przedwzmacniacz razem z korektorem na TDA7317 + 2xLM3886 i chodził bez problemu .Może ci się coś wzbudza w układzie ? Sprawdź czy masz masę dobrze połączoną z końcówką .Może też ci robić zakłócenia złe połączenie masy cyfrowej z analogową , ale nie wiem jak to w twoim układzie wygląda.
  • Poziom 11  
    TDA7318 przesterowuje się

    tak wygląda moja płytka, przy czym jest jeszcze polygon (podłaczony do masy) na całej płytce, i jeśli chodzi o połączenie masy cyfrowej, to nóżka 26 jest podłączona do goldpinu (i dalej do atmegi), do golpinu masy analogowej (od zasilania) oraz do polygonu bezpośrednio też...
  • Poziom 30  
    Ściągnij sobie PDF-a do TDA7317 tam zobacz jak jest masa cyfrowa z analogową podłączona (poprzez rezystor chyba 10om).W twoim układzie dodaj na nóżkach z zasilania jakiś kondensator tak jak to jest w nocie z TDA7317 , no i jeszcze jedno ale może to błąd na płytce , kondensatory na wejściu i wyjściu powinny mieć odwrotną polaryzację (powinny być plusami do TDA , a ty masz na odwrót)
  • Poziom 26  
    Kolego a może podajesz po prostu za duży sygnał wejściowy ?? Spróbuj go zmniejszyć (jeżeli jest np z komputera) i zobaczyć co będzie. Układ jest zasilany z dość niskiego pojedynczego napięcia (pewnie 8V) wiec w związku z tym bezpieczna wartość sygnału wejściowego będzie max jakieś 1-2Vpp. (scalak ma wewnętrzny układ polaryzacji wejść nakładający na sygnały zmienne napięcie stałe Uzas/2 minus jakieś straty na tranzystorach wiec pozostaje dość mały zapas na nałożenie napięcia zmiennego)

    Płytka nie wygląda za szczęśliwie (jak efekt pracy marnego protelowego autorutera:) ), w układach audio używa się topologi mas typu gwiazda- łączących się gdzieś kolo kondensatora odsprzęgającego zasilanie i ścieżki prowadzi się z reguły ręcznie.

    Robiłem na tym układzie kiedyś przedwzmacniacz do aktywnego zestawu 2.1 i podobne problemy miałem tylko omijając wbudowany selektor wejść (pomogło buforowanie za pomocą wtórnika na TL072). Masy analogowa i cyfrowa połącz ale w sposób odpowiedni - czyli tam gdzie będziesz miał punkt wspólny wszystkich mas na płytce.

    Ekrany kabli sygnałowych między końcówką mocy a przedwzmacniaczem łączysz tylko w jednym punkcie z masą sygnałową - np przy końcówce. Masy elektryczne łączysz najlepiej grubym kablem i też w punkcie gdzie się schodzą wszystkie masy jednej i drugiej płytki.

    To dość szeroki temat - poczytaj trochę, w brew pozorom bardzo trudno jest tak wszystko zaprojektować i pospinać ze sobą wszystkie płytki zasilania, przedwzmacniacza, końcówki mocy i sterowania żeby nie było słychać absolutnie żadnego przydźwięku sieciowego oraz uniknąć innych niemiłych niespodzianek.

    Pooglądaj jakieś gotowe wzmacniacze po rozebraniu jak tam jest prowadzona masa (szczególnie japońskie - z reguły są to idealne przykłady "gwiazdy"), poczytaj w Edw artykuły na temat audio (i obejrzyj gotowe układy tam opublikowane) to wtedy będziesz miał jako takie pojęcie o temacie.