Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Kopiowaniem plików, foldery udostępnione i Windows 7 Pro SP1 64bit

8draco8 12 Apr 2011 13:39 4383 5
  • #1
    8draco8
    Level 13  
    Mam mały problem podczas kopiowania danych z komputera z zainstalowanym systemem Windows 7 Professional SP1 64bit na serwer z Sambą. System bez problemu kopiuje pliki o wielkość do około 5MB natomiast przy plikach większych wyświetla błąd 0x8007003A

    Kopiowaniem plików, foldery udostępnione i Windows 7 Pro SP1 64bit

    Specyfikacja komputerów:

    Serwer: Laptop Dell D600 z zainstalowanym Ubuntu PL 10.04.2 LTS, wszystkie aktualizacje dostępne na serwerach Ubuntu zainstalowane, Samba 3.4.7. Laptop jest wpięty w router po kablu.



    Komputer: stacjonarka, również podłączona za pomocą skrętki do tego samego routera, system operacyjny Windows 7 Pro SP1 64bit, również wszystkie aktualizacje zainstalowane

    Konfiguracja katalogu udostępnianego:
    Code:

    [Samba]
       comment = Samba
       security = share
       read only = no
       path = /var/samba
       guest ok = yes
       browseable = yes
       writable = yes
       file mode = 777
       force user = apache
       users = guest, draco, root, samba


    Na tym samym routerze z serwerem bez problemowo współpracuje laptop Asus z Windows Vista 32bit, podłączony po WiFi. Serwer również bezproblemowo współpracuje z komputerami chodzącymi pod kontrolą Windows 7 Ultimate 64bit oraz Windows XP Professional. Jedyne trudności sprawia ta jedna jednostka.

    Wszystkie systemy to oryginalne wersje nie żadne przeróbki torrentowe. Warto dodać że identyczny błąd występował także przed instalacją SP1, więc to raczej nie jest przyczyną. Czekam na wszelkie sugestie.

    EDIT: Po zasugerowanych testach okazało się że nie kopiuje plików także na miejsca sieciowe udostępnione z innych systemów (Windows XP)
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • #2
    zen3x
    Level 33  
    Link Ludzie mają ten sam błąd i kilka pomysłów na rozwiązanie.
  • #3
    8draco8
    Level 13  
    Problem omawiany w linku podanym przez Ciebie dotyczy kopiowania wielu małych plików pomiędzy sambą a systemem. Ja natomiast mam problem ze skopiowaniem choćby jednego pliku większego niż 5 MB. Tak więc temat nadal otwarty.

    Przed chwilą wpadłem na pomysł określenia wielkości pliku wysyłanego do tego katalogu. Po dodaniu do smb.conf

    Code:

    max file size = 0

    problem nadal występuje.
  • #4
    8draco8
    Level 13  
    Z mojego poszukiwania błędu w interenecie wynika że problem najprawdopodobniej leży po stronie systemu Windows 7 na komputerze kliencki, taki sam wniosek wynika z obserwacji zachowania Samby podczas operowania na niej plikami przy użyciu innych systemów a nawet innych jednostek również z systemem Windows 7.

    Przeszukując internet wpadłem na sygestię aby spróbować przekonfigurować ustawenia w programie secpol.msc

    Quote:

    Which OS are you using on the client PC?

    If it's windows 7 x64, try this

    Run secpol.msc
    Drill down through Local Policies | Security Options.
    Find Network Security: LAN Manager authentication level.
    Set this Send NTLM response only.


    Sugestia znaleziona pod adresem: http://forum.wegotserved.com/index.php/topic/14878-error-0x8007003a/

    Niestety to też nie pomogło i problem nadal występuje.
    Jeżeli ktoś ma jeszcze jakieś pomysły bardzo proszę o pisanie. Czasem nawet najprostsze pomysły mogą podsunąć rozwiązanie problemu.
  • #5
    pacek81
    Level 17  
    Może zanim zwalimy wszystko na Windows 7, przetestuj to z innym systemem operacyjnym (np. Windows XP) podpiętym na tym samym kablu.
    Najpierw wyklucz uszkodzenie portów w switchu (routerze), uszkodzenie kabla i poprawność sterowników i ustawień karty sieciowej. U mnie np. uszkadzało pliki i zrywało transfer podczas kopiowania bo ktoś sobie przestawił ustawienia karty sieciowej wymuszając 100Mbps Full Duplex. Sprawdź również, czy jak podłączysz w tej samej sieci komputer z XP i udostępnisz na nim dane, to czy kopiowanie również się przerywa, czy idzie poprawnie.
  • #6
    8draco8
    Level 13  
    Pisałem wcześniej że testy były prowadzone na innych systemach i tam działa a na tym jednym niestety nie chce. Dla spokojności po robiłem trochę zamianek tzn.

    Komputer z problemem podłączyłem po starym kablu w inny napewno działający port -> nadal error

    Komputer z problemem podłączyłem po kablu od kompa z XP Pro który bezproblemu działa z serwerem -> nadal error

    U mnie nie gubi plików, system nawet nie chce rozpocząć kopiowania jeżeli kopiowany plik ma powyżej 5MB, od razu wyrzuca błąd. Sieć w biurze gdzie nie chce to działać wygląda tak że do jednego routera D-Link DSL-2740B podłączone są 4 laptopy i stacjonarka

    1. Stacjonarka - Win 7 Pro SP1 po kablu
    2. Laptop Acer - Win XP Pro po kablu
    3. Laptop Asus - Win Vista Home Premium, po WiFi
    4. Laptop Asus - Win XP Home, po WiFi
    5. Laptop Dell - serwer, Ubuntu 10.04, po kablu

    Wszystkie laptopy bez problemów korzystają z zasobów umieszczonych na Sambie (Laptop Dell), żeby było ciekawiej nie sprawia też żadnego problemu dostęp do udostępnionego ze stacjonarki folderu (zapis/odczyt dowolnej wielkości plików). Jedynie Stacjonarka ma problem z zapisaniem plików na Sambie.

    Samba teoretycznie jest sprawna, ponieważ laptop Dell bardzo często jest używany również w roli serwera plików w innym miejscu, jedyna różnica jest taka że tam łączy się z siecią przez WiFi. W tej drugiej sieci mają do niego dostęp 2 komputery:

    1. Stacjonarka - Win 7 Ultimate 64bit, po kablu
    2. Laptop - Win XP Pro, po WiFi

    I tam nie ma żadnych problemów z operacjami na plikach (również przy użyciu kompa z Win 7). Sprzęt sieciowy użyty w drugiej lokalizacji:

    - router Asmax AR-804u
    - switch D-Link
    - access point Edimax

    Dodano po 29 [minuty]:

    pacek81 wrote:
    Sprawdź również, czy jak podłączysz w tej samej sieci komputer z XP i udostępnisz na nim dane, to czy kopiowanie również się przerywa, czy idzie poprawnie.


    Rzeczywiście, nie kopiuje danych do kompa z Win XP, wyświetlany jest ten sam błąd. Natomiast przy próbie kopiowania do Windows Vista, informuje o braku uprawnień.