Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Klient sieci MS + Critical error (Load Plugins failed)

20 Kwi 2011 23:12 1773 2
  • Poziom 29  
    WinXP Pro SP2, Girder 3.3.4+plugin PixelView. Od dawna używałem WinXP SP2 jako media serwer razem z XBMC i pilotem z kartą TV PixelView i nie było żadnych problemów. Ostatnio postanowiłem dodać kartę DVB-S SkyStar2 do zestawu ale postanowiłem zainstalować od nowa system. Wszystko ładnie pięknie się instaluje jak zwykle ale gdy zaznaczę w Girder opcję uruchamiania programu razem z Windows to przy starcie systemu pojawia się błąd Critical error - Load Plugins failed.

    Wyłączyłem wszystkie inne programy, ładowane przy starcie i nic. Dopiero wyczaiłem, że problem powoduje Połączenie sieciowe Ethernet a dokładnie Klient sieci Microsoft Networks. Przy starcie systemu widać wyraźnie, że Girder uruchamia się pierwszy od innych programów sieciowych uruchamianych przy starcie. Dopiero po paru sekundach wyskakuje błąd i pojawiają się pozostałe ikony w trayu (ikona połączenia sieciowego i inne). Po odinstalowaniu składnika sieci Klient... Girder startuje normalnie razem z innymi programami. No tak, ale ja chcę mieć dostęp do sieci za pomocą klienta. Próbowałem włączać i wyłączać zaporę i inne usługi i nic, pomaga tylko odinstalowanie składnika Klient sieci MS :-(

    Od zawsze przy instalacji WinXP odinstalowuję od razu składniki sieciowe QoS, Klient.. i Udostępnianie. Do tej pory używałem komputera jako odtwarzacz multimedialny na pilota i wsio było OK. Ostatnio zaistniała potrzeba włączenia sieci MS więc dodałem brakujące składniki i wszystko było OK.
    Spróbowałem więc odinstalować i ponownie zainstalować składniki sieci - nie pomaga :-( . W dzienniku zdarzeń żadnych błędów.

    Oczywiście po kliknięciu na OK w oknie błędu, Girder uruchamia się normalnie i pilot działa.
    Klient sieci MS + Critical error (Load Plugins failed)
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 29  
    Niektóre programy (w określonych okolicznościach np. wiele różnych urządzeń PCI) uruchamiane przy starcie komputera wymagają wcześniejszego uruchomienia jakiegoś sterownika systemowego - tak jest w przypadku Girdera przynajmniej w wersji 3.3.4 i pluginu karty PixelView. Dobrym sposobem na rozwiązanie - a raczej ominięcie problemu - jest start Girdera z opóźnieniem np. za pomocą skryptu poleconego przez PeteSh.
    Początkowo podejrzewałem konflikt urządzeń i/lub zasobów np. IRQ z kartą DVB-S SkyStar2. W międzyczasie pojawił się problem z zamykaniem, wstrzymaniem i hibernacją systemu. Próbowałem wielu rzeczy aby temu zaradzić i tak:
    - pomogło odinstalowanie składnika Klient sieci Microsoft Networks
    Klient sieci MS + Critical error (Load Plugins failed)
    - nie pomogło przekładanie miejscami kart PCI
    - początkowo pomogło wymontowanie karty SkyStar2 lecz później okazało się, że problem Girder'a nadal pojawiał się
    - zauważyłem też błąd przy instalacji serwera Apache:
    Klient sieci MS + Critical error (Load Plugins failed)
    - sprawdzałem napięcia 5V, 12V i baterię ale są w normie
    - zrobiłem taki test. Uruchomiłem system z opcją rejestrowania do pliku ntbtlog przy włączonym a następnie przy wyłączonym składniku Klient MS, no i była różnica w kolejności ładowania sterowników od momentu po załadowaniu sterownika Cdfs.SYS
    Klient sieci MS + Critical error (Load Plugins failed)
    - podłączyłem drugi komputer kablem nullmodem do portu COM2 (Host) -> COM1 (WinDbg) i uruchomiłem debuger WinDbg. Przy starcie uruchomiłem tryb debugowania systemu. W czasie pojawienia się błędu Load Plugins failed w debugerze pojawia się jakiś błąd:
    Code:
    Trecol InitERROR: DavReadRegistryValues/RegQueryValueExW(4). WStatus = 5
    
    ERROR: DavReadRegistryValues/RegQueryValueExW(5). WStatus = 5
    ERROR: DavReadRegistryValues/RegQueryValueExW(6). WStatus = 5

    Błąd ten zlikwidowałem wyłączając usługę WebClient ale błąd Girdera nadal został
    - uruchomiłem debug zdalnie w sieci lokalnej i podłączyłem się do procesu Girder.exe. Windbg w oknie Command wyświetlił listę modułów używanych przez Girder.exe (chyba), w każdym bądź razie wyświetlił jakąś listę na której był moduł uxtheme.dll. Ostatnio wyłączałem kompozycje w systemie - pomyślałem, że patch Uxtheme działa w tle gdy nie jest potrzebny, więc włączyłem Kompozycje z powrotem
    - zainstalowałem Bootvis ale po wykonaniu Trace przerwał działanie nakazując ręczną defragmentację dysku więc chyba nic nie zmienił w systemie (miałem wyłączony Harmonogram zadań). Usunąłem Bootvis z dysku i od tej pory Girder uruchamia się bez błędu (nieco dłużej niż bez Klient MS ale jednak :-) )
    - zamontowałem kartę SkyStar2 z powrotem
    - mimo wszystko dla spokoju :-) zastosowałem uruchamianie za pomocą skryptu z opóźnieniem

    No i na razie wszystko oprócz zamykania systemu po użyciu SkyStar2 działa, zdalne sterownie pilotem za pomocą karty TV PixelView (mam też przy okazji przechwytywanie audio/wideo), karta DVB-S i nagrywanie na dysk w DVB Dream, timeshift w ProgDVB, XBMC i YouTube :-):-):-).