Elektroda.pl
Elektroda.pl
X
Oscyloskop cyfrowy Siglent SDS1104X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Pomiar Ph, wzmacniacz na OP-AMP, na wyjściu przebieg prostokątny

Kuniarz 02 Maj 2011 20:45 3894 2
  • #1 02 Maj 2011 20:45
    Kuniarz
    Moderator Projektowanie

    Witam !

    Nie ukrywam, że z elektroniki analogowej specem nie jestem. Przyszło mi zbudować układ do pomiaru Ph. Zastosowałem znany od lat kawałek schematu :

    Pomiar Ph, wzmacniacz na OP-AMP, na wyjściu przebieg prostokątny

    Zmontowałem na płytce, testowałem woltomierzem - wynik zadowalający - dla różnych Ph (mam wzorce) napięcie na wyjściu układu zmienia się. Wszystko wyglądało dobrze, do momentu podłączenia tego do ADC pierwszej lepszej Atmegi. Okazało się, że pomiar oscyluje wokół jakieś tam wartości, przy czym często przyjmuje wartość zero.

    Odkurzyłem stary dobry oscyloskop i okazało się, że na wyjściu układu nie mam stałego napięcia (jak sugerował miernik) tylko przebieg prostokątny.

    Pomiar Ph, wzmacniacz na OP-AMP, na wyjściu przebieg prostokątny

    Wiem wiem, RTFM odnośnie wzmacniaczy operacyjnych, ale może ktoś w tym siedzi od lat i powie "wymień rezystor na taki i taki" itp ;-)

    Pomocy !

    EDIT:

    Przyczyna chyba tkwi w zasilaniu, minus 5V tak naprawdę ma wartość -4V oraz taki przebieg:

    Pomiar Ph, wzmacniacz na OP-AMP, na wyjściu przebieg prostokątny

    Dodałem bezpośrednio na zasilaniu OP-AMP 100 nF do masy, nic to nie dało.

    0 2
  • Oscyloskop cyfrowy Siglent SDS1104X
  • #2 03 Maj 2011 13:55
    malvit
    Poziom 17  

    Najprawdopodobniej wina leży po stronie ICL7660 który zakłóca pracę OP-AMP. Sprawdź pracę układu na zasilaczu klasycznym +5V -5V z odpowiednią filtracją, powinno działać prawidłowo. Zakłócenia pochodzą z przetwornicy co zakłóca pracę ADC i pozostałej cyfrówki.

    0
  • Oscyloskop cyfrowy Siglent SDS1104X
  • #3 03 Maj 2011 19:36
    Kuniarz
    Moderator Projektowanie

    Kolego Malvit, dziękuję za sugestię, niestety pudło ;-)

    Jeśli ktoś chce poznać prawdziwą przyczynę, niech pozostanie przed telewizorem...

    Jak to w 99% przypadków bywa, przyczyną problemu była... ludzka ślepota...

    Nie wstawiłem w obwód kondensatora zaznaczonego kółkiem :

    Pomiar Ph, wzmacniacz na OP-AMP, na wyjściu przebieg prostokątny

    Posiadaczy odbiorników czarno-białych informuję, że kółeczko wokół kondensatora jest czerwone :D

    Garść wniosków na koniec, po prawie 2 dniach kombinowania, w ostatnich etapach okraszonego wiązankami których nie powstydził by się bossman Fryderyka ;-)

    1. zawsze sprawdzaj schemat i płytkę przynajmniej 5x, najlepiej w odstępach czasowych (wydaje Ci się że jest OK, wyjdź z psem, wróć sprawdź, wydaje się że jest OK, wyjdź na piwko do pobliskiego ogródka... itd.)

    2. rzetelne wypełnienie punktu 1 uchroniło by mnie od:
    - szukania po necie informacji na temat op-ampow i ich zasilania (to nie zginie ;-) )
    - wylutowywania kilku drobiazgów SMD
    - wylutowywania i ponownego wlutowania dwóch układów scalonych, oczywiście SMD :P
    - montażu na szybko zasilania symetrycznego z tego co było pod ręką... (na dwóch bateriach 4,5 V w cudowny sposób kupionych w dzień wolny od pracy :P też jest prostokąt na wyjściu :P)

    3. Młodzi adepci elektroniki jak i starsi stażem - nie poddawajcie się ;-)

    Temat zamykam, uwagi może przydadzą się innym.

    1