Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Brak możliwości zainstalowania/odinstalowania VMware Workstation

07 Maj 2011 14:00 4639 5
  • Poziom 18  
    Witam,
    od dłuższego czasu używam VMware Workstation na systemie Win 7 Professional 32bit z wirtualnymi maszynami: Ubuntu 11, Windows XP SP2, Backtrack 4 i Mac OS 10.6. Czasem VWmawe zawieszał się przy pracy z jakimś systemem, ciężko go było wyłączyć nawet na siłę w Menadżerze zadań. Ostatnio wieszał się coraz częściej, a zależy mi na stabilnej pracy z Backtrackiem - co zrobię to się wiesza i tracę co zrobiłem.
    Postanowiłem przeinstalować, mam teraz wersję 7.1.4 b385536, przy próbie instalacji jak i odinstalowania przez Panel sterowania pokazuje się tylko takie okno:
    Brak możliwości zainstalowania/odinstalowania VMware Workstation
    które też trzeba wyłączać w Menadżerze urządzeń. Starsza wersja 7.0.x też ma taki problem. Na Win XP instalacja rusza, więc instalka nie jest wadliwa.
    Nie chcę odinstalowywać na siłę np. programem Revo Uninstaller Pro bo boję się, że potem w ogóle nie da się zainstalować VMware'a. Jaka jest przyczyna tego problemu?
  • Poziom 18  
    Problem rozwiązany po długiej walce. Pomogło skanowanie systemu ComboFixem, który coś znalazł i pousuwał. Potem instalator ruszył, ale dawał błąd, że VMware jest już zainstalowany, jednak wszystkie pliki i foldery (także ukryte) powiązane z VMware usunąłem. Pozostało jeszcze usunąć wszystkie klucze w edytorze rejestru w HKLM --> Software --> VMware, Inc. (Usunięcie folderu VMware, Inc.). Po tych czynnościach instalator ruszył prawidłowo i program zainstalowałem.
    Co dziwne przed tymi czynnościami instalka VMware 6.5.x uruchamiała się normalnie, jednak kończyło się to błędem, że program jest już zainstalowany.
  • Poziom 18  
    Eh, dalej problem... VMware zawiesza się chyba tylko wtedy, gdy jest w trybie pełnoekranowym i zminimalizuję go. Po minimalizacji zwiecha. Oczywiście nie za każdym razem - raz na jakiś czas. Pomagają tylko wielokrotne próby wyłączenia na siłę w Menadżerze zadań lub ponowne uruchomienie systemu. Cóż to może się dziać?

    Edit:
    Wygląda to tak:
    Brak możliwości zainstalowania/odinstalowania VMware Workstation
  • Poziom 11  
    Chyba masz jakieś brudy w kompie... ja mam ten sam system i vmware workstation działa bez problemu, Pare raze mi się tylko tak zawiesił, że maszyna wirtualna się nie chciała wyłączyć, ale to z mojej winy i mogłem przez task managera wyłączyć. Spróbuj jeszcze raz combofixa(kiedyś na xp dopiero po drugim użyciu "uwolnił" kompa). Nie zauważyłeś jakichś innych dziwnych rzeczy? Tylko z vmware problem?
  • Poziom 18  
    Znajomego pytałem to też ma taką konfigurację, nie wiesza mu się w ogóle. U mnie chyba też się nie wiesza, jedynie na Backtracku. Teraz za każdym razem jak tylko zmaksymalizuje pełnoekranowo BackTracka to przy pierwszej próbie minimalizacji zawieszenie. Na XPk i Ubuntu działa jak powinno. Co ciekawe, BackTrack działa jak należy na VMware Player, który instaluje się razem z Workstation. Przeskanuje jeszcze raz ComboFix'em. Jakby ktoś miał jeszcze jakieś pomysły jak rozwiązać ten problem to proszę o porady i z góry dziękuję.

    Edit:
    Prosiłbym o sprawdzenie logów z OTL
  • Poziom 18  
    Już wiem kiedy tak się zawiesza, nie tylko na BackTracku ale i też na Mac OS. Gdy w danej wirtualnej maszynie zmaksymalizowanej na pełny ekran najadę na górny pasek narzędzi, dzięki któremu można m.in. zminimalizować maszynę, to pojawia się napis "To release input press Ctrl+Alt". Wiem, że ta kombinacja jest do przełączania myszki pomiędzy wirtualną maszynę i system host. Po najechaniu myszką na ten pasek ona i tak przestawia się na system host. Gdy pojawi się ten napis:
    Brak możliwości zainstalowania/odinstalowania VMware Workstation
    i gdy zminimalizuję przed jego zniknięciem to cały WMware workstation zawiesza się. Gdy poczekam aż on zniknie - mogę normalnie zminimalizować i wrócić do systemu hosta.
    Teraz pytanie: czy da się gdzieś wyłączyć te podpowiedzi i dlaczego np. na wirtualnym WinXP one nie wyskakują?