Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Sklep ElwronSklep Elwron
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Port serwisowy sterowników WAGO z serii 750

17 Maj 2011 10:51 4402 16
  • Poziom 9  
    Witam, słyszałem o możliwości wykorzystania portu serwisowego (za jego pomocą programuję się sterownik kablem USB) sterowników WAGO jako programowalnego portu RS232.
    Port posiada 4 piny potrzebuję rozpoznać, które piny są Tx, Rx i masą dla RS232
  • Sklep ElwronSklep Elwron
  • Poziom 11  
    za elektroda:
    "Ze sterownikiem łączymy się za pomoca konwertera RS232-TTL
    Opis wyprowadzeń jest na zdjęciu.
    GND VCC daje napięcie 5V na zasilanie MAX232"

    Port serwisowy sterowników WAGO z serii 750


    pozdrawiam
    t,
  • Sklep ElwronSklep Elwron
  • Specjalista Automatyk
    Uważajcie na te gniazdo, ja już widziałem 3 urwane:)
  • Poziom 2  
    Witam

    Czy komus udalo sie uruchomic komunikacje po porcie serwisowym np z ATMEGA lub popularnym zestawem EvB??

    Pozdrawiam
    WENWOJ
  • Poziom 20  
    Pytanie czy komuś udało się połączyć ze sterownikiem za pomocą konwertera USB->RS232TTL poprzez złącze serwisowe?
  • Specjalista Automatyk
    Przez Moxe Uport 1110
  • Poziom 20  
    Prolific USB-to-Serial Comm Port
    FTDI USB Serial Port

    Próbowałem się połączyć z WAGO 750-843 ale się nie powiodło :(
    Może komuś się udało?
  • Poziom 20  
    Komunikacja z sterownikiem już chodzi poprzez oba układy cena modułu i kabelka max. 20zł.

    Mam pytanie czy można zaprogramować sterownik WAGO 750-843 poprzez port tcp/ip zamiast portu serwisowego.
    Próbowałem go skonfigurować ale nie podświetla się zmiana adresu ip cały czas mam (0.0.0.0) bez możliwości zmiany na inny.
  • Specjalista Automatyk
    A nie powinieneś na początku nadać adres poprzez Bootp?
  • Poziom 5  
    shadoweyes napisał:
    Prolific USB-to-Serial Comm Port
    FTDI USB Serial Port

    Próbowałem się połączyć z WAGO 750-843 ale się nie powiodło :(
    Może komuś się udało?


    Czesc,
    Mam pytanie czy komunikacja przez port serwisowy bedzie chodzic na cablu USB/RS232/TTL/PLC2303 ? jak na zdjeciu?
  • Poziom 20  
    Powinno działać, trzeba odpowiednio poustawiać piny wystarczą piny GND , TXD i RXD z tym że trzeba pamiętać o podłączeniu krosowym sygnałów TXD i RXD.
    W moim musiałem wymusić konfigurację potu RS232 na com1 lub com2 potrzebne do pracy w CodeSys.
  • Poziom 5  
    shadoweyes napisał:
    Powinno działać, trzeba odpowiednio poustawiać piny wystarczą piny GND , TXD i RXD z tym że trzeba pamiętać o podłączeniu krosowym sygnałów TXD i RXD.
    W moim musiałem wymusić konfigurację potu RS232 na com1 lub com2 potrzebne do pracy w CodeSys.


    To co +5V nie pdlaczac ? jak na zdjeciu ? tylko TxD ,RxD i GND? Zobacz na zdjecie portu serwisowego
  • Poziom 20  
    Tak, ummie działa bez. 5V można podłączyć gdy posiadałbyś układ z izolacją galwaniczną (optoizolacją ) lub zasilałbyś układ (konwerter usb->RS232 ) ze sterownika a nie z portu usb.
  • Poziom 5  
    Mecze dalej ten sterownik . Wydaje sie musi miec pdlaczenie +5V zeby sie z nim komunikowac.
    Orginalny z PLC Source code nie moge dowload (zawsze : cannot read source code ), ale jak otworze nowy project i jakis prosty LD program flash t o potem mozna juz download and upload.

    Caly czas mam diode na czerwono I/O Error a to jest tylko PLC coupler. Nie mam programu WAGO I/O check i nie moge tego zresetowac z WAGO I/O PRO 32 . Moze to jest normalne ze to jest tylko coupler sam ?
  • Poziom 20  
    To nie jest wina braku podłączenia +5V do przewodu(złącze serwisowe). Sprawdź czy możesz połączyć sie z programu WAGO Ethernet Settings. UpLoad ze sterownika nie zawsze będzie działać gdyż do sterownika trzeba zapisć program z plikami źródłowymi programu. Jeśli nie są zapisane w sterowniku to nie wczyta tych plików i będzie błąd.
  • Poziom 11  
    Witam.
    Odświeżę temat

    Mam pytanko do Shadoweyes?

    Czy ze sterownikiem 750-843 łącząc się za pomocą Prolific USB-to-Serial Comm Port (tak widzi go SetCom , ale nie wiem jaką wersje) korzystałeś z konwertera rs232 TTL, czy też może połączyłeś się bezpośrednio pin 2 -Tx pin 3 -Rx pin 5 GND.
    Mi przy takim połączeniu Wago Eternet seting nie wykrył sterownika
  • Poziom 20  
    Przejściówka powinnabyć dostosowana do standardu RS-232C czyli poziomów TTL(0V. 5V). Pracę coma najlepiej sprawdzić programami testującymi od WAGO -można wtedy ustawić dowolny com na przejścówce np. com 3 i sprawdzić jego działanie. Najlepiej używać przejściówki z optoizolacją gdyż nie uszkodzimy przejściówki albo sterownika. Umnie juz parę takich przejściówek padło bez optoizolacji diody z nich pokazują komunikację ale sygnał nie "docierał" do sterownika ale kupiłem ich sobie więcej bo były tanie cena ok.4zł. Do połączenia z CoDeSys 2 musisz wymusić pracę przjścióki na com2 lub com1. Z powodu sterowników zawartych w tym programie. Moja rada jest taka lepiej wydać troszkę więcej i mieć przjściówkę z optoizolacją , która chroni komuter i sterownik przed uszkodzeniem. Prolific USB-to-Serial urzywałem podobnej przejściówki i komunikacja działała ale była bez optoizolacji i często po kilku miesiącach pracy padała.