Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

EXEL - Problem z przenoszeniem wybranych danych z jednego arkusza do drugiego

radmin87 12 Lip 2011 15:20 3221 3
  • #1 12 Lip 2011 15:20
    radmin87
    Poziom 2  

    Witam,

    Mam problem, chcialbym poznac komende, lub macro czy cos innego, co pozwoli na przenoszenie automatyczne danych z jegnego arkusza do drugiego.
    Dokladniej mowiąc chodzi o to, ze gdy w arkuszu 2 wpisze jakas wartosc np. 15 to wszystkie wybrane dane z arkusza 1 zostana skopiowane w odpowiedniej kolejnosci do arkusza 2.
    Czy jest to mozliwe do zrobienia i czy mozecie mi w tym pomoc.

    Ponizej zamieszczam przykladowy arkusz:

    Chodzi o to ze, jak w arkuszu 2 wpisze/wstawie numer zamowienia np: 10z/4/11 to odpowiednie rekordy z arkusza 1 ze wszystkimi danymi z kolumn B, C, D, O, P, Q, R i V zostana skopiowane do arkusza 2 w niezmienionej formie

    Nie wiem czy jasno to wytlumaczylem i czy jest cos takiego mozliwe.
    Jestem raczej laikiem w sprawach exela, dlatego bardzo prosze o pomoc
    Pozdrawiam :)

    0 3
  • #2 12 Lip 2011 16:04
    PeteSh
    Poziom 30  

    Wstaw w arkuszu 2
    do B2: =WYSZUKAJ.PIONOWO($A2;'arkusz 1'!$B$6:$U$1000;2;FAŁSZ)
    do C2: =WYSZUKAJ.PIONOWO($A2;'arkusz 1'!$B$6:$U$1000;3;FAŁSZ)
    do D2: =WYSZUKAJ.PIONOWO($A2;'arkusz 1'!$B$6:$U$1000;4;FAŁSZ)
    itd.

    0
  • #3 12 Lip 2011 20:37
    radmin87
    Poziom 2  

    dzieki wielkie za pomoc, ale napotkalem kolejny problem.
    W kolumnach z numerem zlecen jest przenoszony tylko pierwszy wiersz poprawnie. Ciezko jest mi to opisywac bez przykladu, dlatego powiem o co chodzi na konkretnym przykladzie.
    Dla zlecenia 10z/4/11 nazwa klienta jest wporzadku, natomiast numer zamowienia klienta w kolejnych wierszach sie nie zmienia, mimo ze w arkuszu 1 dla zlecenia 10z/4/11 z inna data moze byc inny numer zamowienia klienta.
    To samo dotyczy wymiarow. Jest kopiowany tylko ten pierwszy wymiar a nie jak to po kolei wyglada w arkuszu 1
    Nie wiem czy wyjasnilem to przejrzyscie..

    0
  • #4 12 Lip 2011 21:35
    adamas_nt
    Moderator Programowanie

    Dlatego, że w wyszukiwanej kolumnie wartości nie są unikatowe. Funkcja zwróci pierwszy znaleziony, czyli w tym przypadku zawsze 27 wiersz. Należałoby znaleźć pozycję w tabeli i przesuwać górną granicę o WIERSZ()-n, zachowując dolną. Formuła miałaby z 20cm...
    Będzie prościej makrem. Wklej w kod arkusza "arkusz 2", przetestuj (zmiana w A2), dostosuj do własnych potrzeb.

    Kod: vb
    Zaloguj się, aby zobaczyć kod

    0