Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Usunięcie błędu Er2 w sterowniku Tango Negro

ciacho23 09 Aug 2011 15:59 36259 25
Relpol
  • #1
    ciacho23
    Level 11  
    Usunięcie błędu Er2 w sterowniku Tango Negro

    Witam

    Ostatnio Naprawiałem sterownik Tango Negro i chciałbym się z wami podzielić zdobytą wiedzą. Otóż w powyższym sterowniku co jakiś czas wyświetlała się Awaria i występował kod błędu Er2. W instrukcji jest napisane że jest to albo uszkodzenie dmuchawy albo sterownika. W moim przypadku był to sterownik.
    W sterowniku tym mikroprocesor sprawdza sobie obwód dmuchawy i jeśli jest przerwany to wystąpi powyższy błąd. Do tego celu projektanci wykorzystali układ CNY 17-4(transoptor). Prąd zostaje wyprostowany przez mostek 4x IN4148 następnie płynie przez diodę transoptora, za nią jest ograniczony przez rezystor 68k i po przejściu przez dławik i silnik dmuchawy zamyka obwód. W ten sposób jeśli jest przejście to mikroprocesor to wykrywa jako sprawne. Jeśli więc pojawi się błąd Er2 to należy najpierw wymienić rezystor R7- 68k 2W (po długiej eksploatacji bardzo się nagrzewa i może stracić swoje właściwości przy wyższych temp.) a następnie transoptor CNY 17-4. Ja wymieniłem jeszcze mostek gretza i kondensator przeciwzakłóceniowy 100n X2.

    Usunięcie błędu Er2 w sterowniku Tango Negro

    Usunięcie błędu Er2 w sterowniku Tango Negro

    1-R7 68k 2W opornik dużej mocy
    2-U2 CNY 17-4 transoptor
    3-C14 100n X2 kondensator przeciwzakłóceniowy
    4-D3 D4 D5 D6 4xIN4148 mostek gretza

    Sterownik teraz śmiga bez zastrzeżeń
  • Relpol
  • #2
    dasi
    Level 10  
    Witam.
    Ja tez mam problem z ER2 tylko że przed pojawieniem się tego błędu najpierw dziwnie zachowuje się wentylator ( pracuje na bardzo wolnych obrotach ), dodam że sprawdzałem wentylator na krótko i działa normalnie. proszę o pomoc.
  • #3
    ciacho23
    Level 11  
    Spróbuj na początek wymienić rezystor R7 - 68k (dużej mocy). W tym sterowniku regulacją obrotów zajmuje się układ wykonawczy złożony z optotriaka moc3021 i triaka BTB 12 (ale ich uszkodzenie nie powoduje tego błędu). Aby płynnie regulować moc i nie powodować zakłóceń użyto układu detekcji zera składającego się z transoptora CNY 17-4, 4 diod, i rezystora obniżającego napięcie. Układ ten służy również do sprawdzenia obwodu dmuchawy. Ja wymieniłem wszystkie te elementy co pokazałem powyżej i działa dobrze. Nie miałem czasu żeby doszukiwać się który konkretnie nawalił ale sądzę że jak sterownik działa dosyć długo to pewnie rezystor jest już trochę nadpalony i traci swoje właściwości przy wysokich temperaturach. Jak się przyjrzysz to przy nóżkach widać ślady grzania.
  • #4
    dasi
    Level 10  
    Ostatnio obserwowałem swój piec i zauważyłem że, w fazie powrotu pieca do pracy wentylator pracuje na bardzo niskich obrotach. A następnie po pewnym czasie włącza się zabezpieczenie wentylatora ( chyba zabezpieczenie przeciw przegrzaniu). Następuje przerwanie obwodu i błąd ER2. To zachowanie pieca występuje w różnych odstępach czasu ale powraca. Lekarstwem jest wyłączenie sterownika, ale nie wiadomo kiedy znowu się zatnie. Dodam że wymieniłem rezystor R7 i transoptor cny 17-4 .
  • #5
    ciacho23
    Level 11  
    No to teraz przyznam że nie mam pojęcia co się tam dzieje. Skoro włącza się przekaźnik zabezpieczający to może coś jest nie tak z termostatem kosza. Może wypiąć go i zamiast niego zrobić zwarcie tak samo jak jest w miejscu gdzie się podpina termostat pokojowy i zobaczyć czy dalej się to będzie działo. Później oczywiście termostat wpiąć z powrotem. No i podczas prób pilnować żeby się woda w kotle nie zagotowała bo wiadomo że zabezpieczenie nie zadziała.
    Może warto jeszcze wymienić te diody albo je sprawdzić. bo jeśli będzie któraś spalona na zwarcie to prąd będzie omijał transoptor i też będzie występował ten błąd.
  • #6
    dasi
    Level 10  
    Zobaczę ten termostat . Zastanawiają mnie te wolne obroty wentylatora, od czego to może być?
  • #7
    dasi
    Level 10  
    A ma Pan może schemat tego modułu sterującego obrotami wentylatora, bo planuje metodą sapera wymieniać elementy za to odpowiedzialne. Z góry dziękuje.
  • #8
    ciacho23
    Level 11  
    schemat mniej więcej pokazałem na samym początku. Mikroprocesor daje sygnał na optotriaka moc3021 a ten załancza z kolei triaka BTB 12. Te elementy znajdują się zaraz przy tym dużym rezystorze. Ale schematu od producenta niestety nie mam. Jak go kiedyś naprawiałem to na podstawie ścieżek narysowałem sobie ten schemat co jest na samym początku tematu.
  • Relpol
  • #9
    dasi
    Level 10  
    Wymieniłem mostek prostowniczy RB 157, i jak na chwile obecną działa. Dziękuje za pomoc pozdrawiam.
  • #10
    ciacho23
    Level 11  
    Witam ponownie
    Przyznaje rację co do tego mostka prostowniczego RB 157. Ostatnio miałem problem z tym że dmuchawa niekiedy nie chciała się załączyć. Okazuje się jednak, że mikroprocesor do prawidłowej synchronizacji załączania triaka pobiera sygnał za tym mostkiem. Padniecie jednej diody w mostku powoduje złą synchronizację a co za tym idzie problemy z załączeniem dmuchawy. Czyli układ opisany na samym początku wątku służy jedynie do sprawdzenia obwodu dmuchawy!
  • #11
    macbed1a
    Level 10  
    witam panów.
    chciałbym się zapytać kogoś kto się zna trochę na tym błędzie i tej elektronice. mianowicie wymieniłem wszystkie 4 elementy płytki i nadal pokazuje się ten błąd. na początku jest dobrze ale później jak się nagrzeje to wyskakuje. i gdy powinna się dmuchawa załączyć to jest takie pstryknięcie przekaźnika i wyskakuje "Er2" :(
    co jest nie tak i gdzie coś zmienić ?
  • #12
    kubansa
    Level 11  
    Witam,
    mam taki problem, po jakimś czasie nieuzasadnionym wyłącza się pompa. Nie występuje żaden błąd. Podczas pracy również skacze temperatura np. z 50 do 20 stopni. Co może być przyczyną?
  • #13
    ciacho23
    Level 11  
    Witam
    W ustawieniach fabrycznych pompa załącza się powyżej 35'C a wyłącza poniżej 35'C - 5'C czyli poniżej 30'C. Skoro Pan pisze że skacze Panu temperatura z 50 do 20 stopni to pompka wyłącza się programowo.

    Przypuszczam że winą będzie uszkodzony czujnik temperatury. To jest czujnik rezystancyjny. Proponuje zadzwonić do serwisu (0602-251-388) i zamówić nowy.
  • #14
    kubansa
    Level 11  
    Dzięki za odpowiedz, skończyło się wymianą całego sterownika decyzją teścia :-) i obecnie problem ustąpił. Pozdrawiam
  • #15
    darkomanta
    Level 15  
    Witam. Temat stary ale może komuś przyda się mój post. Sugerowane elementy do wymiany w pierwszym poście sprawne. Uporczywy Er2 przestał pojawiać się po wymianie optotriaka MOC3021 w gałęzi sterowania dmuchawą. Nie miałem nowego (ani wyluta) pod ręką więc postanowiłem zamienić go miejscami na próbę z MOC3021 "siedzącym" w gałęzi sterowania pompą wody. Odziwo Er2 przestał się pojawiać a także pompa pracowała prawidłowo. Pozdrawiam.
  • #16
    KGsavage
    Level 1  
    Witam
    Naprawiam owy sterownik , ale płyta w wersjo 03 i na niej jest tam moc 3020 .Wstawiłem moc 3021 oraz wymieniłem wszystkie podawane przez was komponenty do wymiany.Pytanie brzmi : Nie posiadam wentylatora i rozumiem , ze bez wentylatora dalej będzie się pojawiał ten błąd .Czy mam racje? Czy można podpiąć jakikolwiek wentylator aby to sprawdzić?
    Pozdrawiam
  • #17
    MarEwel
    Level 12  
    U mnie wyświetla błąd termostatu kosza,gdzie przy podajniku szufladowym to wyjście mam zmostkowane.Mam tam od samego początku błąd pojawia się co jakiś czas.
  • #18
    ferdek33
    Level 11  
    witam...jestem w posiadaniu pieca na ekogroszek z podajnikiem slimakowym i sterownikiem TANGO ..nie to ze temperatura skacze na wyswietlaczu to po zadanej temperatury sterownik wylacza piec...co moze byc tego przyczyna? z gory dziekuje
  • #19
    jnarloch
    Level 10  
    Miałem podobny problem w sterowniku Tango Negro: komunikat awarii "Er2" oraz trochę wolniejsze obroty dmuchawy (przynajmniej takie miałem wrażenie). Wymieniłem transoptor CNY17-4, optotriak MOC3021 i mostek prostowniczy RB157. Sterownik działa!
  • #20
    swidosliwa
    Level 1  
    jnarloch wrote:
    Miałem podobny problem w sterowniku Tango Negro: komunikat awarii "Er2" oraz trochę wolniejsze obroty dmuchawy (przynajmniej takie miałem wrażenie). Wymieniłem transoptor CNY17-4, optotriak MOC3021 i mostek prostowniczy RB157. Sterownik działa!

    witam ,skorzystam z okazji i dopowiem bo nie zawsze jest to dla wszystkich wiadome , zanim rozbierzecie sterownik i zaczniecie lutować sprawdzcie najpierw kondensator rozruchowy dmuchawy bo padnięty tez wywala błąd Er2 w sterowniku .pozdrawiam
  • #21
    white88
    Level 12  
    WItam, czy ktoś z was miał może przypadek w którym dioda od dmuchawy miga i nie załącza dmuchawy bez błędu Er2? Wymieniłem wszystkie powyższe elementy i nie mam błędu Er2 ( nie miałem go przedtem także ) ale mimo wszystko jedyna reakcja jest miganie diody "dmuchawa" w zadnym z trybów nie działa. Temp normalne, podajnik działa pompa także. Ktoś ma jakiś pomysł takiego przypadku w instrukcji nie ma opisanego.
    Dzięki.
  • #22
    ciacho23
    Level 11  
    Witam
    Ja bym sprawdził taśmę między panelem a płytką wykonawczą. Tam jest chyba 20 - sto żyłowa. Sprawdzić czy każda żyła przewodzi. Może być tak że sterownik wystawia na wyjście sygnał a on przez taśmę nie dochodzi do płytki gdzie ma załączyć dmuchawę.
    Pozdrawiam
  • #23
    white88
    Level 12  
    Dzięki za szybką odpowiedź. Zgadzam się z tobą sprawdziłem to wczoraj wszystko było okay. Sprawa rozwiązana dzwoniłem do serwisu i co się okazało istnieje serwisowe menu ( nie wymienione w instrukcji) dzięki któremu można wyłączyć dmuchawę i podajnik całkowicie. Nie mylić z ustawieniami konfiguracyjnymi bo to nie to. Jak to powiedział przemiły Pan z serwisu " Nie wiem jak wy to robicie ale nie jest Pan pierwszy który tu uruchomił". Kombinacja przycisku nastawa przez 5s i wciśniecie dmuchawy lub podajnika wyłącza/włącza je na stałe. Dioda od podajnika bądź dmuchawy miga wtedy sygnalizując ze jest wyłączona programowo stąd brak błędu Er2. Wejsce do tego menu tylko podczas wybranego trybu Manual.
    Dzięki i pozdrawiam.
  • #24
    termin25
    Level 11  
    jnarloch wrote:
    Miałem podobny problem w sterowniku Tango Negro: komunikat awarii "Er2" oraz trochę wolniejsze obroty dmuchawy (przynajmniej takie miałem wrażenie). Wymieniłem transoptor CNY17-4, optotriak MOC3021 i mostek prostowniczy RB157. Sterownik działa!
    Gdzie ten mostek RB157 jest, bo nie mogę u siebie go znaleźć ? płytka z 2007 roku.
  • #26
    termin25
    Level 11  
    white88 wrote:
    Tuż obok transformatora. Okrągły mały mostek prostowniczy.
    https://obrazki.elektroda.pl/2501369000_1322857542.jpg

    To ja mam jakąś starą wersję tej płytki, bo u mnie jest dokładnie w tym miejscu co podałeś tylko że z drugiej strony, tak samo diody IN4148 są z drugiej strony przylutowane.