Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Linux - problem z połączeniem z ISP przez switcha

16 Wrz 2011 11:09 715 3
  • Poziom 2  
    Witam!

    Na wstępie - jestem prawie laikiem, jeżeli chodzi o Linuksa, znam podstawowe komendy + ew. pogrzebię coś w iptables na zasadzie inżynierii wstecznej ;)

    Mam następujący problem - Slackware służy mi jako brama, od ISP otrzymałem kilka IP, które zamierzam wykorzystać.

    I tu zaczyna się problem - kiedy podłączę kabel ethernet od ISP bezpośrednio do karty sieciowej wszystko działa ok (mam ustawione na eth0 IP oraz maskę prawidłowo), natomiast kiedy podłączę przez switcha (chciałbym na switchu rozdzielać sygnał na kilka urządzeń, każde ze swoim IP od ISP) łącze nie działa - nie pinguje bramy ISP...

    Czy macie może jakieś pomysły co może być nie tak? Jeżeli potrzebne dodatkowe info to chętnie udzielę. Dzięki z góry za pomoc, pzdr!
  • Specjalista automatyka domowa
    Jeśli dostałeś od swojego ISP pulę adresów IP to powinieneś dostać też informacje o przydzielonej adresacji takie jak maska, pierwszy adres sieci lub zakres adresów.
    Te dane musisz wpisać do jakiegoś routera i wyłączyć DHCP oraz NAT.
  • Poziom 2  
    OK, te dane dostałem i wpisałem w konfiguracji interfejsu (eth0).
    Jeśli wepnę kabel, który idzie od anteny ISP bezpośrednio w interfejs -wszystko działa, jeśli zaś wepnę się tym kablem w switcha, a następnie ze switcha do interfejsu eth0 - nie działa...
    Czy NAT może być w tym przypadku problemem?
  • Specjalista Sieci, Internet
    NAT tu nie ma nic do rzeczy. Albo ten switch jest uszkodzony, albo sprawa kabli (skrzyżowany albo nie). Nie wiem, jak masz podany Ethernet z ISP. Zobacz, czy obecny kabel nie jest skrzyżowany.