Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sony VAIO PCG-7A1M i M37516+93L66 reset

atomus2003 22 Wrz 2011 22:57 2668 5
  • #1 22 Wrz 2011 22:57
    atomus2003
    Poziom 17  

    Witam!

    Proszę o zresetowanie wsadu do laptopa SONY VAIO PCG-7A1M opartego o układy M37516+93L66.
    Wylutowaną pamięć odczytałem dwoma różnymi programatorami: BE2Works (dedykowanym adapterem) oraz PonyProgiem z adapterem znalezionym na stronie:
    http://avalon.co.ua/batteries/viewtopic.php?f=89&t=2161&sid=9a76d06b7dd21057b28d694bf6ba4a44
    Obydwa wsady różnią się od siebie, a różnica polega na zamianie miejscami sąsiednich par komórek (szesnastkowo) i nie mam bladego pojęcia który jest prawidłowo odczytany.

    Z góry wielkie dzięki za wszelką pomoc.

    Pozdrawiam!!!

    P.S. Na prośbę kolegi podaje jeszcze odczyt z BE2Works:
    Sony VAIO PCG-7A1M i M37516+93L66 reset

  • #3 26 Wrz 2011 21:38
    atomus2003
    Poziom 17  

    Witam ponownie

    Dzisiaj włożyłem do laptopa zresetowaną baterię, pokazało że ładuje, ale ciągle było 100%. Wyłączyłem laptopa i zostawiłem go tak na ładowarce ok. 4h. Po włączeniu dalej to samo.
    Wyłączyłem laptopa ponownie, odłączyłem zasilacz i włączyłem laptopa.
    Na chwilę włączył się dziwnie piszcząc i zgasł. Za każdym razem to samo. Na zasilaczu działa ok. Baterię rozpoznaje w laptopie (Batterymon).

    Jeszcze jedna anomalia moim zdaniem: aby odczytać parametry baterii programem BE2Works muszę zewrzeć rezystorem 1kΩ 2 pin złącza do masy oraz dodatkowo muszę podać 12V na V+. Dopiero wtedy komunikuje się z programem. Pinologia złącza:
    (GND)(SP)(N.C.)(SCL)(SDA)(V+). Załączam odczyt po pierwszym włożeniu do laptopa:
    Sony VAIO PCG-7A1M i M37516+93L66 reset

    Podejrzewam jednak padnięte ogniwa mimo, że w testach z żarówką i balansowaniem wypadły dosyć dobrze. Możliwe też, że coś z tranzystorami lub bezpiecznikiem jest nie tak. Czy może być coś nie tak ze wsadem pamięci? Zapis/odczyt podanego pliku poprawny.
    Proszę o jakieś dalsze sugestie.

  • #4 26 Wrz 2011 22:38
    jarob
    VIP Zasłużony dla elektroda

    Sprawdź bezpiecznik

  • #5 27 Wrz 2011 22:26
    atomus2003
    Poziom 17  

    Bezpiecznik sprawdzany już wcześniej, ale sprawdziłem jeszcze raz (na mierniku ok. oraz po podpięciu żarówki 21W - świeci). Wygląda na to, że sterownik blokuje pracę baterii lub są uszkodzone tranzystory bądź ogniwa. Jutro walczę z tym dalej, wymienię tranzystory i sprawdzę jeszcze raz ogniwa. Mam jeszcze pytanie: czy jest możliwość złego resetu wsadu, np. zmiana wartości niewłaściwych komórek pamięci?

  • #6 28 Wrz 2011 07:36
    jarob
    VIP Zasłużony dla elektroda

    Wsad jest zresetowany poprawnie.
    Tranzystorów bym się nie czepiał.

    Ogniwa są najbardziej podejrzane o uszkodzenie.

 
Black Friday do -15%
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
Ferguson