Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przekazanie internetu z laptopa do PC.

lesio_7 27 Wrz 2011 13:18 2131 8
  • #1 27 Wrz 2011 13:18
    lesio_7
    Poziom 7  

    Witam czy jest możliwość przekazania internetu z Laptopa A do PC B kablem krosowanym czy czymś podobnym, jeżeli Laptop A jest pod AP który przekazuje sygnał od routera ??

    0 8
  • #3 29 Wrz 2011 22:17
    lesio_7
    Poziom 7  

    Mam SP3 laptop uzyskuje internet od AP z wifi i chce przekazac drugiemu. Wiec Połączenie sieci bezprzewodowej zostawiam jak bylo.

    Połączenie lokalne

    ustawiam

    IP 192.168.0.100 (bo takie mam IP z wifi)

    maska 255.255.255.0

    Brama 192.168.0.1 (takie IP ma moj router)


    komputer nr 2

    IP 192.168.0.99
    maska taka sama
    Brama 192.168.0.100 (bo takie ma moj laptop)

    czy robiec cos zle?

    0
  • #4 29 Wrz 2011 22:34
    bolekis
    Poziom 34  

    1. Musisz mieć działającą usługę Zapora systemu Windows/Udostępnianie połączenia internetowego.
    2. We właściwościach połączenia WiFi zaznaczasz że chcesz udostępnić to połączenie
    dla komputerów podłączonych przez kartę przewodową.
    3. System sam skonfiguruje IP na karcie przewodowej, uruchomi NAT i DHCP. Weryfikacja poleceniem ipconfig/all - adres IP karty przewodowej będzie ustawiony na 192.168.0.1 - taki jest standardowy ZTCP - i już widzę że może Ci to nie zadziałać bo taką samą konfiguracje masz pod WiFi - trzeba będzie zmienić adresację na połączeniu WiFi na jakąś inną.

    0
  • #5 30 Wrz 2011 01:00
    lesio_7
    Poziom 7  

    @3. System sam skonfiguruje IP na karcie przewodowej, uruchomi NAT i DHCP.

    Rozumiem ze wifi w TCP IP ma zostac na uzyskaj adres automatycznie.

    Wiec dla wifi to IP jest 192.168.0.100 (laptop ) a Brama domyslna 192.168.0.1

    a zebym mogl udostepnic kablem to musze miec wlaczana Połączenie lokalne (przewodowe). Tylko ze Połączenie lokalne jak jest wlaczone z konfiguracja z

    IP 192.168.0.100 Brama 192.168.0.1

    tylko gdy tak ustawie to jest ciagle pobieranie adresu sieciowego.

    TYLKO SKAD ON MA GO POBRAĆ SKORO ON MA UDOSTEPNIAC.

    a jak ustawie automatycznie to Ograniczenie lub brak lacznosci.


    Ponawiam 1 probe z IP 192.168.0.100 Brama 192.168.0.1 wyskakuje

    Statyczny adres IP ktory wlasnie skonfigurowano jest juz uzywany w sieci skonfiguruj ponownie adres IP lub nie wyskakuja bledy ale internet juz nie dziala.


    dlatego robie tak jak mowiles

    2 polaczenia sieci bezpewodowej zaawansowane udostepniam zaznaczam dwa ptaszki

    gdy tak ustawie i nie wyskakuja bledy to nie dziala internet na laptopie a tym bardziej na PC


    Dodam ze wczesniej podawalem konfiguracje 192.168.0.x tak naprawde u mnie jest 192.168.1.x

    Kolejna ciekawa sytuacja gdy przy takiej samej konfiguracji odznacze ptaszki OK i zaznacze ponownie wyskakuje taki blad

    https://obrazki.elektroda.pl/6173901700_1317335112.jpg

    po akceptacji internet dziala ale Polaczenie lokalne zmnienia IP na 192.168.0.1 maska taka sama a brama domysla brak

    Dodano po 1 [godziny] 16 [minuty]:

    @ Wikipedia

    Kabel skrosowany jest używany jest jedynie do bezpośredniego łączenia np. komputera z komputerem (bez urządzeń pośredniczących).

    wiec rozumiem ze sie nie da ?

    0
  • #6 30 Wrz 2011 09:53
    bolekis
    Poziom 34  

    Gdzie masz adresację 192.168.1.x? Na którym połączeniu? Zrób "ipconfig/all" przed i po udostępnieniu i wklej wyniki.
    Kabel skrosowany jest OK.

    0
  • #7 30 Wrz 2011 12:49
    lesio_7
    Poziom 7  

    Przed udostepnieniem (wszystko automatycznie)
    Dzisiejsze moje IP to z koncowka 106

    https://obrazki.elektroda.pl/8752063600_1317379294.jpg

    Ustawiam w taki razie w laptopie w sieci lokalnej (przewod) na 192.168.1.106 a brama 192.168.1.1 a na PC 192.168.1.99 brama na 192.168.1.106.

    Wyskakuje blad i w cmd takie cos

    https://obrazki.elektroda.pl/7281239100_1317379638.jpg

    wiec udostepniam wifi wyskakuje komunikat

    https://obrazki.elektroda.pl/6173901700_1317335112.jpg

    a

    cmd https://obrazki.elektroda.pl/7205230600_1317379755.jpg

    0
  • Pomocny post
    #8 30 Wrz 2011 14:25
    bolekis
    Poziom 34  

    Przy udostępnianiu połączenia adresacje po obydwu stronach muszą się różnić chyba że chcesz zrobić tzw. most ale nie o tym teraz mówimy.
    Zostaw więc WiFi na 192.168.1.x, kartę przewodową ustaw na auto - i tak po udostępnieniu zmieni się na 192.168.0.1
    Udostępnij połączenie, podłącz PC, na nim też ustaw automatyczną konfigurację - sprawdź czy PC pobierze adres z zakresu 192.168.0.x, potem ping z PC na 192.168.0.1, jeśli działa to ping na adres 192.168.1.1 i jeśli działa to na 8.8.8.8 - jak zadziała ostatnie to masz dostęp do internetu na PC, potem sprawdź DNS wysyłając "ping" nie na adres IP tylko jakąś nazwe serwera w internecie.

    0
  • #9 02 Paź 2011 16:12
    lesio_7
    Poziom 7  

    Problem rozwiazany. Blad tkwil w blednej konfiguracji adresow IP.

    Laptop A wifi musi miec wszystko automatycznie i udostepnianie polaczenia
    Laptop A polaczenie lokalne musi miec 192.168.0.1 brama 255.255.255.0

    Komputer B automatycznie.

    Przy ponownej konfiguracja przy takiej samej konfiguracji nie dzialalo. Wylaczenie zapory na laptopie A i ponowne uruchomienie rozwiazalo problem teraz przy wlaczanej zaporze rowniez dziala.

    0