Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Brumienie we wzmacniaczu na TDA2040

James596 30 Wrz 2011 01:37 2882 13
  • #1 30 Wrz 2011 01:37
    James596
    Poziom 20  

    Witam.

    Z racji uszkodzenia oryginalnej końcówki mocy w moim wzmacniaczu Fisher, zakupiłem zwykły zestaw NE019, tj. 2x15W na TDA2030.

    Oryginalna końcówka mocy na STK została usunięta, i zamiast niej podłączyłem powyższy zestaw, zamieniając TDA2030 na TDA2040.

    Wszystko działa poprawnie, ale słychać bardzo dokuczliwe brumienie zagłuszające muzykę po cichu. Po zwiększeniu głośności, muzyka zagłusza brumienie. Jest ono słyszalne cały czas, niezależnie czy do wzmacniacza podłączono źródło, czy nie.

    Dopiero odłączenie przewodów sygnałowych od końcówki mocy TDA wycisza brumienie.

    Wzmacniacz Fisher ma dwa punkty masy podłączane do oryginalnej końcówki mocy - każdy na jeden kanał. W dalszej części płytki schodzą się one w jedną ścieżkę, i idą do minusa kondensatorów filtrujących. Końcówka mocy NE019 ma również wspólną masę wejść/wyjść/zasilania.

    Połączenie przewodem masy końcówki mocy z obudową wzmacniacza minimalnie ścisza brum, ale jest on nadal bardzo uciążliwy.

    Jak można wyeliminować tą niedogodność?

    Pozdrawiam, James.

  • Pomocny post
    #2 30 Wrz 2011 12:48
    Rzuuf
    Poziom 43  

    Witam!
    Powodem brumienia bardzo często jest wspólny odcinek "masy" dla zasilania i wzmacniacza, na którym odkłada się spadek napięcia tętniącego, pochodzącego z ładowania kondensatorów prądem impulsowym z prostownika.
    Rozpływ zasilania należy poprowadzić tak, aby wszystkie przewody od prostownika dochodziły wprost do kondensatorów filtra, a zasilanie dalszych części wzmacniacza miało też swój fizyczny początek na zaciskach kondensatorów. Dotyczy to też (a może zwłaszcza) "masy".
    Sprawdź, skąd idzie masa dla stopnia sterującego (przed końcówką) - w tym również potencjometrów i gniazd wejściowych!
    Jeśli trzeba - przemontuj, odcinając przy tym "stare" połączenia masy.

  • #3 30 Wrz 2011 13:57
    James596
    Poziom 20  

    Zatem jeśli dobrze zrozumiałem, to odseparowanie kondensatorów filtrujących od reszty płytki drukowanej, może pomóc?

    W założeniu myślę nad wyprowadzeniem prosto z prostownika przewodów i podłączenie plusa do punktów na płycie drukowanej, a minus prosto do końcówki mocy, dołączając równolegle właśnie kondensator filtrujący.

  • #4 30 Wrz 2011 14:39
    Rzuuf
    Poziom 43  

    Nie tak!
    Druty od prostownika najpierw do kondensatorów, a potem następne połączenie od kondensatorów do płytki! Nie odwrotnie!
    Na drutach między prostownikiem a kondensatorem powstaje spadek napięcia (tętniący!), który Ci się dodaje do napięcia wejściowego, i Ty to potem wzmacniasz - to BŁĄD (niestety, dość częsty, był nawet w konstrukcjach Unitry, ale nie u Grundiga!).
    Jeżeli dopiero do płytki dołączasz kondensator filtrujący, to na płytce masz tętnienia większe, niż na kondensatorze.

  • #5 01 Paź 2011 17:13
    James596
    Poziom 20  

    Dziękuję za odpowiedź.

    Wertując dzisiaj płytę wzmacniacza, zauważyłem jedną nieścisłość która rzuciła mi się w oczy.

    Oryginalnie wzmacniacz zaprojektowany był na zasilanie symetryczne. W związku z tym przewody uzwojeń z trafa idą do mostka prostowniczego - do obu punktów oznaczonych ~

    Natomiast zero trafa pomiędzy odczepami, jest podłączone prosto pod masę wzmacniacza.

    Ja montując końcówkę mocy na TDA, zasiliłem ją napięciem pojedynczym, ciągnąc plus z kondensatora filtrującego, a masę końcówki łącząc z masą wzmacniacza. Jak zatem z tego wynika, końcówka mocy ma masę podłączoną prosto pod zero między odczepami transformatora.

    Czy powinienem delikatnie przerobić układ zasilający? Tzn. zero transformatora dołączyć do jednego z punktów ~ mostka prostowniczego?

    Zamieszczam symboliczny schemat, żeby prosto przekazać co mam na myśli.
    Czy aktualne podłączenie może w jakikolwiek sposób wpływać na brumienie, i czy planowane podłączenie jest poprawne?

    Brumienie we wzmacniaczu na TDA2040

    Pozdrawiam!

  • Pomocny post
    #6 01 Paź 2011 19:12
    KaW
    Poziom 33  

    Myślę ,że trzeba zasilać ten nowozainstalowany wzmacniacz napieciem symetrycznym .Po to był wyprodukowany taki elegancki scalony wzmacniacz
    operacyjny dużej mocy.
    Dzięki swej unikalnej budowie ma on tłumienie tętnień bardzo dobre.
    Trzeba popatrzeć w aplikację producenta.

  • Pomocny post
    #7 01 Paź 2011 20:11
    Rzuuf
    Poziom 43  

    Przy "walce z brumem" zastosuj jedną stałą regułę:
    wszystko, co idzie od transformatora (u Ciebie: odczep) i od mostka, MUSI być dołączone do kondensatorów, i do tych samych punktów (na kondensatorach!) łączysz przewody od wzmacniacza.

    I oczywiście popieram opinię KaW-a.

  • #8 01 Paź 2011 23:00
    James596
    Poziom 20  

    Owszem, mógłbym zasilić go napięciem symetrycznym. Gdyby jednak było to tak łatwe, już dawno zrobiłbym to. :) Napięcie transformatora jest za duże, daje on 2x25V~ co wydaje mi się wartością zbyt dużą dla TDA, a nie chcę ingerować w budowę transformatora i odwijać zwojów.

    Zasadniczo chodzi mi o jedno, czy brak połączenia zera tranformatora do mostka prostowniczego, może wpłynąć na brum? Czy końcówka mocy nie jest w tym momencie zasilana jednopołówkowo?

    Pozdrawiam! ;)

  • Pomocny post
    #9 01 Paź 2011 23:25
    Rzuuf
    Poziom 43  

    Mostek w układzie jak na Twoim rysunku z prawej nie "robi" prostowania jednopołówkowego.
    TDA2040 wytrzymuje napięcie do 40V (stąd pewnie to "40" w oznaczeniu), więc rzeczywiście nie możesz użyć drugiego uzwojenia z mostkiem.
    Aby wykorzystać cały transformator, możesz wyrzucić mostek, środek uzwojeń dać na "zero" między kondensatorami, a z obydwu końców dać po 1 diodzie do kondensatora "plusowego" - będziesz miał też prostowanie 2-połówkowe (2 x jednopołówkowe, pracujące "na zmianę"), lub wykorzystać tylko pół mostka: jego 2 wejścia "~" i 1 wyjście "+" do kondensatora. Druga połówka mostka z diodami do "-" nie będzie wykorzystywana.
    Kiedyś, w czasach "lampowych" tak robiono prostowanie 2-połówkowe na podwójnej diodzie.

  • #10 03 Paź 2011 01:39
    James596
    Poziom 20  

    Dziękuję za podpowiedzi.

    Zasilacz pozostawiłem w oryginalnej niezmienionej formie, podłączając końcówkę mocy pod wyprowadzenia kondensatora filtrującego napięcie +32V.

    Brumienie udało mi się wyeliminować podłączając poprawnie masy, oraz montując porządne przewody ekranowane między potencjometrem głośności a końcówką mocy. Zniknęło prawie do zera, jest minimalnie słyszalne jeśli włożyć ucho w głośnik - być może ze względu na niewielką filtrację 2200uF.

    Pozostał jeden jedyny problem. W dolnych zakresach regulacji potencjometru głośności, wzmacniacz wydobywa z głośników zakłócenia przypominające ćwierkanie o częstotliwości ok. 10kHz. Występuje od ok. 0,5/10 regulacji aż do 1,5/10 by w wyższych zakresach nagle zniknąć. Występuje także przez pierwsze kilka sekund po uruchomieniu wzmacniacza Nie wiem czym jest to spowodowane, być może niewłaściwa rezystancja potencjometru głośności.

    Czy istnieje jakiś prosty filtr, który mógłbym podłączyć na wejściu końcówki mocy? Może jakiś kondensator monolityczny między wejściem a masą wystarczy?

    Pozdrawiam!

    PS. To proste TDA2040 w połączeniu z przedwzmacniaczem dość miło mnie zaskoczyło przyjemnym brzmieniem. ;)

  • #11 03 Paź 2011 09:27
    Rzuuf
    Poziom 43  

    To "ćwierkanie" jest objawem wzbudzania się wzmacniacza na częstotliwościach w pobliżu granicy przenoszonego pasma, a nawet wyżej. Najlepiej to można ocenić dysponując oscyloskopem, ale jeśli go nie ma, zostaje metoda "na macadora": łącząc dodatkowe kondensatorki o niewielkiej pojemności (kilkadziesiąt - kilkaset pF) do różnych punktów (np. kolektor - baza lub kolektor - emiter) w przedwzmacniaczu.
    To nie ma związku z opornością potencjometrów, ale może być związane również z członem RC (kilka ohmów + 0,1uF) na wyjściu TDA2040.
    Czy potencjometry mają metalową obudowę dołączoną do masy?

  • #12 03 Paź 2011 12:52
    James596
    Poziom 20  

    Owszem, potencjometr ma metalową obudowę, ale nie jest ona podłączona do masy - po prostu dwa punkty wyprowadzone na płytkę, i nie połączone z niczym.

    Co ciekawe, po włączeniu wzmacniacza ćwierkanie występuje przez sekundę, by następnie ucichnąć. Dopiero po ok. 2 minutach pojawia się w obu kolumnach.

  • #14 04 Paź 2011 00:13
    James596
    Poziom 20  

    Połączyłem obudowę potencjometru z masą - różnica wystąpiła, ale minimalna.

    Dopiero przepięcie przewodów wejściowych nie do potencjometru, ale w dalsze miejsca zupełnie wyeliminowała piski. Sygnał wejściowy idzie teraz szeregowo przez kondensator 1uF i rezystor równolegle do masy.

    Wzmacniacz gra rewelacyjnie jak na możliwości TDA, nie występują żadne piski, zakłócenia czy brumienie. Jestem zadowolony w 100%. ;)

    Serdecznie dziękuje za pomoc, a zwłaszcza Tobie, kolego Rzuuf. :D

    Pozdrawiam!
    Damian.

TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo