Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

excel, zdjecie ze stanu magazynu

aldonaimaciek 13 Nov 2011 11:26 4413 3
  • #1
    aldonaimaciek
    Level 10  
    Witam.
    Nie wiem w jak to zrobic aby po wystawieniu na fakturze z listy rozwijanej danego produktu zmniejszał sie stan na magazynie. Pozdrawiam.
  • #2
    adamas_nt
    Moderator of Programming
    Wstaw przycisk do arkusza "faktura" i podepnij makro, w którym można wykonać kilka czynności za jednym "klik". Np
    1) Drukowanie /opcjonalnie
    2) Inkrementacja numeru faktury /opcjonalnie
    3) Aktualizacja stanów /konieczne
    4) Czyszczenie druku /opcjonalnie

    Jest jeden problem. W arkuszu "chemia" nazwy nie są unikatowe. Zauważ, że funkcja WYSZUKAJ,PIONOWO zwraca pierwszą wartość od góry. Spróbuj chociaż wstawić spacje końcowe Np,
    "pł do nacz. Ludwik 1l" (3,15zł)
    "pł do nacz. Ludwik 1l " (2,85zł)
    "pł do nacz. Ludwik 1l   " (2,99zł)
    i przyjrzyj się wynikom.

    Wartości też powinny być chyba z kolumny C (cena netto sprzedaży). Nie jest to plik z OpenOffice?
    Przy kopiowaniu formuł pionowo używaj adresów z bezwzględnym Nr wierszy. Np
    =WYSZUKAJ.PIONOWO(B17;chemia!A$2:C$89;2;0)
    inaczej tablica ulegnie przesunięciu.

    Również pozdrawiam.
  • #3
    aldonaimaciek
    Level 10  
    Dzieki za podpowiedz ale z wstawieniem przycisku i podpieciem makra mam problemy (nigdy tego nie robiłem) aktualizacja stonów tego nie mogłem znalesc. Jeszcze raz serdeczne dzieki za pomoc w pracy z excelem. Pozdrawiam
  • #4
    adamas_nt
    Moderator of Programming
    Coś tam (z czystej ciekawości) naskrobałem i szkoda wyrzucić. Zerknij, może się przyda.

    p.s. W OpenOffice nie będzie działać.