Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Atmega8a-PU a Atmega8-16PU ?

oster7 16 Gru 2011 12:23 2564 9
  • #1 16 Gru 2011 12:23
    oster7
    Poziom 15  

    Czym różnią sie te dwie kości ?
    Mam programator taki prosty na LPT i soft 'Bascom' - programator widzi i programuje Atmega8a-PU a tego drugiego nAtmega8-16PU nie widzi [nie wykrywa] ?
    Porównałem karty katalogowe patrząc tylko na wyprowadzenia i widze że są takie same .
    Kupiłem dwie sztuki w obudowie DIP28 i żadnego nie widzi :-(

    0 9
  • #2 16 Gru 2011 13:06
    dondu
    Moderator Mikrokontrolery Projektowanie

    Jakim napięciem zasilasz ten 16PU?

    0
  • #3 16 Gru 2011 13:06
    pawello0101
    Poziom 11  

    Na pewno w Option >compiler>chip musisz mieć ustawioną nazwę uklocka który chcesz zaprogramować, to może być przyczyna.

    0
  • #4 16 Gru 2011 13:17
    oster7
    Poziom 15  

    dondu napisał:
    Jakim napięciem zasilasz ten 16PU?


    5V

    Dodano po 1 [minuty]:

    pawello0101 napisał:
    Na pewno w Option >compiler>chip musisz mieć ustawioną nazwę uklocka który chcesz zaprogramować, to może być przyczyna.


    Kolego ....sorry ale to co piszesz to dla mnie "wyższa szkoła jazdy" :-)
    Może coś jaśniej napisz jak i co tam ustawić ?

    0
  • #5 16 Gru 2011 14:31
    pawello0101
    Poziom 11  

    Jeśli chcesz wgrać jakiś program do procka to przed kompilacją należy wybrać jaki mikroprocesor chcemy zaprogramować
    należy wejść jak na obrazku
    Atmega8a-PU a Atmega8-16PU ?
    i wybrać odpowiedni mikroprocesor
    Atmega8a-PU a Atmega8-16PU ?

    Sprawdź i daj znać

    0
  • #6 16 Gru 2011 15:10
    oster7
    Poziom 15  

    pawello0101 napisał:
    Jeśli chcesz wgrać jakiś program do procka to przed kompilacją należy wybrać jaki mikroprocesor chcemy zaprogramować
    należy wejść jak na obrazku
    Atmega8a-PU a Atmega8-16PU ?
    i wybrać odpowiedni mikroprocesor
    Atmega8a-PU a Atmega8-16PU ?

    Sprawdź i daj znać


    Kolego napisałem w pierwszym poście że 'Atmega8a-PU' programuje mi sie bez problemu bez ustawiania w tych okienkach co pokazałeś - problem jest z "Atmega8-16PU" jest to strasza-poprzednia wersja obecnego Atmega8a-PU.

    Dodam ze mam tak jak pokazujesz w pierwszym obrazku , natomiast nie wiem co ewentualnie wybrać w drugim próbowałem np. "m8def.dat" ale to dalej nic nie daje :-(

    0
  • #7 17 Gru 2011 09:01
    Lonek
    Poziom 19  

    Jeżeli jest tak jak piszesz to chyba masz walnięte te układy - jak kupiłeś na allegro to tam sprzedają wiele takich starych zdewaluowanych kości :-(

    0
  • #8 20 Gru 2011 12:04
    maniek1818
    Poziom 22  

    Programator "samoróbka":?: Może za mały kondensator przy mikroprocesorze. Albo obniżyć prędkość ISP, dodać jakiś delay w parametrach. Skąd kolega jest? Mazury to kraina czy miejscowość?

    0
  • #9 20 Gru 2011 12:08
    pawello0101
    Poziom 11  

    Te procki już nie są produkowane, jeśli były kupione na aukcji to może są używane, takie procki mają żywotność ok 1000 zapisów, można jeszcze obniżyć napięcie zasilania do 4,4V i spróbować zaprogramować.

    0
  • #10 20 Gru 2011 12:30
    dondu
    Moderator Mikrokontrolery Projektowanie

    pawello0101 napisał:
    Te procki już nie są produkowane, ... takie procki mają żywotność ok 1000 zapisów ...

    A skąd takie informacje?

    0
  Szukaj w 5mln produktów