Elektroda.pl
Elektroda.pl
X
Sklep HeluKabel
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Prośba o sprawdzenie schematu, urządzenie rozruchowe

Bula i spula 16 Gru 2011 23:28 4065 21
  • #1 16 Gru 2011 23:28
    Bula i spula
    Poziom 18  

    Witam.

    Płytka będzie w SMD, więc chciałbym uniknąć późniejszych druciarskich modyfikacji, gdybym popełnił jakiś błąd w projektowaniu. W związku z tym mam prośbę do bardziej doświadczonych użytkowników, aby sprawdzili, czy ten układ ma szansę działać.

    Założenia są proste. Jest to urządzenie rozruchowe/prostownik do akumulatorów kwasowych 12.6V. Zadaniem elektroniki jest odcięcie zasilania, jeżeli napięcie wyjściowe spadnie poniżej 7.8V (przeciążenie/zwarcie), lub jeżeli wzrośnie ponad wartość 15V (np. zasiarczony akumulator). Odcięcie odbywa się poprzez przekaźnik 32A umieszczony po stronie pierwotnej trafa (cewka 12V).
    Układ podłączony będzie za mostkami prostowniczymi, bezpośrednio na wyjście. Trafo ma na biegu jałowym trochę ponad 13V skutecznych. Dla świętego spokoju dałem więc dwie Zenerki 7,5V w szereg na zasilanie TL081, aby nie dostawały w kość, chociaż w zasadzie po odłączeniu kabli od akumulatora automatycznie powinno odciąć nadnapięciowe.
    Obejście (kasowanie) zabezpieczenia będzie zrobione na włączniku chwilowym 230v włączonym równolegle z przekaźnikiem, dzięki czemu będzie można ładować mocno rozładowane akumulatory. Nie zrobiłem tego po stronie wtórnej, bo nie ma gwarancji, że przy napięciu poniżej 7,8V zadziała przekaźnik, nawet gdybym podłączał bazy tranzystorów przez diody włącznikiem do plusa. (gdy zabezpieczenie jest aktywne, układ jest zasilany z ładowanego akumulatora)
    Przy okazji, czy przekaźnik+trafo zareagują odpowiednio szybko, aby przy zwarciu nie padły mostki Graetza?

    Z góry dziękuję

    Prośba o sprawdzenie schematu, urządzenie rozruchowe

    edit: Czy dobrze mi się wydaje, że R6 i R7 powinienem zmienić na ok. 10k? Czy wtedy op-ampom nie zabraknie prądu na wyjściu?


    [M]

    0 21
  • Sklep HeluKabel
  • Pomocny post
    #2 19 Gru 2011 13:26
    jarek_lnx
    Poziom 43  

    Trochę błędów jest: wszystkie tranzystory pójdą z dymem - brak rezystorów ograniczających prąd baz, po co są D7,D8 nie pełnią żadnej funkcji, a z podłączenia wzmacniaczy wynika że dwa stany wysokie będą kiedy napięcie będzie mniejsze od 7.8V i jednocześnie większe od 15V co się raczej nie zdarzy ;)
    Dlaczego wzmacniacz operacyjny jako komparator, komparator zazwyczaj lepiej się sprawdza w tej funkcji (np LM393 ma wyjścia typu otwarty kolektor)
    Może przydała by się histereza dla komparatorów?

    A tak przy okazji, najprostszy komparator i z wbudowanym napięciem odniesienia to TL431.

    Najpewniej jest zawsze zrobić prototyp, choćby w pająku albo na płytce uniwersalnej, bo każdemu się może zdarzyć błąd.

    0
  • #3 19 Gru 2011 13:59
    Bula i spula
    Poziom 18  

    W moim zamyśle dodałem D7 i D8, ponieważ op-ampy są zasilane niesymetrycznie, a więc na wyjściu nie zejdzie napięcie do zera, co z kolei spowoduje, że tranzystor się nie zatka nawet przy logicznym 0 na wyjściu, czy źle rozumuję? A diody mają spowodować, że przy napięciu niższym niż 3.9V na bazie tranzystora będzie 0V, a przy wyższym będzie napięcie z op-ampa. Aczkolwiek, zdaje mi się, że diody narysowałem na odwrót tj. powinny być podłączone zaporowo?
    Niestety nie mam w okolicy sklepu, a zakupiłem już wysyłkowo TL081, więc chciłbym przy nich pozostać.
    Masz oczywiście rację, muszę zamienić D5 i D6 miejscami (i odpowiednio inaczej podpisać LEDY) :)
    Czy prąd tranzystorów nie zostanie samoczynnie ograniczony przez prąd kolektora? (ograniczony przez cewkę przekaźnika/R8/R9)
    Podejrzewam, że nie, skoro tak napisałeś. Czy więc poprawnie liczę rezystory:
    -I(bazy)=5mA
    -U=12V
    -R=2k4

    Pozdrawiam

    0
  • Sklep HeluKabel
  • #4 19 Gru 2011 15:04
    jarek_lnx
    Poziom 43  

    Jak D7 i D8 będą w drugą stronę to ma to sens, choć i bez zenerów powinno dać radę, jeszcze przydało by się po rezystorze szeregowo, żeby ograniczyć prąd wyjść wzmacniaczy. Całe napięcie zasilania podane zostanie na połączone szeregowo złącza BE T4 BE T2 oraz BE T3 BE T1 i załączony T2 - prąd popłynie tam gdzie może a nie tylko tam gdzie Ty chcesz (: złącze BE to tylko dioda i nic prądu nie ograniczy jak podasz za duże napięcie.
    W liczeniu rezystorów należało by jeszcze uwzględnić spadki napięcia (na rezystorze odłoży się mniej niż 12V) i prąd popłynie mniejszy, choć w tym układzie jak zamiast 5mA popłynie np 3mA to też zadziała. Przydał by się jeszcze kondensator, podłączony do dzielnika R2 R3 bo C1 w miejscu gdzie jest podłączony może nie filtrować za dobrze.

    0
  • #5 19 Gru 2011 17:30
    Bula i spula
    Poziom 18  

    jarek_lnx napisał:
    Jak D7 i D8 będą w drugą stronę to ma to sens, choć i bez zenerów powinno dać radę, jeszcze przydało by się po rezystorze szeregowo, żeby ograniczyć prąd wyjść wzmacniaczy. Całe napięcie zasilania podane zostanie na połączone szeregowo złącza BE T4 BE T2 oraz BE T3 BE T1 i załączony T2 - prąd popłynie tam gdzie może a nie tylko tam gdzie Ty chcesz (: złącze BE to tylko dioda i nic prądu nie ograniczy jak podasz za duże napięcie.
    W liczeniu rezystorów należało by jeszcze uwzględnić spadki napięcia (na rezystorze odłoży się mniej niż 12V) i prąd popłynie mniejszy, choć w tym układzie jak zamiast 5mA popłynie np 3mA to też zadziała.

    No właśnie, tak orientacyjnie przyjąłem 12V, bo przecież napięcie zasilania układu zgodnie z założeniem może się wahać od 7.8V-15V. A ta wartość ze względu na to, że tranzystor będzie w stanie nasyconym, chyba nie jest krytyczna. Wg. noty napięcie na bazie w stanie nasycenia przy I(baza)=5mA i I(kolektor)=100mA jest równe 0.9V.
    Czy jak wstawię po prostu po rezystorze 1k (biorąc poprawkę na dwie bazy podłączone równolegle) na wyjście każdego ze wzmacniaczy, to załatwi to sprawę?

    jarek_lnx napisał:
    Przydał by się jeszcze kondensator, podłączony do dzielnika R2 R3 bo C1 w miejscu gdzie jest podłączony może nie filtrować za dobrze.

    A mógłbyś trochę to rozwinąć? Czy masz na myśli podłączenie po jednym kondensatorze równolegle do R2 i do R3?
    W zasadzie ten kondensator tam wstawiłem tylko dlatego, żeby mieć pewność, że po zdjęciu kabli z akumulatora układ automatycznie się wyłączy (napięcie szczytowe przekracza próg 15V), bo w trakcie ładowania i tak napięcie będzie (pomijając niewielką amplitudę wynikłą ze spadków napięcia na kablach) stałe.

    Jeszcze zrobiłem jedną przeróbkę dotyczącą zasilania wzmacniaczy. Doszedłem do wniosku, że te diody Zenera [D3,D4]+R1 nie mają sensu, bo napięcie będzie prawie zawsze niższe niż próg zadziałania diod, więc będzie niepotrzebny spadek napięcia na R1 - co gorsza zmieniający się wraz z obciążeniem op-ampów. W związku z tym połączyłem zasilanie op-ampów do plusa za pośrednictwem trzech diod prostowniczych w szeregu, co powinno zbić napięcie o około 2V, dając pewien margines bezpieczeństwa (a jednocześnie napięcie zasilania wzmacniaczy nie powinno już pływać względem zasilania układu). Czy tak może być? Wg. moich wyliczeń nawet przy najniższym dopuszczalnym napięciu, napięcie zasilania wzmacniaczy nie powinno być niższe niż napięcie z dzielnika.

    edit: ort

    0
  • Pomocny post
    #6 19 Gru 2011 17:47
    Mariusz Ch.
    VIP Zasłużony dla elektroda

    Witam.

    Bula i spula napisał:
    Jeszcze zrobiłem jedną przeróbkę dotyczącą zasilania wzmacniaczy. Doszedłem do wniosku, że te diody Zenera [D3,D4]+R1 nie mają sensu, bo napięcie będzie prawie zawsze niższe niż próg zadziałania diod, więc będzie niepotrzebny spadek napięcia na R1 - co gorsza zmieniający się w raz z obciążeniem op-ampów. W związku z tym połączyłem zasilanie op-ampów do plusa za pośrednictwem trzech diod prostowniczych w szeregu, co powinno zbić napięcie o około 2V, dając pewien margines bezpieczeństwa (a jednocześnie napięcie zasilania wzmacniaczy nie powinno już pływać względem zasilania układu).


    Napięciem zasilania nie trzeba się przejmować, bo ono może wynosić nawet 36V. Dodatkowo, zmiany zostaną stłumione, a wzmacniacz pracuje jako komparator. Należy zwrócić szczególną uwagę na sterowanie T3, T4. W tej chwili sygnalizacja nie działa poprawnie.


    Pzdr.

    0
  • #7 19 Gru 2011 19:49
    jarek_lnx
    Poziom 43  

    Z tym kondensatorem nie przemyślałem do końca, bo to nie poprawi następującego problemu - przy napięciu blisko progu górnego układ może zamienić się w generator.
    I nawet dodanie histerezy może nie poprawić. Zamieść poprawiony schemat, żeby było wiadomo o czym mówimy i spróbuj poprawić ten układ z tranzystorami, bo można tam jeszcze sporo błędów zrobić.

    0
  • #8 21 Gru 2011 16:16
    Bula i spula
    Poziom 18  

    Bardzo Wam dziękuję. Słuchając Waszych rad poprawiłem schemat na tyle, na ile potrafiłem.
    Prostownik będzie służył do awaryjnego odpalania samochodu, więc zabezpieczenie nadnapięciowe będzie działało raczej przez krótki czas (w razie słabego kontaktu klem z akku, w razie zasiarczonego akku, po odpaleniu do momentu odłączenia prostownika). Zmierzam do tego, że "strzelanie" przekaźnika przy przekroczeniu napięcia nie będzie mi przeszkadzać, pod warunkiem, że zabezpieczenie będzie w moim przypadku skuteczne.
    Proszę o sprawdzenie, czy teraz schemat jest już poprawny.
    Prośba o sprawdzenie schematu, urządzenie rozruchowe

    0
  • #9 22 Gru 2011 15:59
    jarek_lnx
    Poziom 43  

    Niestety, w takim układzie, nie zadziała. Wytłumaczę na przykładzie T2 i T4. Prąd płynie z zasilania, przez bazę T4 R12 R11 i bazę T2 więc oba tranzystory są włączone na stałe. Żeby wyłączyć T2 napięcie na bazie musiało by spaść poniżej 0.5V a żeby wyłączyć T4 wzrosnąć powyżej Uwe-0.5V. Ten wzmacniacz nie da rady, a dioda Zenera, w takim miejscu, mu to tylko utrudnia.

    0
  • #10 23 Gru 2011 00:16
    Bula i spula
    Poziom 18  

    Rozumiem, że problem leży w połączeniu równoległym baz T2-T4/T1-T3, które będą się wzajemnie aktywować przez rezystory, które przy znikomym prądzie mimo dużego oporu przekażą napięcie na bazy npn?
    Żeby dalej nie brnąć mam taki pomysł, żeby na płytce zostawić sobie miejsce na tranzystory typu pMOS w miejsce T3/T4. Tzn. bramki mosfetów podłączył bym przez opory pod te Zenerki 3v9 (nie łącząc już ich bramek przez opór z masą ani plusem). A z rezystorów R14, R15, R12, R13 bym zrezygnował. Czy to załatwi definitywnie ten problem?
    A teraz bym już mógł złożyć działający układ, zanim dojdą odpowiednie mosfety.

    edit: A czy czasem po prostu usunięcie tych wszystkich oporników 100k podciągających tranzystory do masy/plusa nie usunie problemu? Chyba wyjście wzmacniacza powinno zapewnić zawsze albo połączenie z masą, albo z plusem, więc w sumie chyba są one zbędne...

    0
  • #11 26 Gru 2011 12:11
    jarek_lnx
    Poziom 43  

    Jest to jakiś sposób z tymi FET'ami, można było by dać zenery szeregowo, z każdym rezystorem R1,R11,R12,R15 (zamiast tam gdzie są).
    Ale chyba prościej wyrzycić D7 i D8 a R7,R8,R13,R14 zamienić na 360Ω. Wtedy do załączenia tranzystora T2, przez taki dzielnik, będzie potrzeba ok 4V (a nie 0,6V) i nawet jeśli wzmacniacz da 3V, obciążony prądem płynącym przez R12 w stanie "0", to i tak T2 zostanie wyłączony (pozostałe tranzystory analogicznie)

    Cytat:
    Chyba wyjście wzmacniacza powinno zapewnić zawsze albo połączenie z masą, albo z plusem
    właśnie na tym cały problem polega, że tak jest dopóki się wyjścia nie obciąży, pod obciążeniem napięcie spadnie, albo wzrośnie, zależnie od kierunku prądu obciążenia.

    0
  • #12 02 Sty 2012 15:55
    Bula i spula
    Poziom 18  

    Dla pewności, czy teraz jest OK?
    Jeżeli tak, to przechodzę do trawienia płytki. Nie jest w tej chwili piękna, ale już tyle razy musiałem ją modyfikować po zmianach w schemacie, że nie mam siły znów wszystkiego ładnie układać ;(

    Prośba o sprawdzenie schematu, urządzenie rozruchowe Prośba o sprawdzenie schematu, urządzenie rozruchowe

    0
  • #13 29 Sty 2012 18:46
    Bula i spula
    Poziom 18  

    Panowie, układ już działa, ale zgodnie z waszymi przewidywaniami po naładowaniu akumulatora zamienia się w generator. W dodatku jeszcze dochodzi niska temperatura i momentalnie skleja się przekaźnik :( Czy możecie zaproponować jakiś prosty układ opóźniający (zamiast histerezy), żeby przekaźnik gasł np. co sekundę? Mam nadzieję, że wtedy przestanie się sklejać, bo zrobić elektroniczny przekaźnik na taki prąd i napięcie nie jest łatwo ani tanio.

    0
  • #14 29 Sty 2012 19:05
    Mariusz Ch.
    VIP Zasłużony dla elektroda

    Witam.

    Bula i spula napisał:
    ale zgodnie z waszymi przewidywaniami po naładowaniu akumulatora zamienia się w generator.


    Jest to normalne zachowanie i mała histereza niewiele pomoże. Jeśli rezygnujemy z prądu konserwującego, to element wykonawczy musi być sterowany przez przerzutnik (odłączenie po naładowaniu) lub układ nadzorujący z szeroką pętlą. Poszukaj na forum, wstawiłem dość ciekawy schemat na LM 393.

    Pzdr.

    0
  • #15 29 Sty 2012 20:16
    Bula i spula
    Poziom 18  

    Jednak zależałoby mi, żeby to wykonać z elementów, które mam w domu (elementy elektr. muszę zamawiać wysyłkowo). Żeby nie było że nie szukałem, to zapewne piszesz o tym układzie:
    https://www.elektroda.pl/rtvforum/viewtopic.ph...&sid=7c34994a26c857e0edaba7013bd7736f#5359851

    Ale ja myślałem raczej o czymś prostszym tzn. zrobić opóźnienie czasowe. Czy zwykły układ całkujący na bazę tranzystora ma prawo zadziałać?
    W ostateczności wykonam tamten układ, ale to by oznaczało oczekiwanie na elementy i kolejną komplikację schematu.

    PS. Mam jeszcze jedno pytanie "nie na temat": jakie elementy są potrzebne do układu gasikowego? Czy wystarczy zwykły kondensator ceramiczny np. 100n 400V i rezystor 82Ω 1/4W?

    0
  • Pomocny post
    #16 29 Sty 2012 21:11
    jarek_lnx
    Poziom 43  

    Styki przekaźnika warto zabezpieczyć układem gasikowym. Do dobierania elementów widziałem nomogram, w katalogu ELFY. W obecnym układzie łatwo dodać histerezę (nie przecinając ani jednej ścieżki i nie zmieniając napięć przełączania) - podłączyć pomiędzy kolektorem T3, a punktem wspólnym R2 i R3 diodę z rezystorem szeregowym.
    Histerezę dał bym taką żeby układ pozostał trwale w stanie wyłączonym po naładowaniu.

    Jak chcesz pokombinować z opóźnieniem, to zmień R2 i R3 na 1MΩ daj kondensator kilka - kilkadziesiąt µF równolegle do R3.

    0
  • #17 29 Sty 2012 21:16
    Bula i spula
    Poziom 18  

    Dzięki za konkrety. Ale jeszcze pozwolę sobie powtórzyć pytanie z poprzedniego posta:

    Cytat:
    PS. Mam jeszcze jedno pytanie "nie na temat": jakie elementy są potrzebne do układu gasikowego? Czy wystarczy zwykły kondensator ceramiczny np. 100n 400V i rezystor 82Ω 1/4W?

    Będę wdzięczny za odpowiedź.

    Pozdrawiam

    0
  • #18 29 Sty 2012 22:12
    jarek_lnx
    Poziom 43  

    Nomogram do wyznaczania R i C znajdziesz tu Link strona 11

    0
  • #19 29 Sty 2012 22:38
    Bula i spula
    Poziom 18  

    Ok. Czyli zamiast bawić się w układ RC mogę wstawić tam najzwyklejszy warystor, taki jak w listwach zasilających?
    I do tego dorobię tę histerezę i miejmy nadzieję, że ten mój przekaźnik będzie działać (chyba mocno się nie zgrzał, bo wystarczyło popukać śrubokrętem w obudowę i odpuścił).

    Pozdrawiam

    0
  • #20 30 Sty 2012 18:55
    jarek_lnx
    Poziom 43  

    Możesz, ale nie wiem co będzie skuteczniej gasiło przepięcia na sykach, czy warystor, czy układ gasikowy.

    0
  • #21 30 Sty 2012 21:05
    Bula i spula
    Poziom 18  

    Niestety na hasło warystor w moim lokalnym sklepie usłyszałem "Yyy, rezystor?". Więc zapewne pozostanę przy układzie RC. Ale jest inny problem. Ustawiłem histerezę w ten sposób, że napięcie jest odłączane przy 14V i załączane przy ok. 12.5V. Niestety mimo to na dolnej granicy układ potrafi wpaść w drgania, np. gdy włączę światła mijania na zgaszonym silniku (wtedy napięcie jest na granicy i zamiast doładować do 14V to strzela przekaźnik). Dopiero wstawienie kondensatora 100u na dzielnik napięcia (15k) w 90% eliminuje ten problem, ale wtedy czas odcięcia napięcia to około sekunda i obawiam się, że przez ten czas instalacja może ulec uszkodzeniu np. w przypadku zaśniedziałych klem.
    Czym może to być spowodowane? Jakaś niepożądana pojemność, która powoduje, że układ wpada w rezonans, zanim zdąży "zadziałać" histereza? Może podłączenie bazy tranzystora NPN, lub któregoś innego obwodu przez dławik rozwiąże ten problem?

    0
  • #22 30 Sty 2012 22:46
    jarek_lnx
    Poziom 43  

    Jaki masz teraz układ? Jeśli dobrze rozumiem po wyłączeniu powyżej 14V, przy zmniejszeniu do 12,5V, nawet bez kondensatorów na dzielniku histereza jakby nie działa - podejrzewam że przez jakieś zakłócenia.
    Dodaj kondensator odsprzęgający 100nF równolegle do zasilania wzmacniaczy.

    Dodanie kondensatora na dzielniku uniemożliwia szybką zmianą progu - dlatego kondensator mimo że pomaga to i szkodzi jednocześnie. Gdyby dołożyć rezystor, pomiędzy dzielnik z kondensatorem, a wejście wzmacniacza do którego doprowadzasz rezystor dający histerezę, to nie powinno jedno drugiemu szkodzić.

    0