Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Programowanie pamięci - odtwarzacz sieciowy TEAC WAP-8500.

przemasli 30 Dec 2011 22:16 8810 38
IGE-XAO
  • #31
    przemasli
    Level 11  
    To cóż mam nadzieję, że w końcu uda wam się znaleźć rozwiązanie, bo mnie na tym etapie to przerasta...a tym czasem Życzę Wam jutro szampańskiej zabawy do białego rana i Szczęśliwego Nowego Roku 2012.:sm9: :turn-l:
    pozdrawiam
    ps. i do powrotu do tematu w nowym roku :lol: :bye:
  • IGE-XAO
  • Helpful post
    #32
    Mundi1970
    Level 24  
    No to do roboty ;). Pierwszy krok to sprawdzenie na jakie złącze wychodzi UART (TX i RX portu szeregowego). Multimetrem (miernik w trybie omomierza :) ) należy sprawdzić czy nogi układu 110, 111 (UART1) lub 108,109 (UART0) są wyprowadzone na jakieś złącze.

    Żeby przyszły rok nie był gorszy od tego :bye:.
  • IGE-XAO
  • #33
    przemasli
    Level 11  
    Mundi1970 wrote:
    No to do roboty ;). Pierwszy krok to sprawdzenie na jakie złącze wychodzi UART (TX i RX portu szeregowego). Multimetrem (miernik w trybie omomierza :) ) należy sprawdzić czy nogi układu 110, 111 (UART1) lub 108,109 (UART0) są wyprowadzone na jakieś złącze.

    Żeby przyszły rok nie był gorszy od tego :bye:.


    Witam !już w nowym roku
    Mundi1970 to może ja bym tobie cały ten sprzęcik wysłał i byś osobiście się do niego "dobrał?
    Nie wiem czy sobie z tym wszystkim poradzę, a tak byłyby większe szanse na powodzenie akcji. Przemyśl zagadnienie i daj odpowiedź i tak mi teraz nic po sprzęcie więc co mamy do stracenia.
    Pozdrawiam i zdrowia szczęścia w 2012 roku
  • Helpful post
    #34
    Mundi1970
    Level 24  
    A nie lepiej jest to wysłać tu? ;) ---->> Link
  • #35
    przemasli
    Level 11  
    No właśnie nie lepiej;-( zapłacę za usługę jak za nowy, bo dzwoniłem tam i oni odsyłają do producenta i takie coś kończy się wymianą na nowy koszt rzędu 1000-1400 złotych

    nawet napisałem bezpośrednio do niemieckiego przedstawicielstwa maila z prośbą o poradę bez odzewu
  • Helpful post
    #36
    zieleniuszka
    Level 1  
    witam, ja mam taki odtwarzacz tj Teac Wap 8500,choć nie znam sie wogóle na elektronice,proszę o info jeśli mógłbym jakoś pomóc
  • Helpful post
    #37
    mmaj
    Level 2  
    Znajomy przyniósł mi takie urządzenie(WAP4500) uszkodzone w trakcie uaktualnienia oprogramowania. Szukając rozwiązania trafiłem na ten wątek na elektrodzie, który bardzo mi pomógł w rozwiazaniu problemu. A oto jak sobie poradziłem:
    sprawdziłem omomierzem, że na pinach pokazanych na zdjęciu przez "Mundi1970" jest rzeczywiście serial port.
    Podłączyłem konsolę ustawiając 38400 8n1 bez kontroli przepływu.
    Po uruchomieniu urządzenia przerwałem procedurę uruchomieniową i dostałem prompta u-boota.
    Ze strony "teac.eu" ściągnąłem źródła systemu -plik WAP-4500-emlinux.tar.bz2.
    W pliku Readme.txt w punkcie 6 jest opisana procedura flashowania.
    Dla ułatwienia wklejam wspomniany opis:
    6. Firmware loading
    [1] Use flash programmer to program u-boot to the beginning of the flash.
    u-boot must support "serial flash" and STR8131's internal ethernet phy.
    [2] Follow u-boot's manual to configure u-boot's network settings.
    [2] Setup a TFTP server on PC and follow u-boot's manual to download emlx image to RAM:
    a. tftp 1000000 [image file]
    b. cp.b 1000000 30040000 $(filesize)
    c. setenv bootcmd go 1000010
    d. saveenv
    e. reset
    u-boot will load 2MB bytes from 0x30040000 to 0x1000000 and bootcmd will start kernel
    from 0x100010.

    [4] Boot into Linux kernel to see if everything is OK.

    Nie muszę chyba dodawać, że zadziałało :)

    PS.
    Zapomniałem wspomnieć, że tftp domyślnie szuka serwera o adresie 192.168.1.50 i pliku o nazwie C0A8010B.img, więc najprościej ustawić taki właśnie adres serwera i zmienić nazwę pliku obrazu.
  • #38
    przemasli
    Level 11  
    mmaj wrote:
    Znajomy przyniósł mi takie urządzenie(WAP4500) uszkodzone w trakcie uaktualnienia oprogramowania. Szukając rozwiązania trafiłem na ten wątek na elektrodzie, który bardzo mi pomógł w rozwiazaniu problemu. A oto jak sobie poradziłem:
    sprawdziłem omomierzem, że na pinach pokazanych na zdjęciu przez "Mundi1970" jest rzeczywiście serial port.
    Podłączyłem konsolę ustawiając 38400 8n1 bez kontroli przepływu.
    Po uruchomieniu urządzenia przerwałem procedurę uruchomieniową i dostałem prompta u-boota.
    Ze strony "teac.eu" ściągnąłem źródła systemu -plik WAP-4500-emlinux.tar.bz2.
    W pliku Readme.txt w punkcie 6 jest opisana procedura flashowania.
    Dla ułatwienia wklejam wspomniany opis:
    6. Firmware loading
    [1] Use flash programmer to program u-boot to the beginning of the flash.
    u-boot must support "serial flash" and STR8131's internal ethernet phy.
    [2] Follow u-boot's manual to configure u-boot's network settings.
    [2] Setup a TFTP server on PC and follow u-boot's manual to download emlx image to RAM:
    a. tftp 1000000 [image file]
    b. cp.b 1000000 30040000 $(filesize)
    c. setenv bootcmd go 1000010
    d. saveenv
    e. reset
    u-boot will load 2MB bytes from 0x30040000 to 0x1000000 and bootcmd will start kernel
    from 0x100010.

    [4] Boot into Linux kernel to see if everything is OK.

    Nie muszę chyba dodawać, że zadziałało :)

    PS.
    Zapomniałem wspomnieć, że tftp domyślnie szuka serwera o adresie 192.168.1.50 i pliku o nazwie C0A8010B.img, więc najprościej ustawić taki właśnie adres serwera i zmienić nazwę pliku obrazu.


    Witam!
    Jestem zainteresowany twoją pomocą jak po padniętym zasilaniu podczas wgrywania firmware przywrócić do życia tego WAP-8500. Interesujące jest to co napisałeś ale ja oprócz miernika i jtag po xboxie nie mam innego sprzetu.
    Czy mógłbym liczyc na kontakt?
    pozdrawiam
  • #39
    przemasli
    Level 11  
    Witam!
    Panowie koledzy!
    Wszystkim zaangażowanym w ten post bardzo dziękuje za zaangażowanie w pomoc. Mam nadzieję,że nikogo nie pominąłem w opcji "pomógł". Szczególne podziękowania należą się dla Mundi1970, który bezbłędnie określił na płycie jtaga oraz sposób zaimportowania firmware.

    Jednakże całość zasługi w reaktywację tego WAP-8500 z ogromną radością i wielką wdzięcznością przyznaję mmaj owi, który osobiście zarywając dwa długie późne wieczory przeprowadził mnie przez całą procedurę flashowania odtwarzacza zakończoną pełnym sukcesem -MMAJ- jesteś wielki po stokroć wielkie podziękowania. Oby więcej w naszej społeczności było takich bezinteresownych "wolontariuszy".
    Uważam temat za zamknięty i jeszcze raz wielkie dzięki wszystkim, którzy nie przeszli obojętnie obok niniejszego postu.

    pozdrawiam