Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Pytanie/Proble z SI PROG lub Pony Prog

26 Gru 2011 19:06 1863 8
  • Poziom 9  
    Witam, poniewaz zaczynam dopiero z programowaniem uC chce zapytac o pare spraw(zapewne ktos mnie zaraz odesle do szukaj itd ale nie znalazlem odpowiedzi):

    Otoz zlozylem programator SI Prog zgodnie z tym poradnikiem
    Link

    oczywiscie plytke.adapter tez zgodnie z nim poskladalem.

    Problem w tym ze mimo ze wszystko wydaje sie byc ok ze strony sprzetowej w PonyProg program nic nie widzi. W czym moze byc problem???

    W programie mam dostepne 2 porty com i na zadnym nic, dajac Probe wyskakuje Failed itd.

    Sprawdzalem po podlaczeniu do kompa napiecia na poszczegolnych wyjsciach:

    miso -2,66v
    mosi - 0,6V
    sck - 0,71V
    Vcc - 2,1V
    rst - 0,46V

    Czy takie napiecia sa ok???]Link[/url]
  • Poziom 35  
    Vcc Powinno być 5V. Skoro nie jest to prawdopodobnie podłaczyłeś odwrotnie stabilizator napięcia.
  • Poziom 9  
    stabilizator mam w obudowie to 092 i wg schematu podlaczony jest ok(sprawdzalem bo za 1 razem faktycznie zle podlaczylem)

    a jakie max napiecie nie uszkodzi atmegi8?? wg data pravuje na do 5,5V a jak wejdzie wiecej odrazu mi sei uszkodzi uklad???

    sprawdzam czy mi dzialaja teraz porty COM bo juz zcaynam watpic czy mi dzialaja....
  • Poziom 35  
    Po to jest stabilizator by jak piszesz "nie weszło więcej od razu". Skoro teraz masz stabilizator podłączony poprawnie a nie stabilizuje to wnioskuje że uszkodził się przez złe podłączenie - do wymiany.
    Napięcie 5V podawanie jest przez stabilizator z zewnętrznego źródła zasilania.Jeśli rezygnujesz z tego zasilania powinno tam być przy odłączonym programoatorze 0V lub napięcie jakim zasilany jest programowany układ (zwykle 3,3V lub 5V).
  • Poziom 9  
    mowiac za 1 razem mialem na mysli 1 programator, teraz zlozylem drugi z nowym ukladem
    czyli rozumiem ze jesli uC dostanie wiecej niz te 5V jest do wymiany tak??
  • Poziom 35  
    Pisze o uszkodzeniu stabilizatora a nie uC.
    Skąd ma się wziąć te "więcej"? Stabilizator 5V ogranicza zasilanie do 5V (+-tolerancja układu stabilizatora). Układ uC też ma swoją tolerancje tak więc podanie na krótka chwilę 1..2V więcej też go nie zabije.
  • Poziom 9  
    a jak to jest z wyjsciem miso?? tam przeciez laczymy bezposrednio z com do uC, a jak sprawdzalem napiecia na wyjsciu z com byly powyzej 11V....

    nie wiem co jest nie tak, ale chyba faktycznie cos ze stabilizatorem - podlaczam zew zasilanie, nawet zwykla bateryjke 9V i nie dociera wiecej jak 2,5V ok....
  • Pomocny post
    Poziom 35  
    Diody Zenera Z1 Z1 i Z2 ograniczają napięcia wyjściowe portu RS232 (COM) do bezpiecznego poziomu.
  • Poziom 9  
    zlozylem sobie uklad jak na rys.
    Link
    a i tak mi nie dziala i nie wiem co jest piec juz....

    sytuacja wyglada podobnie jak do tej poprzednio z ta roznica ze ten uklad zlozylem na plytce stykowej zamiast lutowac na uniw...

    dolozylem oczywiscie zew zasilanie, ale w postaci dzielnika napiecia zwyklej baterii 9V(wyszlo mi 4,8 - 4,9V) - nie wiem czy zaislanie z bateryjki jest odpwiednie???

    sprawdzilem napiecia na wyjsciu z portu com - daje ok 11,5V

    ale nawet jak podlacze zwe zailanie to mimo iz samo daje te 5V to po podlaczeniu spada do ok 2,5V...

    nie wiem czemu tak jest???

    czy ktos ogarniety moglby mi to wyjasnic??? :D