Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Jak dodać użytkownika i zabezpieczyć połączenie - mikrotik

maciek.sobie1 09 Sty 2012 23:48 6470 12
  • #1 09 Sty 2012 23:48
    maciek.sobie1
    Poziom 8  

    Witam serdecznie kolegów. Na sam początek chce poinformować ,że w zupełności nie znam się na urządzeniach komputerowych poza standardową obsługą oraz urządzeniach Mikrotik Wynika to też z wieku 48 lat ale i z powodu samej pracy jaką wykonuje. Dlatego zwracam się do Was o wyrozumiałość oraz pomoc w mojej sprawie.

    W do swojego zakładu zakupiłem za grosze sprzęt do Internetu. Problem w tym, że nie wiem jak go skonfigurować w dalszych krokach.
    Posiadam urządzenia Mikrotik RB433 ( będzie nadajnikiem Internetu) oraz tp-Link WA601G i Tp -Link WA5210G- oba urządzenia jako klienci Internet przesyłem kablem przez zasilacz PoE do RB433.
    Moja konfiguracja
    Po uruchomieniu w winbox wybrałem New Terminal i wpisałem system reset-configuration a potem wybrałem (y)
    Po ponownym uruchomieniu wybrałem :
    Bridge – czerwony plus – i w powstałym oknie wybrałem Apply i ok. Potem
    Bridge – Ports – czerwony plus i dodałem 2 porty + 1 wlan.
    Kolejny krok to
    Ip- Addresses – czerwony plus i wpisałem 192.168.1.10/24 wybrałem bridge1 następnie apply i ok.
    Ip- dns- settings i wpisałem 194.204.159.1 a potem 194.204.152.34 i Apple
    Ip-routers- czerwony plus – w oknie tam gdzie getway wpisałem 192.168.1.1 apply
    Nastepnie w interfaces wybrałem wlan1 i uruchomiłem go.
    W Mode wybrałem ap bridge/ Band- 2GHz-B/G kanał 2462 /SSID- WRT/
    Tam gdzie Nstreme odznaczyłem wszystko i wpisałem Frame limit 4000 a Framery Policy Best fit.
    Do tej porty wszystko działa Internet jest - wszystko chodzi.

    Ale tu już się gubię
    Potrzebuje podłączyć użytkowników i zabezpieczyć to jakimś hasłem aby nikt inny z neta nie korzystał oraz zablokować jakieś p2p bo tak mi zalecili aby w pracy mi nie blokowali pobieraniem jakiś plików. Chcę też aby gość używający tp-Ling WA601G miał neta 512 a Ten drugi 1mega. Chcę to zrobić raz a dobrze i nie wiem jak. Proszę o pomoc kolegów w tej sprawie. Z góry dziekuje

    0 12
  • #2 10 Sty 2012 00:32
    piterus99
    Poziom 43  

    Skoro działa to całkiem nieźle Ci poszło. Ale nie jest do końca tak różowo;)
    + Za to, że resetnąłeś konfiguracje przed startem;)

    Zabezpieczenia dokonujesz w Wireless -> Security Profiles. Dodajesz nowy, zaznaczasz WPA2, odznaczasz WPA, wpisujesz klucz, reszta domyślna.
    Następnie przechodzisz do karty i na zakładce Wireless będzie pole Security Profile - tam wybierasz sobie profil utworzony wcześniej i teraz sieć ma już enkrypcję.
    Hasło musisz wprowadzić na obu urządzeniach.

    Co do blokady prędkości. Po pierwsze w tym momencie użytkownicy nie są routowani przez MT tylko przez inny router, z którego masz Internet.
    Musisz wypiąć z bridge'a interfejs WAN, jemu nadać osobny adres, na bridge'u adres musi być z innej klasy. Następnie w IP->Firewall w NAT dodajesz nową regułkę Chain: srcnat out-interface: ether1(lub inny, WAN), action:masquerade.
    Następnie poprawiasz wpis w DNS - musisz zaznaczyć Allow Remote Request.
    Następnie albo nadajesz urządzeniom statyczne adresy albo odpalasz serwer DHCP(Ip->DHCP Server i klikasz setup, kreatorem wszystko zrobisz)

    Jak urządzenia "złapią" adresy, ustawisz im statyczne wpisy (Zakładka Leases, zaznaczasz wpis, klikasz Make Static). W IP-ARP wpisy z ich IP i MAC ustawiasz też na statyczne.
    Następnie przechodzisz do Queues -> Simple i dodajesz kolejki z adresami IP - tam ustalasz maksymalne prędkości dla danego klienta.

    Wycięcie P2P - nie zawsze skuteczne, warto filtrować po L7, ale to do znalezienia w sieci. Na szybko: Ip->firewall zakładka Filter rules, dodajesz: Chain: Forward, P2P: all, Action: Drop

    Może coś przyblokujesz

    0
  • #3 10 Sty 2012 13:23
    maciek.sobie1
    Poziom 8  

    witam Coś zrobiłem nie tak bo się sypło serwera dhcp nie jestem w stanie uruchomić na żadnym interfejsie. Wybieram interfejs i wszytko staje. Wieczorem spróbuje jeszcze raz na spokojnie wszytko. Kłopot się pojawił po poprawieniu DNS wiec coś skopałem.


    "Co do blokady prędkości. Po pierwsze w tym momencie użytkownicy nie są routowani przez MT tylko przez inny router, z którego masz Internet."

    Tak internet mam z modemu ADSL d-link. i kablem leci do PoE przez zasilacz. Zawsze mogę wybrać drugą opcje że zamiast przez Poe To radiowo mam 2 karty w tym Mt. Wcześniej tak też chodziło. Zdziwił mnie fakt że musze nadać nowy adres karcie wlan aby móc ustawić prędkości internetu. Myślałem że wystarczy nadać adres Bridge. Dodam że nadałem adresy w obu urządzeniach na jednym miałem 192.168.1.40 a na drugim 192.168.1.30. Tak było wcześniej o czym zapomniałem wspomnieć. Sprawdzę wszystko jeszcze raz wieczorem

    0
  • #4 12 Sty 2012 23:24
    maciek.sobie1
    Poziom 8  

    Dokonałem kilku zmian. 1) to taka że internet odbieram radiowo a nie przez port PoE. Kłopot w tym że normalnie mam internet na portach rj45 ale nie mam go na wlan1 tak jakby coś blokowało przesył internetu z portu wlan 2 na port wlan 1 który jest ustawiony jako ap bridge. Gdzie popełniam błąd?

    0
  • #5 12 Sty 2012 23:51
    piterus99
    Poziom 43  

    No przecież jak był kabel to było najlepiej jak mogło być. Jeśli nie ma problemów z kablowym przesyłaniem(w sensie kabel przeszkadza), nie rezygnuj z tej opcji.

    Zrób tak(reset konfigu najpierw):
    /ip addr add addr=192.168.1.2/24 int=ether1 <- adres IP, który przyznasz urządzeniu(z puli routera ADSL), interfejs ether1 jako fizyczne wyjście do niego
    /ip route add dst=0.0.0.0/0 gateway=192.168.1.1 <- brama
    /ip dns set server=192.168.1.1, 194.204.159.1 <- DNS
    /ip dns set allow-remote-request=yes <- zezwolenie na korzystanie z DNS przez klientów

    w tym momencie jest Internet tylko na urządzeniu.
    Tworzysz teraz sobie bridge, dodajesz jako porty ether2, ether3, wlan1, wlan2(jak chcesz na obu nadajnikach mieć rozgłaszanie, jak na jednym to pomijasz część)
    Konfigurujesz wlan1, wlan2 jako ap bri, kanały oddalone od siebie - to umiesz.

    /ip addr add address=192.168.15.1/24 int=bridge1
    /ip dhcp-server setup i tutaj odpala Ci się konfiguracja, którą przechodzisz(domyślne opcje są zazwyczaj OK, możesz zawęzić sobie obszar DHCP, ja zawsze robię zakres 200-254)

    i teraz najważniejsze - maskarada(NAT). Bez tego klieci nie będą mieć sieci:
    /ip firewall nat add chain=srcnat src-addr=192.168.15.0/24 action=masquerade

    I w tym momencie, podłączając się pod ether2,3 wlan1,2 dostaniesz adres IP od MT i będzie działać sieć.

    W Winboxie w IP->DHCP Server w zakładce Leases pojawi Ci się nowy wpis. Klikniesz Make Static.
    Przejdź do Queues -> Simple, dodaj wpis z tym adresem IP, a pola max-limit to prędkość, którą chcesz dać klientowi.
    Jeśli oni nie będą kombinować ze zmianą adresów, możesz poprzestać w tym momencie. Jeśli nie, we właściwościach bridge1 zmień ARP na reply-only a w DHCP-Server na zakładce DHCP w opcjach zaznacz Add ARP for leases.

    Jeśli zaś potrzebujesz jednak Internet przez wlan2 - zamień go miejscami w podanym "skrypcie" z ether1 i już.

    Pisałem z pamięci, więc składniowo problemy mogą być, ale sens jest zachowany.

    0
  • #6 13 Sty 2012 18:21
    Krek15
    Poziom 15  

    Cześć
    Koledzy jak wiadomo nasz kolega Maciek ma kłopot i trzeba się skupić na kilku podanych przez niego faktach. Pierwszym z nich jest fakt że nie ma pojęcie o MT a co za tym idzie trzeba to przełożyć na łopatologie a nie wpisy w terminalu.
    Drugim faktem jest że ma on MT R433 a w nim 2 karty wlan za pomocą których chce odbierać i nadawać Internet. Trzeci fakt to taki że posiada już 2 urządzenia klienckie z nadanymi już adresami.

    Pierwsze urzadzenie Tp-Link WA601G z adresem 192.168.1.30
    Drugie urządzenie TP-Link WA5210G z adresem 192.168.1.40

    Oba te urządzenia maja mieć nadaną inną prędkość odbierania neta.

    Stosując łopatologie wygląda to tak: ( pisze też z pamięci wiec niech ktoś to sprawdzi)

    1 - W terminalu wpisujemy system reset-configuration - potwierdzamy Enter a potem „Y” i Enter
    2 - Uruchamiamy Winbox mamy okienko naciskamy ok.
    3 - Bridge-czerwony plus - wyskakuje okno – naciskamy Apply i ok.
    4 – Bridge – Ports- czerwony plus – wyskakuje okno ( dane w otwartym oknie )
    a) Interface = ether1
    Bridge=Bridge1
    Reszta bez zmian nic nie zmieniasz
    Naciskach Apply a potem Copy gdzie otwiera się nowe okno a w nim zmieniasz:

    b) Interface = ether2
    Bridge=Bridge1
    Reszta bez zmian nic nie zmieniasz
    Naciskach Apply a potem Copy gdzie otwiera się nowe okno a w nim zmieniasz:

    c) Interface = ether3
    Bridge=Bridge1
    Reszta bez zmian nic nie zmieniasz
    Naciskach Apply a potem Copy gdzie otwiera się nowe okno a w nim zmieniasz:

    d) Interface = wlan1
    Bridge=Bridge1
    Reszta bez zmian nic nie zmieniasz
    Naciskach Apply a potem ok. To samo ok. w pozostałych oknach.

    Objaśnienie: ether1, ether2, ether3 to porty Lan RJ45 gdzie port ether1 to port PoE zasilanie
    Wlan1 to pierwsza karta radiowa tą będziemy nadawać Internet do obu urządzeń klienckich.

    5- Ip- Addresses -czerwony plus- wyskakuje okno a w nim wpisujesz:

    a) Address =192.168.1.10
    Interface =bridge1
    Potem Apply i ok

    6- Interfaces- zakładka Interface a w niej zaznaczasz wlan1 i naciskasz niebieski przycisk „falkę”
    7- klikasz 2 x na wlan1 otwiera się okno . Przechodzisz do zakładki Wireless a w niej zmieniasz:

    a) Mode=ap bridge
    Band=2.4GHz-B/G
    Frequency=2462
    SSID=Firma
    Następnie przechodzisz do zakładki Nstreme I tam zmieniasz:

    Framer Policy= Best fit
    Framer Limit=4000

    Odznaczas Enable Polling
    Potem Apply i ok.


    Objaśnienie: Karta wlan1 zostala skonfigurowana do nadawania sygnału na częstotliwości 2,4GHz B/G z Nazwą SSID Firma na kanale 11 ( 2462)

    Jeśli chce pan zabezpieczyć prowizorycznym hasłem necik to wchodzimy:

    Wireless- Security Profiles – czerwony plus i zmieniamy:





    a) Name =Haslo1
    Mode=dynamic keys

    W zakładce Static Keys
    a) Key 0=104 bit a obok wpisujesz hasełko z (26 znaków ) potem Apply i ok.

    Przechodzisz do zakładki Interfaces i klikasz na wlan1 i w zakładce wireless zmieniasz
    a) Security Profile =Haslo1

    Objaśnienie: Utworzyliśmy hasło kodujące Internet o nazwie Hasło1 a następnie przechodząc do karty wlan1 ustawiliśmy tam opcje kodowania poprzez utworzone hasło.

    Do tej pory mamy przypisany adres do Bridge oraz skonfigurowaną kartę wlan1 do nadawania Internetu.

    8 - Ip-DNS- w zakładce Static naciskasz przycisk DNS Settings i wpisujesz :

    a) Primary DNS= 194.204.159.1
    Secondary DNS=194.204.152.34

    Zaznaczasz też Allow remote requests

    Potem Apply i ok.

    9 – IP- Routes- czerwony plus i w zakładce General zmieniasz

    a) Gateway=192.168.1.1 potem Apply i ok.

    Teraz skonfigurujemy drugą kartę wlan aby odbierała Internet z twojego modemu ADSL drogą radiową. Zakładam że Internet z modemu idzie drogą niekodowaną czyli bez hasła.

    10 - Wchodzimy w zakładkę Interfaces zaznaczasz wlan2 i odznaczasz niebieską ”fajką”
    11 – klikasz 2x wlan2 i w zakładce Wireless zmieniasz:

    a) Mode=stadion pseudobridge
    Band 2,4GHz B/G
    Naciskasz Apply i następnie naciskasz przycisk Scan – otwiera się okno
    Po kilku sekundach pojawi się lista na której powinien pojawić sie sygnał z twojego ADSL. Zaznaczas na liście sygnał z ADSL i naciskach Connect zamykasz okno i potem Apply i ok.

    Jeśli wla2 będzie dobrze skonfigurowany to w zakładce Interfaces obok wlan2 pojawi się duża czarna literka R.


    Konfigurujemy teraz oba odbiorniki klienckie. Zaczynamy od WA601G

    Uruchamiamy WA601G i wyszukujemy sygnału o nazwie Firma. Następnie wpisujemy hasło jakie ustawiliśmy. Podobnie robimy z Wa5120 szukamy sygnału nazwie Firma i wpisujemy hasło. Teraz oba nadajniki powinny być widoczne w MT w zakładce Wireless – Registration. Będzie tam widoczna karta wlan2 oraz jej adres MAC za pomocą której jesteś połączony z ADSL. Natomiast karta wlan1 pojawi się tam 2 razy albowiem oba urządzenia klienckie będą korzystały z tej karty. Do tego jak klikniesz na te karty zobaczysz u jednej adres 192.168.1.30 a na drugiej 192.168.1.40. Do tego w zakładce Interfaces obok Wlan1 Pojawi sie tez czarna duża literka R.


    Dla informacji. Jeśli nie chcesz ustawiać prędkości klientom wystarczy ze kartę WLAN2 dodasz do Bridge. Czyli wchodzisz Bridge- Ports i czerwony plus i podajesz

    a) Interface = wlan2
    Bridge=Bridge1
    Reszta bez zmian nic nie zmieniasz
    Naciskach Apply a potem ok:

    Od tej pory Internet już działa na wszystkich portach.


    Natomiast jeśli chcesz zrobić podział prędkości to wchodzisz

    12) Ip- Addresses – czerwony plus – w oknie wpisujesz

    a) Address =192.168.0.10 a w Interface=wlan2 a potem Apply i ok

    13) Ip- firewall –zakładka –NAT-czerwony plus – w nowym oknie :

    a) Zakładka General
    - chain= srcnat
    -src address =192.168.1.10/24
    -in interface =wlan2
    -out interface=wlan1
    b) zakładka Action
    - action=masquerade
    Na koniec Apply i ok.
    14) Aby zablokować P2P robisz
    a) Ip->firewall- zakładka- Filter rulet- czerwony plus i zakładce General
    -Chain=Forward,
    -P2P=all –p2p

    W zakładce Action

    -Action= Drop
    Na koniec Apply I ok

    15) Uruchamiamy serwer DHCP
    a) Ip -server setup-zakładka dhcp I naciskasz przycisk DHCP SETUP
    Interfaces wlan1 a potem 192.168.1.10/24 i cały czas ok.
    16) IP-DHCP Server w zakładce Leases pojawią wpisy. Zaznaczasz wpis i klikasz Make Static. NA sam koniec w Queues – Simple Queues – czerwony plus. Zakładka General
    17) wpisujesz w tej zakładce
    a) Name = WA601G
    Target Address= 192.168.1.30
    Max Limit= 512k w drugim oknie 512k
    Na koniec Apply i ok.

    Następnie drugi raz klikasz czerwony plus i podajesz to samo ale zmieniasz tylko „
    Name = WA5210
    Target Address= 192.168.1.40
    Apply i ok.

    To powinno być wszystko. Teraz powinno wszystko chodzić.
    Gwarancji jednak nie dam proszę aby ktoś to jednak bardzo dokładnie sprawdził. Ewentualne poprawki proszę dokonać ale z zachowaniem adresów klienta aby nasz kolega miał jak najmniej do pracy.

    Myślę że przy takiej łopatologii każdy załapie .

    0
  • #7 13 Sty 2012 19:50
    piterus99
    Poziom 43  

    Tak, przy Twoim sposobie nie musi zmieniać adresacji u klientów, za to musi na routerze ASDL - wychodzi na jedno.

    0
  • #8 14 Sty 2012 16:45
    maciek.sobie1
    Poziom 8  

    Sprawdzę tą ostatnią metodę bo nadal nie uruchomiłem net. Samo to że nadając internet wlan1 nie mogę na nim uruchomić serwera DHCP. Zawsze pojawia się na czerwono. Może mylę coś z adresami IP dlatego sprawdzę metodę łopatologiczną daną przez Krek15. Jego metoda jest dla mnie o tyle dobra że nie muszę już zmieniać adresów Ip na urządzeniach klienckich a i hasło też mam już na nich ustawione. Tak to już jest jak się jest za starym na nowinki techniczne.

    0
  • #9 18 Sty 2012 15:01
    maciek.sobie1
    Poziom 8  

    Witam chłopaki

    Za diabły nie mogę tego ustawić. Choć na modemie ADSL mam numer ip przez który się do niego loguje 192.168.10.1 to po ustawieniu na Bridge 192.168.1.10 i na Wlan2 10=92.168.10.1 nie chce to zadziałać.

    Zrobiłem restart
    Potem wpisałem w terminalu
    /ip addr add addr=192.168.10.6/24 int=wlan2 - tą kartą pobieram internet z ADSL
    /ip route add dst=0.0.0.0/0 gateway=192.168.10.1

    /ip dns set server=192.168.1.1, 194.204.159.1---- ten wpis nie działa na moim terminalu
    wiec zrobiłem ręcznie
    Ip-DNS- w zakładce Static wybrałem Settings i wpisałem:
    Primary DNS= 194.204.159.1
    Secondary DNS=194.204.152.34
    Potwierdziłem i ponownie w terminalu wpisałem
    /ip dns set allow-remote-request=yes


    Potem utworzyłem Bridge i wpisałem wszystkie porty poza portem Wlan2 przez który pobieram internet.

    W terminalu wpisałem

    /ip addr add address=192.168.1.10/24 int=bridge1

    Potem ręcznie odpaliłem Serwer DHCP Setap i ustawiłem na Wlan1 przez który będą nadawał internet
    a adres który mi się tam sam wpisał był 192.168.1.1 i reszta potwierdzałem ok.

    Potem w terminalu
    /ip firewall nat add chain=srcnat src-addr=192.168.15.0/24 action=masquerade -- też nie działa wiec ręcznie zrobiłem

    Ip- firewall –zakładka –NAT-czerwony plus – w nowym oknie
    Zakładka General
    - chain= srcnat
    -src address =192.168.1.10
    zakładka Action
    - action=masquerade
    potwierdziłem ok

    Niby tym momencie, podłączając się pod ether1,2,3 oraz wlan1 adres IP dostane niby od MT i będzie działać sieć.

    Mimo to do tej pory nie działa ani nie ma neta na zadnym porcie

    W Winboxie w IP->DHCP Server w zakładce Leases- nie pojawił mi się żaden wpis.


    NA próbę połączyłem się przez bezprzewodowa kartę wlan poprzez port wlan1 ane neta nie było. KArtę skonfigurowałem tak

    Adres 192.168.1.100.
    Maska 255.255.255.0
    Brama 192.168.1.1
    Preferowany DNS 192.204.159.1
    Alternatywny DNS 192.204.152.34

    Koło karty Wlan1 pojawiła się literka R czyli że jest połączenie ale nic więcej - Internetu brak
    Również przy Wlan2 też pojawiła się literka R że jest połączenie z modemem ADSL.

    IP->DHCP Server w zakładce Leases nie pojawił się zaden wpis


    Co robię źle.
    Wiem że marudny jestem ale nie radzę sobie z tym.

    Adres na ADSL 192.168.10.1
    Bridge 192.168.1.10
    Wlan2 192,168.10.6

    Co jest? nawet nie wszystkie polecenia wchodzą w terminal czy to wina wersji?

    WinBox v5.9 on RB433 czy to ma jakieś znaczenie ?
    dziękuje

    0
  • #10 18 Sty 2012 19:18
    piterus99
    Poziom 43  

    Widać ja pisząc je Tobie musiałem się gdzieś strzelić po prostu - polecenia są dobre, literówki pewnie nastrzelałem.
    DHCP odpalasz na bridge'u, nie na żadnym interfejsie to raz.

    Cytat:
    W terminalu wpisałem

    /ip addr add address=192.168.1.10/24 int=bridge1

    Literówka czy tak wpisałeś?

    Cytat:
    Potem w terminalu
    /ip firewall nat add chain=srcnat src-addr=192.168.15.0/24 action=masquerade -- też nie działa wiec ręcznie zrobiłem

    Skąd to .15 jak zaadresowałeś sieć 192.168.1.0/24 ?

    Jeszcze raz.
    Do momentu konfiguracji DNS(włącznie) wszystko robisz OK. Upewnij się tylko, że nie ma innych wpisów adresów dla innych interfejsów.

    Do bri wrzucasz wszystko poza wlan2.
    Na bridge nadajesz IP 192.168.1.1/24
    DHCP Setup, interfejs: bridge1, dalej->dalej...
    IP-Firewall-NAT, plusik, chain:srcnat, src-addr: 192.168.1.0/24, zakładka action: action: masquerade.

    Nie ma bata, musi działać. Jak nie działa to sprawdź:
    1) Czy masz dostęp do Internetu na MT(ping, tracert)
    2) Czy urządzenia się linkują ze sobą
    3) Czy wszędzie na pewno masz poprawne adresy.

    Zamiennie w maskaradzie możesz zamiast src-addr dać out-inteface: wlan2

    0
  • #11 18 Sty 2012 20:04
    maciek.sobie1
    Poziom 8  

    To co wpisywałem dotyczyło pierwszego przykładu który zamieszczam poniżej jako cytat. Restartując Mt zrobiłem wszystko to co poniżej:

    piterus99 napisał:


    Zrób tak(reset konfigu najpierw):
    /ip addr add addr=192.168.1.2/24 int=ether1 <- adres IP, który przyznasz urządzeniu(z puli routera ADSL), interfejs ether1 jako fizyczne wyjście do niego
    /ip route add dst=0.0.0.0/0 gateway=192.168.1.1 <- brama
    /ip dns set server=192.168.1.1, 194.204.159.1 <- DNS
    /ip dns set allow-remote-request=yes <- zezwolenie na korzystanie z DNS przez klientów

    w tym momencie jest Internet tylko na urządzeniu.
    Tworzysz teraz sobie bridge, dodajesz jako porty ether2, ether3, wlan1, wlan2(jak chcesz na obu nadajnikach mieć rozgłaszanie, jak na jednym to pomijasz część)
    Konfigurujesz wlan1, wlan2 jako ap bri, kanały oddalone od siebie - to umiesz.

    /ip addr add address=192.168.15.1/24 int=bridge1
    /ip dhcp-server setup i tutaj odpala Ci się konfiguracja, którą przechodzisz(domyślne opcje są zazwyczaj OK, możesz zawęzić sobie obszar DHCP, ja zawsze robię zakres 200-254)

    i teraz najważniejsze - maskarada(NAT). Bez tego klieci nie będą mieć sieci:
    /ip firewall nat add chain=srcnat src-addr=192.168.15.0/24 action=masquerade

    I w tym momencie, podłączając się pod ether2,3 wlan1,2 dostaniesz adres IP od MT i będzie działać sieć.

    W Winboxie w IP->DHCP Server w zakładce Leases pojawi Ci się nowy wpis. Klikniesz Make Static.
    Przejdź do Queues -> Simple, dodaj wpis z tym adresem IP, a pola max-limit to prędkość, którą chcesz dać klientowi.
    Jeśli oni nie będą kombinować ze zmianą adresów, możesz poprzestać w tym momencie. Jeśli nie, we właściwościach bridge1 zmień ARP na reply-only a w DHCP-Server na zakładce DHCP w opcjach zaznacz Add ARP for leases.

    Jeśli zaś potrzebujesz jednak Internet przez wlan2 - zamień go miejscami w podanym "skrypcie" z ether1 i już.

    Pisałem z pamięci, więc składniowo problemy mogą być, ale sens jest zachowany.



    Natomiast wpisując

    /ip firewall nat add chain=srcnat src-addr=192.168.15.0/24 action=masquerade
    po wpisaniu zaraz zaznaczało się na ciemny brąz literka "S" w słowie SCR-ADDR


    Jak dodać użytkownika i zabezpieczyć połączenie - mikrotik

    podobnie z wpisem
    /ip dns set server=192.168.1.1, 194.204.159.1 <- DNS

    Jak dodać użytkownika i zabezpieczyć połączenie - mikrotik


    Natomiast poza tym wszytkom
    /ip addr add address=192.168.1.10/24 int=bridge1 --tak wpisywałem bo takie kiedyś miałem już adres na bri czyli 192.168.1.10

    Pierwszy mój błąd to taki że uruchamiałem serwer DHCP na interfejsie a nie na Bri. Natomiast martwią mnie wpisy które zamieściłem na foto.

    0
  • #12 18 Sty 2012 21:00
    piterus99
    Poziom 43  

    W /ip dns set server=192.168.1.1,194.204.159.1 ma nie być spacji po przecinku.
    Zamiast src-addr trzeba napisać src-address, ja zawsze naciskam tabulator, stąd to przyzwyczajenie;) Ale można było wyklikać, tak jak pisałem u góry.

    Mój błąd, że w pierwszym opisie nie sprecyzowałem interfejsu dla dhcp-server

    PS. Jak zmieniłeś adresację na routerze ADSL, pierwszy DNS musisz ustawić albo 192.168.10.1 albo nawet i 194.204.159.1

    Kurde pogmatwało się trochę, mam nadzieję, że zrozumiesz. Jak nie, wrzuć konfigurację a ja Ci ją uzupełnię i wrzucisz ją sobie(albo też możesz wystawić mi MT na zewnątrz i też to zrobię) - stawiam, że najpierw chcesz jednak sam.

    0
  • #13 23 Sty 2012 13:57
    maciek.sobie1
    Poziom 8  

    Witam po przerwie. Okazał się ze konfiguracja była dobra od samego początku. Jednak nasz błąd polegał na tym że pomijaliśmy DHCP Client. Niby nic wielkiego ale to było przyczyną całej awanturki z netem. Została jedna sprawa mianowicie w biurze z tp-Link WA601G Mt nadał sam IP i w ustawieniach tp-Ling WA601G jest opcja Dynamic IP(Dhcp) MT szybko znalazł i zaskoczył net. Gorzej sprawa wygląda z TP-Link WA5210G ten nie ma opcji Dynamic IP(Dhcp) Tylko adres IP jaki nadamy taki ma. serwer DHCP nie widzi urządzenia. Wpisałem wiec w DHCP recznie ip TP-Link WA5210G i jakoś chodzi.

    0