Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - funkcja, która może zautomatyzować proces ?

12 Sty 2012 11:32 1291 5
  • Poziom 9  
    Witam,

    Mam pewnien problem z Excel'em - a mówiąc dokładniej - bardzo proszę o poradę czy w przypadku, który opiszę - jest możliwość zastosowania jakiejkolwiek funkcji (czy może makra) ?? A nie jestem za bardzo doświadczony w tym zakresie.

    Przesyłam plik by łatwiej zobrazować problem.

    Najważniejsze kolumny to - kolumnia A (przykladowe numery materiałów), - kolumna C czyli vendor (dostawca):

    -- a chodzi mi o to by można było użyć funkcji, która to wyszczególni pewien określony błąd - taki jak (zaznaczony na żółto) - czyli w przypadku dwóch takich samych materiałów z kolumny A (tutaj 30000002615) - vendor jest takze ten sam (tutaj 1048059) - a powinien być różny - jak w powyższych przypadkach.

    Mam nadzieję, że dobrze opisałem problem i umieściłem temat. Z góry dziękuję za wszelką pomoc.
  • Poziom 40  
    A można dołożyć kolumnę pomocniczą z obliczeniami.
    Jeżeli tak, to dodaj do siebie komórki z kolumny material i vendor za pomocą "&"
    A później formatowanie warunkowe z warunkiem:
    licz.jeżeli(kolumna pomocnicza;dana komórka z kolumny pomocniczej)>1
    ustaw format na żółto
    i już.
  • Poziom 40  
    the_legion a to na pewno jest błąd bo to w realu oznaczyło by dwie dostawy od tego samego dostawcy co nie musi być blednę. Dlaczego to vendor a być błędne a nie na przykład mateial.

    Z tego co rozumie jeśli jest prostowane wg material i występuje tylko podwójnie to można tak
    =JEŻELI(I(A2=A1;B2=B1);1;0)
  • Poziom 9  
    marek003 napisał:

    licz.jeżeli(kolumna pomocnicza;dana komórka z kolumny pomocniczej)>1
    ustaw format na żółto
    i już.


    Dzięki wielkie działa. (a tak z czystej ciekawości - czy jest może jeszcze łatwiejsze rozwiązanie ?)

    Tommy82 napisał:

    the_legion a to na pewno jest błąd bo to w realu oznaczyło by dwie dostawy od tego samego dostawcy co nie musi być blednę. Dlaczego to vendor a być błędne a nie na przykład mateial.


    Tak to jest błąd - ponieważ w tym przypadku "contract" nie zupełnie oznacza to samo co w języku polskim - jest to stała umowa z dostawcą (przy odpowiednich warunkach)- z którą to połączone są inne aplikacje (pozwalające zamówić materiał) i jak ta dana aplikacja widzi ten sam material w dwóch kontraktach (przy wszystkich pozostałych danych takich samych)- wychodzą błędy.
  • Pomocny post
    Poziom 40  
    the_legion napisał:
    a tak z czystej ciekawości - czy jest może jeszcze łatwiejsze rozwiązanie ?


    :) ale mamy wybrednych forumowiczów :)

    "jak się da to sie zrobi" jak to w starym kabarecie było


    Hmm...

    Pewnie że sie da prościej - bez kolumny pomocniczej - tylko formatowanie warunkowe (tylko czy to rozwiązanie jest łatwiejsze jeżeli chodzi o zrozumienie formuły suma.iloczynów() ? )

    Zaznacz cały arkusz
    włącz formatowanie warunkowe
    wpisz formułę (dolary sa ważne :) )
    =SUMA.ILOCZYNÓW(($A$1:$A$10000=$A1)* ($C$1:$C$10000=$C1))>1
    ustaw żółty
    i już.

    Powyżej ograniczyłem do 10000 wierszy.(możesz to zmienić ale oba zakresy [A i C] muszą mieć taką samą ilość wierszy)
    od E2007 możesz zamiast wskazywać konkretny zakres podać $A:$A i $C:$C i wtedy obejmie się całą kolumnę niestety excele poniżej 2007 muszą mieć zamkniety zakres w sumie.iloczynów()
  • Poziom 9  
    :) dzięki marek003 !!

    pytałem dlatego , że tą nową wiedzę będe przekazywał moim współpracownikom a z poziomem wiedzy na temat Excela - to i nich chyba jeszcze gorzej niż u mnie !!

    Temat uważam za zamknięty ! Dzięki marek003 i Tommy82 za pomoc w temacie !!!