Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zasilacz ATX do zasilania 4 taśm led - piszczy

18 Sty 2012 23:04 4887 6
  • Poziom 23  
    Mam zasilacz ATX na KA7500B. Do tego podłączony jest sterownik RGB (pod 12V) na MOSFETach, dokładnie ten:

    Zasilacz ATX do zasilania 4 taśm led - piszczy

    Do tego 20 metrów taśmy RGB. Taśma przy maksymalnym poborze ciągnie ok 6A. Wszystko gra, ładnie działa, ale do czasu zmiany koloru.

    Przy zmianie kolorów (szczególnie na bliski białemu zimnemu) coś bardzo piszczy w zasilaczu. Winne jest oczywiście PWM sterownika, przy różnych kolorach różnie piszczy. Wydaje się, że to piszczenie jest na stronie pierwotnej. Pierwsze co przyszło mi do głowy do podpięcie dużego kondensatora na wyjściu 12V ale nic to nie dało.
    Czy macie jakieś pomysły jak wyeliminować te piski?

    Dzięki i Pozdrawiam
  • Poziom 27  
    Spróbuj dociążyć linie +12V i +5V żarówkami np 21W odpowiednio na 12V i 6V.
  • Poziom 23  
    To nic nie dało.
    12V mam stałe, dałem sztuczne obciążenie linii 5V, tak żeby zasilacz dobrze regulował napięcie 12V. Polega to na tym, że zamiast doprowadzenia faktycznego napięcia 5V z wyjścia przetwornicy zasilacza, wstawiłem w to miejsce LMa 7805, który jest zasilany z 12V. Daje to stabilne 12V przy 6A na wyjściu. Wcześniej napięcie z obciążeniem spadało do 10V.
    Problem to tylko to piszczenie przy innych kolorach niż czysty biały (przez PWM sterownika).
  • Poziom 27  
    Myrek1 napisał:

    Problem to tylko to piszczenie przy innych kolorach niż czysty biały (przez PWM sterownika).


    Bo biały - to robi się z mieszania kolorów RGB. Wtedy wszystkie LEDY jakie są to świecą.
  • Poziom 23  
    DamianRTV napisał:
    Myrek1 napisał:

    Problem to tylko to piszczenie przy innych kolorach niż czysty biały (przez PWM sterownika).


    Bo biały - to robi się z mieszania kolorów RGB. Wtedy wszystkie LEDY jakie są to świecą.


    Ehh, przecież wiem i pisałem o tym wcześniej. Jak pobór jest liniowy to jest ok, ale przez PWM sterownika (inne kolory niż biały) są te piszczenia i za nic nie wiem jak je zmniejszyć/wyeliminować.
  • Poziom 42  
    Używając zasilacza przeznaczonego do zasilania LEDów a nie komputerów.
  • Pomocny post
    Poziom 27  
    Zapewne piszczą cewki, spróbuj je zalać woskiem, jeżeli tylko w tym problem, to nie powinno być problemów.