Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wzmacniacz mocy na HEXFET'ach EE1/94 PL

Piotrek Stp 24 Mar 2008 15:33 101101 265
  • #241 24 Mar 2008 15:33
    wzmak123
    Poziom 18  

    z tego co zauważyłem jak w źródłach prądowych dałem diody gdzie prąd 3mA był już przy 1,6V tranzystory bd139/bd140 nie grzały się tak mocno ,
    spróbuj zwiększyć rezystory R24,R27 na 180Ω, gdzieś na audio stereo była mowa o nich. a tranzystory bym zostawił te IRFP9140/240 w końcu mają najbardziej zbliżony rds

    Potrafisz napisać podobny artykuł? Wyślij do mnie a otrzymasz pendrive 32GB.
  • #242 07 Kwi 2008 21:29
    shade007
    Poziom 10  

    Temat mnie zaciekawił i chciałem zobaczyć co z tego wychodzi. Zamówiłem sobie części. BD'ki mam firmy ST (nie zastanawiałem się nad wyborem) do tego IRF9540 i IRF540. Z Rezystorami R32 i R33 coś namieszałem bo dałem coś koło 3 ohm, a drugi 27 1% i właśnie one zapłonęły ;)
    Hm. byłem niecierpliwy, dobierałem tylko t4-t3, t2-t1 podłączyłem, ustawiłem prąd spoczynkowy na 9mV na rezystorach 0.1 ohm. R25-28=22ohm, R26-T29=120. Dodałem zenerki 12V w szeregu z 4148. Zrobiłem dopiero jeden kanał.
    Podłączyłem aparat komórkowy z dzielnikiem napięcia na wejście i przez parę minut wspaniale grało.
    Potem dym i zaświeciły się rezystory r32 i r33 za mała moc. Wylutowałem spalone rezystory, grało jeszcze 10 minut. Potem spalił się bezpiecznik, przy T12 oraz zenerka zabezpieczająca bramę. Drugi bezpiecznik nienaruszony. Nie wiem jak końcówka T12. Wszystko działo się jakąś godzinkę temu.
    Tyle było zabawy.

  • #243 07 Kwi 2008 22:03
    Robertinus
    Poziom 13  

    Zabawę to może i miałeś, ale z Twojego opisu trudno wyciągnąć jakieś konstruktywne wnioski.
    Nie dołożyłeś staranności by dobrać właściwej oporności rezystory, ich moc też była zbyt niska a wszystko poskładane w pośpiechu.
    Pomyłka w rezystorach sugeruje też, że nie selekcjonowałeś elementów i na dobrą sprawę nie wiadomo np. czy któryś kondensator nie miał upływności, co mogło by właśnie być przyczyną spalenia bezpiecznika a najprawdopodobniej i hexfetów.
    Czyli dalej wiemy tyle ile wiedzieliśmy przed twoim postem. :cry:

    Oczywiście nie chciałem Cię obrazić, to tylko luźne wnioski.

  • #244 11 Kwi 2008 16:38
    shade007
    Poziom 10  

    Nie jestem za bardzo doświadczony.
    Nowy ładnie się uruchomił. IRF'y wyciągnąłem na przewodach by były bliżej siebie. Na początku odpaliłem z 12V trafo ustawiłem i jest ok. Nie wiedziałem wówczas, że bez obciążenia grzeją się strasznie R32 i R33, dałem 1W i jest ok. Bardzo przyjemny dźwięk. Radiator dość ciepły ma chyba z 50 stopni.

  • #245 12 Kwi 2008 18:50
    urzedas
    Poziom 14  

    Witam !!!

    Co można wstawic w miare pospolitego zamiast bc617 w ukladzie opoznionego zalączania głośników ??? - troche cieżko znaleźć tego tranzystorka :/

    Czy móglby być np bc517 ???

    pozdrawiam

  • #246 12 Kwi 2008 19:01
    Robertinus
    Poziom 13  

    Pewnie składając układ nie unikniesz zakupów np. w TME
    http://www.tme.pl/katalog/
    Mają BC617
    BC517 ma trochę niskie napięcie - 40V i znacznie mniejszy prąd - ale myślę. że powinien sobie poradzić.

  • #247 13 Kwi 2008 13:00
    Robertinus
    Poziom 13  

    Znalazłem ciekawy opis na diyaudio, raise0 w ostatnim poście pisze, że udało mu się poskromić wzbudzający sie wzmak, proponuję zobaczyć fotki, które zamieścił.
    Nie patrzcie na zamieszczony przez niego schemat, tam popełnił błąd i źle wskazał łączone obwody, fotka z PCB wyjaśnia zagadnienie.
    Krótko mówiąc wg. jego teorii pomogło połączenie bazy T7 z R25 i R28
    http://www.diyaudio.com/forums/showthread.php?s=f25e45841a23188342392d85d272a9a5......
    Czy ktoś z Was próbował takiej przeróbki?, ew. co z tego wyszło?

  • #248 16 Kwi 2008 22:00
    Macieqz
    Poziom 10  

    Witam!

    Właśnie odpaliłem prototyp nr 2 takiego wzmacniacza - po drobnych modyfikacjach:
    - każdy kanał potrzebuje tylko przemiennego zasilania – trafo 2x24 (prostownik i filtr na każdym kanale oddzielny, kondensatory w filtrze to 2x2,2mF + 6,8 mF przed IRFem)
    - płytka oczywiście zmodyfikowana odpowiednio do tego celu (i do posiadanych elementów).
    - układy ograniczenia napięcia bramek IRF
    - zwiększone wartości rezystancji bramek IRF
    - zmienione wartości niektórych rezystorów (na wartości z podstawowego typoszergu metalizowanych 1%)
    - inaczej rozłożona masa.
    - większe pola lutownicze wszystkich elementów
    - zasilacz i mostek na każdym kanale – wystarczy 2x24, sygnał i głośnik i gra.
    -
    Tranzystory T1,T2, T3, T4 o podobnym współczynniku wzmocnienia (hfe około 680, tolerancja 1%)
    Tranzystory T5 i T6 też parowane jeżeli chodzi o współczynnik wzmocnienia. WAŻNE. Zapewniają stabilność punktów pracy układów różnicowych. Nie muszą mieć zbliżonego wzmocnienia do układów T1-T2 i T3-T4, jedynie w stosunku do siebie. Ważny jest też ten sam charakter zmian w funkcji temperatury. Podobnie diody stabilizacji termicznej.
    (jeżeli mamy parę NPN o innym wzmocnieniu niż PNP to sprawę załatwiamy punktem pracy – polaryzacja wyjścia – nie polecane lub dobieramy wzmocnienie tranzystorów stabilizujących – lepsze rozwiązanie)
    Podobnie T8-T9 oraz T10-T11 też dobierane w pary (jak jeden 150 to drugi 140 lub 160, bez przesady). Można tego nie robić, ale w tedy będzie problem z brakiem symetrii połowek złożonego sygnału na IRF (i składową stałą)
    Tranzystorów wyjściowych nie parowałem. Z lenistwa. Można było zdjąć charakterystyki prąd źródło dren w funkcji napięcia na bramce, ale tego nie robiłem.
    Tranzystory BD139 i 140 z Farchilda – są wykonane bez metalizacji obudowy – nie ma problemu z radiatorem. Ponadto są dosyć powtarzalne jeżeli chodzi o hfe.
    Prototyp odpaliłem początkowo z BC557b i 547b zamiast 560c i 550c. Wszystko było stabilne. Po zmianie na grupę c wzmocnienia pojawił się problem z punktem pracy tranzystorów T1 i T3 – składowa stała na wyjściu. Po zmniejszeniu rezystancji polaryzacji wejścia z 10MW na 3,3MW wszystko wróciło do normy (ze składową stałą)

    Podczas uruchamiania układu, zwrócić uwagę na spadki napięć na R17 i R18, R23 i R22, R24i R27 – powinny być równe. Nierówność napięć – źle sparowane tranzystory stopnia wejściowego lub sterującego – nierównomierne wysterowanie IRFów i składowa stała na wyjściu. (nierównomiernie grzeją się IRFy, T10 i T11, nierównocześnie gasną diody stabilizacji termicznej). Po wygrzaniu i zgrubnym ustawieniu zera warto podpiąć oscyloskop i generator zamiast regulacji prądu spoczynkowego ‘na słowo z gazety’. Po przepuszczeniu przez wzmacniacz fali prostokątnej (ja sprawdzałem na 10kHz) widać wszystkie niepożądane zjawiska. Przy zbyt małym prądzie spoczynkowym stopnia sterującego IFRami, da się zauważyć oscylacje rzędu 50kHz występujące po załamaniu szybko narastającego czoła fali prostokątnej. Przy zbyt dużym – z prostokąta robi się ‘sinus’. Regulując prąd płynący przez T7 potencjometrem P2 doprowadzamy do wygładzenia przebiegów (górnej i dolnej połówki) regulując jednocześnie składową stałą potencjometrem P1. Układ poprawnie przenoszący nawet najmniejszy sygnał wejściowy (w granicy czułości) nie wymaga regulacji prądu spoczynkowego w ciemno – za pomocą pomiaru jego wartości. Wartość jest drugorzędna – ukałd ma działać i nie zniekształcać sygnału. Jeżeli trochę grzeje – nic nie szkodzi. Takie elementy, takie punkty pracy i takie ciepło (100mA przy 70V to 7W – to już czuć). Warto też zrobić próbę obciążeniową w ten sam sposób – generator i oscyloskop na wyjściu (oraz z grzałka w wiadrze - obciązenie) celem zbadania zachowania wzmacniacza w calym zakresie prądów wyjściowych.




    I jeszcze jedno. Nie uruchamiać ukałdu nieobciazonego – waro zapiąć 100Ω 5W na wyjście – zewrzeć do masy wejscie – unikniemy niespodzianek. Automatyczne ograniczenie prądu żarówkami wskazane – ja nie stosowałem – 5 kanałów odpaliłem (kolejene wersje) i żaden nie odlecial. No, 1 parę IRFów wypaliłem, kiedy przesadziłem z prądem spoczynkowym – totalne zwarcie + 35 z – 35V. Ale to nie z powodu zakłóceń czy wzbudzenia.
    Nie ma znaczenia jakie mamy IRFy. Mam tanie ‘szybkie’ IRFxxxN i droższe IRFxxxBP i nie ma róznicy. Oczywiście zasilanie filtrowane jest dodatkowo kondensatorami 100n typu MKT (wszystkie moje pojemnosci są tego typu, za wyjątkiem C5), oraz zabudowany jest układ obcinania pików na bramkach IRFów. Zamiast oprawek wkładek 5x20 mam rezystory 0R15. Wzmacniacz nie wzbudza się. Owszem, jest czuły na dotyk cylindrów kondensatorów filtrujących zasilacza oraz do masy. Ale to normalne zjawisko.
    Układ trzeba regulować i uruchamiać w miejscu pracy. Inaczej zachowuje się na stole, inaczej w obudowie.

  • #249 17 Kwi 2008 11:09
    Robertinus
    Poziom 13  

    Macieqz napisał:

    Po zmniejszeniu rezystancji polaryzacji wejścia z 10MW na 3,3MW wszystko wróciło do normy (ze składową stałą)

    Czy mógł byś rozwinąć to zagadnienie ?, jakie elementy zmniejszałeś ?, czy chodzi o rezystory R7 i R8 ?

  • #250 17 Kwi 2008 20:56
    Macieqz
    Poziom 10  

    Dokładnie tak. Okazuje się, ze przy wzmocnieniach rzędu 700 (BC550 i 560 grupa c 2007r) wzmacniacz jest zbyt czuły i kapryśny. Podczas pracy niska (fatalna) stabilność punktu pracy tranzystorów stopnia wejściowego. Kiedy projektowano wzmacniacz, półprzewodniki chyba miały inne parametry niż teraz (hfe). Wywaliłem 550c 560c, kupiłem worek 556 i 546 grupy B (100 szt za 10zyli z przesyłką na Allegro). Parowałem na wzmocnienia 320 (PNP i NPN). 3M3 poszły do worka i wróciły 10M 9R7 i 8). 2 najnowsze wersje PCB zmontowane i działają. Wzmacniacz się nie grzeje nawet przy ciągłej pracy 2x10W deth metalu w głośnikach.

  • #251 20 Kwi 2008 12:27
    Robertinus
    Poziom 13  

    Parując BC550C/560C średnie wzmocnienie miałem ok. 450.
    Czy zastosowane przez Ciebie BC546/556 nie mają przypadkiem większych szumów niż 550/560 ?

  • #252 25 Kwi 2008 21:14
    Macieqz
    Poziom 10  

    46/56 są na wyższe napięcie Uce -> maja grubsze póprzewodniki. teoretycznie powiny mieć większe szumy - większa objętość -> więcej nośników.
    Nie sprawdzałem. Nie ma aparatury. Oscyloskopem raczej nie pomierzę (sieć i zakłócenia na samych kablach ~ poziom szumów). Trudno ponadto to stwierdzić, jeżeli wlutuję 550/60c to jest konieczność ponownej regulacji układu - zmienią się punkty pracy pozostałych tranzystorów końcówki.
    Inna sprawa, że na 550.60 to mój amp nie chodzi dobrze - jak napisałem uprzednio jest kapryśny, szaleje punkt pracy, ponadto buczy :(. Można policzyć od nowa wzmacniacz róznicowy - zmienić rezystory wyznaczające punkty pracy ale nie wiem czy to ma sens.
    Moje 550/560c miały hfe prawie 700 (680).
    Mam zamiar wrzucić tam MPSA18 lub coś podobnego, dedykowanego do audio, a nie półprzewodniki ogólnego stosowania.[/img]

  • #253 21 Maj 2008 18:30
    El_liero
    Poziom 24  

    Kto mi powie jak sprawdzić poprawnośc tranzystorów w tej końcówce mocy, czyli MOSFET oraz HEXFETów?

  • #254 08 Lut 2011 21:45
    LORDUS
    Poziom 14  

    Witam serdecznie może ktoś z was spotkał sie z takim trafem i będzie mógł mi pomoc okreslić jakie to ma parametry?? w linku fotki http://www19.zippyshare.com/v/43929490/file.html

    a pomiędzy wyjściami takie rezystancje:
    1-2=36,6ohm
    3-4=1,4ohm
    9-8=1,1ohm
    8-7=1ohm
    7-6=1ohm
    6-5=1,1ohm
    5-9=2,2ohm
    5-8=1,8ohm
    5-7=1,1ohm
    6-8=1,4ohm
    6-9=1,9ohm
    7-9=1,5ohm

    wyjścia na zdjęciach są podpisane :)

    Pozdrawiam i liczę na wasza pomoc :)

  • #255 10 Lut 2011 18:02
    El_liero
    Poziom 24  

    podłącz sobie do sieci i zmierz napięcia.
    Na podstawie rezystancji nikt ci nie nie powie.

  • #257 06 Mar 2011 16:23
    El_liero
    Poziom 24  

    to nie żadna przeróbka tylko oryginał, o którym zresztą mowa w tym temacie od początku.

  • #258 01 Lis 2011 17:32
    mmpolska
    Poziom 9  

    Witam forumowiczów,
    Jako że i mnie spodobał się dany projekt postanowiłem sobie go zbudować.. niestety natknąłem się na problem na który po trochu zaczyna mi brakować sił... Otóż grzeją (a właściwie palą) mi się rezystory R24 i R27 150 Ohm 1% zaraz po dołożeniu zasilania. Dodam że Tranzystory końcowe T7, T10, T11, T12 i 13 sprawdzałem już kilka razy co prawda domowymi sposobami i wydają się ok. Mało tego wszystkie BD dla pewności wymieniłem, Rezystory w otoczeniu również sprawdzane co do wartości i brak efektów. Zatem moje pytanie co po kolei sprawdzać by wyeliminować dany problem.

  • #259 02 Lis 2011 16:34
    El_liero
    Poziom 24  

    Też miałem taki problem, rozwiązałem go poprzez parowanie tranzystorów pod względem wzmocnienia czyli hfe. Ale to jest 10% rozwiązania, prawdopodobnie problem tkwi w prądzie spoczynkowym. Sprawdź spadek napięcia na R25 i R28 oraz RF1 i RF2.
    No i czy w ogóle regulowałeś P2?

  • #260 02 Lis 2011 21:14
    mmpolska
    Poziom 9  

    A widzisz. Niby o tym myślałem a jednak zapomniałem lecz jest kolejny problem gdyż p. spoczynkowego nie mogę ustawić. Wartość nie reaguje na kręceniem potencjometrem który jest sprawny lecz takowego prądu praktycznie brak tak jakby gdzieś ścieżka była przerwana lub któryś tranzystor czy rezystor nie był sprawny....

  • #261 03 Lis 2011 01:02
    El_liero
    Poziom 24  

    El_liero napisał:
    Sprawdź spadek napięcia na R25 i R28 oraz RF1 i RF2.
    No i czy w ogóle regulowałeś P2?


    sprawdziłeś?

    A jak masz uszkodzone PCB to o czym tu gadać :) ?

  • #262 13 Lis 2011 12:13
    mmpolska
    Poziom 9  

    PCB było/jest sprawne. Jak się okazało winę ponosił jeden z tranzystorów, który raz działał a pięć razy nie :p Teraz Prąd daje się bez problemu regulować do wartości zadanych. Napięcie na wyjściu sprowadzone do zera również bez problemu. Problemem natomiast jest nadmierne grzanie się tranzystorów końcowych przy obecnym prądzie spoczynkowym i obciążeniu. Nie nagrzewają się w kilka sekund co prawda a po kilkunastu kilkudziesięciu minutach jednak raczej za bardzo się grzeją przy takim radiatorze. Więc pewnie będzie trzeba zejść jeszcze z poziomu prądu spoczynkowego na mniejszą wartość...

  • #263 13 Lis 2011 13:18
    El_liero
    Poziom 24  

    za mały prąd spoczynkowy daje większe zniekształcenia, za duży grzeje niepotrzebnie trany i jeszcze cos tam powoduje.

    Jaki masz spadek napięcia na RF1 i RF2?

  • #265 14 Lis 2011 10:00
    El_liero
    Poziom 24  

    No to masz prąd spoczynkowy 200mA, ustaw na 150mA jak ci sie za bardzo grzeje. Nie dawaj poniżej 150mA. Z tego co pamiętam 200mA jest zalecane. Może masz za mały radiator...

  • #266 08 Lut 2015 14:56
    vgw
    Poziom 15  

    Temat troche odgrzewam, bo gdzies został zapomniany już kilka lat a wzmacniacz mino 20 lat od wydania Elektrora wciaż na czasie.
    Znalazłem na rosyjsko języcznych stronach układ wzmacniacza identyczny do "naszego", ale z tranzystorami wyjściowymi 2SC5200 / 2SA1943 ( nie mosfety ) i mocami do 400W.
    Wydaje się wiec, że można opracować uniwersalny układ pod kątem mocy i nawet typu tranzystorów wyjściowych. Jak różnice w odsłuchu nie wiem, bo nie robiłem jeszcze ani jednego , ani drugiego układu.
    Czy ktoś byłby zainteresowany eksperymentami ? Z czasem opracuje plytke uiwersalna i jeden schemat do obu wersji ( i np. dwa kolory co sie zmiania w wersjach )

  Szukaj w 5mln produktów