Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Nixie - jak dla mnie dziwne...

23 Gru 2004 18:34 1461 5
  • Poziom 11  
    Witam!

    Próbuje sobie sklecić jakiś zegarek na lampkach Nixie (właściwie to już mam pewne zaawansowane zaczątki bo zegarek chodzi tyle, że jego mózgiem jest PeCet i jego port drukarki) ale napotkałem pewną denerwującą mnie niejasność.

    Może kilka danych: Lampki Z560M sterowane poprzez 74141.

    No i właśnie problem tkwi (chyba) właśnie w 74141. Otóż zgodnie z jego dokumentacją, po podaniu na jego wejścia cyfry większej niż 1001 nie powinien wysterować żadnego z wyjść. Przekonany o tym fakcie myślałem, że tym prostym sposobem uda mi się wygasić dowolny wyświetlacz. Tak się jednak nie dzieje. Po podaniu cyfry większej niż 9 efekt jest taki, że zapalają się wszystkie cyfry wyświetlacza.

    Czy ktoś się już spotkał z czymś takim? Dzięki za odzew!
  • Poziom 28  
    daj linka do noty katalogowej, bo jakos niechce mi sie wierzyc, aby tak bylo ?
    moze kupiles jakis scalak w zastepstwo ?
    kiedys mialem taki przypadek z jakims niemieckim zamiennikiem
    i wlasnie zamiast wygaszac to wyswietlal potem
    A,B,C,D...
    bo to byla inna kostka niz deklarowana przez sprzedajacego
    albo zamisc schemat projektu, cos wykombinujemy
  • Pomocny post
    Specjalista - urządzenia lampowe
    eddie.t.h napisał:
    Może kilka danych: Lampki Z560M sterowane poprzez 74141.

    No i właśnie problem tkwi (chyba) właśnie w 74141. Otóż zgodnie z jego dokumentacją, po podaniu na jego wejścia cyfry większej niż 1001 nie powinien wysterować żadnego z wyjść. Przekonany o tym fakcie myślałem, że tym prostym sposobem uda mi się wygasić dowolny wyświetlacz. Tak się jednak nie dzieje. Po podaniu cyfry większej niż 9 efekt jest taki, że zapalają się wszystkie cyfry wyświetlacza.


    Ja bym stawiał na za duże napięcie zasilania wskaźników - w stanie wygaszenia wszystkich cyfr napięcie na anodzie wskaźnika wzrasta na tyle że przewyższa sumę napięcia zapłonu wskaźnika i napięcia zenerki wbudowanej w każde wyście drivera.
  • Poziom 28  
    zgadza sie moze to byc dokladnie taka przyczyna
    powinienem sie na poczatku zapytac jakie jest maxymalne napiecie dla kolektorow wyjsciowych ukladu
    (niewidzialem noty chyba ma wyjscia OC)
    bo niewiedzialem nigdzie ttli na napiecie powyzej 60V
    a po wygaszeniu to przeciez poleci w gore jak nic
  • Poziom 11  
    Dziękuję wszystkim za odzew!!!

    Dla uściślenia - mam układy tesli mh74141.

    Problem faktycznie chyba leży po stronie zasilania. Po odpowiedzi jdubowski zrobiłem szybki test (wtórnik emiterowy w zasilaniu lampek) i faktycznie udało mi się dojść do momentu w którym lampki wygasają. Z tym, że jasność zapalonych pozostawia wiele do życzenia...

    Nie mam w tej chwili miernika pod ręką i wszystko wykonuję "po omacku" dlatego też nie mogę podać konkretnej wartości napięcia ani prądu lampek. Jak na mój gust to mam zbyt "miękki" zasilacz (zrobiony na szybko z trafoków z tajwańskich zasilaczy) lub źle dobrane rezystorki anodowe.

    Jak się wszystko wyjaśni to dam znać.

    Jeszcze raz wielkie dzięki!

    Dodano po 2 [godziny] 47 [minuty]:

    No i wszystko już jasne :-).

    Otóż problem był tak banalny, że aż mi wstyd... Otóż napięcie zasilające lampki było niefiltrowane! Jako, że układ jest w fazie testów to zbudowany jest w "pająku" a ja niezauważyłem sterczącej samotnie w powietrzu nogi kondensatorka :-P.

    Miernik jak to miernik - uśrednił sobie wartość, a ja w poczuciu własnej wartości zwaliłem całą winę na 74141, który poprostu bronił się przed zbyt wysokim napięciem (w szczytach półfali).

    Po podłączeniu kondziołka i ponownym wyregulowaniu układu (tzn. napięcia i prądu anodowego) wszystko działa tak jak należy.

    No ale tak to już jest jak się człowiek spieszy... Jako. że kupiłem lampki+podstawki+74141 na kilogramy (dosłownie) to zależało mi na jak najszybszym ich sprawdzeniu (wiem, wiem - usprawiedliwiam się :-) ).

    No w każdym razie już wszystko ok!

    Dziękuję za pomoc!