Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Nie działający programator USBasp

Motor RKS 05 Lut 2012 15:35 4886 33
  • #1 05 Lut 2012 15:35
    Motor RKS
    Poziom 9  

    Kupiłem ostatnio programator USBasp i mi on nie działa. Diody nie zapalają się podczas pracy i nie mogę w ten sposób zaprogramować avr. Już nawet zrobiłem sam drogi programator USBasp i tam zapalają się diody podczas pracy ale nadal nie mogę zaprogramować avr. Pojawia mi sie następujący komunikat avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc
    Proszę o szybką pomoc. Bo już nie wiem co mam robić.

    0 29
  • #2 05 Lut 2012 20:55
    gaskoin
    Poziom 38  

    A wgrałeś sterowniki do windowsa bo coś mało informacji nam zdradziłeś.

    0
  • #3 05 Lut 2012 21:26
    Motor RKS
    Poziom 9  

    Jasne ze tak instalowalem nowsze i starsze. Nawet próbowałem już na 3 systemach i dalej nic

    Dodano po 21 [minuty]:

    W avrdude pojawia mi się taki komunikat avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

    0
  • #4 05 Lut 2012 21:27
    gaskoin
    Poziom 38  

    A urządzenie jest poprawnie widziane przez system ?

    Jak nie, to na schemacie są diody zenera 3V6, jak masz możliwość to wsadź tam 3V3 - czasami pomaga.

    0
  • #5 05 Lut 2012 21:39
    Motor RKS
    Poziom 9  

    tak w tym mam diody 3V3 Nie działający programator USBasp

    0
  • #6 05 Lut 2012 22:14
    mirekk36
    Poziom 42  

    ten komunikat z avrdude:

    Cytat:
    error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc


    na 100% mówi o jednym. Na pewno programator nie jest widziany w systemie windows i nie ma innego wyjścia.

    Nie napisałeś jaki masz system. Ale jeśli Win7 to przeczytaj to i obejrzyj tam filmik:

    http://mirekk36.blogspot.com/2011/05/wszystko-o-usbasp.html

    generalnie to musisz zacząć od tego, że ten komunikat nie będzie ci się już pojawiał co będzie oznaczać, że w końcu poradziłeś sobie ze sterownikami. Chociaż równie dobrze może to oznaczać problem sprzętowy z programatorem :( ale spokojnie - obejrzyj ten materiał najpierw.

    0
  • #7 06 Lut 2012 08:13
    Motor RKS
    Poziom 9  

    Sterowniki instalowałem już na win7, vista i xp i dalej nic ciągle to samo. Postępowałem zgodnie jak na filmie i ciągle to samo. W menadżerze urządzeń system widzi urządzenie.

    0
  • #8 06 Lut 2012 08:22
    mirekk36
    Poziom 42  

    To pokaż zrzut ekranu jak to wygląda w menadżerze urządzeń ...

    0
  • #9 06 Lut 2012 09:15
    Motor RKS
    Poziom 9  

    wygląda to tak
    Nie działający programator USBasp

    Dodano po 36 [minuty]:

    Diody dalej na programatorze nie świeca się, sprawdzałem je miernikiem i są dobre. Napięcie na programatorze też jest. Już nie wiem kompletnie co to za przyczyna że programator nie działa.

    0
  • #10 06 Lut 2012 10:40
    mirekk36
    Poziom 42  

    Ok, a teraz tak - jak podłączasz programator do komputera to windows go wykrywa ? tzn np jak miałeś odinstalowany sterownik - to pojawiło się nowe urządzenie? Albo teraz gdy masz zainstalowany i odłączasz/podłączasz - to znika ten USBasp z menadżera urządzeń ?

    0
  • #11 06 Lut 2012 13:07
    Motor RKS
    Poziom 9  

    Tak wykrywa go bezproblemowo. jak odinstalowałem sterownik i podłączyłem to pojawiło się jako nowe urządzenie. A jak odłączam USBasp to znika, a jak podłączam to pokazuje ze jest zainstalowane.

    0
  • #12 06 Lut 2012 13:37
    mirekk36
    Poziom 42  

    Ma procesor ATmega8 pod ręką ? podłącz go - weź program MkAvrCalculator, zainstaluj sobie z niego poprawną wersję AVRDUDE (zakładka "Ustawienia" ramka "avrdude" klawisz "Instaluj") i wtedy sprawdź i daj znać. Bo może w takim razie masz jakieś trefne avrdude. A to w MkAvrCalculator jest na 100000% sprawdzone.

    0
  • #13 06 Lut 2012 14:04
    Motor RKS
    Poziom 9  

    Dalej to samo wyskakuje tan sam komunikat error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

    0
  • #14 06 Lut 2012 15:00
    mirekk36
    Poziom 42  

    No to sorry ale ja się poddaję - taki komunikat to mi się pokazuje ale TYLKO i WYŁĄCZNIE wtedy gdy odłączę fizycznie USBASP od kompa i próbuję wywołać AVRDUDE. Wtedy mam dokładnie właśnie:

    Cytat:
    avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc


    i nigdy się nie spotkałem żeby było inaczej a od kilku lat działam tylko z tymi programatorami. Coś gdzieś musisz robić nie tak .... albo przeinstaluj Windows albo sprawdź sobie to wszystko na innym kompie może u kolegi i zobacz jak to się zachowa. A jak ruszy to już będziesz wiedział że masz Windę do przeinstalowania.

    0
  • #15 06 Lut 2012 16:37
    435758
    Użytkownik usunął konto  
  • #16 06 Lut 2012 16:44
    Motor RKS
    Poziom 9  

    Teraz pojawia mi się nowy, inny komunikat:

    avrdude.exe: set SCK frequency to 187500 Hz
    avrdude.exe: error: programm enable: target doesn't answer. 1
    avrdude.exe: initialization failed, rc=-1
    avrdude.exe: AVR device initialized and ready to accept instructions
    avrdude.exe: Device signature = 0x000000
    avrdude.exe: Yikes! Invalid device signature.
    avrdude.exe: Expected signature for ATMEGA8 is 1E 93 07

    avrdude.exe done. Thank you.

    0
  • #17 06 Lut 2012 17:23
    mirekk36
    Poziom 42  

    No to ten komunikat oznacza już że w końcu programator jest OK ;) ale źle jest podłączony procesor. Masz podłączone wszystkie linie ISP i to właściwie oraz zasilanie do procesora ?

    0
  • #18 06 Lut 2012 17:39
    Motor RKS
    Poziom 9  

    No dobra wszystko jest ok ale dlaczego mi się diody nie palą na programatorze.
    Nie podłączyłem ISP i zasilania.

    0
  • #19 06 Lut 2012 19:40
    435758
    Użytkownik usunął konto  
  • #20 06 Lut 2012 20:02
    Motor RKS
    Poziom 9  

    avrdude.exe: set SCK frequency to 187500 Hz
    avrdude.exe: error: programm enable: target doesn't answer. 1
    avrdude.exe: initialization failed, rc=-1
    avrdude.exe: AVR device initialized and ready to accept instructions
    avrdude.exe: Device signature = 0x000000
    avrdude.exe: Yikes! Invalid device signature.
    avrdude.exe: Expected signature for ATMEGA8 is 1E 93 07

    avrdude.exe done. Thank you.

    Dodano po 1 [minuty]:

    Wsad był już wgrany jak kupiłem ten programator

    0
  • #21 06 Lut 2012 20:18
    435758
    Użytkownik usunął konto  
  • #22 07 Lut 2012 13:50
    Motor RKS
    Poziom 9  

    Zmieniłem diody w programatorze i zaczęły Led świecić, ale pojawia mi sie komunikat nie rozpoznano urządzenia USB.
    Nie działający programator USBasp

    Dodano po 1 [minuty]:

    W AVRDUDE pojawia mi się teraz komunikat:
    avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

    avrdude.exe done. Thank you.

    Dodano po 4 [minuty]:

    Zainstalowałem sterowniki usbasp.2011-05-28.tar.gz ze strony http://www.fischl.de/usbasp/
    ale dalej nic.
    Nie działający programator USBasp

    0
  • #23 07 Lut 2012 18:00
    435758
    Użytkownik usunął konto  
  • #24 07 Lut 2012 19:42
    Motor RKS
    Poziom 9  

    Na tym obecnym procku mam wgrany wsad tylko z wcześniejszych wersji, bo jak go zakupiłem to on już był wgrany.
    A w jaki sposób mam wgrać jeszcze jeden wsad z usbasp.2011-05-28.tar.gz, bo ja dopiero zaczynam bawić z prockami i nie wiem jak i co. Dopiero się uczę tego wszystkiego.

    0
  • #25 07 Lut 2012 20:08
    435758
    Użytkownik usunął konto  
  • #27 07 Lut 2012 21:09
    435758
    Użytkownik usunął konto  
  • #28 08 Lut 2012 14:43
    Motor RKS
    Poziom 9  

    ok czy zaprogramowany układ powinien wyglądać tak
    Nie działający programator USBasp

    0
  • Pomocny post
    #29 08 Lut 2012 17:57
    435758
    Użytkownik usunął konto  
  • #30 08 Lut 2012 19:23
    Motor RKS
    Poziom 9  

    Ok wielkie dzięki.

    0