Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Jak zalogować się na ukryte konto w Viście

uczen100 08 Lut 2012 01:46 2247 8
  • Poziom 10  
    Witam.

    Posiadam dwa konta: konto standardowe i drugie z prawami administratora z hasłem. (Konto root administrator mam niestety wyłączone).

    Chciałem ukryć to konto z prawami administratora, aby nie pojawiało się one przy uruchamianiu systemu. Zrobiłem to dodając wpis do rejestru do "HKEY_Local_Machine\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList"

    Teraz mój problem polega na tym, że nie jestem w stanie wykonać żadnej operacji z prawami administratora, ponieważ ukrytego konta nie widać nawet w okienku, które wyskakuje przy próbuje uruchomienia aplikacji z prawami administratora.

    Zatem czy istnieje jakiś sposób aby usunąć ten wpis z rejestru lub zalogować się na konto z prawami administratora przez np. konsole?
  • Pomocny post
    VIP Zasłużony dla elektroda
    Na ekranie logowania: podwójny Ctrl+Alt+Del i wpisz login i hasło swojego konta z prawami administratora (tu nie mam pewności czy zadziała).

    Zawsze możesz uruchomić wiersz polecenia (cmd) i wpisać:
    runas /user:Twoje_konto_z_prawami_admina regedit
  • Poziom 10  
    Ctrl+Alt+Del niestety nie działa domyślnie w Viście, wymaga zmiany ustawień, których nie jestem teraz wstanie wykonać ze względu na to, że nie mam praw administratora...

    Druga opcja wydawała się być obiecująca jednak wyskakuje komunikat:

    Cytat:
    BŁĄD PROGRAMU RUNAS: Nie można uruchomić - regedit
    740: Żądana operacja wymaga podniesienia uprawnień.


    Jakieś inne rady :cry: ?
  • Pomocny post
    VIP Zasłużony dla elektroda
    No tak, upierdliwy UAC czuwa.
    A to:
    runas /user:Twoje_konto_z_prawami_admina cmd
  • Poziom 10  
    To przechodzi, jednak próba uruchomienia regedit według pierwszej rady w nowo otworzonym oknie CMD, które rzekomo zostało uruchomione z prawami administratora również zwraca błąd o konieczności podniesienia uprawnień...
  • Poziom 34  
    Jak sobie skutecznie podciąłeś gałąź na której siedzisz, to w Win-dzie musi to zaboleć, zwłaszcza, że zapewne nie zrobiłeś kopii zapasowej rejestru na nośniku zewnętrznym przed "gmeraniem" w nim, bo jak inaczej takie operacje nazwać. To nie ironia, to fakt potwierdzony przez Microsoft. Może też warto na przyszłość nieco zainteresować się Linux-em? To takie sobie moje pytanie niekoniecznie retoryczne :)
  • VIP Zasłużony dla elektroda
    Ok, spróbujmy z poleceniem reg (na logike nie powinno zadziałać :) )

    czyli w tym oknie cmd, które uruchomił użytkownik z prawami administratora wklep:

    reg delete "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList" /v uczen100

    (uczen100 <- to przykładowa wartość którą wcześniej dodałeś do podklucza \UserList)

    -
    W razie czego możesz posłużyć się WinRE z nośnika instalacyjnego (czy HDD) i tam się rozprawić z problemem - Napraw komputer - Wiersz polecenia i j.w.

  • Poziom 43  
    A jeszcze inaczej (mutacja ostatniej sugestii, którą WojtasJD podał) - start z płyty i wybór opcji naprawy przy użyciu cmd - to jest wiersz poleceń konta wbudowanego - i zwykła aktywacja przez net user administrator /active:yes (ew. to samo dla konta Użytkownika, o ile to o nie chodzi)?
    Gdyby operacja dot. wbudowanego się powiodła, to resztę można już z jego poziomu w samym systemie zrobić.
  • Poziom 10  
    Powyższych metod już nie próbowałem, jednak udało się problem rozwiązać inaczej.
    Zbootowałem komputer z płytki Hiren's BootCD i uruchomiłem Mini Windows XP. Tam wczytałem pliki swojego rejestru i usunąłem trefny wpis...